Covers Interleaf 6 for Windows NT, Windows 95, and Motif

INSIDE Interleaf®

Andy Salisbury
INSIDE Interleaf®

Andy Salisbury

ONWORD PRESS®
TRADEMARKS

Interleaf 6 and System6 are registered trademarks of Interleaf, Inc. OnWord Press is a registered trademark of High Mountain Press, Inc. Other products and services are mentioned in this book that are either trademarks or registered trademarks of their respective companies. OnWord Press and the author make no claim to these marks. The GO! Bowl program mentioned in this book is an unpublished work by the author.

WARNING AND DISCLAIMER

This book is designed to provide information about Interleaf 6. Every effort has been made to make this book complete and as accurate as possible; however, no warranty or fitness is implied.

The information is provided on an “as–is” basis. The author and OnWord Press shall have neither liability nor responsibility to any person or entity with respect to any loss or damages in connection with or rising from the information contained in this book.

ABOUT THE AUTHOR

Andy Salisbury graduated from the United States Air Force Academy in 1983 and has been involved with technical documentation since his first assignment in the U.S. Air Force. In 1989, he began working with Interleaf software to produce technical reports for U.S. Air Force test programs. In 1992, he left the service to pursue his passion for Interleaf software.

Today, he is a Senior Applications Consultant in the Denver, Colorado branch of Technical Publishing Solutions, Inc. (TPSI). At TPSI, he works with Interleaf users to help them gain control and improve the quality of their information. He has developed numerous custom applications with Interleaf Lisp software, including a redlining tool for Interleaf documents. He is an avid bowler and you may find him (in his spare time) in a bowling alley pursing the ever elusive 300 game. He can be reached through e-mail at andys@denver.tpsi.com.

ACKNOWLEDGMENTS

I would like to thank the team at OnWord Press for making my first book a memorable experience. Thanks to David Talbott, Margaret Burns, and Carol Leyba for listening to my ideas, providing great feedback, keeping me on track, and giving lots of production guidance. Thanks to Stacy
Dymalski, Jonathan Starr, and Jennifer Maxwell for technical reviews. Thanks to Interleaf for producing a quality product, especially, Claudia Dent, Dave Bucholtz, Dana Finnegan, and Michael Daitzman for answering my questions and keeping me supplied with beta software.

Special thanks to Bob Olson, John Huddock, and Patty Fukasawa at TPSI who enthusiastically supported my work on this book. I am grateful to Patty for not only reviewing the book, but for also being a friend. Special thanks to Colette Renteria who amazes me with what she does with Interleaf graphics. She provided the illustrations on pages 2–30, 2–33, and 15–321. All of them were done with Interleaf software.

Most of all, I would like to thank my family for their sacrifices. Thanks to Marriage Encounter for giving me the tools to improve my marriage during this otherwise busy time creating a book. I dedicate this book to my wife, Amy, who gently reminds me that dialogue is spelled with a “ue.”

**BOOK PRODUCTION**

This book was produced using Interleaf 5 and Interleaf 6 by the author. Adobe Type 1 Fonts were installed using Interleaf’s Font Management Utility. The cover design is by Lynne Egensteiner, using QuarkXpress 3.11 and Aldus FreeHand 3.0. Clip art is from the ClickArt Incredible Image Pak by T/Maker Company. Screen captures were created with HiJaak Pro 3.0 from Inset Systems.

**OnWord Press**

OnWord Press is dedicated to the fine art of professional documentation.

In addition to the author who developed the material for this book, many members of the OnWord Press team contribute to the book that ends up in your hands. In addition to those listed below, other members who contributed to the production and distribution of this book include Joe Adams, James Bridge, Roxsan Meyer, Jean Nichols, Robin Ortiz, and Bob Leyba.

Dan Raker, President
Kate Hayward, Publisher
Gary Lange, Associate Publisher
David Talbott, Acquisitions Editor
Carol Leyba, Production Manager

Janet Leigh Dick, Marketing Director
Margaret Burns, Project Editor
Andy Salisbury, Production Editor
Lynne Egensteiner, Cover Designer
Kate Bemis, Indexer
# Table of Contents

## Introduction

- Who Should Read this Book
- How This Book Is Organized
- Conventions Used in this Book
- Companion Disk

## Part I—Developing an Interleaf 6 Publishing Attitude

### Chapter 1—The Interleaf 6 Environment

- Starting Interleaf 6
  - Interleaf 6 for Windows
  - Interleaf 6 for Motif
- Becoming Acquainted with the Desktop
  - Minimizing the Desktop
  - Desktop Icons
  - Navigating Icons and Their Windows
- The Clipboard and System6 Cabinet
  - Clipboard
  - System6 Cabinet
- Quitting Interleaf 6

### Chapter 2—What Is a Document?

- Becoming Acquainted with a Document
  - Creating a Document
  - Opening a Document
  - The Document Window
  - Minimizing a Document Window
  - Closing a Document
- Documents Are Structured Information
- The Structure of Interleaf 6 Documents
  - The Component Bar Is Like a Closet Rod
  - Components Are the Hangers
  - Masters and Instances
PART II—CREATING BEAUTIFUL DOCUMENTS WITHOUT TRYING .......... 35
Setting the Stage for Part II of this Book ........................................ 35

CHAPTER 3—CREATING A DOCUMENT ........................................... 3-37
Installing the User Guide Template ............................................. 3-37
   Opening a Window to the Companion Disk ................................ 3-38
   Running the Install Program ................................................ 3-38
Accessing the User Guide Template ............................................. 3-38
Creating and Opening a Document ............................................. 3-41
Entering Text .............................................................................. 3-41
   Entering the Chapter Title ................................................... 3-42
   Creating a Section .................................................................. 3-43
Deleting and Replacing Text ...................................................... 3-47
   Deleting a Word ................................................................. 3-48
   Deleting a Paragraph (or Component) ................................... 3-48
   Deleting a Range of Text ..................................................... 3-48
   Replacing Selected Text ....................................................... 3-49
   Undoing a Change .................................................................. 3-49
Moving and Copying Text .......................................................... 3-50
   Moving a Range of Text ....................................................... 3-50
   Moving a Component .......................................................... 3-51
   Copying a Range of Text or a Component .............................. 3-52
"Local" Text Formatting ............................................................. 3-53
   Changing Text Properties ..................................................... 3-54
Saving and Closing a Document ................................................ 3-55

CHAPTER 4—MORE DOCUMENT EDITING ................................. 4-57
Incorporating Other Documents ................................................. 4-57
   Using Other Interleaf 6 Documents ....................................... 4-58
   Using Non-Interleaf 6 Documents ........................................ 4-62
Changing Component Types ....................................................... 4-63
   Changing Single Components .............................................. 4-64
   Changing Multiple Components .......................................... 4-66
Applying Widespread Changes .................................................. 4-67
   Searching and Replacing Text .............................................. 4-68
   Searching and Replacing Format ......................................... 4-69
Finding Document Objects ......................................................... 4-70
   Jumping from Point to Point in a Document ......................... 4-72
Controlling Page Breaks .............................................................. 4-73
## Table of Contents

Starting a Component on a New Page ........................................ 4-74
Keeping Other Items Together .................................................. 4-75
Checking and Correcting Spelling .............................................. 4-77
Checking an Entire Document ..................................................... 4-77
Spelling Checking Extras .......................................................... 4-80

### CHAPTER 5—PRINTING A DOCUMENT ........................................ 5-81

Printing a Document in Windows NT ........................................... 5-81
  Choosing the Print Destination .............................................. 5-82
  Choosing Pages and Copies to Print ........................................ 5-82
  Choosing To Use a Header Page ............................................. 5-82
  Printing Status ........................................................................ 5-84
  Setting Print Options in Windows NT ........................................ 5-85
  Setting Document Print Properties .......................................... 5-86
Printing a Document in Motif ..................................................... 5-87
  Choosing the Print Destination .............................................. 5-88
  Choosing Pages and Copies to Print ........................................ 5-88
  Printing Status ........................................................................ 5-90
  Setting Print Options in Motif .............................................. 5-91
  Setting Print Properties in Motif ........................................... 5-93

### CHAPTER 6—ADDING ILLUSTRATIONS ..................................... 6-95

Pasting an Illustration into a Document ....................................... 6-95
  Pasting a Graphic into Text ................................................... 6-95
  Pasting a Graphic into an Open Frame ..................................... 6-97
Creating an Illustration Reference .............................................. 6-107
  Creating a Reference: Automatic Method .................................. 6-107
  Creating a Reference: Manual Method ..................................... 6-109
  Creating a Reference to a Page Number .................................... 6-112
Shaping Text Around an Illustration .......................................... 6-112
  Adjusting the Frame's Properties .......................................... 6-113
  Shaping Text .......................................................................... 6-115

### CHAPTER 7—TABLE BASICS .................................................... 7-119

Creating a Table ........................................................................ 7-119
  Creating a Table from Scratch ................................................ 7-120
  Creating a Predefined Table ..................................................... 7-121
Emptying the Contents of a Table .............................................. 7-122
  Navigating Within a Table ..................................................... 7-122
  Selecting Cells ....................................................................... 7-123
  Using the Empty Cell(s) Command .......................................... 7-125
Entering Text in Table Cells ....................................................... 7-126
Entering Cell Edit Mode ......................................................... 7-126
Adding More Rows ................................................................. 7-128
Creating Rows ........................................................................ 7-128
Copying Rows ......................................................................... 7-129
Moving Rows ........................................................................... 7-129
Changing Table Rulings ............................................................. 7-131
Selecting Rulings ..................................................................... 7-131
Ruling Properties ....................................................................... 7-132

CHAPTER 8—USING BOOKS FOR LONG DOCUMENTS .............. 8-133
Books: Special Containers ......................................................... 8–133
What Objects Are Used in Books? ............................................. 8–134
Books Force Objects into Relationships .................................... 8–135
Table of Contents ...................................................................... 8–139
Tagging Information .................................................................. 8–139
Creating a Table of Contents .................................................... 8–142
Reformatting a Table of Contents ............................................. 8–144
Indexing a Book ...................................................................... 8–147
Creating and Modifying Index Entries ...................................... 8–147
Creating an Index ...................................................................... 8–152
Reformatting an Index ............................................................... 8–154

PART III—NOT FOR DOCUMENT DESIGNERS ONLY .................. 157
Setting the Stage for Part III of this Book ................................... 157

CHAPTER 9—PAGE LAYOUT ...................................................... 9-159
Establishing Page Dimensions .................................................. 9–159
Defining Printed Sides ................................................................. 9–161
Single Versus Double Sided ....................................................... 9–161
Double-Sided Considerations ................................................... 9–162
Setting Number of Columns ..................................................... 9–163
Other Document Properties ....................................................... 9–164
Headers and Footers ................................................................ 9–166
Viewing Header and Footer Boundaries ................................... 9-166
Changing the Size of Headers and Footers ............................... 9–167
Changing the Number of Headers and Footers ......................... 9–168
Repeated Page Content ............................................................... 9–170
Creating and Using Page Numbers .......................................... 9–170
Adding Section Titles to the Header .......................................... 9–173
Adding Page Revision Information ............................................ 9–174
Repeating Frames ..................................................................... 9–180
CHAPTER 10—FORMATTING PARAGRAPHS AND HEADINGS ........... 10-185
Basic Component Properties ........................................... 10-185
Component Text Properties ........................................... 10-185
Component Format Properties ...................................... 10-186
Component Page Properties ....................................... 10-190
Component Tab Properties ....................................... 10-191
Defining Paragraphs .................................................. 10-191
First Level Paragraph .............................................. 10-192
Second Level Paragraph .......................................... 10-194
Defining Headings .................................................. 10-196
Separate Headings ................................................. 10-196
Inline Headings ..................................................... 10-198

CHAPTER 11—FORMATTING LISTS AND DEFINING INLINE COMPONENTS .... 11-205
Defining Lists Using Component Prefixes ....................... 11-205
Defining Unordered Lists ......................................... 11-206
Other Unordered Lists ............................................ 11-210
Defining Ordered Lists ............................................ 11-210
Restarting Ordered Lists ......................................... 11-213
Other Ordered Lists ............................................. 11-218
Highlighted or Repeated Words and Phrases ....................... 11-219
Using Inline Components for Highlighted Words ............... 11-219
Using Inlines for Repeated Words or Phrases ..................... 11-222

CHAPTER 12—FORMATTING TABLES ........................................ 12-225
Creating a Table ..................................................... 12-225
Formatting Table Columns ........................................... 12-227
Changing Column Widths .......................................... 12-227
Selecting Columns .................................................. 12-228
Changing Column Properties ...................................... 12-230
Formatting Column Contents ...................................... 12-233
Formatting Table Headers .......................................... 12-235
Changing the Format of Heading Cells ........................... 12-236
Rename the Row and Make It a Header Row ....................... 12-237
Notes About Header Rows ....................................... 12-239
Using Straddles in a Table Definition ....................... 12-241
Creating a Horizontal Straddle .................................. 12-241
Creating a Vertical Straddle ..................................... 12-241
Changing a Cell’s Vertical Alignment ............................. 12-242
Updating Row Masters with Straddle Information ............. 12-243
Using Rulings in a Table Definition ............................. 12-245
The Chart Data Dialog Box ........................................ 17-346
Editing Chart Properties ......................................... 17-352
Creating a Bar Chart ............................................. 17-356
Creating a Line Chart ........................................... 17-358
Adding Titles and Legends to a Chart ......................... 17-361
Using Predefined Chart Templates ......................... 17-362

The Equation Editor ................................................. 17-364
The Equation Editor Dialog Box ................................ 17-364
The Language of the Equation Editor ....................... 17-365
Editing an Equation ............................................ 17-366
Changing the Font Size of an Equation ...................... 17-368
Lining Up Equations ............................................ 17-369
Equation Keywords Reference ............................... 17-370

APPENDIX A—THE COMPANION DOCUMENT TEMPLATE .......... A-371
Template Structure ............................................. A-371
MASTER Objects ................................................ A-374

APPENDIX B—CUSTOMIZING YOUR ENVIRONMENT .............. B-383
Creating Links to Desktop Objects ....................... B-383
Creating a Link to the start Document ..................... B-384
Using the start Document Link ........................... B-385
Adding a Printer in Motif .................................. B-386
Pick the Printer Menu and Name ......................... B-386
Set Filtering Options ..................................... B-386
Pick Printer Type and Modify Options ................. B-387
Setting Your Own Preferences ........................... B-390
Keyboard Preferences ................................... B-390
View Preferences ........................................ B-390

INDEX ............................................................................. 391
Introduction

**Who Should Read This Book**

If you are new to Interleaf 6, then this book is for you. Whether you create documents from predefined templates, design documents for others to use, or illustrate documents, you’ll find something in this book for you. Even if you have used Interleaf 5 in the past and are moving up to Interleaf 6, you can still pick up a few things from this book (more than the user interface has changed). If you have been using Interleaf 6 for Motif, version 6.0.3, you’ll find changes in appearance and functionality covered in this book.

Although this book was written to the 6.1 release of Interleaf 6 for Windows using Windows NT, the procedures and techniques demonstrated will be applicable to the 6.1 version for Windows ‘95 and Motif. Screen captures in Motif were created with the current version of the software, which at press time was 6.0.3. There may be some minor variations when the 6.1 version is released.

**How This Book Is Organized**

This book is organized into five parts. Part I is designed to give you an introduction to the Interleaf 6 environment and get you thinking about documents in a new way. Part II has you create documents in a way that a typical user might create documents—using a template created by someone else in your company. Part III digs deeper into documents and has you format objects and build your own template. Part IV shows you how to design graphics into documents and has you create a few of the different types of graphic objects available in Interleaf 6. Appendices provide a reference to the document template on the companion disk and tips to customize your environment. A comprehensive index is included.
CONVENTIONS USED IN THIS BOOK

The following conventions were used throughout this book:

Command strings, which are a series of menu selections, for example, File→New→Container→Folder, appear in bold type with an arrow separating each level of the menu.

Key commands appear in all capital letters, for example, ENTER key.

Commands entered at the system prompt appear in italic type, for example, ileaf.

Notes, tips, and warning are shown as follows:

**Note**  Notes present important information that might otherwise be overlooked.

**Tip**  Tips show shortcuts and hints that help you to be more productive.

**Warning**  Warnings point out functions and procedures that could get you into trouble if you are not careful.

COMPANION DISK

A bonus companion disk is attached to the inside back cover of this book. The disk contains files for you to use as you go through the exercises. The disk is a high-density, 1.44 Mb DOS format disk that can be used with both the Windows and Motif versions of Interleaf 6. Whenever a reference is made to a file from the companion disk, the INSIDE Interleaf disk icon will be shown in the margin.

You can install the companion disk by following the instructions found in Chapter 3 (see page 3–37). The installation is automated by using an Interleaf Lisp script. Additional information and last minute changes can be found in the readme.txt file on the disk.
Part I introduces you to Interleaf 6 and its use as a publishing tool. You will begin by taking a quick tour of the Interleaf environment. You will learn to look at a document as more than formatted text on a page, and when you do, you will see a document the way Interleaf 6 sees a document—as structured information. When you finish with Part I, you will be ready to move on to the rest of the book and begin "Publishing with an Attitude."
CHAPTER 1

The Interleaf 6 Environment

This chapter presents some basics about the Interleaf 6 environment. You will participate in a mini-session where you will learn to start Interleaf 6, work with the Interleaf 6 Desktop, create and manipulate Desktop objects, and quit Interleaf 6. By participating in this mini-session, you will begin your first step toward “Publishing with an Attitude.”

STARTING Interleaf 6

Welcome to Interleaf 6. If you're the type of person who wants to jump right in, you'll be happy to know that in this chapter you'll begin working through a mini-session with Interleaf 6. If you're a little more cautious—don't worry—I'll guide you through the process with plenty of pictures and descriptions. In either case, get ready, because here we go!

Interleaf 6 for Windows

On computers running Microsoft Windows, Interleaf 6 is started by double-clicking the Interleaf 6 icon in the Program Manager. Open the Program Manager window and then the Interleaf 6 group window. Double-click on the Interleaf 6 icon to start the program. In a moment, the
Interleaf 6 Desktop will appear on your screen. Refer to Figure 1–1 for the startup procedure.

**Note** Starting Interleaf 6 varies with the type of windows system your computer is using. This book will primarily address Interleaf 6 for Windows. Interleaf 6 for Motif is functionally equivalent to Interleaf 6 for Windows; however, when there is a difference, illustrations and commands peculiar to Interleaf 6 for Motif will be shown after Interleaf 6 for Windows. If you’re a Motif user, you’ll be happy to know that starting Interleaf 6 is one of only a few areas where there is a significant difference in the program.

### Interleaf 6 for Motif

On computers running Motif, Interleaf 6 is started by entering `ileaf6` at an operating system prompt. Operating system prompts are accessible in an X terminal window. Open an X terminal window. At the prompt, type `ileaf6` followed by the ENTER key. Select a license mode and options and then select the OK button. Refer to Figure 1–2 for the startup procedure.

**Note** If it is available, check out the Book Catalogs (now know as Network Style Sheets) license. This will allow you to use the style sheets included in the template provided on the companion disk. If a Network Style Sheets license is not available, you’ll still be able to use the template, but without the use of style sheets.

**Note** Unless you’re using node locked licenses, you’ll be given a dialog box asking you to check out a license. Checking out a license includes selecting both a license mode and license options. See your system administrator for a description of the licenses available at your site. If any of the licenses chosen are being used by other users on your network, the license manager will notify you that the licenses aren’t currently available. You’ll either have to select different licenses or wait until the licenses are available.
While Interleaf 6 is starting, you will see the startup screen.

If this is the first time starting Interleaf 6, you'll be asked to provide your name.

Figure 1–1. Starting Interleaf 6 for Windows from the Windows NT Program Manager
Type `ileaf6` followed by the ENTER key.

Select a license mode.

Select any optional features you want during this session.

Choose OK to continue with Interleaf 6 startup.

**Figure 1-2. Starting Interleaf 6 for Motif from a command prompt**

**BECOMING ACQUAINTED WITH THE DESKTOP**

Now that you have started Interleaf 6, you see the Interleaf 6 Desktop. The Desktop window is the main Interleaf 6 window. It shows you where your current work area is, gives you a method for interacting with container and file icons, and lets you organize your work much the same way you would organize the paper files in your office. Figure 1–3 shows the Desktop’s window as it appears when you start Interleaf 6 for the first time.
Minimizing the Desktop

You can work with the Desktop window open or minimized. To minimize the Desktop, click on the minimize button. When the Desktop is minimized, it will appear on your screen as an icon. To restore the Desktop to an open window, double-click on the icon. Take a few seconds to practice minimizing and restoring the Desktop.

Desktop Icons

The interior of the Desktop window contains icons representing directories and files. The directory icons, also known as containers, you’ll work with most are cabinets, drawers, folders, and books. The document is the primary icon you’ll use for formatting text and graphics. Other non-Inter-
leaf 6 files may appear within the Desktop as host file icons. The System6 and Clipboard are special icons used in Interleaf 6 and will be discussed in their own section later in this chapter. Figure 1–4 illustrates some of the common icons found within Interleaf 6.

**Note** Interleaf 6 containers are similar to the Folder icon you'll find in the Windows File Manager. Functionally, there is no difference between cabinets, drawers, and folders. They allow you to organize your work in a visual hierarchy much the same way you would file papers in your office: folders in drawers in a filing cabinet. The book is a special container that allows you to establish a relationship between the icons within the book. You use books primarily for large documents. You can create indexes and a table of contents within a book, and many people can work on different parts of a book at the same time.

**Creating Icons**

We're now going to practice creating a few icons. We'll begin by creating a folder. If your Desktop is minimized, restore it to an open window. At the top of the Desktop window you'll find a menu bar. Click your mouse on the File menu, click on New, click on Containers, and finally, click on Folder. Alternately, you can create the folder icon by pressing the mouse button with the cursor on the File item, and holding the mouse button down as you drag the cursor along the cascading menus. When you highlight the the choice you want (in this case Folder) release the button. In either case, a new folder icon will appear on your Desktop.

![Figure 1–5. Creating a new Folder icon](image-url)
Note For the remainder of this book, when I want you to choose a particular command, rather than state “Click your mouse on the File menu, click on New, click on Containers, and finally, click on Folder,” I’ll ask you to “Choose File→New→Containers→Folder.”

Tip You can also use mnemonics to choose a selection on a menu. A mnemonic is a single character associated with a menu item and is underlined in the menu text. If no pulldown menus are visible, pressing the ALT key followed by a mnemonic will activate a menu and the next mnemonic keystroke, or series of keystrokes, will choose a command. For example, to create a new folder you can type: ALT+F, N, C, and E (In Motif, the ALT key function may be performed by another key. On some computer keyboards, the function is performed by a key with a diamond on it.)

Renaming Icons

Now that you have created a new folder icon, the first thing you’ll want to do is give it a new name. Anticipating this, any newly created icon has its name highlighted so that you can begin typing the new name immediately. After you have typed in a new name, be sure to end the name edit by deselecting the name. You can deselect the name by clicking the mouse somewhere other than on the name being edited. Figure 1–6 illustrates the procedure for editing icon names.

Figure 1–6. Renaming icons
The selection of a desktop object's name differs between Windows and Motif. In Windows, when the name is selected it has a light background. In Motif, when the name is selected it has a dark background.

**Displaying File Names or Desktop Names**

The name you just typed is known as the desktop name. This name is different than the name given to the actual directory or file on your computer's file system. You may find it important to know the exact file system name of an icon, or you may need to ensure an icon has been given a specific file system name. If so, you can change the view of icon names from desktop names to file names. This will allow you to view the file name or edit the file name as described in the previous section.

*Figure 1-7. Changing the display of icon names*

To change the display from desktop names to file names, choose **View → File Names**. To change back to desktop names, choose **View → Desktop Names**. The action of changing between file names and desktop names can be seen in Figure 1-7.

*Tip* You can see both the desktop name and file system name in the title bar of any open container or file window.
Opening an Icon

Now that you have created and renamed a folder, let's see how to open it. If you click once on an icon it becomes selected. The name of the icon will highlight in black to indicate it is selected. To open an icon, you need to double-click the icon. For container icons, the default behavior is to open in the current window (except for a top-level book which will open in its own window). If you want to open in a new window, you'll need to hold down the SHIFT key while you double-click. Open My Memos in its own window by holding the SHIFT key while double-clicking. Figure 1–8 shows the selected icon and the open container window.

![Double-click on an icon to open it.](image)

**Figure 1–8. Opening a container icon**

Navigating Icons and Their Windows

While working with Interleaf 6, you may find that you have many container windows open on your screen. You'll find yourself in a situation where you'll want to move or copy a few documents to a new container. It would be great to have both container windows visible when you decide to move or copy documents, but that usually isn't the case. You need an efficient way to find containers and move files from one container to another. In this section, you're going to learn how easy it is. I'll first show you how to move from one window to another, and then how to copy documents from one container to another.

Finding Containers

In the previous section you created and opened the My Memos folder. You should still have that window open; if you don't, then open it now. On the menu bar you'll find GoTo. Click on GoTo once to display the menu. The entries on this menu change as you work with Interleaf 6—each time you open a new container its name gets added to the menu. The Desktop is always listed on this menu. Choose Desktop now to return to the Desktop window. Figure 1–9 illustrates the GoTo menu. You can try using the GoTo
menu from the Desktop window to return to the My Memos folder. When you have finished, return once again to the Desktop.

![Figure 1-9. Returning to the Desktop window](image)

**Tip** You can move to any directory on your computer’s file system by using GoTo→Pathname... and typing the pathname into a dialog box. If you want to move back to the parent container, use GoTo→..(Up a level).

Now that you have moved back to the Desktop, create a document icon. So far, you have seen how to use the menu along the top of the Desktop window to create a folder, and you can create a document the same way. But, I want to take this opportunity to show you another way to create a document.

**Warning** What I’m about to show you is for power users, those who want to be power users, and die-hard Interleaf 5 users who don’t want to give up Interleaf’s original interface. Yes, I’m talking about popup menus. If you feel you’re going to be overwhelmed by all of the different menus and choices, then forget I ever mentioned popup menus and skip to the next section. You can do (almost) everything in Interleaf 6 without popup menus, and you can come back and read this section when you’ve become more familiar with Interleaf 6.

With your mouse cursor inside the Desktop window, click the right mouse button or press and hold the right mouse button. You’ll see a popup menu. Popup menus have the most commonly used commands located on them so you can work faster by not having to move the mouse cursor to the top of a window each time you want to use a command. On this popup menu
choose **New → document** and a document icon will be created for you on the *Desktop*.

If you would like the practice, change the name of the document to *My document*. It's not necessary to change the name; we're just going to use the document icon for illustrating dragging and dropping icons.

![Image](image.jpg)

**Figure 1-10.** Creating a new document with a popup menu

### Dragging and Dropping Icons

Congratulations on making it this far, especially if you created a document with a popup menu! Really, popup menus aren't bad once you are comfortable with the regular menu items. You'll find them to be a tremendous time saver when you're using Interleaf 6.

Well, it's time to see how to move icons around in container windows. At this point you should be in the *Desktop* window with the *My Memos* folder and a document. To move an icon around in a window, you position your mouse cursor over the icon, press and hold the mouse button, and move the mouse. When the icon is where you want it to be, release the mouse button and watch it move. Try this now with the document icon.

To move an icon into another container, drag it until it is over the container icon. You'll know that it's targeted for the right container when the container highlights. Drop the icon by releasing the mouse button, and watch the icon disappear into the container icon. If you happen to have the container's window open, you'll see it reappear inside the container's window. Try this now with the document icon. Figure 1-11 shows the document icon...
being moved to another part of its container and then moved into the My Memos container.

If both the Desktop window and My Memos window are open and visible on the screen, you can also move the document icon from one window to another by dragging out of one window and dropping it into the other window.

Select the document, drag it to another place in the window, and release the mouse button. The document will move to a new position in the window.

Now select the document again, drag it over the folder. When the folder highlights, release the mouse button.

The document will disappear from the current window and will reappear in the folder's window.

![Figure 1-11. Dragging and dropping icons](image)

**Cutting Unwanted Icons**

Well, we're almost to the end of this first mini-session with Interleaf 6 so it's time to clean up the Desktop and get rid of unwanted icons. In the My Memos window, select the document you just moved there. Choose Edit→Cut to remove the icon from the window. Choose File→Close to close the My Memos window. Move to the Desktop window and cut My Memos by selecting it and choosing Edit→Cut. You may notice the Clipboard icon flash as My Memos disappears from the Desktop. That's because any object cut within Interleaf 6 goes to the Clipboard. Once in the Clipboard, the object is ready to be pasted somewhere else in the Interleaf 6 environment.

Now that we've removed unwanted icons, we have one more stop before our initial mini-session in Interleaf 6 is complete: the Clipboard and System6 cabinet.
The Clipboard and System6 Cabinet

The Clipboard and System6 cabinet are two special icons that are required for the proper operation of Interleaf 6. You won't spend much time working with them directly, but understanding their functions can help you use Interleaf 6 more effectively.

Clipboard

The Clipboard is the place where cut or copied objects are stored. Objects remain on the Clipboard until you paste them somewhere else in the Interleaf 6 environment, or delete them.

Pasting from the Clipboard

Open the Clipboard now and you will see the document and folder you cut while cleaning up your Desktop (see Figure 1-12). The My Memos folder is selected since it was the last object cut from the Desktop. All objects selected within the Clipboard are acted upon the next time you choose the Paste command in the Interleaf 6 environment. To see how this works, move your cursor into the Desktop window and choose Edit→Paste. My Memos will move from the Clipboard back onto the Desktop. Now Cut My Memos back to the Clipboard.

Tip Earlier, you moved an icon from one container to another by dragging and dropping it. Another way to move an icon when you don't have immediate access to both the source and destination containers is to use the Clipboard. Use Edit→Cut to temporarily store an icon on the Clipboard. Find and open the destination container, and Edit→Paste the icon into the destination container.
Deleting Objects on the Clipboard

Now that both *My Memos* and *My Document* are on the *Clipboard*, we want to remove them permanently from the Interleaf 6 environment using a **Delete** command. Deleting unneeded objects will help you reduce the clutter in your Interleaf 6 environment and free up the disk space consumed by the objects. It is a good idea to periodically clean up your *Clipboard*.

You can delete objects from the *Clipboard* in two ways: only selected objects, or all objects. To delete only selected objects, first select those objects you want to delete, and then choose **Delete→Selected**. To delete all objects on the *Clipboard*, first deselect any selected objects by clicking the mouse on an empty area within the *Clipboard*, then choose **Delete→Delete All**. In either case, you'll be given a dialog box asking you to confirm the deletion. Figure 1-13 shows the **Delete→Delete All** command.

**Warning** Objects that you delete from the Clipboard are gone forever. Make sure the objects are no longer needed before confirming the delete operation.

![Figure 1-13. Deleting objects from Interleaf 6](image)

After you have deleted the objects, you can close the *Clipboard*.
Tip You can delete objects and bypass the Clipboard altogether by selecting an object and choosing the Edit→Delete command. Bypassing the Clipboard with the Delete command can return the mouse cursor to you much sooner than using the Cut command. The Cut command takes longer because it must physically move the cut objects to the Clipboard instead of just removing them from the disk.

System6 Cabinet

The System6 cabinet provides storage for many items important to your Interleaf 6 environment, such as choices that appear on the File→New submenu and the Custom menu. Containers holding sample documents, clip art, and site-specific information set up by your system administrator may also appear in the System6 cabinet.

Open your System6 cabinet by double-clicking on its icon, and you’ll see some of the contents mentioned above (Figure 1–14). One of the objects we’ll investigate further is the Create cabinet.

Create Cabinet

The Create cabinet holds the different items that appear on the File→New submenu. Open the Create cabinet and look at the different icons it contains (see Figure 1–15). Each file icon (e.g., document) represents a choice on the File→New submenu. Each container icon (e.g., Filter Templates) represents another submenu, with the container’s contents becoming the submenu choices. You, or your Interleaf 6 administrator, can alter the objects within the Create cabinet to change the choices on your File→New submenu.

Figure 1–14. Contents of the System6 cabinet
Warning Unless you're absolutely sure of what you're doing, don't alter or remove any icons within the Create or System6 cabinets or you could adversely affect your Interleaf 6 environment.

Figure 1-15. Contents of the Create cabinet and corresponding choices on the File→New submenu

Tip In Figure 1-15 you may have noticed that some of the icon names are in italicized text. This is an indication to you that the icon represents a link to another file or directory on the computer's file system. Specifically, look at the document that is selected. It is a link to a file with a pathname of: ..\i6home.i$$\commocab\Creatcab\document.doc. The pathname of the selected document is visible in the message bar along the bottom of the Create window.

You can now close your Create and System6 cabinets and return to the Desktop.

QUITTING Interleaf 6

You're just about to complete this first mini-session (and this first chapter). All that's left is to learn how to quit Interleaf 6. To quit Interleaf 6, choose File→Exit and Confirm that you want to quit on the dialog box. Any open windows and icons belonging to Interleaf 6 will be removed from your screen. If any of the open windows are documents with unsaved changes, you'll be given an opportunity to save the changes before Interleaf 6 quits. If you change your mind about quitting (or if you want to go on to the next
chapter and learn about documents now), then you can choose Cancel on the dialog box instead.

**Figure 1-16. Quitting Interleaf 6**

**SUMMARY**

In this chapter, you learned some basics about the Interleaf 6 environment. You learned how to start Interleaf 6, and you became acquainted with the *Desktop* and the types of objects it contains. You learned how to create, rename, move, cut, and delete desktop objects. You were made aware of the importance of the *Clipboard* and *System6* cabinet to the Interleaf 6 environment. Finally, you learned how to quit Interleaf 6.

The next chapter will explore the Interleaf 6 environment in more detail by describing the most important desktop object: an Interleaf 6 document.
CHAPTER 2
What Is a Document?

This chapter describes a document. After a brief introduction to an Interleaf 6 document, you'll visually explore the structure of a document. You'll see how Interleaf 6 views the structure of a document, and an Interleaf 6 document will be compared with a clothes closet (you will be required to use your imagination). You'll finish this chapter by learning about the objects that provide structure in an Interleaf 6 document, and you'll learn the difference between masters and instances of objects.

BECOMING ACQUAINTED WITH A DOCUMENT

The document is the main object you'll work with in Interleaf 6. All of the text and graphics you create will be contained within a document. In the previous chapter, you took a tour of the Desktop. It's time now to become acquainted with a document.

Creating a Document

Start Interleaf 6 if it isn't already running. Create a new document by choosing File→ New→ document on the Desktop menu (see Figure 2–1).
Opening a Document

Before you can work on the contents of a document, you must open it. Documents are opened just like container icons are opened—first select it, and then choose File→Open, or double-click the mouse on the document icon. Unlike containers where you have a choice of opening the container in the current window or in a new window, all documents open in their own window.

The Document Window

The document window is the main work area in Interleaf 6. Any text or graphic you place on a page is put there through a document window. Figure 2–2 shows a document window for the document you just opened. At a glance, a document window shows you the structure and content of a document. The document window gives you a method for navigating within a document and access to the tools required for creating and editing text and graphics.

The main parts of a document window are a menu bar, tool bar, document rulers, component bar, text and graphics area, page controls, and status
bar. You will become more familiar with the parts of a document window as you work with documents in the following chapters.

![Diagram of document window parts]

**Figure 2-2. The document window**

**Minimizing a Document Window**

You can minimize a document window just like you can minimize the Desktop or other container windows. However, when a document window is minimized, you can't edit the document. When you find yourself working with multiple documents simultaneously, being able to minimize a document's window is a very handy feature for managing your working environment.

Now would be a good opportunity for you to practice minimizing a document window. Figure 2–3 shows a document window before and after it is minimized.
Note When you minimize a document window, all tools and tearoff menus (available in Motif only) associated with the document are also removed from your screen. Later, when you restore the document’s window, the tools and menus open when you minimized the window will be restored.

Closing a Document

Closing a document window is similar to closing container windows—choose File→Close on the document’s menu bar. If you haven’t made any changes to the document, the window will close without any further input from you. However, if you did make changes that haven’t been saved, you’ll be asked by Interleaf 6 what you want to do with the document. Figure 2–4
what is a document? 2-25

shows a dialog box giving you four choices: Save, Hold, Cancel, or Close. Table 2-1 describes these choices. You'll get a chance to work with these choices again in Part II of this book.

Table 2-1. Possible Choices for Closing a Modified Document

<table>
<thead>
<tr>
<th>Choice</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save</td>
<td>Saves any changes you have made. Choose this if you want the changes to become permanent.</td>
</tr>
<tr>
<td>Hold</td>
<td>Hold your changes in a work-in-progress version of the document. Choose this when you're in the process of revising a document, but want to keep an original version of the document until you've finished with the document revisions. The next time you open the document, you'll be working with the work-in-progress version.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Cancels a document close. Choose this if you decide not to close the document and want to leave it open.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes a document without saving any changes. Choose this if you don't want any of the changes saved with the document. If you choose this, any changes that you have made will be lost.</td>
</tr>
</tbody>
</table>

documents are structured information

Now, I wish to digress for a few pages and talk about what documents are and how Interleaf 6 views a document. It's important for you to understand this if you're to work effectively with Interleaf 6.

So just what is a document? Memos, letters, and reports are documents. The book you're reading is also a document, although a rather long one. Documents aren't limited to paper, either. Today, you can learn about dinosaurs or outer space, consult medical references, and perform research in an encyclopedia with documents displayed on your computer. What all of these documents have in common, whether paper or electronic, is they contain structured information.

What Is Structured Information?

Structured information is data in the form of text and graphics (and in some cases, animation and sound) that is organized in a logical fashion to
convey meaning. A letter is one type of document that has a well known structure: date, sender’s address, recipient’s address, salutation, body consisting of paragraphs, closing, and signature. A report is another type of document that has a structure: title, subtitle, author, summary, and a body which may consist of sections and subsections. A well structured document allows a reader (or a computer) to find specific information quickly and easily.

**Inferring Structure from Document Design**

We often look at a document and infer its structure from the document’s design. For example, Figure 2-5 shows the first page of a fictitious typewritten report. Visually, we can interpret the report’s structure. The title of the report appears at the top of the page. Below the title is the name of the report’s author; and below that, the report’s subtitle. Following the subtitle is the report’s summary. The main body of the report follows the summary. Each section of the report body is started with a numbered heading and contains any number of paragraphs. But this isn’t the only way a report can be presented.

![Figure 2-5. Structure of a typed report]
Figure 2-6 shows the same fictitious report, only this time it is typeset. The appearance is vastly different, but you can still infer the same document structure. In fact, some of you will find it much easier to see the report’s structure in the typeset copy than in the typewritten copy—design is important for conveying document structure and meaning.

**Designing Documents Is Expensive**

In the typewritten report, the typist has to spend a significant amount of time planning the design of the document as he types the information—he has to decide when to end a line and start a new one, or how much spacing to put between paragraphs or between paragraphs and headings. Things have improved with word processors and electronic typesetters, but even a typeset document can require a lot of time specifying the design of the information before the final document is produced.

Timely delivery of documents is critical to the success of many businesses. Spending time formatting a document means less time is available to add information to the document. Wouldn’t it be great to have a tool that allowed authors and typists to concentrate on adding structured information to a document, rather than spending time learning how to format, and
actually formatting a document? Of course, the answer to that question is yes; and such a tool does exist. It’s called Interleaf 6.

**Interleaf 6 Lets You Concentrate on Information**

Interleaf 6’s approach to document creation is to treat a document as structured information. This allows you to concentrate on entering information into a document’s structure, rather than trying to design and format the information to create a structure. Sure, Interleaf 6 allows you to design and format documents, too. But Interleaf 6’s power is that it allows you to separate the function of assembling information from varied sources to create a document from the functions of designing and formatting a document. I hope to make this clearer in the next section.

**The Structure of Interleaf 6 Documents**

Let’s take another look at the fictitious report shown in Figure 2–6. This report is shown in an Interleaf 6 document in Figure 2–7. If you wish to see this report for yourself on your Desktop, create a Report1 document by choosing File→New→Samples→Report1, and then open it.

>Note The sample documents are only available if installed by your Interleaf 6 administrator.

Interleaf 6 presents the contents of the report in the text area of a document window the same way it will print on paper (this is known as WYSIWYG—what you see is what you get). If you look along the left side of the document window you see something that doesn’t get printed on paper: the document’s component bar.
The Component Bar Is Like a Closet Rod

Interleaf 6 documents are like clothes closets. Think of a clothes closet for a moment. It is designed to store clothing. The closet rod holds all of the clothes that go into a closet. Hangers, garment bags, shoe bags, and tie racks hold clothing that hangs on the closet rod. Each is designed to hold a certain article of clothing. Each item you hang on a closet rod is hung in a certain order, has a relationship to the other items hung on the closet rod, takes up a certain amount of space, and holds its article of clothing in a certain way. Without the closet rod and hangers, your clothes would lie in a heap at the bottom of the closet.
A document is analogous to a clothes closet, with the component bar being the closet rod and components acting like hangers, garment bags, shoe bags, and tie racks. Without a component bar and components, a document's information would lie in an unrecognizable heap at the bottom of the document. Just as hangers, garment bags, shoe bags, and tie racks are designed to hold different articles of clothing, components are designed to hold different pieces of information.

Figure 2-8. A document is like a closet

Components Are the Hangers

Look again at Figure 2-7 and see the different component names in the component bar. At the top of the component bar is a component named title. As the name suggests, it holds the title of the report. The next component is author and it holds the name of the report's author. Throughout the rest of the report, the information contained in the report is held in appropriately named components: the report's subtitle is held in a subtitle component, section headings are held in headnum components, and section text is held in paragraph components.
Just as you wouldn't hang a suit on a tie rack, you wouldn't want to place the report's title in a paragraph component. You hang clothes on items designed to hold them and you don't worry about how the clothes are hung. Likewise, you put information into components that are designed to hold them and you don't worry about how to format them—the formatting is taken care of automatically by the properties assigned to the component. So while working with Interleaf 6, all you really need to remember is that your information should be held in the component that is most appropriate for the information.

Masters and Instances

An efficiently organized closet uses different items to hang and store clothing. Likewise, a well-designed document template will contain most, if not all, of the component definitions you need to assemble your information into documents. In addition to components, documents contain other objects for assembling information. The object definitions in a template are known as master objects.

Master Objects

Master objects are stored with a document and are used for creating new objects. To see the types of objects available in the Report1 document choose Edit→Create on the document's menu bar. A dialog box like the one shown in Figure 2–9 will appear, showing you the types and names of all masters in the document.

**Note** If the sample documents were not installed by your Interleaf 6 administrator, you can use a regular document (File→New→Document) to follow along.

Click on the Components button to see all of the component masters available. Click on the Frames button and the list of masters will change to show all of the different frame masters available.

Master objects control the default text properties, format, content, and tab settings of newly created objects in a document. Each time you create a new object, Interleaf 6 consults the master object definition of the same name and creates a new object with all of the same properties. This new object is known as an instance of a master.
You can try this for yourself by creating a few different components in the report. You can create a new component by selecting the name of the component in the name list and clicking the Create button.

![Image of Create Report dialog with options for Components, Tables, Inlines, Frames, Page Numbers, List, Local (All), Author, Bullet, Footnote, Header Left, Footer Left, Header Right, Header Center, Footnote Center, Page Rule, Inline, Unnumbered, Numbered, Full Page, and Help.]

**Figure 2-9. Master objects in the Report 1 document**

**Instance Objects**

You’ll enter text and graphics into these instances, and you may occasionally modify some properties of the instance so that it is different from its master. But as long as an instance has the same name as a master, it will always maintain a relationship with the master. In Part II of this book, you will have a chance to create many different types of instances and you will see how to make changes to instance properties.

**Instances of Masters**

If you’ll permit me to return to the components are hangers analogy, think of a list of masters as a closet supply catalog showing all of the different types of hangers available for purchase. When you decide upon the hanger you want, you purchase it and bring it home. When you hang it on the closet rod it becomes an instance of the hanger shown in the catalog. It has all of the same properties as the master. Likewise, when you use a master object in a document, you have created an instance object. See Figure 2-10 for an illustration of this point.
Variations of Masters

When an article of clothing keeps falling off a hanger, you might decide to use a clothes pin to hold the clothing; thus, modifying the hanger. By attaching a clothes pin to the hanger, you have changed some of the hanger's properties; but it is still recognized as a hanger. You have created a variant hanger. You can also modify some properties of instance objects and create variant instances.

There is nothing wrong with occasionally using a variant hanger or a variant instance of an object. However, if you find yourself using the same variation often, you should find a different type of hanger or object to suit the job. For your closet, you'll need to thumb through the closet supply catalog and hope you can find the perfect hanger. In a document, search the master object list. If the right object doesn't exist, you can create a new one. In a very simple fashion, this is how document masters and instances work.

You have now finished with all of the documents you created and opened in this chapter. Close any open documents now. If you want to delete them, do that now, too. When you have finished with that, you can quit Interleaf 6.
**SUMMARY**

In this chapter you learned about documents. You created, opened, and closed a document. You visually inspected a document to infer its structure. You learned that Interleaf 6 looks at documents as structured information, and how this frees you to concentrate on the information in a document rather than on its formatting. After being shown how an Interleaf 6 document is like a closet, you may never look at documents (or closets) the same way again. Finally, you learned about masters and instances of objects.

In the next chapter, you’ll build upon the knowledge you have gained so far as you begin to create and work with documents.
Part II
Creating Beautiful Documents Without Trying

Part II will show you how to create beautiful documents using a pre-existing template. Using a template will allow you to concentrate on information structure rather than text format. You'll begin by creating a new document, and after you see how easy that is, you'll do more editing using some existing documents. Next, you'll learn to print the documents you create. You'll learn to include illustrations and create text references to them. You'll also learn to create tables. After you complete these document basics, you'll learn to use Interleaf 6 books for longer documents. With books, you'll get a chance to create a table of contents and an index.

Setting the Stage for Part II of this Book

You have been assigned to the documentation department of a software company that designs and manufactures database software for bowling leagues and tournaments. Your department is responsible for user's guides describing the use of the software. Your job is to take information from different writers and artists and assemble it into a final document.
CHAPTER 3
Creating a Document

This chapter presents information on creating a simple document. You'll create and open a new document. You'll enter text that will be formatted automatically as you type. You'll learn to delete and replace text. You'll also learn to move and copy text to other areas of a document. You'll learn how to format selected areas of text. Finally, you'll learn to save and close a document.

INSTALLING THE USER GUIDE TEMPLATE

Congratulations on your new job assembling user's guides for your software company. You'll be building the documentation for your company's latest program called GO! Bowl. Your company expects you to use its standard template for this user's guide. The User Guide template can be found on the companion disk and will be used with the examples given in the rest of this book.

An installation program has been provided on the disk. The installation program is written in Interleaf Lisp, so you must have Interleaf 6 started to run the program. When you run the installation program, the User Guide template will be extracted from the disk and put into the Create cabinet on your Desktop.
**Note** Interleaf Lisp is a built-in programming language that comes with Interleaf 6. With Interleaf Lisp, you can add powerful capabilities to your documents, or create additional programs to improve your working environment.

To run the install program, you'll need to open a window to the disk.

**Opening a Window to the Companion Disk**

Perform the procedure in Figure 3–1 to open a window to the User Guide disk. After the window is open, you can run the install program.

**Running the Install Program**

Now that you have the contents of the companion disk displayed in a window, you're ready to run the install program. See Figure 3–2 for the procedure.

**Accessing the User Guide Template**

The template has been installed, and it is now available on the File→New menu. Figure 3–3 shows how the template might appear on your menu. To access any object in the template—as well as any object that was included on the companion disk—you will click on File, click on New, and then click on Inside Interleaf with the mouse. The submenus below Inside Interleaf represent everything included on the companion disk.

For a description of the User Guide template, including its structure and the objects defined within it, see Appendix A.
Insert the disk into the drive.

If you're using Motif

Mount the disk as a PC file system. You will need to be the super user to mount the file system. See your system administrator for assistance.

If you're using Windows

Choose **Goto**→**Pathname**...

Type in the pathname to the disk, for example `a:\` if the disk is in drive A:. For Motif, the pathname should be set to the mount point for the PC file system. Click on **GoTo**.

**Figure 3-1.** Opening a window to the companion disk
Select the install Lisp icon and choose Tools→Load.

Choose Install to proceed with the installation.

Choose Continue.

Return to the Desktop using GoTo→Desktop. Remove the disk from the drive. On Motif, unmount the disk and then eject it. See your system administrator if you require assistance.

**Figure 3-2.** Running the install program

**Figure 3-3.** Accessing the User Guide template on the File→New menu
Creating and Opening a Document

In this chapter, you are going to create a document from the User Guide template. The document you will work with is called start. To create it choose File → New → Inside Interleaf → User Guide → Body → Part → Chapter → start (see Figure 3-4). The start document will be created on your Desktop.

Whew! That was a very long menu for creating a start document. If you’re wondering if there is a better way to create the start document the next time you want one, there is. You can use a link to the start document to make it appear sooner on the File → New menu. If you are interested in creating such a link, you’ll find information on creating the link in Appendix B.

Well, now that a new start document has been created on your desktop, change the name to Introduction, and then open Introduction by double-clicking on its icon. You’re ready to begin entering text into the Introduction document.

Entering Text

When you open the document, you’ll see in the component bar a single component, h:chapter. The h:chapter component contains the start of a chapter, as well as the chapter title. The structure of the h:chapter component will become clear as you work through the other chapters in this part of the book. For now, you are just interested in entering text for this chapter. You’ll begin by typing the title.
Enter the Chapter Title

The words *chapter title*, which already appear in the document, are contained within inline components. Inline components have many of the same properties as top-level components (components that are displayed in the component bar), but are used within other components to add additional structure and formatting of the information they contain.

Think of the inline component as a single hanger within a clothes bag that is hanging in your closet. The clothes bag has only one attach point to the closet rod, but may contain many hangers within it. The \texttt{h:chapter} component attaches the chapter title information to the document through the component bar, and contains a number of inline components. You can see the inline component markers on either side of \textit{chapter title}. Figure 3–5 shows the document zoomed to 200 percent to make it easier to see the inline component markers.

\begin{figure}
\centering
\includegraphics[width=\textwidth]{figure3-5.png}
\caption{Selecting the old chapter title}
\end{figure}

You want to change the chapter title to \textit{Introduction}. Select the words \textit{chapter title} by placing the mouse cursor to the left of the word \textit{chapter} but inside (to the right of) the inline component marker. Press the mouse button, and while holding the button down, drag the mouse to the right until
both words are highlighted. Be careful to stay within the inline component markers when selecting the text. Type in the word *Introduction*. When you first begin typing, the selected text will be deleted. As you type, the text caret will move to the right, leaving behind the stream of characters you have typed. When you have finished, your document should look like Figure 3–6.

![Figure 3-6. The chapter title after its change](image)

**Creating a Section**

Now that you have changed the chapter title, you're ready to create the first section of the chapter. Minimally, a section consists of a heading and a paragraph, and will be created below the chapter title. Ensure the current component insertion point, indicated by the horizontal bar, is below the `h:chapter` component. To do this, click the mouse in the component bar below the `h:chapter` component. The current insertion point indicates the location where Interleaf 6 will create the next component. Figure 3–6 shows the component bar insertion point located below the `h:chapter` component. You may also select a component to establish the current insertion point. New components will be created after the selected component.
Creating a Section Title

With the component bar insertion point correctly positioned, chose Create → Component... from the menu, or click on the Create button in the tool bar. This will bring up the Create dialog box (see Figure 3–7). Scroll through the list of components until you find an h:1 component. Highlight it, then select the Create button. A new h:1 component will be created in the component bar.

As described in the User Guide reference in Appendix A, the h:1 component will automatically contain the proper numbering for a first level component within a chapter. The automatic numbering is accomplished with an autonumber in the component prefix. A prefix is everything located to the left of the prefix marker (vertical bar) which indicates the end of the prefix. The content of a component prefix is shared among all components with the same name. In this case, all h:1 components have an autonumber in the prefix.

The title of this section is: The History of Bowling. Type the title to the right of the prefix marker. Figure 3–8 shows the Introduction document after you have created the section title.
If you accidentally type to the left of the prefix marker, all h:1 components will have The History of Bowling as part of the section title. You can easily fix this by deleting the text and repositioning the text insertion point to the right of the prefix marker.

Creating a Paragraph

Now that you have created the section title, you need to create the paragraphs within the section. Paragraphs are created with a p:0 component. The component caret should be positioned after the h:1 component. Using the Create dialog box, find and highlight p:0 and select Create. A p:0 component will be created at the current location in the component bar. Type the following paragraph without using any carriage returns—the text will automatically wrap to the beginning of the next line when the text reaches the right margin.

Bowling has been around since approximately 5200 B.C. Evidence to support this is an ancient version of a ball and pins in an Egyptian child's grave. Stone age man [as evidenced by the popular cartoon character
Fred “Twinkle-Toes” Flintstone also enjoyed the recreational activity of rolling rocks at other rocks. “Nine-pins,” where the pins are arranged in a diamond shape, became very popular as a recreational sport in the 1800’s in New York. Gamblers soon invaded the sport, and participation in “nine-pins” was banned. Being the enterprising people that Americans are, it wasn’t long before the ban was circumvented by adding another pin to the setup, and arranging the pins in the shape of a triangle. The game was renamed “ten-pins,” and is with us today.

While you typed in the paragraph, you may have noticed that the open double quote (“) was created automatically when you pressed the double quote key (” on the keyboard. This is because Interleaf 6 uses intelligent quotes to aid you as you type. Another character to notice is the true hyphen (-). The true hyphen is different from the hyphen you find on a typewriter (—) — it is really an en dash — and is created by pressing a special key sequence (ESC –) or choosing the character from the Create → Character submenu. Other special characters can be created using the Create Character dialog box which is opened by choosing Create → Character → Other....

You have another paragraph to type, so you’ll need to create a second p:0 component for the paragraph. You can do this by using the Create dialog box, but a faster way to do this is by pressing the RETURN or ENTER key when you reach the end of the paragraph. Any time you use the ENTER key in Interleaf 6, a new component identical to the current component is created. In fact, any time you use the ENTER key, the current component is split into two components at the current location of the text caret. After you have created a second p:0 component, type in the following paragraph:

Bowling has become a very popular recreational and sporting activity. In 1895, the American Bowling Congress was formed to standardize the rules and regulations of bowling. Today, the ABC is the principal organization sponsoring organized league and tournament bowling. According to rules created by the ABC, leagues and tournaments sanctioned by the ABC must keep accurate records of bowlers’ league and tournament participation and performance. That’s where our latest software product, GO! Bowl, can help you in your task as a league or tournament secretary.

Great! You are well on your way to completing this first chapter. Your document should now look like Figure 3–9.
1.1 The History of Bowling

Bowling has been around since approximately 5200 B.C. Evidence to support this is an ancient version of a ball and pins in an Egyptian child's grave. Stone age man (as evidenced by the popular cartoon character Fred "Wrinkle-Bes" Flintstone) also enjoyed the recreational activity of rolling rocks at other rocks. "Nine-pins," where the pins are arranged in a diamond shape, became very popular as a recreational sport in the 1800's in the New York Gambler's soon invaded the sport, and participation in "nine-pins" was banned. Being the enterprising people that Americans are, it wasn't long before the ban was circumvented by adding another pin to the setup, and arranging the pins in the shape of a triangle. The game was renamed "ten-pins," and is with us today.

Bowling has become a very popular recreational and sporting activity. In 1895, the American Bowling Congress was formed to standardize the rules and regulations of bowling. Today, the ABC is the principal organization sponsoring organized league and tournament bowling. According to rules created by the ABC, leagues and tournaments sanctioned by the ABC must keep accurate records of bowlers' league and tournament participation and performance. That's where our latest software product, GO! Bowl, can help you in your task as a league or tournament secretary.

Figure 3-9. Introduction document's contents

DELETING AND REPLACING TEXT

You can delete single characters by using the BACKSPACE and DELETE keys. If you want to change more than a few characters at a time, there are more efficient ways to delete and replace text. First, you must select the text you want to change. Text can be selected in a variety of ways: selecting words, sentences, paragraphs (and components), or ranges of text. It is easy to tell what text is selected, because it shows up highlighted on the screen. You can also select text by selecting one or more components in the component bar. When you do, the component name will be highlighted, but the text will not.
Deleting a Word

To delete a word, you must first select it. In the first line of the second paragraph, place the mouse pointer in the word “very.” Double-click to select the word and the spaces that follow it. By selecting the trailing spaces with a word, your document will maintain proper spacing after you delete the word. Figure 3–10 shows the selected text. Choose Edit→Cut from the document’s pulldown menu, and the word “very” will be removed from your document. The remaining text will automatically reformat. You can also use the Cut button on the text tool bar. Text that is cut is placed on Interleaf 6’s Clipboard.

![Figure 3–10. Double-clicking a word selects the word and trailing spaces](image)

Deleting a Paragraph (or Component)

Deleting an entire paragraph (or other type of component) is as simple as selecting the appropriate component and using the Cut button. You can try this by selecting a $p:0$ component in the component bar and then clicking on the Cut button. Click the Undo button to restore the paragraph. (More about Undo later.)

Deleting a Range of Text

Double-clicking selects a word, but you can select a range of text by dragging the mouse. Place the mouse pointer at one end of the text you wish to select. Now press and hold the mouse. Drag the pointer to the other end of the text. Once the range of text is selected, cut it.
Tip Another way to select a range of text is to position the text caret by clicking at one end of the range you wish to select. Then, while pressing the SHIFT key, click where you want the selection to end. Everything between the text caret and the second place you clicked will be selected. To select a range of text that doesn't appear on the screen at one time, use the scroll bar to make the end of the desired selection area visible and then SHIFT-Click.

Replacing Selected Text

You have seen how to delete words and ranges of text. Sometimes, after deleting the text, you will want to enter replacement text. To do this quickly, you can skip the clicking on the Cut button and just begin typing (you did this earlier when you entered the title for this chapter). All of the text you have selected will be replaced by the new text you type.

Undoing a Change

What happens if you change your mind about the text you just replaced? Well, you can use the Undo feature of Interleaf 6 to restore your document to its previous condition. To see how this works, select the second p:0 component in the component bar. After it is selected, click on the Cut button and watch the paragraph disappear from the document. To undo this change, choose Edit → Undo Cut from the document pulldown menu, or click on the Undo button in the tool bar.

After you use the undo feature, you'll notice changes besides having the paragraph reappear in the document—the Undo button changes into a Redo button (just in case you change your mind again). Clicking the Redo
button will again delete the paragraph from the document. You can also choose **Edit → Redo Cut** on the menu.

**MOVING AND COPYING TEXT**

Sometimes you might find that you want to move or copy text to different areas of your document, instead of just deleting it from the document. Moving and copying text begins just like deleting it—you must first select some text.

**Moving a Range of Text**

Moving text applies to any selected text, be it a word, sentence, or some other range of text. Once you have the desired range of text selected, you can drag it to another area of your document. To try this out, select the sentence in the second paragraph of the document that reads: “Bowling has become a very popular recreational and sporting activity.” (Make sure that you have selected the space following the sentence.) With the mouse over the selected text, press and hold the mouse button. As you begin to move the mouse, it will change to a pointer with an arrow head in one corner and the characters “abc” in a box attached to the arrow (see Figure 3–12). Drag this pointer to the beginning of the first paragraph and release the button. The sentence will move to the beginning of the first paragraph. Use the Undo button to restore the sentence to its original location.

**Note** When moving text, it is important to place the head of the arrow at the baseline of the text where you want the new text inserted. If you’re not careful, the text may end up a line above or below the intended location.
1.1 The History of Bowling

Bowling has been around since approximately 5200 B.C. Evidence to support this is an ancient version of a ball and pins in an Egyptian child's grave. Stone age man (as evidenced by the popular cartoon character Fred "The Flintstones" also enjoyed the recreational activity of rolling rocks at other rocks. "Nine-pins," where the pins are arranged in a diamond shape, became very popular as a recreational sport in the 1800's in New York. Gamblers soon invaded the sport, and participation in "nine-pins" was banned. Being the enterprising people that Americans are, it wasn't long before the ban was circumvented by adding another pin to the setup, and arranging the pins in the shape of a triangle. The game was renamed "ten-pins," and is with us today.

In 1895, the American Bowling Congress was formed to standardize the rules and regulations of bowling. According to rules created by the ABC, leagues and tournaments sanctioned by the ABC must keep accurate records of bowlers' league and tournament participation and performance. That's where our latest software product, GO! Bowl, can help you in your task as a league or tournament secretary.

Figure 3-12. Moving selected text

Moving a Component

Moving a component is similar to moving a range of text. Select the second component in the component bar. With the mouse over the selected component, press and hold the mouse button. Drag the component to another area of the component bar and release the button. Figure 3-13 shows the component moved to just after the chapter component. After you have practiced moving the component, use the Undo button to undo your changes.
Bowling has become a popular recreational and sporting activity around since approximately 5200 B.C. Evidence has been found in support of bowling in a stone age man’s grave. Stone age man’s grave character Fred “Mr. Twist-It” Flintstone also enjoyed bowling. In 1895, the American Bowling Congress was formed to set rules and performances. That’s where our latest software product comes in to assist you in your task as a league or tournament secretary.

1.1 The History of Bowling

In 1895, the American Bowling Congress was formed to set rules and performances. According to rules created by the ABC, a member of the ABC must keep accurate records of bowlers’ participation and performance. That’s where our latest software product comes in to assist you in your task as a league or tournament secretary.

In 1895, the American Bowling Congress was formed to set rules and performances. According to rules created by the ABC, a member of the ABC must keep accurate records of bowlers’ participation and performance. That’s where our latest software product comes in to assist you in your task as a league or tournament secretary.

Selected component before move.

Component after move.

Figure 3-13. Moving components

Copying a Range of Text or a Component

Copying text or components is similar to moving text or components; the difference is that you first press the CTRL key before you drag and drop the text or component. For example, you can quickly copy the words “American Bowling Congress” to the end of the second paragraph. To do this, select “American Bowling Congress.” Press and hold the CTRL key while you point to the selected text, press and hold the mouse, and drag the cursor to the end of the paragraph. You’ll notice that the mouse changes as it did for moving text (except now there are more than one box indicating a copy). When you release the mouse button, the selected text will be copied to the end of the paragraph and the original text is unchanged (see Figure 3-14).

An alternate method for copying a selection is to use the Copy and Paste buttons on the tool bar. After you have selected the text you wish to copy, click on the Copy button. A copy of the text is placed on the Interleaf 6 Clipboard. Now, position the text caret (or component insertion point, if you
copied a component) to the desired location. Click on the Paste button and a copy of the text (or component) will be pasted.

Press and hold the CTRL key while you drag the cursor to a new location.

Release the mouse button and the selected text is copied to the new location.

Bowling has become a popular recreational and sporting activity. Bowling has been around since approximately 5000 B.C. Evidence to support this is an ancient version of a ball and pins in an Egyptian child's grave. Stone age man (as evidenced by the popular cartoon character Fred “Fred the Flinstone”) also enjoyed the recreational activity of rolling rocks at other rocks. "Nine-pins," where the pins are arranged in a diamond shape, became very popular as a recreational sport in the 1800's in New York. Gamblers soon invaded the sport, and participation in "nine-pins" was banned. Being the enterprising people that Americans are, it wasn't long before the ban was circumvented by adding another pin to the setup, and arranging the pins in the shape of a triangle. The game was renamed "ten-pins," and is with us today.

In 1895, the American Bowling Congress was formed to standardize the rules and regulations of bowling. According to rules created by the ABC, leagues and tournaments sanctioned by the ABC must keep accurate records of bowlers' league and tournament participation and performance. That's where our latest software product, GO! Bowl, can help you in your task as a league or tournament secretary.

In 1895, the American Bowling Congress was formed to standardize the rules and regulations of bowling. According to rules created by the ABC, leagues and tournaments sanctioned by the ABC must keep accurate records of bowlers' league and tournament participation and performance. That's where our latest software product, GO! Bowl, can help you in your task as a league or tournament secretary. American Bowling Congress

"LOCAL" TEXT FORMATTING

Earlier I mentioned that as you type text into a component, it will automatically take on the default formats defined for the component. However, there may be times when you want to override the default format for some, but not all, of the text in the component. I call this "local" text formatting because it only applies to selected text and not globally to all text in the component. So what can you change with local formatting? Well, just about anything: bold, italic, underline, font family, font size, text color, and more.
Changing Text Properties

Let's apply local text formatting to some of the text we have written so far. Select “GO! Bowl” in the second paragraph. We want to change the formatting of these words because it is the title of our program and we want it to stand out. With the text selected, we can easily change the font family or point size; bold, italic, and underline formats; or add revision bars, since these items appear on the tool bar (see Figure 3-15). But if you want to change more than these items, you need to use the Text Properties dialog box. You can bring up the text formatting dialog box by choosing Properties→Selection... or Properties→Text... from the document pulldown menu. You can also click on the Properties button. Either way, the Text Properties dialog box will be displayed (see Figure 3-15).

Figure 3-15. Text Properties dialog box and text properties on tool bar

As you can see from the Text Properties dialog box, you can change many formatting properties of the selected text. (By the way, the Text Properties dialog box also shows you the properties of currently selected text.) We want to change the selected text, “GO! Bowl,” to italic, and we want to
change its color to the same shade of blue being used elsewhere in the document. Click on the Italic check box to turn italic on. Click on the color button and choose blue from the Color dialog box. Click the Apply button and “GO! Bowl” will change to italic and blue. You can click Close to dismiss the Text Properties dialog box.

**Tip** The button labeled *Use Component Defaults* will allow you to quickly change selected text back to the default properties of the component. This is very useful when moving or pasting text from one type of component to another (since the text that is pasted will retain its original formatting).

**SAVING AND CLOSING A DOCUMENT**

You have done quite a lot of work on editing the *Introduction* chapter of your first user’s guide, and you want to save this work, because it is time to take a break. Well, saving and closing your document are probably the easiest and one of the most important things you can do. Choose **File → Close** from the document pulldown menu. Since you have made edits to the document, you will be given a message box asking you what you want to do with these changes (see Figure 3–16). Click on Save to save your work and close the document.

![Figure 3–16. Message box for closing a modified document](image-url)
If you want to save your work, but leave the document open, you can choose **File → Save** from the document menu, instead. You can also click on the Save button in the tool bar.

**SUMMARY**

In this chapter, you installed the template from the companion disk and used it to create your first document for a new user guide. You learned how to choose components—the hangers for information—and enter text into them. You learned that a component takes care of automatically formatting the text you type into it. You learned how to delete, replace, move, and copy text. When necessary, you learned how to override the default text formatting properties of a component to apply “local” text formatting.

In the next chapter, you’ll expand your knowledge of editing with Interleaf 6 and see how you can work with existing documents.
CHAPTER 4

More Document Editing

This chapter describes some additional editing features you can use within an Interleaf 6 document. You'll use Interleaf 6's ability to add other documents to the document you are working on, even if that document is a non-Interleaf 6 document. You'll see how changing component types allows you to change text formatting. You'll learn how to apply widespread changes in a document. You'll learn some basics about controlling pagination in a document. After editing the document, you'll use the spelling checker to check and correct document spelling.

INTEGRATING OTHER DOCUMENTS

After completing the last chapter, you are well on your way to creating a User Guide for the GO! Bowl program. However, you still have a big task in front of you before the documentation is complete. But, don't worry! You don't have to type in all the text and graphics in a document. In fact, people in other departments of your company have been writing many parts of the User Guide, and all you have to do is bring their text into the documents you are working on. Some of the other departments are using Interleaf 6, just like you. However, there are others departments that have standardized on different word processors, like Microsoft Word and WordPerfect, and you need to be able to use their text as well.
Before you begin this chapter, you'll need to open the *Introduction* document you started in the last chapter. What!? You didn't save it? Well... Okay, because a completed *Introduction* document can be found on the **File**→**New** menu. So, if you don't have an *Introduction* document, you can create one by following the procedure shown in Figure 4-1.

**Figure 4-1. Creating an *Introduction* document**

### Using Other Interleaf 6 Documents

The program management department has done some work for the *User Guide* using Interleaf 6. Their completed document is ready for you to use in your *Introduction* document. Create the program management document by following the illustration shown in Figure 4-2.

**Figure 4-2. Creating the program management document**

The program management document, *PGM_MGT*, was created with Interleaf 6 using the same template you are using to create the *User Guide*. You're not going to use the entire *PGM_MGT* document in your *User Guide*, because you know that the program management group often includes information that no user would ever want to read. So, you are going to pick and choose the items you want to use.
Working with Multiple Documents

Since you are going to pick and choose the information you want to incorporate into your User Guide, you need to be able to work with both documents at the same time. Interleaf 6 allows you to have multiple documents open. Open both the Introduction and PGM_MGT documents (by double-clicking on each of them). You’re going to work with both of the windows open; however, any time you are working with multiple documents, you can minimize some of the document windows to reduce the clutter on your screen.

Copy Specific Items

After you have looked at the PGM_MGT document, you have determined that you want everything but the first component and the last section, which asks the question, “What did it take to create this program?” You don’t think the users want to, or care to, know the details, so this section will

| Figure 4–3. Selecting unwanted items at end of document |
not be included. You want to select everything else (except the first component) and place it into your *Introduction* document.

In the *PGM_MGT* document window, scroll to the end of the document and position the component caret just before the *h:1* component starting the unwanted section (see Figure 4–3). Choose **Edit → Select → To End** to select all of the components from the current point in the component bar to the end of the document. Cut the selected components from the document. Scroll to the beginning of the document and position the component caret between the *h:chapter* and the *h:1* component. Again, select all components to the end of the document as you did before. This time, however, you will copy these components to the *Introduction* document.

If your screen is large enough to view both the *PGM_MGT* and *Introduction* documents at the same time, you can drag the selected components with the mouse from the *PGM_MGT* window into the *Introduction* window. (You could resize the windows so that the component bars of each document are visible.) If both document component bars aren’t visible, click the Copy button in the *PGM_MGT* window to copy the selected components onto the Interleaf 6 *Clipboard*.

Move to the *Introduction* window, ensure the component bar caret is at the end of the document and active, and click the Paste button. When you paste in the information, Interleaf 6 may give you a notice (shown in Figure 4–4), stating that some information in the pasted items will be overridden by information already in the document. Since both documents you are joining come from the same template, it is okay to confirm.

![Figure 4-4. Interleaf 6 wants to be sure you’re not going to lose information](image)

**Warning** When you drag and drop components from one document to another, you will not be given any chance to confirm the operation. If you change your mind, you can use the Undo command in each document.
Interleaf 6 automatically adjusts the heading numbers to the correct values. This is a feature of Interleaf 6 autonumbers, and because both of the documents you combined used the same document template (consequently, the same autonumber streams) when they were created. (More about autonumbers later.) Your results should look like Figure 4-5. You have successfully included parts of another Interleaf 6 document into your own!

1.1 The History of Bowling

Bowling has become a popular recreational and sporting activity. Bowling has been around since approximately 5000 B.C. Evidence to support this is an ancient version of a ball and pins in an Egyptian child's grave. Stone age man (as evidenced by the popular cartoon character Fred "Bedford-ber" Flintstone) also enjoyed the recreational activity of rolling rocks at other rocks. "Nine-pins," where the pins are arranged in a diamond shape, became very popular as a recreational sport in the 1800's in New York. Gamblers soon invaded the sport, and participation in "nine-pins" was banned. Being the enterprising people that Americans are, it wasn't long before the ban was circumvented by adding another pin to the setup, and arranging the pins in the shape of a triangle. The game was renamed "ten-pins," and is with us today.

In 1895, the American Bowling Congress was formed to standardize the rules and regulations of bowling. According to rules created by the ABC, leagues and tournaments sanctioned by the ABC must keep accurate records of bowlers' league and tournament participation and performance. That's where our latest software product, GO! Bowl, can help you in your task as a league or tournament secretary.

1.2 Setting Up

You install GB on your computer using the program SETUP.EXE. The Setup program install GB itself, Help files, sample files, and other product components from the distribution disk to your hard disk.

Figure 4-5. Pasting specific components from PGM_MGT to Introduction
Note When a region is active, it is the target of any actions resulting from clicking buttons on the tool bar. You can tell if a region of a document (component bar or text area) is active by looking at the highlighting of the component caret, selected components, text caret, or selected text. In Figure 4-5, the component bar is active, because the selected components have a black (solid) highlighting. The text area is inactive and can be seen by the gray (patterned) highlighting of the text caret. Clicking on the Cut button with the component bar active will cut selected components (not selected text) from the document.

Using Non-Interleaf 6 Documents

The marketing department uses Microsoft Word and has prepared some information for your User Guide. They have saved their text in Microsoft Word Rich Text Format (RTF). It just so happens that their document was installed in your Create cabinet when you installed the companion diskette.

Create the Marketing Document

Because the marketing document is in the Create cabinet, you can choose File→New→Inside Interleaf→Exercises→marketing to place it on your Desktop. Once created, you'll notice that its icon looks a little different than a standard Interleaf 6 document icon (see Figure 4-6). This lets you see at a glance that Interleaf 6 has recognized the document is an RTF file.

Figure 4-6. Creating the marketing department document.

Interleaf 6 will automatically convert the RTF file from the marketing department into Interleaf 6 components when you copy the RTF file into your document. To see how this happens, drag the RTF file into the component bar of your document just prior to the Setting Up section of the docu-
ment. After a few seconds (while Interleaf 6 is converting the file) the text created by the marketing department becomes a part of your document (see Figure 4–7). The component names of the new text don't match the component names in your document, but we'll see how we can change that—and get the text properly formatted—in the next section.

![Figure 4-7. Incorporating the marketing department RTF file](image)

**CHANGING COMPONENT TYPES**

The marketing department document you just pasted contains components named head, subhead, and para. These components are not in use
in the *Introduction* document, so they need to be changed into the right components.

**Tip** The names of these components come from Microsoft Word styles. Using Word templates with the same names as Interleaf 6 components can really simplify the task of assembling documents.

### Changing Single Components

Select the component named *head*. Choose **Properties → Selection...** from the document pulldown menu to display the Component Properties dialog box. Click the More button to access a menu and choose **Convert to...**. A Convert dialog box is displayed. Scroll through the list of components until you find *h:1* and select it (see Figure 4–8). Click **Convert**. The

![Component Properties for head - Introduction]

![Convert - Introduction]

**Figure 4–8.** Changing a component
head component has now become an h:1 component, with proper numbering and formatting applied.

Select the first subhead component to change it into an h:2 component. This time, however, instead of using the Change dialog box, use the following keystrokes: Press CTRL-N (currently on Motif, it is CTRL-C); the status bar is updated to show you are changing the name of a component. Use the ↑ and ↓ cursor keys to scroll through the names until h:2 is displayed in the status bar. (You could press H to display a component whose name begins with h or H, and continue to press H, repeatedly, until h:2 is displayed.) When the right component name is displayed, press the ENTER key to change subhead to an h:2 component. Figure 4–9 shows this procedure. If

![Figure 4-9. Changing components with keystrokes](image)


2. Choose component name using ↑ and ↓.

3. Press ENTER to change component. Status bar shows change.
you decide you don't want to change the component, press the ESC key to abort the change.

**Changing Multiple Components**

You could select and change each component individually, but you have better things to do with your time, so change groups of them all at once. Choose **Edit → Select → All of**... from the document pulldown menu (see Figure 4–10). This displays a Select dialog box. Scroll through the list of components, choose `para`, and click Select.

![Select dialog box](image)

**Figure 4–10. Selecting multiple components**
All of the *para* components will be selected. You can now change these components to *p:0* components by bringing up the Convert dialog box like before. An alternative to the Convert dialog box is the Change dialog box. The Change dialog box is easier to get to than the Convert dialog box (which is only accessible through the Component Properties dialog box), but it is only found on a popup menu. To open the Change dialog box, position the mouse cursor in the component bar and press and hold the right mouse button. Choose **Change...** from the popup menu. Scroll through the list of components and highlight *p:0*. Click on Change to change all of the selected components

![Change dialog box](image)

**Figure 4-11.** Opening the Change dialog box using a popup menu

After you have changed all of the *para* components, change the remaining *subhead* components into *h:2* components. Figure 4-12 shows the marketing department document fully integrated into the *Introduction* document after the components have been changed. Compare this to the before picture, shown in Figure 4-7, and you can see that you accomplished quite a lot—just by changing the names of the components!

**Applying Widespread Changes**

The *Introduction* document needs to have some changes made to it because the authors of the other documents that you included didn't follow the same conventions you did when creating the document. You can perform editing functions on the document as a whole. Some of these functions are searching for and replacing text, and searching for and replacing format. You might have to find specific Interleaf 6 objects to make
Keeping track of everyone's performance can be a very demanding job, especially if the league or tournament is very large. The main reason for this program is to allow you, the league or tournament secretary, to complete your duties as quickly and efficiently as possible so that you can GO! Bowl with everyone else.

1.2 | Why GO! Bowl?

Keeping track of everyone's performance can be a very demanding job, especially if the league or tournament is very large. The main reason for this program is to allow you, the league or tournament secretary, to complete your duties as quickly and efficiently as possible so that you can GO! Bowl with everyone else.

1.2.1 | It Does It All

GO! Bowl is a comprehensive package that does everything for you. It figures all averages, handicaps, high scores, points, and standings. It keeps track of prizes, as well as, awards for ABC, WIBC, and YABA. It even keeps track of bowler's payments and bank deposits — perfect for you league secretaries who are also the league treasurer!

1.2.2 | User Friendly

GO! Bowl uses the standard user interface of Microsoft Windows to make using the program easy and very friendly. Pull-down menus make it easy to find what your looking for, and if you have a question about how to do something, on-line help is just a key press away.

1.2.3 | Immediate Access to Rules

GO! Bowl has a built in word processor for creating your league rules, and features immediate access to those rules. It also includes the most recent set of rules and guidelines.

Figure 4-12. Introduction document after components are changed

some sort of change to them—that change could be formatting, content, or both. And while you're making these widespread changes, you want to know how do to these things quickly and efficiently.

Searching and Replacing Text

In the combined Introduction document, there are references to the GO! Bowl program that were typed in as “GB.” Before you can complete this document, you need to change all of the occurrences of “GB” to “GO! Bowl.” You can accomplish this with Interleaf 6's search and replace capability.
In the *Introduction* document, choose **Tools → Find/Change...** (or click on the Find Text button) to bring up the Find & Change dialog box. In the Find & Change dialog box, you specify search criteria and, if applicable, replacement text. In the Find text field, type *GB*. You want to match the case so you don’t accidentally find occurrences of “gb,” so click Match Case to turn case matching on. In the Change To text field, type *GO! Bowl*. You are now ready to perform the search and replace (see Figure 4–13). In the pulldown next to the word Change, choose All. Click on the Change button to change all occurrences of “GB” to “GO! Bowl.” The dialog box status area will tell you that Interleaf 6 is finding and replacing all occurrences.

![Find & Change dialog box](image)

**Figure 4–13.** Find & Change dialog box

**Searching and Replacing Format**

If you remember from the last chapter, we changed the only occurrence of “GO! Bowl” to italic and blue. To be consistent, we need to change all occurrences of “GO! Bowl” to match. This is also done with the Find & Change dialog box.

Open the Find & Change dialog box, if you closed it, and type in *GO! Bowl* as the text you want to find. Type in *GO! Bowl* as the Change To text or turn on the Change Text Properties Only option. The last step before executing the change is to modify the Change To text properties by clicking Text Props... next to the Change To text field. This will display the Change Properties dialog box shown in Figure 4–14.

Change the Face to Italic using the Face menu button, and change the color to blue using the Color menu button. All of the other items display As
Found to indicate no change will be made to these other text properties. Click Close to return back to the Find & Change dialog box. The TEXT PROPS... button is now in upper case to indicate modified text properties. Perform the search and replace as before by clicking Change. After the change, your document should look like Figure 4-15.

**Note** Although the previous examples both replaced text, you can use the Find & Change dialog box to just search for text without making any changes. Instead of clicking Change, click on Find to find the text shown in the Find field.

**Finding Document Objects**

Because Interleaf 6 documents are structured, you have another way to search for information in the document independent of the text. You can search for the following objects: components, inline components, and graphic frames in a document. To see how this works, open the Find Object dialog box by choosing **Tools**→**Find Object**... (or clicking the Find Object button). The Find Object dialog box (shown in Figure 4-16) allows you to specify the type of object to search for and the name of the object, if desired.
1.2 Why GO! Bowl?

Keeping track of everyone’s performance can be a very demanding job, especially if the league or tournament is very large. The main reason for this program is to allow you, the league or tournament secretary, to complete your duties as quickly and efficiently as possible so that you can GO! Bowl with everyone else.

1.2.1 It Does It All

GO! Bowl is a comprehensive package that does everything for you. It figures all averages, handicaps, high scores, points, and standings. It keeps track of prizes, as well as, awards for ABC, WIBC, and YABA. It even keeps track of bowler’s payments and bank deposits — perfect for you league secretaries who are also the league treasurer!

1.2.2 User Friendly

GO! Bowl uses the standard user interface of Microsoft Windows to make using the program easy and very friendly. Pull-down menus make it easy to find what you’re looking for, and if you have a question about how to do something, on-line help is just a key press away.

1.2.3 Immediate Access to Rules

GO! Bowl has a built-in appendix for multiple league rules and features.

**Figure 4-15.** Introduction document after changing text and format

The *Introduction* document has an inline component named *emp:user* that I want you to search for. So, change the Object type by choosing Inline on the object menu button. After you make this change, the Name scroll list will change, showing all of the names of inline components currently being used in the document. Find and select *emp:user* in the list. Click on Find. Interleaf 6 should display the last page of the *Introduction* document where the inline component occurs (see Figure 4–16). The inline component is left in a selected state so that you can copy, delete, or easily edit it.
Jumping from Point to Point in a Document

You'll find times during final document cleanup when you'll feel like you're scrolling from the beginning to the end to the middle, cutting some text or graphics, and then scrolling to yet another place to paste the information. If you have to do this often, you can be wasting a lot of time just scrolling back and forth to items that you have already found before. You can use an Interleaf 6 feature, called a mark, to put in a place holder (like a bookmark) that you can then jump back to very quickly.
Setting a Mark

In the Introduction document, set a mark at the current insertion point (or current text caret location) by pressing CTRL–F2 then SPACE BAR. You have just set a mark that you can jump back to later.

Exchanging Mark and Current Point

Now that you have a mark set, you can scroll to some other point in the document. Click the mouse to set the current insertion point. Let's assume that you just copied something from this part of the document and need to paste it back at the mark you set earlier. After you have copied the text, exchange the current point with the mark by pressing CTRL–F2 CTRL–F2. You are now at the previous mark and can paste your text. If you need to return to the location where you copied the text, type CTRL–F2 CTRL–F2 to exchange the current point and mark again.

Selecting from Mark to Current Point

In the last chapter, I showed you how to select a range of text by dragging the mouse or using a SHIFT–click combination. You can also set a mark and select all of the text between the mark and the current insertion point. Set the mark at one end of the range of text you want to select. Position the text caret at the other end of the range and press CTRL–F2 ENTER. The range of text is now selected and can be deleted or copied. This is a great way to select text that spans multiple components across pages of a document.

CONTROLLING PAGE BREAKS

Interleaf 6 automatically paginates a document as you create it. Sometimes the pagination isn't what you want it to be. Interleaf 6 gives you a great deal of control over pagination in a document. For example, on page 1 of the Introduction document, section 1.2 begins very close to the bottom of the page (see Figure 4–17). You think it will look better at the top of the next page, rather than on the bottom of the current page, so change its pagination properties.
1.4 Before You Run Setup

Before you install Go! Bowl, make sure that your computer meets the minimum requirements and that your Go! Bowl package contains the required items.

1.4.1 Check the Hardware and System Requirements

To run Go! Bowl, you must have certain hardware and software installed on your computer. The system requirements include:

- Any IBM®-compatible machine with an 80386 processor or higher.
- A hard disk with at least 32 megabytes of free space.
- A 5¼" or 3¼" floppy drive.

Starting a Component on a New Page

Select the corresponding h:0 component in the component bar and choose Properties → Selection... to open the Component Properties dialog box. (You could also open the dialog box by double-clicking on the component.) Click on the Page button at the top of the dialog box to access the page properties for the component shown in Figure 4-18. Click the Begin New Page button to force the component to start on a new page. Choose Changes to Current from the Apply option menu and click Apply. Figure 4-19 shows the result after applying the change.
Click to make component begin on a new page. Apply changes to the current component.

**Figure 4-18.** Setting page properties on the Component Properties dialog box

---

1.4 **Before You Run Setup**

Before you install GO! Bowl, make sure that your computer meets the minimum requirements and that your GO! Bowl package contains the required items.

1.4.1 **Check the Hardware and System Requirements**

To run GO! Bowl, you must have certain hardware and software installed on your computer. The system requirements include:

- Any IBM®-compatible machine with an 80386 processor or higher.
- A hard disk with at least 32 megabytes of free space.

**Figure 4-19.** Change in pagination after applying new page properties

**Keeping Other Items Together**

Looking through the rest of the document, you find a paragraph leading into a list, but the list ended up up on the following page (this occurs at the bottom of page 3 and is shown in Figure 4–20).
1.4.3 Make Backup Copies of the Distribution Diskettes

Before you run Setup, make backup copies of the GO! Bowl disks using one of the following commands:

- `parttitle`
- `list:bullet` The Copy command on the File menu in the Windows File Manager.
- `list:bullet` The Copy Disk command on the Disk menu in the Windows File Manager.
- `list:bullet` The Copy or Diskcopy command in MS-DOS

1.4.4 Read the README.TXT File

The README.TXT file lists any change to the GO! Bowl documentation since its publication. To read the file, double-click README.TXT in the File Manager, or use the Type command in MS-DOS. Check the first section of the file for any new information about installing GO! Bowl.

---

**Figure 4–20.** Paragraph separated from following list

To begin fixing this, select the p:0 component and change its page properties to disallow breaks below the component. Do this by clicking on Allow Breaks: Below Component until it is turned off (not checked). Apply the change to this component only.

Well, that didn’t help much, because now the list is broken after the first item—the two remaining items are now at the top of the next page by themselves. Another change needs to be made. Leave the Component Properties dialog box open and select the second list:bullet component of the three. The Component Properties dialog box will update to show the properties of the newly selected component. Since this is the second item of three, not allowing a break above or below should fix the pagination problem. Click on Allow Breaks: Below Component and Allow Breaks: Above Component to turn these items off. Apply the change to this component. Your document should look like Figure 4–21. Interleaf 6 brought all of the components together on the previous page.
Before you run Setup, make backup copies of the COl Bowl disk using one of the following commands:

- The Copy command on the File menu in the Windows File Manager.
- The Copy Disk command on the Disk menu in the Windows File Manager.
- The Copy or Diskcopy command in MS-DOS.

Check the first section of the file for any new information about installing COl Bowl.

Figure 4-21. Keeping the paragraph and list together

CHECKING AND CORRECTING SPELLING

Okay, now your document is looking good and you are about ready to route it for review. First, you want to check your document for incorrect spelling—there is nothing worse than routing a document with spelling errors, especially when you have a spelling checker at your disposal to help you catch errors.

Checking an Entire Document

To check the entire document, it is best to position your text caret at the beginning of the document. Spell checking begins at the current insertion point and proceeds toward the end of the document. By starting at the beginning of the document, you'll know the entire document has been checked when Interleaf 6 asks if you want to wrap to the beginning of the document.

Choose Tools→Spelling..., or click on the Spelling button. Interleaf 6 will check the document and when it finds a word that is misspelled or not in
the dictionary, it stops and shows you the word and alternatives (see Figure 4–22).

Figure 4–22. Finding an unrecognized word

The word “Flintstones” is spelled correctly. As you can see from Table 4–1, you can add the word to the dictionary, skip it once with No Change, or skip it for the remainder of your Interleaf 6 session with Ignore All. Choose No Change. Interleaf 6 will find other unrecognized words. Correct them if they need correcting by choosing Change. If Interleaf 6 can't find the correct word to suggest for an unrecognized word, as is the case with the word “Stetup” in Figure 4–23, type in the correct word, “Setup,” and click on Change.
Table 4-1. Possible Choices When a Word Is Unrecognized

<table>
<thead>
<tr>
<th>CHOICE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Change</td>
<td>The word is spelled correctly and you want to skip it just this time without adding it to the dictionary. If it occurs again, it will be presented as unrecognized.</td>
</tr>
<tr>
<td>Change</td>
<td>The word is incorrect and will be changed to the text shown in the Change to field. If none of the presented options is correct, type the correct word in the Change to field, and click Change.</td>
</tr>
<tr>
<td>Ignore All</td>
<td>This word is spelled correctly and you want to skip it always without adding it to the dictionary. If you quit and restart Interleaf 6, the word will come up as unrecognized.</td>
</tr>
<tr>
<td>Change All</td>
<td>The word is incorrect and all occurrences will be changed.</td>
</tr>
<tr>
<td>Dictionary</td>
<td>The word is spelled correctly. Click on Add to add the word to your private dictionary. If you don’t have a dictionary, a new one will be created on your Desktop.</td>
</tr>
<tr>
<td>Add</td>
<td></td>
</tr>
<tr>
<td>Dictionary</td>
<td>Highlight a word in the Suggestions list and click Remove to remove it from your private dictionary.</td>
</tr>
<tr>
<td>Remove</td>
<td></td>
</tr>
</tbody>
</table>

When Interleaf 6 reaches the end of the document, it will present you with an option to continue checking spelling at the beginning of the document (see Figure 4-24). This is handy if you began checking spelling other than at the beginning of the document. Since you began spell checking at the
beginning of the document, choose Cancel to end spell checking. You can
dismiss the Spelling dialog box by clicking on Cancel.

![Spelling dialog box]

Figure 4–24. A chance to continue checking spelling from the beginning of
the document

**Spelling Checking Extras**

You can select a word or range of text and then check the spelling of only
the selected text. Use this if you have already checked spelling but have
made only localized changes to the document.

If you want to check the spelling in a graphic frame, it’s best done by posi-
tioning the current insertion point in text before the frame. Interleaf 6 will
automatically find all of the text located in microdocuments in the frame
and spell check them. If you begin checking while in the frame, it is pos-
sible to miss some of the text because of the back-to-front order of objects
in the frame. The only way to spell check a header or footer frame is to be
in the frame, but you may have to check each microdocument separately.
(I’ll talk about frames and microdocuments in a couple of chapters.)

When you have finished checking your document, you can close and save
it. Keep it safe because you’ll use it later when you bring multiple docu-
ments together into an Interleaf 6 book.

**SUMMARY**

In this chapter you did more editing with documents. You incorporated
both Interleaf 6 and non-Interleaf 6 documents into your document. You
learned how to change the components of the incorporated documents to
components used in your document and how this automatically for-
matted the information. After all of the information was brought together,
you saw how you could make widespread changes to search for and
replace text and formatting. You learned how to control pagination to your
liking. Finally, you checked the spelling before you sent the document out
for review. In the next chapter, you’ll learn how to print your document so
you can give it to someone to review.
This chapter describes how to send a document to a printer. You will learn to select a printer previously defined on your computer system. You will learn to select various options for printing your document.

In the last couple of chapters, you created a document that will eventually be used as an introduction in a *User Guide* about your company's latest software product. Right now, you need to get the document printed so that someone else can review it. This chapter will show you how to print the document.

Earlier in the book, I told you that the Windows and Motif versions of Interleaf 6 were very similar, with only a few areas where there is a significant difference in how you accomplish a task. Printing is one area where there is a difference. So, you'll first see how to print the document in Windows NT, and then how print the document in Motif.

**PRINTING A DOCUMENT IN WINDOWS NT**

Interleaf 6 for Windows uses the standard Windows NT printing system for printing documents; so, if you're familiar with printing from other applications, you already know how to print from Interleaf 6. If you are new to the
Windows NT environment, you’re about to see how easy it is to print your document.

If the Introduction document isn’t open, open it now. Print the document by choosing File→Print... from the document window menu, or click on the Print button. Interleaf 6 will give you a dialog box so you can choose the print destination, pages to print, number of copies to print, and print quality (see Figure 5-1).

Choosing the Print Destination

The name of the current default printer in Windows is displayed on the dialog box. You can print to this printer, or print to a file. If you need to change the default printer, you’ll click on Setup... and choose additional printer options. Additional printer options are described in greater detail beginning on page 5-85.

The type of file you print to depends on the option you check. Print to File will produce a PostScript file. You will find this option handy if a printer isn’t currently available, or you want to send the printer file to someone electronically who can then print your document without having to use Interleaf 6.

Print to WorldView file will create a file that you can view using Interleaf’s WorldView product (which is used for the online help in Interleaf 6). You can use this option to send your document to someone for online review. They can view your document on their computer and then annotate it with electronic notes that can be sent back to you.

Choosing Pages and Copies to Print

Make sure the Print Range is set to All so that the entire document is printed. For our example, only one person needs to review your document at a time, so set the number of copies to one. When you’re ready to send your document to the printer, click OK.

Choosing To Use a Header Page

If you click on Header Page to turn it on, Interleaf 6 will automatically create a header page with your print job. A header page is useful to help get print jobs to the right people, especially in a networked environment where many different people might have access to the same printer. An
Interleaf 6 header page will contain information about the user who printed the job, when the job was printed, and information about the

Choose Print... from the File menu...

...choose the print range, set the number of copies,

...and click the OK button to send the document to the printer.

**Figure 5-1.** Printing your document in Windows NT
source of the job, such as the Interleaf 6 document name and date last saved. A sample header page is shown in Figure 5–2.

![Sample header page](image)

For: Andy
Printed on: Sun, Jun 19, 1994 21:20:24
Document: Introduction
Last saved on: Mon, Jun 13, 1994 20:56:50

A page similar to this will be printed if Header Page is selected on the Print dialog box.

**Figure 5–2. Sample header page**

**Printing Status**

While the document is being sent to the printer, Interleaf 6 will display a status message in a dialog box (see Figure 5–3). If for some reason you need

![Print status dialog box](image)

Clicking Cancel will cause Interleaf 6 to stop sending the document to the printer.

**Figure 5–3. Print status dialog box**
to stop printing in the middle of the print job, click Cancel on this dialog box, and Interleaf 6 will cancel the print job.

**Setting Print Options in Windows NT**

In addition to the basic printing options you have already seen, Interleaf 6 gives you the ability to choose other options to control your printed output.

Earlier you saw that you could choose either the default Windows printer or a file for the print destination. If you wish to change the default printer, or information about the paper used in the printer, you need to click on the Setup... button (shown in the dialog box in Figure 5–1) to bring up the Print Setup dialog box similar to the one shown in Figure 5–4.

![Print Setup dialog box in Windows NT](image)

To change the destination printer, use the printer pulldown list next to Printer to choose from the currently installed printers on your system. You can then choose options appropriate for that printer. For the proofing printer I have installed while writing this book, I have the ability to change the page size (Form) and the page orientation.

**Note** The options displayed in the Print Setup dialog box vary, depending on the printer and printer driver you are using. For information about the various options, consult your Microsoft Windows NT documentation and the documentation that came with your printer.

More advanced options about the printer can be accessed by clicking the More... button. When the More... button is clicked, a dialog box similar to the one shown in Figure 5–5 will be displayed. On this dialog box, you can adjust properties controlling the appearance of the printed output.
You can also change print properties such as the print quality, or resolution, the scale of the printed output (normal is 100 percent), and how fonts are handled by the printer. For a description of these advanced options, see your Windows and printer documentation.

**Setting Document Print Properties**

In addition to setting items that are specific to the printer, you can also instruct Interleaf 6 how you want certain things in the document printed. These document specific properties are on the Print Properties dialog box that you open by choosing Properties → Printing... on the document window (see Figure 5-6). These properties are briefly described in Table 5-1.

![Figure 5-6. Document printing properties](image-url)
After you have applied these properties, they are stored with the document and remembered the next time you decide to print the document.

### Table 5-1. Description of Printing Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Underlines</td>
<td>Determines whether underlines should be printed. If underlines are printed, specifies placement of the underlines either at baseline or below descenders of characters.</td>
</tr>
<tr>
<td>Strikethroughs</td>
<td>Determines whether strikethroughs should be printed.</td>
</tr>
<tr>
<td>Deletion Marks</td>
<td>Determines whether deletion marks, ▲, should be printed. Deletion marks identify text that has been deleted with Interleaf 6's Revision Management feature.</td>
</tr>
<tr>
<td>Revision Bars</td>
<td>Determines whether revision bars should be printed.</td>
</tr>
<tr>
<td>Orientation</td>
<td>Normally set to Same as Page. If Rotate 90 Degrees is selected, the image is rotated on the output page. The image is not reformatted, so part of the image may be cut off if the page is not large enough.</td>
</tr>
<tr>
<td>Default Printer (Motif)</td>
<td>Establishes the default printer for printing the document. Can be set to a type of printer, for example, nearest PostScript printer, or to a specific printer name.</td>
</tr>
</tbody>
</table>

### Printing a Document in Motif

If you are using Interleaf 6 for Motif, you send your document to the printer by choosing **File→Print...** from the document menu bar, or clicking on the Print button. If the **Introduction** document isn't open, open it now. Use either method above to begin printing the **Introduction** document. Interleaf 6 will give you the Print dialog box shown in Figure 5–7 to let you choose the print destination, pages and copies to print, and whether or not to use a header page.
Choosing the Print Destination

You can choose to send your document to a printer, a file, a WorldView file, or to an encapsulated PostScript (EPS) file to be embedded in another application. You'll be sending the Introduction document to a printer, so click on the Printer option next to Print To. You now need to choose the printer.

Note The difference between printing to an EPS file and printing to a regular file is that an EPS file is only a single page and is intended to be embedded into another application; whereas, printing to a file can include multiple pages, and the page description is not limited to PostScript—it could be Hewlett-Packard Printer Control Language (PCL), which is understood by all of Hewlett-Packard's LaserJet printers (and compatibles).

In the Motif environment, you may have access to many printers located throughout your network. Your Interleaf 6 system administrator should have set up at least one, if not more, public printers for you to access. You can also set up customized printers of your own; but for now, you'll print your document to a public printer. (Appendix B will show you how to set up your own custom printer.) To choose a public printer, click on the Public option in Printer List. Then, use the drop down list next to Printer Name to choose the appropriate printer.

Choosing Pages and Copies to Print

You want to print your entire document, so click on the All option next to Pages. Also, check that Both is selected so that the even and odd pages will print.

When all of your printing parameters are set the way you want them, click on Print to begin the print job. Interleaf 6 will display the status of the print job in the document window status bar. If you need to cancel the print job, press CTRL and G simultaneously.
Choose Print... from the File menu...

...choose the destination, print range, set the number of copies, and turn on or off the header page and then click the Print button to send the document to the printer.

**Figure 5-7.** Printing your document in Motif
Printing Status

While the document is being sent to the printer, Interleaf 6 will display a status message in the document window's message area. The message will let you know that the pages are being composed, the printer file is being created, and the document is being sent to the printer. When the document has been sent to the printer, you will be notified in the message area (see Figure 5–8). You can then begin working with Interleaf 6 again.

**Note** The amount of time you have to wait for the document to be sent to the printer depends on the size of the document and where the document is filtered. If your document is filtered on the desktop, you will have to wait until the printer file is created and sent to the printer. To be able to get back to work more quickly, especially if the documents you print are large, ask your Interleaf 6 administrator to set up filtering on the print server.

![Figure 5-8. Print status in document window's message bar](image)
Setting Print Options in Motif

If you wish to change printing options in Motif, click on the Options... button on the Print dialog box (see Figure 5-7). Interleaf 6 will display a Print Options dialog box similar to the one shown in Figure 5-9. This dialog box gives you the ability to change items that are specific to the printer, such as double-sided printing (duplex), source of paper, size of the paper, and the list goes on. Not all of the items are available — it depends on the printer installed and, more specifically, the PostScript printer description (PPD) file chosen for the printer. Table 5–2 summarizes some of the more common options. After you have selected all of the options you want, click the Apply button to return to the Print dialog box.

Figure 5-9. Motif printing options
Table 5-2. Summary of Common Printing Options

<table>
<thead>
<tr>
<th>OPTION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duplex</td>
<td>Instructs the printer to print on both sides of the page. Options allow you to tumble the pages (print “head to toe”) as they are printed. In order to use this option, the printer must support duplex printing.</td>
</tr>
<tr>
<td>Paper Source</td>
<td>Instructs the printer where to get paper for printing. Manual feed means you will have to insert each sheet of paper manually. Paper tray tells the printer to use a built-in paper tray. If the printer has more than one input tray, you can specify the tray.</td>
</tr>
<tr>
<td>Paper Size</td>
<td>Autoselect tells Interleaf 6 to automatically choose a paper size large enough to hold the printed image. This is normally the default. If you want to override the setting, choose override and then specify the paper size. If the image is larger than the selected paper size, Interleaf 6 will split the image up over multiple pages.</td>
</tr>
<tr>
<td>Output Bin</td>
<td>If the printer has more than one output bin, you can tell Interleaf 6 which bin to use. If you change the output bin, be sure to select the correct orientation of the paper in the bin. If you choose face up, Interleaf 6 will print the document from last page to first page; and if you choose face down, Interleaf 6 will print from first to last.</td>
</tr>
</tbody>
</table>
Setting Print Properties in Motif

If you wish to set Print Properties in Motif, these are accessed by clicking on the Properties... button on the Print dialog box (see Figure 5–7). Interleaf 6 will display the Print Properties dialog box shown in Figure 5–10. These properties are the same properties described for Windows (because they're really document properties and not printer properties) and a brief description has been presented in Table 5–1. After you have applied these properties, they are stored with the document and remembered the next time you decide to print the document.

![Print Properties dialog box](image)

**Figure 5–10.** Document printing properties in Motif

**Note** In Interleaf 6 for Motif, version 6.1, you will probably find the print properties dialog box by choosing Properties→Printing... from the document menu and not from the Properties... button on the Print dialog box (as shown in Figure 5–7 for version 6.0.3).

**Summary**

In this chapter, you sent your *Introduction* document to a printer. The method you used to print the document depended on whether you are using Interleaf 6 for Windows or Interleaf 6 for Motif. You were also shown some of the different print options you have available. Again, these differ with your operating environment.

In the next chapter, you'll learn how to add graphics to your documents.
CHAPTER 6
Adding Illustrations

This chapter describes how to include referenced illustrations within a document. You will learn different ways to paste graphic files into your document. After a graphic has been added to your document, you will learn to create a reference in your text to the graphic. You will also learn to shape text around an illustration.

PASTING AN ILLUSTRATION INTO A DOCUMENT

It has often been said that a "picture is worth a thousand words." Interleaf 6 allows you to incorporate graphics along with your text, and you can edit the graphics within your document. You're going to add some graphics to the documentation for your User Guide. These graphics have been created by some illustrators and graphic artists in your company. The first graphic was created in Interleaf 6. The second graphic is from a screen capture of the GO! Bowl program and was created with another application.

Pasting a Graphic into Text

The Introduction document you printed and sent out for review in the last chapter has been returned with a comment to add a graphic to spice it up. A graphic artist in your organization, working with Interleaf 6, has created
a graphic for you to use. Create the graphic on your desktop by choosing File→New→Inside Interleaf→Graphics→spare1 (see Figure 6-1).

**Figure 6-1. Creating a graphic for pasting into a document**

Now open the *Introduction* document and go to page 1. Position the Desktop window and the *Introduction* document window so that both are visible. Now, select *spare1* and drag it to the middle of the first paragraph of the *Introduction* document. Interleaf 6 will automatically create a frame—an object that contains all graphics in Interleaf 6 documents—and place the graphic into it (see Figure 6-2).

1.1 *The History of Bowling*

Bowling has become a popular recreational and sporting activity. Bowling has been around since approximately 5200 B.C. Evidence to support this is an ancient version of a ball and pins in an Egyptian child's grave. Stone age man (as evidenced by the popular cartoon character Fred "Fredkle/Barb" Flintstone) also enjoyed the recreational activity of rolling rocks at other rocks. (at "Nine-pins," where the pins are arranged in a diamond shape, became very popular as a recreational sport in the 1800's in New York. Gamblers soon marshaled the pins, and participation in "nine-pins" was banned. Being the enterprising

**Figure 6-2. Graphic pasted into text**

Later in this chapter, we'll reposition the graphic and shape the text around it. For now, close the *Introduction* document, making sure you save it when asked by Interleaf 6.
Pasting a Graphic into an Open Frame

The second illustration you’ve been given is a screen capture from the GO! Bowl program. This screen capture belongs in another chapter of the User Guide, so create the document used for that other chapter on your Desktop: choose File→New→Inside Interleaf→Exercises→League Setup. Open League Setup and find the section titled Address/Phone under Adding Bowlers (see Figure 6-3).

Create the League Setup document...

...then, open it to the Address/Phone section.

Figure 6-3. Creating and opening the League Setup document
Creating a Frame

You're going to paste the screen capture into the document; however, unlike the previous graphic you pasted—where Interleaf 6 automatically created a frame for you—you will paste the screen capture into a frame you created. So, before you can paste the illustration, you need to create a frame.

When you create a frame in Interleaf 6, you place a frame anchor in the text area of the document (see Figure 6-4), and then modify the frame's properties to position the frame precisely where you want it to appear on the page (see Figure 6-5). However, the template you are using has a predefined component for creating figures. By using the predefined component, you are guaranteed consistent use of frames throughout the User Guide (not to mention you are saved the time and effort required to modify the frames' properties for exact size and placement).

To create a frame in text, choose Create→Frame to access the Create dialog box.

Click Frames.

Find and select the name of the desired frame...

...and click Create to create the frame in text.

Figure 6-4. Creating a frame in text
Adding Illustrations

Creating a Predefined Component Containing a Frame

To create a frame for the screen capture, first position the component bar insertion point after the last paragraph (p:0) in the Address/Phone section. Now, create a component named \textit{figure:num}, to create a frame that already has a numbered figure title within it. Figure 6–6 illustrates how to create the component.

\textbf{Figure 6–5.} Modifying frame properties
Position the component bar insertion point and choose Create→Component... to access the Create dialog box.

Click Components...

...choose the desired component...

...and click Create...

...to create a predefined component containing a frame with initial content.

field to field, the status bar will change showing you the field name. Fill in the address, beginning with the street. A second line is available if needed. Enter the city, two letter state abbreviations, and zip code. Next enter both the home (or night) telephone number, and the work (or day) telephone number.

Figure 1.1.

Figure 6-6. Creating a frame using a predefined component

Opening the Frame

Well, you now have a frame for the screen capture you want to include in your document; but before you attempt to paste the illustration into the document, you must make sure the frame is open. Frames are opened the same way other objects are opened in Interleaf 6—double-click on it with the mouse. Figure 6-7 shows an open frame.
Adding Illustrations

field to field, the status bar will change showing you the field name. Fill in the address, beginning with the street. A second line is available if needed. Enter the city, two letter state abbreviation, and zip code. Next enter both the home (or night) telephone number, and the work (or day) telephone number.

![Figure 1.1](image_url)

1.2.2 | Performance

Click on the Performance tab of the Bowler Information window. This window shows the bowler's best performances to date.

**Figure 6-7. Appearance of an open frame**

**Converting the Screen Capture**

Now that the frame is open, you are ready to paste the screen capture into it. First, create the screen capture on your Desktop by choosing File → New → Inside Interleaf → Graphics → bwlrinfo. This will create a TIFF (tagged image file format) file on your Desktop (see Figure 6-8).

Select the TIFF file and convert it into an Interleaf 6 image file. This is done by choosing File → Import/Export... to open the Import/Export dialog box. Click Convert on the dialog box to convert the file using a built-in TIFF filter.

**Note** Interleaf 6 can handle a number of graphic file formats. Among the many formats are TIFF, HPGL, and EPS. Optional filters are available from Interleaf to allow Interleaf 6 to handle IGES and CGM. If you have other formats, there are plenty of third-party conversion tools that will allow you to convert an unsupported file format into one of Interleaf 6's supported file formats.

**Pasting the Illustration**

Converting the file may take a few seconds; the actual time required depends on the size of the file and the configuration of your computer. When Interleaf 6 has finished converting the file, you will see it appear as
a new icon next to the original file on the Desktop (see Figure 6–8). Select this new image and cut or copy it to the Clipboard.

Once the image is on the Clipboard, it is ready to be pasted into the frame. Click the mouse in the frame where you want the image pasted. Finally,
choose Edit→Paste from the menu or click on the Paste button on the tool bar. The image will appear in the frame and is left selected (see Figure 6–8).

**Adjusting the Illustration’s Size**

As you can see in Figure 6–8, the illustration is quite small. To make the illustration easier to see, you’ll need to enlarge it. You can enlarge the illustration by just dragging one of its handles (more about handles in

When you open a frame, the document’s menus change to give you commands to use with graphics. Open the Measurements dialog box by choosing Change→Measurements... from the new document menu.

Click the multiplication button, type in 2, and click Apply to size the graphic to twice its size diagonally.

The graphic is immediately sized within the frame. Some of the graphic is currently beyond the frame’s borders.

**Figure 6–9.** Changing an illustration’s size with the Measurements dialog box
Chapter 15), or you can more precisely size the object by using the Measurements dialog box.

Bring up the Measurements dialog box by choosing Change → Measurements... from the document window (see Figure 6–9). In the diagonal size area, click on the multiplication button, type in the number 2, and then click on Apply. This will make the illustration twice as large while preserving the ratio of height to width.

**Adjusting the Illustration’s Position**

You probably need to reposition the illustration within the frame. You can do this by selecting the illustration and dragging it to a new location. To drag the illustration, place the mouse inside the bounding box of the illustration, hold the mouse button down, and drag to a new location (see Figure 6–10). Once at the desired location, release the mouse button.

![Figure 6–10. Dragging the illustration to a new location](image)

**Closing the Frame**

Click the mouse outside the frame to close the frame, or choose Change → Close Frame on the document menu. When the frame closes, it will readjust its height. The frame you are working with has a property that forces it to set its size to the contents of the frame. Since the present size of the frame is smaller than the illustration, the frame will increase its size to fit the contents (see Figure 6–11). Now, however, the line that was intended to be at the bottom of the frame is in the wrong place. It’s time to use another tool to adjust the position of the line.

**Adjusting Other Objects in the Frame**

Inside the frame, select the line that is in the middle of the frame. Your document style policy states that this line should appear exactly 1.5 picas
Choose Change→Close Frame from the document menu or click outside the frame to close it.

This type of frame will readjust its height to fit the contents of the frame.

![Figure 6-11. Closing the frame causes it to resize](image)

below the lowest edge of any item in the frame. You already know about the Measurement dialog box, and you'll use it for the exact placement of the line. First, you must get the line aligned with the bottom edge of the screen capture. Interleaf 6 provides you with a command that will quickly and easily perform the alignment for you.

Since the frame has already adjusted its height to fit its contents, the bottom edge of the frame is in the same location as the bottom edge of the screen capture. You can use the Arrange→Align to Frame→Bottom Edge command on the selected line to move the line to the bottom of the screen capture (see Figure 6-12). If this weren't the case, you could obtain the same results by selecting both the line and the screen capture and using Arrange→Align→Bottom Edges instead.
Select the line in the middle of the frame. On the document menu choose Arrange→Align to Frame→Bottom Edge to position the line near its final location.

Move the line to its final location below the graphic using the Measurements dialog box. Move the line down an additional 1.5 picas.

Close the frame by clicking outside the frame. It will readjust its size, and the line will be correctly positioned.

Figure 6–12. Adjusting other contents of the frame

Now, use the Measurements dialog box to move the line down by 1.5 picas. You can type 1:6 for 1 pica and 6 points, which is the same as 1.5 picas since there are 12 points in a pica. Click Apply, and the line will move down (dis-
appearing from view until the frame is closed and automatically readjusts its height).

**Note** Interleaf 6 is very flexible when it comes to units of measure. If you are not comfortable with picas and points you can type in 0.25 inches for the distance to move the line. Interleaf 6 will convert the measurement entered (0.25 inches) into the units being used in the document (1:6 picas:points).

**CREATING AN ILLUSTRATION REFERENCE**

Now that you have pasted an illustration and positioned it within a numbered frame, you want to tie it into the text by creating a reference of the form “See Figure 1.1” You probably noticed that when you created the figure:num component that it already had a number assigned to the figure: 1.1. Well, you could just type see Figure 1.1 within your text. If you do, you could be creating all kinds of problems for yourself later when you decide to add more numbered figures or rearrange the order of the numbered figures. Remember, Interleaf 6 is automatically numbering the figures as you create them; so, you should let Interleaf 6 manage any references to these automatically numbered figures.

There are two ways you can create a reference, which is called an autonumber reference: the automatic method or the manual method.

**Creating a Reference: Automatic Method**

The automatic method is the easiest way to create an autonumber reference. What makes it easy is that Interleaf 6 automatically creates a reference and you just have to paste it into your text. The procedure amounts to three steps: select an autonumber, create a reference (which places it on the Clipboard), and paste the reference into a document (see Figure 6–13).

**Selecting an Autonumber**

The frame you created for the screen capture contains an autonumber. The autonumber is located inside an object known as a microdocument (more about microdocuments in Chapter 15). To gain access to the autonumber, the microdocument must be open for editing; so, double-click on the microdocument (you may have to first open the frame by double-clicking on it). When the microdocument is open for editing, you'll see a text
caret within it, and the component bar will change to show the name of the component within the microdocument (in this case title:fig). Position the cursor over the autonumber and click to select the autonumber.

Double-click on the figure title to open the microdocument.

Click on the autonumber to select it.

Have Interleaf 6 create the autonumber reference for you automatically by choosing Create→Autoreference. You'll receive a confirmation in the document status bar.

Position the text insertion point where you want the reference to appear, and paste the reference.

Figure 6-13. Creating a reference by the automatic method
Creating a Reference to the Autonumber

Now that the autonumber is selected, choose **Create→ Autoreference.** The status bar of the document will indicate that an autonumber reference has been created on the *Clipboard.* Since it is on the *Clipboard,* it is ready for a paste operation.

Pasting the Reference into Text

The autonumber reference that is on the *Clipboard* is just waiting for a place to be pasted. In the Address/Phones section of the *League Setup* document, there is a sentence that reads: “The bottom half of the window changes to show fields for address and phone numbers.” After the word “numbers” and before the ending period, type *(see Figure)* leaving a space between *Figure* and the closing parenthesis. Position the text insertion point between the space and the parenthesis and choose **Edit→ Paste.** The autonumber reference is now part of your text, and Interleaf 6 will automatically track its value for you.

Creating a Reference: Manual Method

The manual method for creating an autonumber reference is not as easy as the automatic method, but it does have its advantages (see Tip on page 6–112). What makes this method a manual method is that you are responsible for creating the tags used in the references. A *tag* is a unique combination of characters that identify an autonumber. The manual method involves four steps: select the autonumber, modify the tag property of the autonumber, create an autonumber reference, and modify the tag property of the autonumber reference (see Figure 6–14).

Select an Autonumber

Select the figure autonumber. Selecting an autonumber is no different under the manual or automatic methods of creating a reference, so I won't repeat what was stated before. If you need a refresher, or you just skipped to this section, go back and read how to select an autonumber under the automatic method.

Modify the Autonumber Tag

Under the automatic method, you just created an autonumber reference on the *Clipboard.* In the manual method, you want to examine and modify the autonumber’s Tag property. With the autonumber selected, choose **Edit→ Properties...** and an Autonumber Properties dialog box will appear.
Select the autonumber...

Change the Tag property to MyTag. (The current value, if any, is the tag Interleaf 6 created in the automatic method. When you create a reference using the manual method, this field will normally start off blank.)

Apply the change and Interleaf 6 will ask you to confirm the scope of the change (for our example, click Change Autonumber Only).

All current autonumber references will read NO TAG. Delete the current reference so you can create one from scratch.

Position the text insertion point where you want to create the autonumber reference.

Create the autonumber reference by choosing Create→Reference→Autonumber... The reference will be created and the Autonumber Reference dialog box will open so you can type in the tag MyTag. Apply the new tag.

Figure 6-14. Creating a reference by the manual method
Adding Illustrations

The tag property will already have some random value that was assigned by Interleaf 6 under the automatic method. Change the tag to MyTag or to some other value and click Apply.

You will notice that the previous reference you created in the Address/Phone section reads NO TAG. This is Interleaf 6's way to let you know that you have an autonumber reference that it can't resolve. Since you changed the tag of the figure autonumber, you could just select the reference and modify its Tag property to match what you just typed. But to see how to create a reference from scratch, you'll forego that right now and just select and cut the reference.

Create an Autonumber Reference

Where you deleted the previous autonumber reference, create a new reference by choosing Create→Reference→Autonumber. Interleaf 6 will create an autonumber reference at the text insertion point and automatically open the Autonumber Reference dialog box so you can type in the tag. Notice that the autonumber reference in the text currently reads NO TAG.

Modify the Autonumber Reference Tag

Since the Autonumber Reference dialog box is open, just type in MyTag, or whatever you typed before. Make sure that whatever you type matches the Autonumber tag exactly (including case of the letters). Click Apply and the autonumber reference in the text will immediately change from NO TAG to its correct value. Close the dialog box.

Congratulations, you have created an autonumber reference using the manual method. By the way, if you are wondering if it matters whether or not you create and tag the reference first or tag the autonumber first, it makes no difference—eventually, Interleaf 6 will resolve the reference.
**Tip** Manually creating a reference to an autonumber allows you to create references in your text to autonumbers that haven't been created yet. For example, suppose you want to reference an illustration in an appendix that is being written by another author, but the appendix has not yet been created. You can't use the automatic method, because it requires you to have access to the autonumber that is used to label the illustration.

You could wait until the appendix has been written and then use the automatic method; but you don't know when the other author will write the appendix, and you don't want to wait. So, use the manual method. You must make sure that you and the other author agree on a tag name to use for the illustration's autonumber—if the appendix illustration shows the dimensions of a bowling lane, you could both agree to call the tag BOWLLANE.

**Creating a Reference to a Page Number**

One other reference you may wish to create, especially if the autonumber being referenced doesn't appear close to the text reference (such as when you reference something in another chapter or appendix), is a page reference so you can guide your reader to the proper page.

For example, revisit the autonumber reference you created in the Address/Phone section. After the autonumber reference and before the closing parenthesis type `, on page` leaving a space after the work `page`. Select the previous autonumber reference by clicking on it. Copy the reference, and paste it just before the closing parenthesis. Bring up the Autonumber Reference dialog box and change the reference type to Autonumber Page Location. Click Apply and watch the autonumber reference change to reflect the page where the illustration appears. Figure 6–15, on page 6–113, shows the procedure. Save the League Setup document for later use.

**SHAPING TEXT AROUND AN ILLUSTRATION**

Remember the graphic pasted into the Introduction document at the beginning of this chapter? It is time to revisit it and adjust the final placement of the graphic and adjust the text so that it flows around it.
Adding Illustrations

Adjusting the Frame’s Properties

Open the *Introduction* document and find the graphic of the bowling pins and ball. With the present frame properties, the frame displaces the lines of text. By placing the frame behind the text, both the graphic and the text can occupy the same location on the page. Select the frame and modify the frame’s placement properties to place it behind the text and aligned to the right page margin (see Figure 6-16).

Add the text, on page and then copy the current autonumber reference and paste it where you want the page reference to appear.

![Figure 6-15. Creating a reference to a page number](image)

Open the Autonumber Reference dialog box and change the type of reference.

Apply the change and see the page referenced in the document.
1.1 The History of Bowling

Bowling has become a popular recreational and sporting activity. Bowling has been around since approximately 5200 B.C. Evidence to support this is an ancient version of a ball and pins in an Egyptian child’s grave. Stone age man (as evidenced by the popular cartoon character Fred “Flintstone” Flintstone) also enjoyed the recreational activity of rolling rocks at other rocks. “Nine-pins,” where the pins are arranged in a diamond shape, became very popular as a recreational sport in the 1800’s in New York. Gamblers soon invaded the sport, and participation in “nine-pins” was banned. Being the enterprising people that Americans are, it wasn’t long before the two another pin to the setup, and arranging the pins in the order of “ten-pins,” and is with us today.

In 1895, the American Bowling Congress was formed to standardize the rules and regulations of bowling. According to rules created by the ABC, leagues and tournaments sanctioned by the ABC must keep accurate records of bowlers’ league and tournament participation and performance. That’s where our latest software product, GO! Bowl, can help you in your task as a league or tournament secretary.

Click on the graphic to select its containing frame.

Choose Properties → Selection.

Change the frame’s Placement to Underlay.

Set horizontal and vertical references to Page (Without Margins) and align horizontal to Right and vertical to Top.

Change vertical offset to match paragraph offset.

Click Apply and watch as the frame is repositioned.

Figure 6-16. Placing a frame behind text
Forcing the frame behind the text is accomplished by setting the frame Placement to Underlay. When the frame Placement is set to Underlay, the Reference section of the Frame Properties dialog box allows you to adjust both horizontal and vertical references. Set the horizontal reference to Page (Without Margins) and Alignment Right. Set the vertical reference to Page (Without Margins) and Alignment Top.

Looking at the ruler at the left side of the document, you can determine that the paragraph begins about 26 picas down from the top margin, so use this value for the frame's vertical offset. After you make all of these changes to the property dialog box, click Apply and watch the frame change its position and the text flow over the graphic.

**Tip** You may also want to reposition the frame’s anchor to the first line of the paragraph and set the frame vertical reference to Anchor and alignment to Top. Referencing the anchor will force the frame to stay with the text as the document is edited and repaginated. Modifying frames will be addressed more thoroughly in Chapter 14.

**Shaping Text**

Now that the text is in front of the graphic, you are ready to modify the text's profile using the Shape Text tool. Start the Shape Text tool by choosing `Tools→Shape Text`. Each line in the document will display a shape bar at the left and right component margins, and a Shape Text dialog box will appear (see Figure 6-17). Shaping text involves two basic steps: select one or more shape bars, and reposition them.

**Selecting Shape Bars**

A *shape bar* is the vertical bar found at the left and right sides of a line of text and normally coincides with a component's margins. You select a shape bar by clicking on it. After it is selected, you can move it left or right of its current position. If you have many lines you want shaped to the same location, you can select multiple shape bars before performing a move. You can select multiple shape bars by either holding the mouse button down and dragging a box around the desired shape bars, or pressing CTRL while clicking with the mouse to add shape bars to the selection. Once all of the desired shape bars are selected, you can apply the same change to all of them.
Choose **Tools → Shape Text...** to enter shape mode. Each line will have a shape bar located at the left and right component margins.

Select a shape bar by clicking on it. The Shape Text dialog box will update to show the current location of the shape bar. Drag the shape bar to a new location.

After shaping all lines of text, exit shape mode by clicking Exit Shape in the Shape Text dialog box.

---

**Figure 6–17.** Shaping text around the outline of the graphic.
Moving Shape Bars

With one or more shape bars selected, you're ready to adjust their position. The simplest way to move a shape bar is to drag it left or right with the mouse. As you drag the cursor left or right, the shape cursor (in the ruler at the top of the document) will show the selected shape bar's numerical position.

You can also drag the shape marker in the document ruler to change the location of the associated shape bar.

Finally, you can enter numerical values in the Shape Text dialog box and move or shift the selected shape bars by typing in a value and selecting either the Move to or Shift by option and clicking Move.

Use any of the above methods to shape the text around the graphic. When you're finished, click Exit Shape to leave shape mode. Your document should look similar to the document in Figure 6-17.

Summary

In this chapter, you learned to place an illustration into a document, both into text—where Interleaf 6 automatically created a frame—and into a frame that you created. You also learned how to create a reference to a numbered illustration—for that matter, any autonumber. Finally, you learned how to shape text around an illustration in your document using the shape command.

In the next chapter you will learn how to work with tabular data in an Interleaf 6 document by using Interleaf 6 tables.
CHAPTER 7
Table Basics

This chapter describes table basics. You will begin by creating a predefined table. You will learn how to quickly empty the cells of a table. You will then enter text into the different cells. You will learn to select and modify the cells and columns of a table. You will learn to add rows to a table. You will learn to change the table rulings.

CREATING A TABLE

When you think of tables, you might think of rows and columns of numbers or simple text. Interleaf 6 is very good at handling this type of table. However, tables don't have to be limited to just rows and columns of text and numbers. Interleaf 6 allows you to create very complicated tables containing both text and graphics.

In this chapter, you'll get a basic look at tables. You'll begin by creating a table from scratch. You'll next create a predefined table. The predefined table is used in the User Guide for a glossary of terms. For both the new and predefined tables, you'll use the glossary document found in the user guide template. Create the glossary document by choosing File→New→Inside Interleaf→User Guide→Rear→glossary (see Figure 7-1). Open the document and get ready to create a table.
Creating a Table from Scratch

Let's begin by creating a table from scratch to see how it is done. Choose Tables→Create Table... on the document window pulldown menu to display the Create dialog box. Under the Local (All) list, select (<New>) and then click Create. You'll need to type in the initial number of rows and columns for your new table (supplying a name is optional since Interleaf 6 will create a name based on the number of rows and columns if you leave the Name entry blank). After you have supplied the number of rows and columns, click Create and the table will be created at the current component bar location. Figure 7-2 shows how to create a new table.

Choose Tables→Create Table... from the menu to access the Create dialog box with the Tables option selected.

Select (<New>) and then click on Create.

Enter the number of rows and columns (and an optional name for your table). Click Create to add a new table to your document.

Figure 7-2. Creating a new table
That's all there is to creating a new table. Sure, you'll still need to fill in, and possibly modify, the rows and columns (you can see how this is done in Chapter 12). For now, you'll fill in and modify a predefined glossary table. So, select (in the component bar) all of the rows of the table you just created and delete them.

**Creating a Predefined Table**

Creating a predefined table is similar to creating a new table, except that instead of selecting (<New>) you'll select the name of the predefined table. The predefined table you want to create is named `glossary`. In the Create dialog box, select `glossary` and click Create (see Figure 7–3). Notice that the table you created has some initial content—in this case, the content describes how to use the table to create a glossary of terms. In some cases, you'll keep the initial content and just add to it. For the glossary to the *User Guide*, you'll want to empty the current table contents so you can begin with a fresh, but properly formatted, table.

Choose **Tables → Create Table...** from the menu to access the Create dialog box with the Tables option selected. Select `glossary` and then click on Create to add the predefined glossary table to your document.

![Create - glossary dialog box](image)

![Table: TERM | DEFINITION](image)

**Figure 7–3.** Creating the predefined glossary table
**EMPTYING THE CONTENTS OF A TABLE**

To empty the contents of a table but leave the formatting intact, you select the cells you wish to empty and choose **Tables → Empty Cell(s)** from the pulldown menu. I'm going to show you how to select table cells, but first, I'll have to show you how to move around within a table.

**Navigating Within a Table**

When you are working within a table, the current insertion point is either a table caret or a text caret. Figure 7–4 shows the table caret, as well as the different parts of a table.

**Moving the Table Caret**

When you want to select a cell, or a range of cells, the location of the table caret is important. To change the location of the table caret, move the mouse over a vertical ruling until it changes into a cross-hair pointer. Click the mouse button once and the table caret will appear to the right of the ruling. You can also move the table caret to a new location by using the arrows keys on the keyboard.

![Figure 7-4. Working with tables](image)
Moving the Text Caret

When you want to edit the text within a table cell, you click the mouse in that cell to make the text caret visible. To move the text caret to another cell, you can click the mouse in another cell, or you can use the arrow keys. To click in another cell, be sure that the I-beam pointer is showing and not the column selection pointer. If the column selection pointer is showing when you click the mouse, you will select the entire column.

Selecting Cells

Now that you know how to move the table caret around a table, you’ll see how you can use its location to select table cells. Cells can be selected in a few ways: by using the pulldown or popup menu, by using the mouse, or by using the mouse and keyboard.

Using a Menu

Using the pulldown (or a popup) menu offers you many choices for selecting cells. Let’s practice selecting all but the first row (the header) of the table. Position the table caret in the first row. From the menu, choose Tables→Select Cells→in Current Row. Now that you have selected all of the cells in the current row, you can use another menu command, Tables→Select Cells→Toggle, to select all of the cells except for those in the first row. Figure 7–5 shows the procedure of selecting the cells using the menu.

Deselect the cells by clicking the mouse anywhere outside the table within the text area of the document.

Using the Mouse

You can use the mouse to select cells. Selecting cells with the mouse isn’t dependent upon the current location of the table or text caret. Instead, what matters is where the mouse pointer is when you begin the selection.

To select the last three rows of the glossary table, position the pointer vertically over the second row and horizontally over the far left ruling or the far left cell (the mouse will change to the cross-hair pointer when over the ruling, and to the I–beam pointer when over the cell). Click and drag the mouse to the right and down until all cells in the last three rows are selected.
With the table caret in the first row, choose **Tables→Select Cells→in Current Row** to select all of the cells in the first row of the table.

Now select all but the first row, choose **Tables→Select Cells→Toggle**.

**Figure 7-5. Selecting cells with a menu**

**Using the Mouse and Keyboard**

The third method to select cells involves using the mouse while pressing a key on the keyboard. There are two keys of importance on the keyboard, the **CTRL** and **SHIFT** keys. When using the **SHIFT** key, the position of the table caret is important because all of the cells between the table caret and
the mouse pointer are selected. When you use the CTRL key as you press the mouse, additional cells are added to (or subtracted from, if already selected) the cells selected.

To again select the last three rows of the table, this time using the mouse and keyboard, begin by positioning the table caret in the second row over the left ruling. While holding down the SHIFT key, position the pointer over the cell in the last row, right column, and click the mouse. All of the cells that need to be emptied—except for the first row—should be selected.

**Using the Empty Cell(s) Command**

Now you have seen a number of ways to select cells, and I hope you took the time to practice selecting cells using the different methods. Now it's time to empty the selected cells. If they are not already selected, select the cells in the final three rows of the table. Once the cells are selected, choose Tables→Empty Cell(s) from the menu. All text within the selected cells will be deleted, but the formatting will remain intact. Your glossary table is now ready for new terms (see Figure 7–6).

**Note** If you have used Interleaf 5, you'll notice that there is quite a difference in how you empty cells. Since you have the ability to select partial columns in Interleaf 6, you no longer have an option to empty cells only in selected rows. If you empty cells, you empty all selected cells. It may take some getting used to, but the new way of selecting cells gives you the ability to empty non-contiguous cells—something you can't do in Interleaf 5.
Once all of the target cells are selected, you can empty them by choosing Tables → Empty Cells(s).

Figure 7-6. Using the Empty Cell(s) command

**ENTERING TEXT IN TABLE CELLS**

Now that you have emptied the body of the glossary table, you can add new terms to the table. For the software manual you’re creating, you’ll be adding the following terms:

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>kegler</td>
<td>An alternate term for a bowler. Kegler comes from the German word <em>kegeln</em>, meaning to bowl.</td>
</tr>
<tr>
<td>turkey</td>
<td>Three strikes in a row.</td>
</tr>
<tr>
<td>Brooklyn</td>
<td>Hitting the wrong side of the headpin. For a right-handed bowler, the right side of the headpin, or the 1–3 pocket, is the correct side of the headpin.</td>
</tr>
<tr>
<td>strike</td>
<td>Knocking down all ten pins on the first ball of a frame.</td>
</tr>
</tbody>
</table>

**Entering Cell Edit Mode**

To enter text into a table, you click on a cell to start cell editing. You know that you are editing a cell when you see the text caret in a cell. You’ll also know you’re editing a cell when you see the names of the components within the cell, instead of the row names, in the document component bar (see Figure 7-7).
When you are not editing the contents of a cell, the table caret and row names are visible.

When you are editing a cell's contents, the text caret and component names are visible.

Figure 7-7. Editing a table cell

After you enter cell edit mode, you have all of the normal text editing features available to you. Use these features to fill in the first three terms of the glossary table. After you have entered the first three terms, your glossary table should look like Figure 7-8. In the next section, you'll learn how to add more table rows.

Figure 7-8. Entering the first terms in the glossary table

Tip To make it easier to find the cell boundaries in a table, you can display invisible table cells by choosing View→Markers... from the pull-down menu. This will bring up the View Markers dialog box where you can turn on Invisible Table Rulings. All invisible table rulings will appear light gray.
**Adding More Rows**

You’ll need to add a table row to hold the fourth glossary term I’ve asked you to enter. You can add rows by either creating new rows or copying existing rows into the table.

**Creating Rows**

Creating a row is similar to creating components. To create a new row at the end of the table, position the component bar caret below (and touching) the last row, or click the mouse within the last row of the table, and choose **Tables -> Create Row...** to bring up the Create dialog box. The Create dialog box will show the available table rows for the *glossary* table. Select row and click Create to create a new row named *row* (see Figure 7-9). You can now enter the final term.

---

**Figure 7-9. Creating a new row**

Position the component bar insertion point immediately after the last row of the table. Choose **Tables -> Create Row...** to access the Create dialog box with the Table Rows option selected.

Select row and click Create to add a new row to the table. You are now ready to add the final glossary term.
Note You can create a new row by positioning the table caret in the last row of the table and then pressing the ENTER key. (Make sure you have a table caret and not a text caret, or you’ll end up with a new component in the current table cell.)

Copying Rows

Although creating a new row has allowed you to add the final term, you can copy a row as a way to add another term. You’ll find that copying an existing row is sometimes the more appropriate way to add a new row, especially if much of the content you want to use is already present in the existing row.

Copying a row is very similar to copying components: select the row you want to copy, copy it to the Clipboard, reposition the component caret to the location of the new row, and paste the row from the Clipboard.

Moving Rows

Now you have entered all of the terms for the glossary. One feature of a glossary is that the terms are entered in alphabetical order. Our glossary of terms is not in alphabetical order, so we need to move a few rows around.

In the component bar, select the row you want to move. Drag the row to its new location and release the mouse button.

The row moves to the new location.

<table>
<thead>
<tr>
<th>TERM</th>
<th>DEFINITION</th>
</tr>
</thead>
<tbody>
<tr>
<td>kegler</td>
<td>An alternate term for bowler. Kegler comes from the German word Kegel, meaning to bowl.</td>
</tr>
<tr>
<td>turkey</td>
<td>Three strikes in a row.</td>
</tr>
<tr>
<td>Brooklyn</td>
<td>Hitting the wrong side of the headpin. For a righthanded bowler, the right side of the headpin, or the 1-3 pocket, is the correct side of the headpin.</td>
</tr>
<tr>
<td>strike</td>
<td>Knocking down all ten pins on the first ball of a frame.</td>
</tr>
</tbody>
</table>

Figure 7–10. Rearranging table rows
Earlier, you learned how to move components around a document. As you may have guessed, moving table rows is like moving components.

The third and fourth glossary entries need to be moved. Let’s begin by moving the third row (glossary entry Brooklyn). In the component bar, select the fourth overall table row, which is the third occurrence of the table row named row. Now drag the row until the pointer is after the row named head. Release the mouse and the row will move to the new location (see Figure 7–10).

Now select the last row of the table (glossary entry strike) and move it up one row (before glossary entry turkey). The final glossary table should look like Figure 7–11.

<table>
<thead>
<tr>
<th>HEAD</th>
<th>DEFINITION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brooklyn</td>
<td>Hitting the wrong side of the headpin. For a right-handed bowler, the right side of the headpin, or the 1–3 pocket, is the correct side of the headpin.</td>
</tr>
<tr>
<td>Keager</td>
<td>An alternate term for bowler. Keager comes from the German word kegeln, meaning to bowl.</td>
</tr>
<tr>
<td>Strike</td>
<td>Knocking down all ten pins on the first ball of a frame.</td>
</tr>
<tr>
<td>Turkey</td>
<td>Three strikes in a row.</td>
</tr>
</tbody>
</table>

**Figure 7–11. The sorted glossary table**

**Note** Many people who have used other word processing packages that support sorting and math operations in a table have wondered if Interleaf 6 tables can do the same. I always give the same answer to this question: “Not out of the box, but with some Interleaf Lisp you can.” Actually, with Interleaf Lisp you can make tables do all kinds of things. If you want an introductory look at what you can do with Interleaf Lisp, check out David Weinberger’s book, The Adventurer’s Guide to Interleaf Lisp. Although written for Interleaf 5, the guide does point out many useful things that can be done with Lisp extensions. Generally, Lisp code in his book that doesn’t rely on the user interface can be used in Interleaf 6 with little, or no, modification. David’s book is also available from OnWord Press.
CHANGING TABLE RULINGS

The final topic in this chapter deals with table rulings. A rule is a printer’s term for the vertical or horizontal lines used to separate the cells of a table. To edit table rulings, you must be working in a table. You’ll then be able to access the Rulings dialog box by choosing Tables→Edit Rulings... from the pulldown menu (see Figure 7–12). Now that you have access to the Rulings dialog box, you can select table rulings and modify ruling properties.

![Figure 7-12. Accessing the Rulings dialog box](image)

**Selecting Rulings**

Before you can modify any properties, you have to select the rulings you want to modify. You can select rulings in two ways: using the mouse, or using the Rulings dialog box.

**Using the Mouse to Select Rulings**

When you opened the Rulings dialog box, the mouse cursor changed into a cross hair when the mouse was over the table. This cross hair is an indication that you are in rulings mode.

To select a ruling with the mouse, position the cross hair cursor over a rule and click. The rule will begin to flash to indicate it is selected. To add more rules to the selection, press and hold the CTRL key while you click the
mouse cursor over the other rules. Only the part of the rule that borders a single cell is selected each time you click the mouse.

**Tip** To quickly select an entire rule, position the mouse cursor over a rule and double-click. All horizontal or vertical rules in line with the current rule will be selected.

**Using the Rulings Dialog Box to Select Rulings**

While you can select all the rulings of a table with the mouse, the Rulings dialog box provides an efficient way to select different groups of rulings in a table. The top portion of the Rulings dialog box (see Figure 7–12) allows you to select all rows, all columns, all rulings, or table borders. If you previously had rulings selected, you can click Again to reselect those rulings. The final choice is to deselect any selected rulings by clicking Deselect.

**Ruling Properties**

The bottom half of the Rulings dialog box allows you to modify the properties of selected rulings. You can make rulings invisible or visible, single or double, change the color, and change the weight (or thickness).

Put these properties to use by selecting the bottom ruling of the table and changing it to visible and blue. Close the Rulings dialog box. You have now finished editing your glossary table.

**Summary**

In this chapter you learned some table basics. You created a table from scratch, and you worked with a predefined glossary table. The predefined table had to have its contents deleted to make room for your contents. You edited the table’s contents to add new glossary terms. You learned how to add additional rows to a table and how to move rows around a table. Finally, you saw how you could modify the rulings within a table. In chapter 12, you will get a chance to work with more table properties to create more complex tables.

In the next chapter, you’ll see how you can use Interleaf 6 books to assemble the different documents you have worked with so far into a preliminary user guide.
CHAPTER 8
Using Books for Long Documents

This chapter describes an Interleaf 6 book. You will learn about the objects contained within a book and the special relationship they have to each other by being members of a book. You will learn about another Interleaf 6 feature—Network Style Sheets—and how they help you control the format and content of a book. You will also learn how to create and format a table of contents and an index within a book.

BOOKS: SPECIAL CONTAINERS

In the preceding chapters you worked exclusively with documents and their content. In this chapter, you will be working with books—container objects that hold other objects. You might be wondering what books are used for. Well, books give you the ability to construct very large documents within Interleaf 6. Books allow many people to work on different parts of a large document at the same time. Books allow you to use the power of Interleaf 6 to automatically create tables of contents and indexes. Another very important capability of a book is that it can help you enforce style and layout within your organization's documents using Interleaf 6's Network Style Sheets. In the next few sections, I'll show you how to put the power of books to use.
I have already mentioned that books hold other objects, but before we look at those other objects let's take a closer look at a book. Figure 8–1 shows a book icon and an open book container. A book container window looks the same as other container windows within Interleaf 6. The only difference visible in the container is the addition of the menu entry Book.

**Figure 8–1.** A closer look at a book

On the Book pulldown menu you’ll find functions that apply only to books: generating tables of contents and indexes, and keeping the objects in the book synchronized. We’ll visit these functions later. First, let’s look at the type of objects used in a book.

**What Objects Are Used in Books?**

Books are container objects designed to hold other objects, but not all objects are functional in a book. The objects that have special significance in a book are a document, another book, a style sheet, and a style sheet binder (these objects are shown in Figure 8–2).

**Figure 8–2.** Objects that are functional in a book

**Documents**

The basic object used in a book is a document. In fact, normally you’ll have many documents within a book. Each document may contain information pertaining to a chapter or section of the book.
Sub-Books

You can also use books within books. Using books within books allows you to organize the contents of a book even further. You may find that your User Guide grows into multiple volumes, with each volume a book in its own right. To enforce a consistent style or to create a master index across all volumes, you can place all of the volumes into one top-level book.

Network Style Sheets and Binders

Network Style Sheets are used to control format, layout, and content of other objects within a book. Style sheets look like documents with an arrow projecting from within to the right. This symbolizes the fact that things within the style sheet have influence over objects that are located to the right of the style sheet.

Binders are special containers that serve to organize style sheets. You may have some style sheets that control page properties, some that control component formatting, and others that control content of text or graphics. To keep these style sheets from taking up a lot of space in a window, they can be placed inside a binder.

Tip Other objects may be placed in a book, but they don't affect the documents in the book. If you would like to keep supporting information within the book but not part of the book's printed contents, you can use a cabinet, drawer, or folder to organize the supplemental material.

Books Force Objects into Relationships

As a container, a book is used to organize other objects. When objects are stored in a book, they acquire properties that allow relationships to be established among the objects. The relationships of importance are page numbers, autonumbers, and references.

To demonstrate the relationships—and to get ready to complete other tasks in this chapter—create a book to hold the documents you have created so far. Create a book by choosing File→New→Containers→Book from the menu (see Figure 8–3). Rename the book to User Guide. Move the Introduction, League Setup, and glossary documents you worked on earlier into the new book. Because order is important, place the Introduction first, League Setup to the right of Introduction, and glossary to the right of the first two.

Figure 8–3. Creating a book to hold other documents

Hierarchy of Objects in a Book

When you put objects in a book, the object that is closest to the upper left corner of the book is considered to have the highest precedence in the book. This means that page numbering and autonumbering will begin with the object closest to the upper left of the book. Objects that are to the right or below the first object in the book will inherit page numbers and autonumbers from the first object.

What does this mean for our User Guide? Since the Introduction is the first object in the User Guide, it should be chapter 1. League Setup should be chapter 2 since it is the second object in the book. Verify this by opening

Because League Setup is the second icon in the book, the chapter number takes on the value of 2.

Figure 8–4. League Setup is chapter 2 within the book
League Setup to see that it is chapter 2 (see Figure 8-4). You’ll also notice that League Setup now starts on page 5 of the User Guide.

You may wish to open the other documents to see what their autonumbers and page number values are.

**Rearranging Objects in a Book**

There will be times when you are creating your documentation that sections will need to be rearranged. Whenever you rearrange objects within a book, Interleaf 6 will automatically adjust the page numbers and autonumbers for you.

To see this for yourself, reposition the League Setup document window and the User Guide container window so that you can see both. Select the Introduction document and drag it to the right to position it after League Setup. When you release the mouse button, Interleaf 6 will readjust the relationship between the documents. League Setup is now the first object in the User Guide book, so it becomes chapter 1 (see Figure 8-5). You’ll also see that League Setup begins on page 1.

Move Introduction back to its original position. You can now close all open documents within the User Guide.

If you rearrange the icons in the book so that League Setup is now the first icon, the chapter autonumber will automatically take on the value of 1.

*Figure 8–5. The effect of rearranging documents within the book*
Maintaining Document Order Within a Book

Because the order of objects within a book is critical, there is a command you can use to clarify the order of objects in a book. The command is View→Line Up Icons. To use this command, select all of the objects within the book and choose View→Line Up Icons (see Figure 8–6). Interleaf 6 will neatly arrange the icons while maintaining their present order.

Now that you have seen how a book allows objects to interact with each other, it is time to see other features of the book that you’ll use as you put the finishing touches on your documentation: Table of Contents and Indexes.

To clarify the order of icons within a book (or any other container), select the icons and choose View→Line Up Icons from the menu...

...and Interleaf 6 will neatly arrange the icons within the container window.

Figure 8–6. Using the View→Line Up Icons command
Note Occasionally you may receive a message from Interleaf 6 that icons have been positioned by the operating system. What that means is that Interleaf 6 doesn’t have any information about where the icons should be lined up (either the document attribute files are missing or you don’t have read access to them). You can either move the icons to establish a defined position within Interleaf 6, or you can use the View→Line Up Icons command.

Table of Contents

Almost any document created that is not a letter or memorandum has a table of contents. Interleaf 6 has a Table of Contents feature that allows you to decide what information should be contained in the table of contents. After you have tagged the information for the table of contents, you use an Interleaf 6 command to collect all of the information into a document. The final step to creating a table of contents is to format the information to meet the style of your documentation.

Tagging Information

When building a table of contents, the information that is included in the table of contents actually appears within your documentation as the content of components and inline components. You tell Interleaf 6 what information to include in the table of contents by tagging components.

Deciding What To Tag

What you actually tag for the table of contents will depend on the guidelines established by your organization. The template for the User Guide has all chapter headings and the top two levels of section headings tagged for the table of contents. Now that the information to include in the table of contents has been decided upon, it needs to be properly tagged in Interleaf 6, normally a straightforward process.
How To Tag Components

Information is tagged for the table of contents by tagging the component that contains the information. Tagging components is a straightforward process: modify the component's content properties. What is not always straightforward is making sure the component contains only the information you want to include in the table of contents. Let's see how the information is tagged in the User Guide templates and then I'll explain why getting the correct information isn't always straightforward.

Open the Introduction document and move to page 1. Select an *h:1* component and open the Component Properties dialog box (remember, you can double-click a component name to bring up the dialog box). Click on the Content button. In the middle of the dialog box, you see two entries related to table of contents: Document and Page Stream. This is where you tell Interleaf 6 that you want the contents of the selected object to be included in the table of contents, the name of the table of contents document, and the page number stream to use for this entry. The *h:1* component should already have “toc” in the field for Document, and “page” should be the value for Page Stream (see Figure 8-7). If the entry for Docu-
ment is left blank, then this component’s content will not be included in any table of contents document.

If you check the properties for any h:2 component, you should also see that they are tagged with the same table of contents information. The final object you may wish to examine is the h:chapter component. You may remember that the h:chapter component has a component prefix that contains not only an autonumber, but a frame. When the table of contents is generated, the autonumber will be converted to plain text in the table of contents document, and the frame contents will be ignored.

Let’s mark an item for the table of contents. Since the desired headings are already marked for the table of contents (by means of the default definitions of the components), select a paragraph component (p:0) and set its properties for the table of contents. Make sure you use “toc” for the Document value (see Figure 8–8). Apply this change only for this component and close the dialog box. Remember the paragraph you tagged so you can look for it in the toc document.

\[\text{Figure 8-8. Tagging a component for the table of contents}\]
Use Caution When Tagging Information

I said earlier that it is not always straightforward to tag information for the table of contents. Assume that the headings for the User Guide are inline with the main paragraph text instead of in a separate component. If you were not familiar with inline components, you might think that you can simply tag the top-level component in the component bar to get the heading included in the table of contents. True, the heading will be in the table of contents, but so will the rest of the paragraph text.

If all of your headings are set up in this manner, you'll now have to make major edits to the table of contents document to get rid of all the unwanted information. You might think this is a lot more effort than you bargained for and decide to build your table of contents by hand. "No one would ever do that!" you might be thinking to yourself. Well, I've seen it first hand. Not knowing about inline components led to this situation. You, of course, won't make the same mistake because you are reading this book! (You'll find more information about setting up a heading as an inline component in Chapter 10.)

Tip  You can take advantage of the fact that all text in a tagged component is copied to the table of contents for purposes other than creating a table of contents. For example, you could tag key components for a table of contents document named Summary. When the table of contents command is used to generate a table of contents, a Summary document will be created that will contain key information you can then edit to create an executive summary.

Creating a Table of Contents

Now that the information has been tagged in your User Guide, it is time to use Interleaf 6's built-in command to generate the table of contents document.

The TOC Command

To create a table of contents document, select all of the objects within the book and choose Book→TOC from the menu. Each of the selected documents are scanned and a document named "toc" is created, containing information from all of the selected documents (see Figure 8–9).
Select all of the documents within the book and choose Book→ TOC from the menu.

Interleaf 6 creates a document named toc that contains all of the table of contents information.

**Figure 8–9.** Running the Book→ TOC command

---

**Tip** If you wish to create a table of contents on a subsection of the book, select only those objects to include in the table of contents and run the Book→ TOC command.

---

**Ensuring the Documents Within a Book Are Synchronized**

You may have received a message from Interleaf 6 that some of the items in the book were out of date (see Figure 8–10). You would have received this message if, after moving the documents into the book, you did not open all of them and then close them again. The reason for this is that table of contents information is stored by Interleaf 6 in summary files associated with each document icon. Normally, summary files are only created when a document is within a book. Moving a document into a book does not automatically create a summary file. You must open the document and then close it again for the file to be created.

Interleaf 6 provides a command you can use to ensure the summary files are up to date: the Book→ Sync command (see Figure 8–10). When you receive a notice that files are out of date, or you want to guarantee that all of the summary information is accurate, synchronize your documents. To do this, select all of the objects within the book and choose Book→ Sync.
from the menu. You can now use the Book→TOC command with confidence that everything is up to date and accurate.

If you receive this message from Interleaf 6, you have a summary file that is out of date or non-existent. This can occur when a document has never been in a book before and is now part of a book. When this happens, click Cancel.

To update the summary files, select all of the icons within the book and choose Book→Sync from the menu.

Interleaf 6 will display a message so you can confirm that you want to synchronize the documents. Click All to force all files to be updated, or Outdated to synchronize only the outdated file(s). Interleaf 6 will let you know the status of the Sync command when it is finished.

**Figure 8-10.** Synchronizing documents in a book

**Reformatting a Table of Contents**

Select and open the toc document. You’ll see the chapter headings and first two level headings, along with their page numbers (see Figure 8-11). You will also see the paragraph you tagged earlier, in its entirety, in the toc document. If you look at the component name in the component bar, you should be able to see that each one has had “TOC” appended to it: h:1 became h:1TOC, h:0 became h:0TOC, and h:chapter became h:chapter-TOC.

The default format and layout of the toc do not meet the style requirements of the User Guide template and will need to be modified. With Network Style Sheets, reformatting the toc document is a simple process.
The entire contents of each marked component is copied to toc.

Each item in toc has "TOC" appended to it.

Frame contents are not included: autonumbers and page numbers are converted to ordinary text.

![Image of Interleaf 6 - toc]

**Figure 8-11.** Interleaf 6 default format for table of contents

### Using Network Style Sheets

Start by creating a TOC sub-book. Do this by choosing **File → New → Inside Interleaf → User Guide → Front → TOC → <whole book>** from the menu. You'll use this sub-book so that the style sheet will only affect the table of contents and not any other documents in the User Guide. If the toc document is open, close it without saving any changes (you may just wish to recreate the toc document). Open the TOC book and move the toc document into it. Make sure that you place the toc document to the right of the TOC Cat style sheet. Now open the toc document. As the document is opening, you may notice a message in the status bar stating “Reading exported masters from ‘TOC Cat’...” During this time, Interleaf 6 is applying the master definitions stored in the style sheet to the components in the toc document. When the document has been composed, it should look very different than the default formatting provided by Interleaf 6 (see Figure 8-12).
Create a TOC sub-book and place the toc document into it and to the right of the style sheet.

Now when you open the toc document, it will be formatted with the definitions contained within the style sheet.

The entire contents of the p:O component is still copied to toc, but there is no definition in the style sheet to control its formatting.

The word “Chapter” has been automatically included as part of the h:chapterTOC master definition.
All you have left to do is add the table of contents title to the beginning of the document. The table of contents title is added by creating a component named `TOC:title` at the beginning of the catalog. You’ll find it exported from the `TOC Cat` style sheet.

The `TOC Cat` style sheet controls page properties, headers and footers, and formats of the components used in the `toc` document. Within the style sheet, there are definitions for `h:0TOC`, `h:1TOC`, `h:chapterTOC`, and other items that we know have already been marked for the table of contents (remember, these component names come from the names of corresponding components that have been previously tagged for the table of contents, plus the addition of “TOC”). This makes it easy to have a style sheet predefined to control these components.

**INDEXING A BOOK**

Long documents usually provide an index as an aid to the reader. Interleaf 6 has an Index feature that allows you to embed index information within your document. Because the index information is embedded within a document, you may decide to index the documentation as you are writing rather than wait until all of the writing is finished. In either case, once you have created the index information, you’ll use an Interleaf 6 command to automatically collect and sort the index information and then build it into an editable document. The final step is formatting the index to meet the style of your documentation.

**Creating and Modifying Index Entries**

The most important step in creating an index is embedding the index information within your document. So far, the documents that are in your *User Guide* have no index entries. You will add a few index entries so that you can create an index.

**Creating a New Index Entry**

One way to create an index entry is to position the text insertion point next to the word or phrase that will be the subject of the index and create the index entry. Open the *Introduction* document and move to page 1. Position the text caret just to the right of the title “The History of Bowling.” Choose `Create→Index`... and Interleaf 6 will create an index token at the current point and open the Create Index dialog box (see Figure 8–13).
Type in the headings that you want to appear in the index. To view the index document properties, click on Properties... in the Index Document section.

Initially, the Level 1 Heading will have the value **Empty**. You want the entry in the index to read “bowling, history” so you need to enter two levels of headings: bowling at the first level, and history at the second level. Double-click the Level 1 Heading and type the word bowling. In the Level 2 Heading type the word history. For this entry, you can leave the Sort column alone; when you apply the headings, Interleaf 6 will automatically copy the values from the Heading column into the sort column.
All of the other settings at this point are okay, so you can click Apply to create the index entry. When you position the mouse pointer over the index token and click once, the token will become selected. If you look at the message in the status bar you will see: “Selected index token: bowling:history.”

**Note** If you are curious, the other entries allow you to specify the range and typeface for the index entry, and the properties of the index document. For range, you will normally use the Current Page setting. Other settings are described in Table 8-1. Typeface will normally be left as Roman. You may decide to use an alternate typeface—italic, for instance—when the index entry refers to an illustration; that way, your reader can see from the index where an illustration is referenced for a certain topic. The index document properties allow you to change the index document name (you may wish to set up multiple index documents) and the type of locator to use in the index document: a page number or an autonumber. If all of your paragraphs are numbered, you may wish to use the paragraph autonumber so the reader can find the paragraph that contains the topic.

Create an additional index entry so that your reader can find a reference to Fred Flintstone. For the Level 1 and Level 2 Headings use *Flintstone* and *Fred*, respectively. Use Current Page for the index range. Save and close the *Introduction* document.

**Creating a New Index Entry: An Alternate Method**

Another way to create an index entry is to select a word or phrase and then choose **Create**→**Index**... Interleaf 6 will create an index token following the selection, and the Level 1 Heading will already contain the selected text instead of **Empty**.

Create an index entry this way in the *League Setup* document. Open *League Setup*. In the first paragraph, select the word *league* and choose **Create**→**Index**... from the menu. The Level 1 Heading in the Index Token Properties dialog box will already have the value *league*. In the Level 2 Heading type *new*. Apply the properties and close the dialog box.

Add a second index entry to *League Setup* in the second paragraph. The index entry should read *league* and *parameters* as the two levels of index headings.
### Table 8-1. Choice for an Index Entry Range

<table>
<thead>
<tr>
<th>RANGE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Page</td>
<td>The page containing the index entry will appear in the index.</td>
</tr>
<tr>
<td>Page Range</td>
<td>The page range beginning with the page containing the index entry through a specified number of pages will appear in the index. You will have to provide the count.</td>
</tr>
<tr>
<td>This Component</td>
<td>The page range beginning with the page containing the index entry through the end of the containing component will appear in the index. If the component ends on the same page as the index entry, a single page number will be used.</td>
</tr>
<tr>
<td>To Named Component</td>
<td>The page range beginning with the page containing the index entry through the beginning of the next component with a given name will appear in the index. You will have to provide the name.</td>
</tr>
<tr>
<td>See (Also)</td>
<td>Refers the reader to another index entry. If this entry has no other page locators, then the word See appears in the index. If other page locators exist, then the words See Also will appear in the index. When you set this as the range, you must also type the text that appears after See (Also).</td>
</tr>
</tbody>
</table>

**Tip** If you have many places where you want to put the exact same index entry (so that multiple pages will be listed in the index document), you don’t have to create a new index token from scratch each time. Index tokens can be cut, copied, and pasted like other objects within Interleaf 6; so just copy the desired index token and paste it in the other locations where you want to set up a reference.

### Modifying an Existing Index Entry

Before you actually create an index, let’s learn to modify index entries. It will not be uncommon to decide that you want all occurrences of an index entry to have different values for the index headings. For instance, in the User Guide you have decided to change the entry `league:new` to `league:starting new`. If this entry occurs in many places, you will be spending a lot of time trying to change each one manually to the new headings.
The best approach is to find one occurrence of the index token and modify the index token properties using the Index Headings dialog box (see Figure 8–14).

To globally change the value of an index heading, open the Index Token Properties dialog box and click on Rename Headings... to open an Index Headings dialog box.

Enter the old values in the Heading column and the new values for the heading in the Change To column. Click on Apply to change the heading values.

The Index Token Properties dialog box will reflect the new values. All other index tokens that had the same values for headings will also be modified.

**Figure 8–14. Changing index headings**
First, find the index token for the *league:new* entry. Select the token and open the Index Token Properties dialog box by choosing Edit → Properties... or by clicking on the Properties button on the tool bar. Click the Rename Headings... button to change the headings on the Index Headings dialog box. Click on the Level 2 Headings drop-down arrow and select new. In the Change To column enter the new value for the Level 2 Heading: *starting new*. Click on OK or Apply to modify all index tokens with the headings *league:new*. If you look at the Index Token Properties dialog box you’ll see that the value for the Level 2 Heading has been changed. Click on OK to dismiss the dialog box.

**Tip** While we are on the subject of modifying index entries, you may have wondered what the Sort column is used for. Well, when Interleaf 6 creates an index, it is sorted based upon the entries in the Sort column. You don’t have to enter values in the Sort column directly as the values in the Sort column default to the values entered in the Heading column. If you want the index entry to show up in the index with its current headings but sorted in a different order, you can override the default sort values by entering a different value in the sort column.

For example, if you have *grade:one*, *grade:two*, and *grade:three* as the heading values for an index, they will appear in the sorted index with *grade:three* appearing before *grade:two*. If you want them to appear in a numerical order instead, then under the Sort column for each each index token you should enter 1 for one, 2 for two, and 3 for three. Now when sorted in the index the entries will appear as *grade:one*, *grade:two*, followed by *grade:three*.

**Creating an Index**

Now that all that preparation has gone into creating index entries, it is time to create an index. Creating the actual index document is the easiest step in the process of indexing documents with Interleaf 6—all you have to do is select the documents to include in the index and choose the index command. Interleaf 6 offers two different index commands: one for creating a normal index, and one for creating a master index.

As the name implies, a normal index is the type of index you will use in most situations. A normal index creates an entry for each index token found in a document. The page locator is the value of the page number or autonumber you chose to use for the index. A master index, on the other
hand, adds the name of the top-level sub-book as part of the locator. This makes a master index useful for a multiple volume set of documentation. In addition to a normal index for each volume, you can create a master index that will have the volume name as part of the page locator.

**Generating a Normal Index**

To create a normal index, select the documents you want included in the index and run the normal index command. Interleaf 6 will scan all of the selected documents and then create an index document.

Open the *User Guide* book and select the *Introduction* and *League Setup* documents. Create a normal index by choosing *Book ➔ Index ➔ Normal* on the menu. Open the resulting *Index* document to see how the index entries have been formatted into an index (see Figure 8-15).

Interleaf 6 has created a sorted index. Each group of entries beginning with the same letter is preceded by a component named *IndexLet* that has the corresponding letter for content. Each index entry will be contained in one or more components named *LevelX*, where *X* can range anywhere from 1 to the number of levels you have defined for your index entries. Since all

---

**Figure 8-15.** Creating a normal index
of our index entries have no more than two levels of headings, we will find only components with names Level1 and Level2.

As you have probably noticed from Figure 8–15, not all Level 2 Headings correspond to a Level2 component. The rule Interleaf 6 uses is straightforward: if the previous heading level is unique, include the current level in the same component, with the levels separated by a comma; if the previous heading level is not unique, use a separate component for the current level. Since two of the index entries you created contained “league” for the Level 1 Heading, you find both of them in a Level2 component immediately following a Level1 component, with “league” as its content. Since there is only one index entry with a Level 1 Heading containing the word “bowling,” the Level 2 Heading “history” is contained in the same component, with the two heading levels separated by a comma.

**Generating a Master Index**

Generating a master index is very similar to generating a normal index, but there is just a little more preparation that must be performed. Each section or volume of the documentation must be placed into a sub-book. The name of the sub-book will be used in generating the locator within the index.

To create a master index for the *User Guide*, create two sub-books within the *User Guide* container window. Name the first sub-book Part I and move the *Introduction* document into it. Name the second sub-book Part II and move the *League Setup* document into it. Now create the index just as you did before, but this time choose **Book→Index→Master** from the menu. Open the *Index* document and look at the location of each of the index entries. In addition to the original page number, the name of the sub-book is included to help the reader find the information (see Figure 8–16).

**Reformatting an Index**

Reformatting an index requires the same process as reformatting a table of contents. Create a new sub-book and name it *back*. Move the *Index* document into *back*. Now create an index_sty style sheet by choosing **File→New→Inside Interleaf→User Guide→Rear→index_sty** from the menu. As with the table of contents, we are using a sub-book so that the style sheet will not affect anything outside of the sub-book.

Make sure that the *Index* document is to the right of the index_sty style sheet. Open the *Index* document. As the document is opening, you should
To create a master index, first create sub-books within your documentation. Give each sub-book the name you want to appear in the master index (Vol. I, Vol. II, System Administration, Programmer’s Reference, etc.).

Select all of the documents and sub-books you want indexed and choose Book→Index→Master from the menu. Interleaf 6 will create a sorted index document. Open the Index document to see the default formatting and the sub-book names used for the index locators.

The sub-book name is now part of the page location.

**Figure 8-16. Creating a master index**

notice a message in the status bar stating “Reading exported masters from ‘index_sty’...” When Interleaf 6 finishes composing the Index document, you should see the new format. The most noticeable differences are that the index letters are now colored blue and the document is a single column document (see Figure 8-17).

To finish the formatting of the Index document, create an index:title component at the beginning of the document. The index:title component is exported from the index_sty style sheet.

**Summary**

In this chapter, you learned about Interleaf 6 books and that they have some very useful features. You should now understand how a book forces objects into relationships, and those relationships are dependent upon the order of the objects within the book. You also learned about two very important book features: tables of contents and indexes. You saw how Net-
Inside a new sub-book, create the index_sty style sheet. Position the Index document to the right of the index_sty style sheet and then open the document.

The Index document will take on the format and layout defined in the style sheet.

**Figure 8-17.** Formatting an index with a style sheet

work Style Sheets can be used to control the formatting and layout of the table of contents and indexes you create.

You have completed all of the chapters in the second part of this book, and now have the basic skills required to effectively assemble your company's user documentation from their existing template. In the next part of the book, you will learn more about the different properties that go into designing a document as you create your own User Guide template.
PART III
Not For Document Designers Only

Part III describes the essentials required to design and modify documents and document components. You'll begin by modifying page layout, which can affect your design of paragraphs and headings (the second topic in this part). You'll then learn how to format lists and other useful objects. You'll learn how to design a table, and when you have completed that, you'll learn how to bring all you have learned together into a document template.

SETTING THE STAGE FOR PART III OF THIS BOOK

Your department is responsible for user's guides describing the use of the software. Until now, the user's guides have always been printed. Now, however, the company wants to have online user's guides. You have been given the task to design a document template for displaying the user's guides online. Since you want your existing Interleaf 6 files to be easily converted to the new format, you will use the User Guide template currently used by the documentation department (described in Appendix A) and redesign it for online display. Along the way, you have also been asked to design additional objects for use by the department's authors.
CHAPTER 9

Page Layout

This chapter describes some of the options for composing the pages of a document. You will learn how to select page dimensions. You will learn how to establish single-sided and double-sided layouts. You will also learn how to create documents with more than one column. You will learn how to create page content that repeats on all pages of the document. Specifically, you will learn how to create running headers and footers, you will see how to define and include page numbers, and you will learn a technique for creating finger tabs on the document pages.

ESTABLISHING PAGE DIMENSIONS

When designing a document, one of the first things you should decide is the size of the page and the size of the margins. Many other elements of your document design will be affected by your choices of page size and margins.

Begin by creating a new document (File → New → document) and then opening the document. To access the page properties of the document choose Properties → Document... from the menu. You will be presented with the Document Properties dialog box. Click on Size to edit the page size and margins.
Since you are now trying to design a document that will be viewed online, you want to decrease the page size. Although many computers today support screen resolutions as great as 1280 pixels wide by 1024 pixels high, many users are still working with a VGA screen (600 × 480 pixels) that does not support the display of an 8.5 × 11 inch page. Even the popular display size of 1024 × 768 doesn’t display a letter size page. Reducing the page size will minimize the amount of scrolling you have to do.

Assume that you are writing documentation for a VGA screen. A page size you might consider using is a width of 6 inches and a height of 5 inches. Double-click on the 8.5 in the width field to select it and type in 6. Do the same for the height, except type in 5.

For margins, set the left and right margins to 0.25 inch each (you don’t need much for online viewing), the top margin to 0.5 inch, and the bottom margin to 0.5 inch (see Figure 9–1). Once you have set all of the margins, click Apply. Interleaf 6 will repaginate your document and leave the Document Properties dialog box open.

Choose a standard paper size or type in your own custom size.

If you have set up double-sided layout, then Left and Right may read Inner and Outer.

Figure 9–1. Page Size properties
Note The values given here for page dimensions and margins are just examples. For your own documentation, you will use whatever values are most appropriate for producing effective and professional online documentation.

Defining Printed Sides

For our online document, we want to use a single-sided page layout; but if you are printing your documentation, in most cases you will print on both sides of a sheet of paper. Although I had you establish the page dimensions first, for paper documents you may find it more efficient to define the number of printed sides first. This is done by clicking Layout on the Document Properties dialog box.

Single Versus Double Sided

You tell Interleaf 6 to use both sides of a sheet when you change Page Layout from Single Sided to Odd Page Left or Odd Page Right (see Figure 9-2). As the choices imply, when you choose Odd Page Left all pages on the verso, or left hand, page of a two-page layout will have odd numbers and all pages on the recto, or right hand, page will have even numbers. The more common case is to choose Odd Page Right (see Figure 9-3).


When a document is double-sided, you can set the type of Side Margins to use: Inner/Outer or Left/Right.

Figure 9-2. Page Layout
Double-Sided Considerations

When you choose a double-sided layout, such as Odd Page Right, two other Layout properties become active: Side Margins and Begin With. The Side Margins property can be set to Inner/Outer or Left/Right. When you choose Inner/Outer, the left margin of left-hand pages and the right margin of right-hand pages are the outer margin. The inner margin is the right margin of left-hand pages and the left margin of right-hand pages. The Inner/Outer setting allows you to add more white space along the binding edge of the page. When you choose Left/Right, then both the left- and right-hand pages will have identical left and right margins. Figure 9–4 shows you the different Side Margins settings.
The setting you choose here will change the names of the associated margins on the Size sheet of the Document Properties dialog box; that's why I said you may find it more efficient to set the Layout properties before the Size properties. If you choose Inner/Outer after you have already set the Left and Right Margins, you will have to reset the Inner and Outer margins on the Size sheet. If you later decide to go back to Left/Right margins, you won't have to re-enter the Left and Right margins, Interleaf 6 will remember the settings.

You can experiment with these settings. When you have finished, reset the document for single-sided so we can continue to define our online document.

**Setting Number of Columns**

In addition to setting page size and margins from the Layout sheet, you can establish the number of columns in your document. For example, if you wanted to set up a double-column document, change the Number of Columns setting to 2. Once you have done this, the Gutter Width and Balance Columns properties become active (see Figure 9–5).

The Gutter Width specifies the amount of space between the columns of a multiple column document. The default value for Gutter Width is 2 picas (0.3321 inch). When the Balance Columns box is checked, Interleaf 6 will balance the content of all columns. When the check box is not checked,
content will remain in one column until it reaches the bottom of the column; at that time, it will flow into the next column. If the number of columns is greater than 1, then Gutter Width and Balance Columns become active.

**Figure 9-5.** Balanced versus unbalanced columns

For the online documentation you are creating, stick with a single-column document.

**Tip** All of the columns created by Interleaf 6 have the same width. If you find it necessary to create columns of varying widths, the effect can be accomplished by using microdocuments within a frame on the page. This technique can also be used to temporarily change from a single column to multiple columns on the same page of a document. For example, in a single column document, you can create a frame that spans the width of the page. In the frame, you can create a microdocument that is set to two or more columns. This will give you a section of your document that has a different number of columns than the rest of the document. (For more about microdocuments, see Chapter 14.)

**Other Document Properties**

Other document properties are available from the Document Properties dialog box. These include Composition (hyphenation, revision bar placement, component spacing, and font system), Vertical, and Units properties. If you want more information about these properties, consult Interleaf 6's online documentation. You can access the online documentation by clicking Help on the Document Properties dialog box.
The Composition sheet allows you to define hyphenation, placement of revision bars, how spacing is adjusted between components, and the font system to use with the document.

The Vertical sheet allows you to turn on vertical justification. When vertical justification is on, you can adjust the parameters used by Interleaf 6 to perform the justification.

The Units sheet allows you to specify the units for different parts of the user interface. Here, leading and font size are specified in points, and everything else is in inches.

*Figure 9–6. Other document properties*
Headers and footers are graphic frames that occur at the top and bottom of each page. The contents of headers and footers are shared among all pages within a document. The size of the header and footer frames is implicitly defined when you establish the top and bottom margins of your page layout. The number of header and footer frames is determined by page layout properties. You may have noticed a section on the Document Properties Layout sheet dealing with properties of headers and footers. These properties determine whether there is a different header or footer on the first page of the document, and if the header and footer are allowed to span the entire width of the page or bleed into the margins.

Viewing Header and Footer Boundaries

While designing a page layout, you might find it helpful to see what part of a page is taken up by a header or footer. To see the boundaries of the header and footer frames in your document, you tell Interleaf 6 to show all closed frame borders with a dotted line. This is done by choosing View → Markers ... on the document pulldown menu. This will bring up the View Markers dialog box. To view the header and footer frames, choose View → Markers... and turn on the Closed Frame Borders check box in the View Markers dialog box. Interleaf 6 will show you the boundaries of the header and footer frames with a dotted line.

Figure 9-7. Displaying header and footer frame borders
ers dialog box where you can turn on Closed Frame Borders (see Figure 9–7).

**Changing the Size of Headers and Footers**

Now that you can see the exact boundaries of the header and footer, you can adjust the header and footer size and immediately see the results on the page. You can change the size of the headers and footers in two different ways. The most obvious way is to adjust the top and bottom margins of your document. To increase the height of the header, increase the size of the top margin. To decrease the height of the header, decrease the top margin. To change the width of the header, change the left and right margins (see Figure 9–8).

<table>
<thead>
<tr>
<th>Margins</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Top</td>
<td>1 inches</td>
<td></td>
</tr>
<tr>
<td>Bottom</td>
<td>0.5 inches</td>
<td></td>
</tr>
<tr>
<td>Left</td>
<td>0.25 inches</td>
<td></td>
</tr>
<tr>
<td>Right</td>
<td>0.25 inches</td>
<td></td>
</tr>
</tbody>
</table>

**Figure 9–8. Changing header and footer size by changing document margins**

If you want the header and footer frames to extend to the edge of the page, turn on Header/Footer Bleed. Do this by bringing up the Document Properties dialog box, changing to the Layout sheet of the dialog box, clicking on Bleed, and then clicking Apply. If you have left Closed Frame Borders on, you will see the frame border expand to the complete width of the page (see Figure 9–9).

You have now seen how to adjust the size of headers and footers. Next, you’ll see how you can change the number of headers and footers in a document.
To make headers and footers bleed into the side margins, turn on Bleed (found on the Layout sheet of the Document Properties dialog box).

**Figure 9-9.** Allowing headers and footer to bleed to the edge of the page

### Changing the Number of Headers and Footers

Each document can have, at most, three different headers and three different footers. Why three? Well, let’s begin with a single-sided document. A single-sided document has one header and one footer that are shared across all pages of the document. Earlier, you saw how to create a double-sided document. In a double-sided document, there are now two different headers and two different footers—one each for the left- and right-hand pages. The content of headers and footers on a right-hand page is shared by all right-hand pages in the document. The same is true for the left-hand pages.

The third header and footer come into play when you turn on the Different First Header and Different First Footer properties of the document (on the Layout sheet of the Document Properties dialog box). Many times this feature is used when you have a document that starts a new section or chapter of your documentation and you want the first page to look different (see Figure 9-10). If you look at the pages of this book, you’ll see that a different header is used on the first page of each chapter; this is accomplished by turning Different First Header on.

Changing the number of headers and footers is a simple matter of changing Page Layout, Different First Header, and Different First Footer properties of the document (see Figure 9-11).
What do you do if you need more than three different headers or footers in a document? You can begin by breaking your document up into multiple documents. You can also use some additional Interleaf 6 features to actually display different information in the headers and footers from page to page without violating the rule of having the content shared among all of the pages. And finally, you can use repeat content frames. As you work through the rest of this chapter, you'll see how to use these Interleaf 6 features.
REPEATED PAGE CONTENT

Now that you have seen how to control the basic dimensions of a page, you are ready to add some content to your document. The content that we are concerned with here is repeated content. Repeated content usually occurs in the header and footer of a page, but can occur anywhere using repeated frames within Interleaf 6. The most common items that appear in the header or footer are page numbers, section titles, and page revision information. We'll first look at how to add these different types of items to headers and footers, and then I'll show you how to set up repeat content frames.

Creating and Using Page Numbers

Interleaf 6 allows you to use more than one page number on a page. This feature allows you to have one page number to identify an overall page number within a book or report, and another page number to identify the page number relative to a chapter or section. Multiple page numbers are possible because you can define multiple page number streams within a document.

Creating a New Page Number

You define page number streams using the Page Number Streams dialog box which you access by choosing Properties → Page Number Streams... from the document pulldown menu.

Create a new page number stream named small by typing small at the top of the dialog box and then clicking New. You can now modify the page number stream properties. Change Number Type to lowercase Roman numerals (i, ii, iii). We want small to refer to pages relative to the current document, so turn off Starting Number Inherit. Those are all of the changes we'll make, so click on OK to apply your changes and dismiss the dialog box (see Figure 9–12). Now let’s use these page numbers in our document.

Referencing the Page Number in a Text String

Let’s put the page numbers in the footer of the document. Page numbers can be inserted into two different objects (a text string or a microdocument) within the footer or any other frame. Open the footer frame by double-clicking within it. To create a text string or a microdocument, use the Drawing palette (see Figure 9–13). Bring up the Drawing palette by choosing Tools → Graphics Palettes → Drawing... from the menu.
For the first page number, use a text string. Click on the text button, drag the mouse right, and choose the text string tool before releasing the mouse. Now position the mouse in the footer where you want the page number and click once. A text string anchor is now present where you clicked the mouse. To insert the default page number stream in this text string, type \texttt{ESC P} or \texttt{ESC #}.

\textbf{Tip} You can also create a reference to the name of the document by typing \texttt{ESC N} or \texttt{ESC @} in a text string.

Only the document’s default page number stream may be inserted in a text string. That means that the new page number stream, \texttt{small}, is not accessible in a text string unless it is changed to the default page number stream for the document. Rather than change the document’s default page number stream, you can use a microdocument to display the other page number streams in a document.
Once the frame is open, bring up the drawing palette by choosing **Tools → Graphics Palettes → Drawing...**

To create a text string, choose the text string tool button.

Position the mouse where you want the text string to occur and click.

Press ESC P, or ESC # to create a reference to the default page number.

**Figure 9-13.** Adding a page number to a text string

**Referencing the Page Number in a Microdocument**

Return to the footer frame and make sure it is open. If the Drawing palette is not open, open it now. Choose the microdocument tool using the same procedure you used to choose the text string tool. Position the mouse cursor in the footer and click to create a microdocument. Open the microdocument by double-clicking on it. Now insert a reference to a page number using the Create dialog box (see Figure 9-14). (You can bring up the Create dialog box by choosing **Create → Reference → Page Number...**.) Select the page number you created earlier, **small**, and then click Create. You now have references to both page number streams in the footer of your document.
To create a microdocument, choose the microdocument text tool button. Position the microdocument in the frame and click. Open the microdocument by double-clicking on it.

Create a page number reference by choosing **Create** → **Reference** → **Page Number**.

Select **small** and click **Create**. A reference to the current page number, using the **small** page number stream, is created in the microdocument.

**Figure 9-14.** Adding a page number to a microdocument

**Adding Section Titles to the Header**

If you want to include the title of the most recent section in the header of your document, you can use an Interleaf 6 feature known as variable content. Variable content allows you to adhere to the requirement that the content of a header frame is shared across all pages of a document. In the case of variable content, the microdocument holding the content is the same, and the formula for the text within the microdocument is the same. However, the formula refers to components whose contents can change.
from page to page. For example, if you want to create a telephone directory for your company using Interleaf 6, you can use variable content to put the names of the first person and last person on each page in the header of that page.

**Creating a Variable Content Component**

To set up a variable content component in the header, create a microdocument in the header (see Figure 9–15). It is a good idea to size the microdocument to the width of the header (or at least large enough to hold the longest line of text expected). Size the microdocument by dragging a handle. After the microdocument has been sized, open the microdocument for editing by double-clicking on it. The component bar will change to show the microdocument’s component. Select the component and bring up the Component Properties dialog box. Switch to the Content sheet of the Component Properties dialog box.

In the Content area of the dialog box, turn on Variable content. The selections under Source Component are now effective. Set Position to Last on Page and Name to the name of the component that represents the section title, in this case subhead. (Later, after you have defined the headings in your document, you can change subhead to the name of first level headings, h:1.) Apply the change to the current component and the content will now show the value of the last subhead to have appeared on the page (or on a previous page if there are no subheads on the current page).

**Note**  Variable content components have their Read Only property automatically set so that you can’t accidently edit the content. If you wish to change the content of a variable content component, you must first turn variable content off.

**Adding Page Revision Information**

The final type of content in headers and footers I will address involves adding page revision information, such as the date the page is effective or published, to a header or footer. Many long technical publications have a very long lifetime and undergo many revisions. Many times, only the pages that have actually changed are printed and distributed. As an aid to keep track of pages, a date or revision number is added to the page.
Create a microdocument in the header. Size the microdocument to hold the longest possible line of text.

Open the microdocument for editing by double-clicking on it. Double-click on the component name to access the Component Properties dialog box.

Turn on variable content, and then set the Source Component to Last on Page. Set the name of the component to the component that represents section titles: subhead.

Apply the changes. The header should now contain the text of the most recent section title.

Figure 9-15. Creating variable content components
Revision Information Is Attached to Components

The components found on a page are where you will keep track of revision information. For example, if you are revising a document, your revisions actually take place at the component level. If you change the text in a component, you will change the revision information for that component to reflect that it has been modified. Assume the date of the original document was March 13, 1988, and the date when a revision was published was October 16, 1990. On pages containing components that remain unchanged from the original publication, you want the date March 13, 1988 to be printed. Likewise, on pages that contain at least one component that was modified in the revision, you want the date October 16, 1990 to appear.

Interleaf 6 allows you to add this revision information and display dates based on the revision information using attributes and attribute references. An attribute is a user-definable property that can be associated with an Interleaf 6 object. Once an attribute is assigned to an object, the attribute's value is available to assist Interleaf 6 with the creation of a document. We're going to use the value of an attribute to put the proper revision date on a page, but before we can do that, we have to define the attribute, and its possible values, to Interleaf 6.

Defining a Revision Attribute

Attributes are defined on the Attributes Setup dialog box. Access this dialog box by choosing Properties → Attributes Setup... from the menu. The Attributes Setup dialog box has three main areas: one for defining control expressions for a document, a second for defining which attributes are present in the document, and a third for defining the values that are allowed for an attribute.

To add an attribute, type in the name of the attribute in the field above the Add, Change, and Delete buttons in the second area of the dialog box. Type in the name revision for our page revision date attribute, and click on Add. At this point, we can use the revision attribute and assign any value to it. However, we want to limit the values that can be assigned as a revision attribute. We limit the values by turning on the Restricted option for Value Type. When the restricted option is on, the Add, Change, and Delete buttons are now enabled in the third area of the dialog box. Type 1 in the text box above the Add, Change, and Delete buttons, and then click Add. Click OK to apply these changes and close the dialog box. By restricting the value to 1, you can only set the revision attribute to 1 or to nothing at all. This will
prevent your authors from mistakenly setting the value to a number which has no corresponding date.

Define an attribute on the Attribute Setup dialog box. Access this dialog box by choosing Properties→Attribute Setup... from the menu.

Type in the new attribute name and click Add. Set Value Type to Restricted and add the allowed values.

In this case, add 1 as the only allowed value by typing 1 and clicking Add. Apply the changes.

**Figure 9-16.** Defining new attributes

**Using the Revision Attribute**

Now that you have defined a revision attribute, you can set this attribute to a 1 on any component that is modified in the first revision of the document. Any components that are unchanged from the original edit will not have a value assigned to the revision attribute. Once these values are assigned at the component level, you can reference the values of the attribute in a microdocument in the header or footer of the page.

Select a component to modify its attributes. Choose Properties→Attributes... to gain access to the Attributes dialog box (see Figure 9–17). Click on
the name (revision) of the attribute you want to add, pick a restricted value from the drop down list, and click Add. Apply the changes to the current component.

Choose Properties→Attributes... to gain access to the Attributes dialog box. Click on revision, pick 1 from the drop down list, and click Add. Apply the changes to the current component.

**Figure 9-17. Setting a component’s revision attribute**

**Reference the Revision Attribute**

To reference an attribute, first create a microdocument in the page header. Double-click on the microdocument to open it. Insert an attribute reference by choosing Create→Reference→Attributes... from the menu. In the Create Attribute Reference dialog box, select revision and click Create (see Figure 9-18). An attribute reference has been created. Now, you need to tell Interleaf 6 what text to display based on the value of revision attributes found on the page.

Select the attribute reference by clicking on it. Choose Properties→Selection... to open the Attribute Reference dialog box. Since we want the page to reflect the latest revision of anything on the page, we will select Page as the range and Maximum for the reference. For the first revision of the document, components can either be unchanged from the original document (attribute value unassigned) or changed in the first revision (attribute value of 1).

When a value is unassigned, you reference that value with the term *nil* (which is a Lisp value that means “empty” or “not true”). If nil is the highest
Create a reference to an attribute by choosing Create→Reference→Attributes... Select the attribute from the Create Attribute Reference dialog box and click Create.

Select the attribute reference by clicking on it. Open the Attribute Reference dialog box by choosing Properties→Selection.... Enter the values and their corresponding display text. Click Apply and the reference should now reflect the attributes present on the page.

Figure 9-18. Referencing an attribute

value on the page, then we want to display the original date. So the first entry in the Attribute Reference dialog box will be if NIL. show March 13, 1988. The second entry will be if 1 show October 16, 1990. (Remember, these dates were discussed as the original publication and first revision dates of the document.) Apply the changes.

You will now have a date displayed in the microdocument. On pages that are unchanged (e.g., no components on the page with a revision attribute
set to 1), the original date will appear. Modified components (revision attribute set to a 1) will cause the date on the page to become the date of the document’s first revision.

**Repeating Frames**

Now that you have seen how to get different types of content to repeat in the headers and footers of the pages in your document, you may be wondering if there is a way to get information to repeat in other areas of the page. The answer to this is yes, if you use repeating frames.

A repeating frame is a frame that will appear at the same location on consecutive pages in your document. For instance, if you have a two-column document and you want to put a vertical rule between the columns, you can accomplish this with a repeating frame. If you want to create finger tabs, a shaded region along the outer edge of the page to allow the reader to easily find sections of your publication, you can accomplish this with another repeating frame. I’ll finish this chapter with an example of creating finger tabs using a repeating frame.

**Creating a Finger Tab Frame**

Move to the first page of your document and create a new frame. Select the frame and bring up the Frame Properties dialog box by choosing *Properties → Frame...* from the menu. Repeating frames share content, so create a new frame master to hold the content of the repeating frame (see Figure 9–19). Click on New to bring up the Define Master dialog box. Type *fingertab* as the name and click Define. Close the Define Master dialog box.

In the Frame Properties dialog box, set the properties shown in Table 9–1. Change Apply to Changes to All and then click on OK. You will then be presented with a series of dialog boxes. Click “Apply anyway” or “Apply and do not ask again this session” on the first dialog box; click Master on the second dialog box; and click Confirm on the last dialog box. Congratulations! You have created a repeating frame along the outer margin of the page. If you look at the pages of your document, you should see this frame in the same location on every page. You now have to add appropriate content.
Table 9-1. Possible Frame Properties for a Finger Tab Frame

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>On the Layout Sheet:</td>
<td></td>
</tr>
<tr>
<td>Placement:</td>
<td>Overlay</td>
</tr>
<tr>
<td>Width:</td>
<td>Fixed 0.25 inches</td>
</tr>
<tr>
<td>Height:</td>
<td>Fixed 1.0 Inches</td>
</tr>
<tr>
<td>Horizontal Reference:</td>
<td>Outer Margin</td>
</tr>
<tr>
<td>Horizontal Alignment:</td>
<td>Outer</td>
</tr>
<tr>
<td>Horizontal Offset:</td>
<td>0.0 Inches</td>
</tr>
<tr>
<td>Vertical Reference:</td>
<td>Page (Without Margins)</td>
</tr>
<tr>
<td>Vertical Alignment:</td>
<td>Top</td>
</tr>
<tr>
<td>Vertical Offset:</td>
<td>0.0 Inches</td>
</tr>
<tr>
<td>On the Content Sheet:</td>
<td></td>
</tr>
<tr>
<td>Content:</td>
<td>Shared On</td>
</tr>
<tr>
<td>Repeating:</td>
<td>Begin On</td>
</tr>
</tbody>
</table>

Adding Content to the Frame

The simplest content you can add to make this a finger tab is a filled rectangle. Open the frame. To create the rectangle, you need the Drawing palette and the Commands palette. To open both at once, click on the graphic palettes button in the document tool bar.

First, use the rectangle tool on the Drawing palette to create a rectangle in the finger tab frame. Next, use the Size to Frame All command on the Commands palette to cause the rectangle to fill the entire frame.

Finally, change the fill color of the rectangle to black using the Fill/Edge dialog box (brought up by clicking on the Fill/Edge button on the Commands palette). Figure 9–20 shows the procedure.
After bringing up the Frame Properties dialog box, click New to define a new frame master. Type fingertab as the new master name and click Define.

Set the appropriate layout and Content properties. Apply all changes to all.

Answer affirmatively to all of the dialog boxes.

You have now defined a new fingertab frame and it appears on the current page and all following pages of your document.

**Figure 9-19.** Creating a repeating frame
With the box drawing tool, create a box inside the fingertab frame. Don’t worry about sizing the box to fill the frame—use a graphics command to do that.

Choose the Size to Frame All command to have the box fill the frame.

Click on the Fill/Edge command button to access the Fill/Edge dialog box.

Turn on Fill and choose a fill color of black and a solid fill color. Click OK to apply the changes to the box. You now have a solid black box to serve as a finger tab.

Figure 9-20. Adding a filled rectangle to the fingertab frame
Turning Repeating Frames Off

To turn off the repeating frame, create another fingertab frame on the page where you want the frame to end. Interleaf 6 will insert the frame and automatically adjust the frame's properties so that Repeating is set to End on the page where the frame anchor occurs. If you wanted to start a new series of finger tabs at this point, create another repeating frame, but make sure you use a unique name, such as fingertab2.

Summary

In this chapter, you saw how to use document properties to design the page layout of a document. You learned how to set up single- and double-sided documents and to define multiple columns. You also learned how to add some common content to the headers and footers found on the pages. These common items included page numbers (which you learned to define), document name, running headers, and page revision information using Interleaf 6 attributes. Finally, you learned how to use repeating frames to put shared information anywhere on a page.

The type of content you can place in headers, footers, and repeating frames is not limited to the items presented in this chapter. You can use any Interleaf 6 object that can be placed in a frame. Chapter 15 describes working with frames, and the objects that go in them, in greater detail. The next chapter will show you how to define the other objects that go on a page: components.
CHAPTER 10

Formatting Paragraphs and Headings

This chapter describes how to define basic text components used in a document. You will learn how to change component font properties and component layout properties. You will apply this to creating different document objects for paragraphs and headings.

BASIC COMPONENT PROPERTIES

In the last chapter, you began the redesign of your document by adjusting the basic properties of a document. You’ll begin this chapter by looking at basic component properties. You’ll recall that components are the main objects—the text and graphic hangers—that hold information in a document. The different types of components are designed using text, format, page, and tab properties. After I give you a brief introduction to the various component properties, you’ll redefine some of the components within the Software User Guide documents.

Component Text Properties

The text properties of a component are used to control how text is actually displayed on the screen and on the printed page. As you can see in Figure
10-1, the Text sheet of the Component Properties dialog box controls the font (family, size, bold, and italic) and other properties, such as the color of the text, underlining, superscripts and subscripts, kerning, and revision markings (revision bars, strikethroughs, and overbars). Another property that is related to the text properties is the dictionary language to use for spell checking and hyphenating the text. Interleaf 6 gives you the ability to use a different dictionary—or no dictionary at all—for different types of text.

All of these properties are established as the default text properties of the component. It is still possible to override these default settings for a subset of the text within the component. (You saw how this was done in Chapter 3 in the section “Local” Text Formatting.)

![Component text properties](image)

**Figure 10-1. Component text properties**

**Component Format Properties**

Format properties control the alignment of text within a component, and the spacing around, as well as between the lines of text within, a component. Formatting properties are contained on the Format sheet of the
Component Properties dialog box (see Figure 10–2). Alignment can be one of six values: Left, Right, Justified, Centered, Inner, or Outer.

Left and Right spacing is measured from the edge of a column (in a single column document these are measured from the left and right margins, respectively) and is an absolute measurement; whereas, the Above and Below spacing is a default value. The default values don’t necessarily specify the actual space above or below a component; the values are used in a formula (that you can adjust) used by Interleaf 6 when adjusting vertical spacing of components on a page.

![Component Properties dialog box](image)

**Figure 10–2. Component format properties**

**Effect of Document Composition Properties**

The formula you set up is found on the Composition sheet on the Document Properties dialog box (see Figure 10–3). You can have Interleaf 6 add the value of the below margin of one component to the above margin of the following component, use the maximum or minimum margin between components, use just the above margins, or use just the below margins. In addition, you can also specify whether the spacing is applied between components or from one baseline to the next baseline. Figure 10–3 illustrates these differences.
When composition is set to measure margins between components, you can tell Interleaf 6 how to determine the spacing. Add, Above Only, and Below Only do just as their names imply. Maximum uses the maximum value between the Below margin of the top component and the Above margin of the bottom component. Minimum uses the minimum value of these two measurements.

When composition is set to measure margins between baselines, the Below margin of the top component is added to the Above margin of the bottom component. The sum is then used as the space from the baseline of the last line of text in the top component to the baseline of the first line of text in the bottom component.

**Figure 10-3.** Effects of different document composition properties
It is important to know which formula is in effect when you are designing a component's format properties. For example, if only the below margins are being used to determine spacing between components, then you needn't bother with setting above margins for every component you define. The default settings in a document are to add above and below margins together and to have Interleaf 6 apply this space between the components. Unless you make changes to the formula, you should set both the Above and Below margins.

**Effect of Document Vertical Properties**

One other aspect of the formula Interleaf 6 uses to compose a page that doesn't have a direct impact on how you define components (but you should be aware of) is page justification. Page justification is defined on the Vertical sheet on the Document Properties dialog box (see Figure 10–4). When Vertical Justification is on, Interleaf 6 will attempt to balance the columns in the document. When Justify Pages is also on, Interleaf 6 will attempt to justify the pages in the document. Interleaf 6 accomplishes this by adjusting component margins (by shrinking or stretching them), by increasing the space between lines within a component (feathering), and by increasing frame margins. The amount each of these items may be stretched or shrunk is determined by the settings on the Vertical sheet. For page justification, a short page is defined as the page at the end of a document, or one that ends because the next component was forced to start on
a new page; whereas, a long page is defined as any page that isn’t a short page—text in a component is split and wraps to the next page.

**Note** Although vertical settings don’t have a direct impact on the values you set for component properties, you need to be aware of them. There have been times when I have been adjusting component properties to get text to fit “just so” on a page and couldn’t get the results I was looking for until I turned vertical justification off.

**Component Page Properties**

After you have decided what a component should look like by setting Text and Format properties, you need to make some decisions about how Interleaf 6 should treat the component around column and page boundaries. You’ll make your choices on the Page sheet of the Component properties dialog box. Page properties fall into two general categories: control of component placement, and control over how the component behaves at column and page breaks. Use of these properties is very straightforward. Figure 10–5 shows the page sheet of the Component Properties dialog box.

---

*Figure 10–5. Component page properties*
Component Tab Properties

The last area of basic component properties involves tabs. Tabs allow you to precisely align text on the page and should be used instead of typing spaces to line text up into columns. Tabs are defined on the Tabs sheet of the Component Properties dialog box (see Figure 10–6). This sheet allows you to add, change, or delete individual tabs, or modify all of the tab stops at once. You’ll see how to use component tab properties later in this chapter.

![Component Properties for p:0 - start](Image)

Displays the tab stops for the component. To edit or delete a tab stop, select it from this list.

**Figure 10–6.** Component tab properties

Defining Paragraphs

Now that I have introduced you to some basic component properties, it’s time for you to put these properties to use in defining components. The first type of component you’ll define is a paragraph component. A paragraph component is the component that holds most of the text within a document.

You’ll continue to work with the document you used in the last chapter to set up page properties. If you haven’t already renamed the document from
its default name, you might consider renaming it to online so you don't confuse it with some other document you might create later.

Now open online. Create a para component and delete all other components. Open the Component properties for para by double-clicking on its name in the component bar of the document window. (You can also click on the Properties button in the tool bar after you have selected a component.) Since the paper-based template has paragraph components named p:0 and p:1, we need to create these two paragraph masters in our online template document.

**First Level Paragraph**

To create a first paragraph we'll rename the current para master since we won't be using any para components in our User Guide. Click on More to access a cascading menu where you can then choose Rename Master.... Enter p:0 in the dialog box and click OK (see Figure 10-7). Now that you have renamed the master to p:0, let's define the properties for this top-level paragraph.

For easy reading of the documentation online, use a sans-serif font and a little larger point size than you would use for a paper document. So, on the Text sheet change the font family to Swiss and a size of 14 points. On the Format sheet, change the alignment to left aligned, and change the margins to 0.08 inches above and below the component. Also, set the initial indent to 0.0 inches. For line spacing, set it equal to the largest font on the line plus 2 points. After you have made all of these settings (see Figure 10-8),
change the Apply option to Changes to All and then click the Apply button. If you receive a confirmation dialog box, confirm the apply. Congratulations! You have created a new master component.

**Note** The values being used for the design of the online components are for illustration purposes only. There are many good books that describe everything that you should consider when designing for online display.

After making changes to component properties, change Apply to Changes to All.

Click on Apply. Interleaf 6 will ask you to confirm the changes. Click on Apply anyway, or click on the other Apply button so you won’t be bothered with this again. (If you do make a change that you want to undo, you can always revert to the saved or backup version of the document. Of course, you’ll lose any other changes you may have made.)

**Figure 10-8.** Applying changes to the master
Note Remember that a master is a default definition of a component and is stored with a document. An instance is a component (based on a master) actually in use within a document. When you make changes to the properties of a component instance, you must apply the changes to all to cause the master definition to be updated. This also has the effect of modifying all of the components within the document that have the same name. The next time you create an instance of the component, it will have all of the new properties that are assigned to the master.

If you remember the closet example from Chapter 2, the hangers in your closet are instances of hangers you might find specified in a closet supply catalog. If you bend a hanger in your closet, you have modified properties of an instance. If you want to modify the catalog specifications for this hanger to include your modifications (in other words, modify the master definition), you’ll have to request the changes from the manufacturer of the hanger. When the manufacturer makes the changes, the specifications will change in the catalog, and the next time you order that hanger, it will have your modifications already in place.

Second Level Paragraph

Now, let’s create the component to hold the text for second level paragraphs. Second level paragraphs are used for sub-paragraphs and share many of the same properties as first level paragraphs. The main differences between the two are that the second level paragraph will have its left margin indented and have smaller Above and Below margins.

Since a second level paragraph is very similar to a first level paragraph, the easiest way to create one is to start from a first level paragraph. Create another p:0 component in your document. Click on the new p:0 component in the component bar. Open the Component Properties dialog box. To create a new component master for the second level paragraph, click on New... to access the Define Master dialog box (see Figure 10–9). Type in p:1 for the name of the new master and click on Define. You have now defined a new component.
When you click on New..., you will be presented with the Define Master dialog box. Enter a new master name. When you click Apply, all the properties (and content and attributes if they are turned on) will be copied to the new master. The Component Properties dialog box now displays the name and properties of the new component.

![Define Master dialog box](image1)

You'll see that the name of the selected component in the component bar is now p:1 and the Component Properties dialog box also shows the name p:1. You now have to modify p:1 component properties to make it look like a second level paragraph. Change the above and below margins to 0.04 inches each, and the left margin to 0.5 inches. Now, apply the changes to all. When you have done this, Interleaf 6 will give you a message that the master definition for p:1 has been updated.

![Component Properties for p:1 - online](image2)

**Figure 10-9.** Creating a new master

You may be wondering by now if you can use the preexisting components in the User Guide template instead of renaming masters or creating new masters from scratch. The answer is, “Yes, you can.” Just copy the components from the existing document template into your new document and change the component properties for online display. Make sure you apply your changes to all so that the master definition is updated.
DEFINING HEADINGS

Now that you have defined the paragraph components used in the *User Guide*, it's time to define the headings. There are a number of different components used within the *User Guide* template for headings. (For a description of all the heading components, see Appendix A.) In this chapter, I will show you how to create new versions of some of those headings. I will show you two different styles of headings that will be used in the online version of the *User Guide*: headings in separate components and headings as inline components.

Separate Headings

Creating a heading as a separate component is no different than creating separate components to hold paragraph text: you create a new component, rename the master or create a new master, modify the component's properties, and apply changes to all to update the master.

To create a new *h:1* heading component, you'll start with the existing component *head*. Create a component named *head*. Using the Component Properties dialog box, rename the master to *h:1*. Change the font family to

![Figure 10-10. Changing a component's text color](image)
Thames, size to 20 points, and change the color of the font from its default blue to black (see Figure 10–10).

On the Format sheet, change the Above margin to 0.3 inches and the Below margin to 0.1 inches. The online version of the heading will not contain a number (so it will not have a prefix). Also, since we still want the heading included in a table of contents, type in toc as the name of the table of contents document on the Content sheet (see Figure 10–11). Apply your changes to all so that the master is updated. You have defined a first level heading.

Now, define a second level heading, h:2, by copying or creating a new h:1 and modifying its properties. The properties you want to modify are Size to 18 points, Above margin to 0.2 inches, and Below margin to 0.05 inches. Apply the changes to all. You have now defined a second level heading.
Note Another important aspect of the Apply Changes to All setting is that only the properties that you have modified are applied to the master and all components. For example, assume you are modifying a component that already had a different font from other components of the same name, and you only change the component margins. When you Apply Changes to All, only the margin properties will be applied—not the font properties of the component. If you want all of the properties of the selected component to be applied to the master and other components within the document, then choose Apply All Props to All.

**Inline Headings**

For the online version of the documentation, you have also been instructed by your boss to create a heading that occurs on the first line of a paragraph. This type of heading is known as in inline heading. You create inline headings using Interleaf 6 inline components. Inline components are created from the Create dialog box or by selecting a range of text and converting it into an inline component.

You are already familiar with using the Create dialog box for creating top level components. To use it to create inline components, simply choose the Inlines option, select the name of the inline component you want to create, and click Create (see Figure 10–12). The inline component will be created at the text insertion point.

![Figure 10-12. Creating an inline component with the Create dialog box](image-url)
Converting Text into an Inline Component

You can also convert selected text into an inline component. Begin by creating a $p:0$ component (since the inline component you're defining is intended to appear on the same line as a regular paragraph). Type in the word \textit{Heading}, a period (.) followed by a space, and then the words, \textit{Here is some text}. Now, select the word \textit{Heading} along with the period, and then choose \textbf{Edit} $\rightarrow$ \textbf{Convert to Inline...} from the menu. This will open the Con-
vert to Inline dialog box where you choose the name of the inline component to convert to—in this case choose \textit{h:2}—and then click on Convert. The selected range of text will be converted to an inline and take on the properties of the inline component. You can see this process illustrated in Figure 10–13.

You want the inline heading to be called \textit{h:3}, and you want it to have the same size font as the rest of the paragraph text. You’ll need to change the properties of the inline heading. To do this, select the inline component and edit its properties.

**Selecting an Inline Component**

To access the properties of an inline component, you must first select it. To select an inline component, move the mouse over one of the inline component markers on either end of the inline component. You’ll know that you’re over the marker when the mouse cursor changes into an arrow.

To let Interleaf 6 find an inline component for you, choose \textbf{Edit}→\textbf{Find Object...} from the document menu.

Change the type of Object to Inline. You can leave Name set to (Any) or change it to the specific name you are looking for. Click Find.

Interleaf 6 will find the next inline and leave it selected.

*Figure 10–14.* Letting Interleaf 6 find inline components
Once the mouse has changed into an arrow, click the mouse to select the inline component.

You may also find it easier to select the inline component by using Interleaf 6's Find Object dialog box. Bring up the Find Object dialog box by choosing **Edit → Find Object...** from the menu. Change the type of object you want to find to Inline, the name of the object to (Any) to find any inline component, and if your current insertion point is beyond the inline, turn on Find Backward. Now click Find and Interleaf 6 will find and select an inline component for you (see Figure 10–14).

### Inline Component Properties

Once you have selected an inline component, you can open the Inline Properties dialog box. This dialog box is opened by choosing **Properties → Inline...** from the menu, or clicking on the Properties button in the tool bar. Inline properties differ slightly from top level component properties. You won't find properties for margins since an inline component is part of another component, but you'll find basic text (family, size, bold, and italic), advanced text (revision bars, caps, dictionary, etc.), and general for-
matting (placement, column and page breaks, and content) properties (see Figure 10-15).

This inline heading will be named \textit{h:3} for a third level heading. Create a new master from the current \textit{h:2} inline component. (Don't rename the \textit{h:2} master because you'll still need it for second level headings.) After you have created the new master, modify the new master's properties.

Change to the Basic Text sheet. Change the font size of the inline heading by clicking on the Size drop down list. If you scroll to the top of the list, you'll see that in addition to choosing a predetermined size (like you do with standard components), you can set the font size the same as (Inherit Same), larger than (Inherit Larger), or smaller than (Inherit Smaller) the surrounding text. Choose Inherit Same for the font size (the size will change to read the actual size, with (i)—for inherit same—to the right of the size). Make sure the font family is Thames and that Bold inherits the opposite (~i) value.

On the Format sheet, enter \textit{toc} as the table of contents document name to use. Apply your changes to all to update the master (see Figure 10-16).

\textbf{Tip} While you could have selected 14 points for the font size of the inline component, telling Interleaf 6 to inherit the same font has its advantages. One advantage is that if you later decide to change the paragraph font size, the inline heading font size will automatically change without you having to modify its properties. Another advantage is that if the inline component is used in different top level components where the point size may be different, a single inline master will be adequate—you won't need different inline components for 12 point, 14 point, and 16 point top level components. This advantage will become clearer in the next chapter when you create inline components for highlighted and repeated words and phrases.
For an inline heading, choose the font Family and then set the Size to Inherit Same. Interleaf 6 will show you the current size followed by (i) to indicate the size is inherited. To make the heading stand out, set bold to Inherit Opposite. Interleaf 6 will display (~i).

The inline heading will be included in the table of contents. On the Format sheet, you’ll find an area for specifying the table of contents document name. Type in toc.

Apply the Changes to All to update the master component definition.

**Figure 10-16.** Component properties for an inline heading
SUMMARY

In this chapter, you set out to redefine some of the components in the User Guide template so that the User Guide could also be formatted for display online. You were introduced to some of the basic component properties you might deal with in defining new components. With the knowledge of these component properties, you defined some components for paragraphs and headings. You also learned how to define inline components and saw how to modify their properties for use as inline headings.

Not every component from the User Guide template was addressed in this chapter. However, included on the companion diskette is a template with all of the components redefined for display online. If you installed the diskette, you’ll be able to create a template by choosing File→ New→ Inside Interleaf→ Exercises→ online from the Desktop menu.

In the next chapter, you will expand the knowledge gained in this chapter as you format components to use as lists and highlighted and repeated words and phrases.
CHAPTER 11
Formatting Lists and Defining Inline Components

This chapter builds on the last chapter. You will create additional components for use as lists (both unordered and ordered), and highlighted or repeated words and phrases.

Defining Lists Using Component Prefixes

In the last chapter, you took care of defining basic components for paragraphs and headings. The User Guide template also has different types of lists. These lists fall into two general categories: unordered and ordered lists. You'll create components to handle these different types of lists. What will make creating these lists possible is a component property known as a prefix.

A prefix is content found at the beginning of a component that is shared by all components with the same name. This shared content property is controlled on the Content property sheet of a top level component and the
Format sheet of an inline component. Let’s see how to use the prefix property.

**Defining Unordered Lists**

The first type of list you’ll create is a bullet, or unordered, list. You use this list type to present items where the order isn’t important, such as listing features of a software program. When formatted, you want unordered lists, as well as all the lists of the on-line template, to share many of the same font properties as regular text; so, begin by creating a p:0 component (you are again working with the online document). Select the p:0 component and open the Component Properties dialog box. Create a new master named `list:bullet`.

**Setting Up a Component Prefix**

The first thing you should do is set the component’s content property to `Prefix` and then apply the changes to all. Interleaf 6 will update your display.

![Define a new master named list:bullet.](image1)

On the Content sheet, turn on Prefix and Apply Changes to All.

![Component Properties for list:bullet - online](image2)

Interleaf 6 creates a prefix marker. Everything to the left of the marker (currently nothing) is the prefix. All `list:bullet` components will share this prefix.

![Example of a list:bullet component](image3)

**Figure 11-1.** Defining a bullet (unordered) list
by showing a prefix marker at the beginning of the component. Currently, there is no content to the left of the prefix marker (see Figure 11–1). The next step is to add the necessary content and then update a few more properties to complete the list:bullet.

**Adding Content to a Prefix**

To add content to the prefix of a component, position the text insertion point to the left of the prefix marker and type in the desired text. In this case, you want to add a bullet symbol to the prefix. Interleaf 6 provides an easy means for adding a bullet—just select it from a menu. The menu choice you want to use is `Create → Character → Bullet`. Immediately after creating the bullet symbol, enter a tab (see Figure 11–2). The tab is necessary so text that falls on the second and subsequent lines of the component will line up along the left side with text on the first line of the component. After you enter the tab, you’ll notice a large gap between the bullet and the prefix marker. If you were to enter text into this component at this point, you’ll see that it still wouldn’t line up on the left side. To finish the formatting of the bullet, you need to adjust a few more component properties.

Position the text insertion point to the left of the prefix marker. Create a bullet by choosing `Create → Character → Bullet` from the menu.

Enter a tab after the bullet. The tab will allow you to precisely align the text by modifying some of list:bullet’s properties.

**Figure 11–2. Creating a bullet symbol**
Adjusting Properties Using the Document Ruler

Instead of relying solely on the Component Properties dialog box to adjust the properties of the \textit{list:bullet} component, you are going to use the document ruler at the top of the document window. The document ruler shows the margins of the current component, as well as the initial indent and tab settings, with respect to the page margin. You can select and drag objects on the document ruler to adjust the properties of the current component a little more interactively than if you use just the dialog box. Once the component is the way you want it to appear, you can take the properties of the current component and use them to update the component master and the other instances in the document.

To make it a little easier to see the effect of your adjustments, type enough text into the \textit{list:bullet} component to span at least two lines. Now, select the left margin marker in the document ruler and drag it to the right to set the left margin. When you are near a half inch, release the mouse button to set the left margin. Notice how the text has been adjusted (see Figure 11-3).

Next, select the initial indent marker, and drag it to the left of the component's left margin. By setting the initial indent to the left, you are creating room for the bullet symbol. Since you inserted a tab after the symbol—and the next tab setting is at the component left margin—the text on the first line will always line up with text on other lines of the component (see Figure 11-3).

Now, if you revisit the Component Properties dialog box for the \textit{list:bullet} component, you'll see that the settings on the Format sheet have been modified. These settings represent only the current component's properties; the master has not been modified and neither have any other \textit{list:bullet} instances. Since the settings on the current \textit{list:bullet} component are what you want for all components, apply All Props to All (see Figure 11-3).

\textbf{Note} If you use a space instead of a tab, it is not guaranteed that the text on every line will line up. (Remember, Interleaf 6 is busy adjusting the size of spaces to fit text on a line.) In most cases, you'll want to use the precise placement offered by a tab. For example:

- This bullet uses a space instead of a tab after the bullet. Notice that the text isn't lined up exactly.
- This bullet uses a tab after the bullet. Notice the precise alignment of text on the left.
Drag the left margin marker right and release when close to 0.5 inches.

Drag the initial indent marker left and release when about 0.25 inches from the component left margin.

When you look at the properties of list:bullet, you’ll see the changes you made on the ruler reflected on the format sheet. These properties only apply to the current list:bullet component. To make these properties apply to all list:bullet components, including the master, Apply All Props to All.

Figure 11-3. Adjusting bullet list properties
Other Unordered Lists

Now that you have created a list:bullet, create another component to use for a checklist in the same way. This new component should be named list:check. You can begin with a list:bullet component instead of a p:O component; that way, you’ll only modify the content of the prefix. When it is time to create the square symbol used for a checklist, choose Create→Character→Other... from the menu. Switch to the Symbols font and insert the square symbol (see Figure 11-4).

To create a symbol, choose Create→Character→Other... to open the Character Palette. Choose the appropriate font family (Symbols) from the drop down list. Display the page where the symbol occurs and select the symbol. Click Insert to insert the selected symbol at the current insertion point.

![Character Palette](image)

*Figure 11-4. Inserting a square symbol*

Defining Ordered Lists

Now that you have a couple of unordered lists to work with, you need to define some ordered, or numbered, lists. Begin by creating another p:O component. Select the new p:O component and create a new master named list:num. Just as you did with an unordered list, set the Prefix property for this list so that you can add content to the prefix. The content you will add to the prefix is a tab, an autonumber, and another tab. After you have entered content in the prefix, you’ll be ready to adjust other properties of list:num.
Creating an Autonumber

After you have entered the first tab, you are ready to create an autonumber. Choose Create→Autonumber... from the menu. On the Create dialog box, select list and then click Create. This creates an autonumber token that Interleaf 6 will manage (more about that later). Now enter another tab after the autonumber.

Modify Component Properties

Now that the content of the prefix has been established, modify the properties of the component to make it look like a numbered list—a number aligned with the first line of text, and multiple lines of text aligned along the left side. Again, you can use the document ruler to make the adjustments. For this numbered list, set the left margin to about three-quarters of an inch; the initial indent should be set far enough left of the component margin to leave room for the autonumber. (Normally, you can set the initial indent back to the left edge of the column. If entered on the Component Properties dialog box, the initial indent would be shown as the negative of the left margin.)

To get the autonumber lined up correctly, drag the tab marker at the far left of the ruler to one-quarter inch left of the component margin. The tab location represents where the right side of the number will be aligned. The tab properties of the component still need to be modified to make this happen. Once you have made adjustments using the component ruler, go back to the Component Properties dialog box to adjust the tab.

On the Tab sheet of the Component Properties dialog box, select the first tab setting in the Tab Stops list. When you select the tab setting, its properties are editable in the area below the Tab Stops list. Make sure the location is set to -0.25 inches, and change the type to Decimal. When you use a decimal tab, you need to tell Interleaf 6 which character to use as a decimal. Normally you will type a period (.) or a comma (,) as the decimal character, but you are free to type any character. The autonumber you are using has a period following the number, so make sure there is a period in the box labeled Decimal Char. Click on Change to copy these changes to the Tab Stops list. Now, apply changes to all to update the master definition of list:num. You can also accomplish this alignment with a right tab.
After creating a new component master named list: num and giving it a prefix, enter a tab in the prefix. Follow the tab with a list autonumber and another tab.

The autonumber can be created by choosing Create→ Autonumber... and selecting the autonumber from the Create dialog box.

Adjust the component’s left margin and initial indent using the document ruler. Also, drag the tab stop at the far left to the location where you want the right side of the autonumber to line up.

Final adjustments to the tab setting can be made on the Tab sheet. Select the tab you want to modify, enter new values—change Type to Decimal and Decimal Char to a period—and click Change to update the tab. Now Apply Changes to All to update the master.

**Figure 11-5.** Creating a numbered (ordered) list.
Note Tab stops can be measured from the component margin or from the column margin. When measuring tabs from the component margin, any tab left of the component margin is negative. When measuring tabs from the column margin, tabs left of the component margin will have a positive value as long as they are also to the right of the column margin.

Restarting Ordered Lists

When you use list:num components to create an ordered list, Interleaf 6 will automatically adjust the numbering of each item based upon its location within the list. That is, the first item will be numbered 1, the next 2, and so on. Later in your document, you may decide to create another ordered list using list:num components. You’ll find that the first item in this second list does not begin with 1, but begins with whatever number is next in the sequence. To make the list begin with the number 1, you need to tell Interleaf 6 that the list is starting over. You do this by setting a property of the autonumber (see Figure 11-6).

To restart an autonumber, first, select it.

Open the Autonumber Properties dialog box by choosing Properties → Selection... from the menu. Turn Restart on and click Apply.

Interleaf 6 will restart the autonumber.

Figure 11-6. Restarting an autonumber
You can also define a utility component that will start your autonumbers over, without having to adjust an autonumber property each time. The utility component is used whenever you start an ordered list and employs Interleaf 6 functionality with multiple level autonumbers. In a multiple level autonumber, Interleaf 6 will automatically restart a lower level autonumber after each higher level autonumber. The utility component will include both a first and second level autonumber so that the second level autonumber is restarted automatically. Before you can define the utility component, you need to make some changes to the autonumber used to number your lists.

**Defining Multiple Level Autonumbers**

The list autonumber currently used in component list:num is a single level autonumber stream. It needs to be changed to a stream with two levels. Choose Properties Autonumber Streams... from the menu to open the Autonumber Streams dialog box. Select list so the rest of the dialog box reflects the properties of the list autonumber stream. Type in 2 in the Number of Levels field and click Apply. Display the properties for the second level by changing Level to 2. Verify that the Number Type is 1,2,3..., Starting Value is 1, Suffix is a period (.), and Show Autonumber is on. Also, turn on Show Last Level Only. When all of these settings are correct, click on Apply (see Figure 11-7).

What you have just instructed Interleaf 6 to do is display only the second level autonumber, which is an Arabic numeral, whenever it finds a second level autonumber token named list. You also want to tell Interleaf 6 not to display anything whenever it encounters a first level autonumber token for list, but you'll wait until you've redefined the list:num component to set that property (otherwise, you won't be able to see the autonumber while modifying the component).

**Defining a Utility Component**

Now that you have redefined the list autonumber stream, you are ready to use it in a component. Create a new list:num component. From the Component Properties dialog box, create a new master named list:num*. All of its properties now match list:num. In the prefix of list:num*, position the text insertion point after the autonumber that is already there. The autonumber already present in the prefix is a level 1 token that will force the level 2 autonumber you're about to create to restart. Create a level 2 list autonumber using the Create dialog box. You are finished defining the utility
component *list:num*. Figure 11–8 illustrates the steps you just went through.

Choose Properties → Autonumber Streams... to open the Autonumber Streams dialog box. Select the stream named list.

Change Number of Levels to 2 and click Apply.

Change Level to 2 to see the properties of the second level of list.

![Autonumber Streams dialog box](image)

**Figure 11–7.** Modifying autonumber properties

You need to change the content of the *list:num* prefix to contain a level 2 *list* autonumber. Select the autonumber, open the Autonumber Properties dialog box, change Level to 2, and click Apply. If you move *list:num* so it is ahead of *list:num*, you’ll see that the autonumber in *list:num* picks up a value of 2 (see Figure 11–9).

Finally, hide all level 1 *list* autonumbers by turning Show Autonumber off. The resulting components *list:num* and *list:num* are ready to be used for ordered lists. Whenever you have a new list, start it with *list:num*. Use *list:num* for all additional items in the list (see Figure 11–10).
Tip By using list:num* as the first component of a numbered list, you can gain more than just having Interleaf 6 restart the autonumber for you. If you want to have additional space between the top of the list and the paragraph above it, you can increase the Above margin of list:num*. Similarly, you can create a component for the last item in a list and have it add additional space below the list. You might name the component list:num! and base it on list:num. You would increase the Below margin.

Create a second list:num component.

Open the Component Properties dialog box for the component and create a new master named list:num*. This new master has all of the same properties as the list:num master.

Position the text insertion point in the prefix of list:num*. Make sure it is located immediately after the autonumber already in the prefix.

Create a second level list autonumber. Notice that the value of the autonumber is 1. This is because Interleaf 6 will restart the lower level autonumber when it occurs after a higher level autonumber. The utility component, list:num*, is finished. Now you need to modify the main component, list:num.

Figure 11-8. Creating a utility component to start ordered lists
To change the level of an autonumber, select the autonumber and open the Autonumber Properties dialog box.

Change the level (in this case to 2) and click Apply.

The autonumber has been changed to a level 2 autonumber (but you won't see its value change until you place it behind a level one autonumber).

To complete the definition of the utility component for creating autonumbers, revisit the Autonumber Streams dialog box and turn Show Autonumber off for level 1 list (see Figure 11-7).

**Figure 11-9.** Changing the list:num autonumber to second level

Numbered lists are now created using list:num* to start the list and list:num to continue the list.

**Figure 11-10.** Creating lists with list:num* and list:num
Other Ordered Lists

The User Guide template has one other type of ordered list that uses the lower case alphabet in the prefix. The components used to create these lists are list:alpha* and list:alpha. The components use an autonumber named alpha. You can create these the same way as the numbered list. Figure 11–11 shows the relevant properties of the components and the autonumber used to make these lists.

These are the properties of the autonumber stream alpha. alpha has 2 levels. The first level has Show Autonumber off. The second level uses a,b,c... as the Number Type. Show Autonumber and Last Level Only are on.

Below are the component properties of list:alpha*. Most properties are the same as list:num. Only Format and Tabs are different. list:alpha* has a prefix containing an alpha autonumber (both level 1 and level 2) and a tab. list:alpha's properties are identical, except it only has a level 2 autonumber in the prefix.

Figure 11–11. Alphabetic list properties
**Highlighted or Repeated Words and Phrases**

In your documentation, you will find cases where certain types of words need to have special emphasis, or highlighting. These words or phrases can represent titles of other documents, names of functions, or, as is the case with this book, names of Interleaf 6 objects (which appear in italics). The policies your company has in place for formatting your documentation may say that you should always set the title of other documents in italics, functions in bold, and Interleaf 6 object names in italics.

In each of these cases, you can simply select the text in question and click on the appropriate button on the tool bar to make the text bold or italic. However, when you format your text in this way, you lose valuable information about why you formatted the text—italic text might represent a title of a document or the name of an Interleaf 6 component. You also lose the ability to globally change the formatting when your company policies change.

In situations where the same information is repeated in different places of your document, such as the title of the program you are writing about, you can just type the text that represents the information. You might also apply special formatting—bold, italic, or different font color—to this text. Once again, you'll lose valuable information about the text and you lose the ability to apply global changes. If the name of the program is changed just before you go to press, would you rather search for all occurrences of the program name or make the name change (and other format changes) just once?

Using inline components, you can maintain the valuable information about your text while providing global control of formatting and content. The next two sections will show you how to use Interleaf 6 inline components to help you manage highlighted and repeated words and phrases.

**Using Inline Components for Highlighted Words**

When defining inline components for highlighted words, you are primarily concerned with basic text properties of the inline component. You can choose to firmly establish the font family, size, bold, or italic, or you can allow some of the font properties to be inherited, with one or two specific properties firmly established. For example, the on-line documentation has three inline components defined: `emp:function` to identify the names of functions, `emp:user` to highlight text typed by the user of the documen-
tation, and \texttt{emp:variable} to identify variable names. Each is formatted a little differently so that the reader can recognize these three different types of highlighted text. I'll show you how the inline component for function names is created, and you can create the other two on your own (I'll show you the relevant properties).

### An Inline for Function Names

You have already seen how to create an inline component when you created an inline heading in Chapter 10. I'll repeat the steps again, except this time they are for creating an inline for function names. To begin, create a \texttt{p:0} component to hold the inline component. Within the \texttt{p:0} component create an inline component (you can use \texttt{p:0}, although any name is okay). Select the inline component and open the Inline Properties dialog box. Click on New... and create a new master named \texttt{emp:function} (see Figure 11-12).

For the on-line documentation, the basic identifier of a function name is that it is set in Courier. Therefore, on the Basic Text sheet, change Family to Courier. Also, you want the font size of function names to match the surrounding text, so scroll through the Size list and set it to Inherit Same. Apply the changes to all.

![Define Master](image1)
Beginning with an inline \texttt{p:0}, define a new \texttt{emp:function} inline master.

![Inline Properties](image2)
Change Family to Courier. Set Size to Inherit Same (which changes to the current size followed by (i) to indicate inheritance). Bold and Italic are off. Apply Changes to All.

*Figure 11-12. Creating an inline component for emphasized text*
Other Emphasized Inlines

The other two inline components, *emp:user* and *emp:variable*, are created the same way as *emp:function* was created. Figure 11–13 shows the appropriate Basic Text properties of each.

*emp:user* uses Courier and inherits its font size. Bold is on.

*emp:variable* uses Courier and inherits its font size. Italic is on.

**Figure 11–13.** Properties of other inline components
Tip When creating new components, you can use a colon, as well as other special characters, to separate parts of the name. If you keep the beginning of the name the same for many different components, Interleaf 6 will group these components together on the Create dialog box. For inline components that are used for highlighted, or emphasized, text, using “emp:” at the beginning of the name will keep all emphasized text inlines together, as well as identify their purpose for emphasized text. For shared content inlines, you can use “shared:” at the beginning of the name.

Using Inlines for Repeated Words or Phrases

The User Guide template does not currently use an inline for the program name it is documenting, but you think it is a good idea to use an inline in the event your marketing department decides to change the name. So, you'll create an inline component to hold the name of the program. Begin by creating an inline p:0 and then creating a new master named shared:program from the inline (see Figure 11–14).

Since this is the name of a program, you want stricter control over what the name looks like; therefore, you will inherit only the font size and set the rest of the font properties to predetermined values. Set the following font properties on the Basic Text sheet: Family set to Swiss, Bold on, Italic on, and Color to blue. When defining inline components for repeated words, in addition to being concerned with basic text properties, you also need to adjust content properties of the component. On the Format sheet, turn on Shared Content (see Figure 11–14). Now apply the changes to all. If there is content in the component when you turn shared on, Interleaf 6 will ask you if you want to use the contents of the instance or the master for the shared content. If the instance contains the content you want all other instances to have, then use the contents of the instance. The master will also have its contents replaced with the content of the instance.

If you want to see the effect of shared content, create another inline shared:program in the document. Position your cursor in one of the shared:program components and type in the name Go! Bowl. Both inline components will have characters inserted as you type (see Figure 11–15).

You now have a shared content inline that you can create whenever you need to use the name of the program. You can create other shared content inlines for other repeated words.
Create a shared content inline by beginning with any inline component. Select the inline, and from the Inline Properties dialog box create a new master. Name the master `shared:program` to hold the name of the program being documented.

Interleaf 6 will give you the opportunity to choose which content should be used for the master. After you choose instance or Master, Interleaf 6 will again ask you if you are sure you want all instances of the component to have their content replaced. Click Confirm.

Figure 11-14. Creating a shared content inline.
As text is typed into the inline component on the left, the inline component on the right—which shares content with the inline component on the left—is updated.

Figure 11-15. Typing text into shared content inlines

SUMMARY

In this chapter, you continued to define components for use in the on-line version of the User Guide template. You added unordered and ordered lists to the components available to your authors. You also defined inline components that are useful in managing highlighted words and repeated words and phrases.

In the next chapter, you will expand the knowledge gained in these last two chapters as you learn to format tables.
CHAPTER 12
Formatting Tables

This chapter describes how to build table templates for use in a document. You will learn to format table columns, both cell formatting and column properties. You will create new row definitions to define header rows. You will learn to use cell straddles and rulings in a table definition. You will learn steps required to keep a master table definition current.

CREATING A TABLE

In an earlier chapter (Chapter 7), you created a predefined table and entered text into it. Interleaf 6 took care of formatting the information within the table. You were also able to add additional predefined rows to the table. Now, you are going to create a table from scratch, and turn it into a master that can be used by other authors. These authors will be able to create the table and enter information without worrying how to format it.

To begin, open the online document you have been working with for the last couple of chapters. Choose Tables→Create Table... from the document menu. This will open the Create dialog box with the Table option selected. Select (<New>) as the table you want to create and click Create. Interleaf 6 will ask you to provide a name and the number of rows and columns the table will initially have. Don't worry if you don't have exact values here—you can change them later. You're going to build a table that will be
used to demonstrate different uses of the GO!Bowl program. The table will resemble a bowling league recap sheet, so name the table *recap*. Start with six columns and eight rows. Click on Create and Interleaf 6 will create the table for you (see Figure 12-1).

If you examine the table, you will see that every table cell has the name *cell* (see Figure 12–2). This is the default name that Interleaf 6 gives to the table cells. (Actually, the default name given to a table cell is formed from the name of the table, a colon, and the word cell, in this case *recap:cell*.) To make the table useful as a master table, you need to redefine these cells to represent the function they perform within the table.

To make it easy to see the effects of changes you are about to make, populate the table with the information shown in Figure 12–3.
If you examine the cells of the table, you will see the default name given to them by Interleaf 6. The name is formed from the table’s name and the word cell. The table name doesn’t appear in the component bar.

Add content to the recap table to make it easier to see the effects of your formatting changes.

**Figure 12-2. Default table cells**

**Figure 12-3. Content of the recap table**

**Formatting Table Columns**

One of the first things you might do to a table like this is format the table columns. Formatting the table columns involves making two types of adjustments to the columns: changing the column widths, and formatting the contents of the columns.

**Changing Column Widths**

Currently, all of the columns of the table have the same width; but the amount of information (and width) in each column will vary by the time you are through with the table. To change the width of one or more columns, position a caret within the table and choose **Tables→ Change Width...** from the document menu. The Change Column Width dialog box will open (see Figure 12–4). Next, select a column (or columns) to modify and make your changes.
Position a current insertion point within the table and choose Tables→Change Width... to open the Change Column Width dialog box. Enter a new column width and click Apply.

**Figure 12-4.** Changing column widths

**Selecting Columns**

For the purposes of changing column widths, there are a number of different ways to select a column. The most straightforward way to select a single column is to click the mouse within the column. The Change Column Width dialog box will immediately update to show the selected column. Or, you can click on the rule at the left edge of the column to reposition the table caret. The table caret indicates the current column. To actually select the column, choose Tables→Select Cells→in Current Column. Finally, you can position the cursor over a horizontal rule within the desired column until it changes into a double-headed arrow and then click the mouse. The entire column will be selected. Each of these methods is illustrated in Figure 12-5.

If you need to select multiple columns for modifying column widths, there are a few ways to select more than one column. First, position the mouse cursor over one column in the range, press and hold the mouse button, and drag to the other end of the desired column range (it's not necessary to select every cell in each column). Release the mouse and the Change Column Width dialog box will show the selected columns. Second, you can position the cursor over a horizontal rule and click to select a single column.
There are many ways to select a single column for the Change Column Widths dialog box.

Clicking the mouse in a cell is sufficient to select a column.

Positioning the table caret to the left of the column and choosing **Tables**→**Select Cells**→**in Current Column** will also work.

You can also position the cursor over a horizontal rule until it changes into a double-headed arrow. Click the mouse and the column will be selected.

Add to the selection by positioning the cursor over a horizontal rule in another column and click while holding down the SHIFT key (in Motif, you can just click the middle mouse button). All columns in the range will be selected. Finally, you can select noncontiguous columns by holding the CTRL key while clicking the cursor over a horizontal rule. Each of these methods is illustrated in Figure 12-6.

**Figure 12-5.** Different methods for selecting a single column

**Note** Selecting a column for changing its width is less restrictive than selecting a column for copying or cutting. When you select a column for copying or cutting, you must actually have the entire column highlighted as a selection. When selecting a single column for changing its width, it is sufficient to just click within the column or reposition the table caret. However, if you wish to change the width of more than one column at the same time, you must select the columns the same way as if you were copying or cutting multiple columns.
One way to select multiple columns is to press and hold the mouse in one column and drag until all desired columns are highlighted. The Change Column Width dialog box shows the selection.

Another way to select multiple columns is to first select a single column. Then, position the mouse over a horizontal rule in a column at the end of the range of columns.

To select a contiguous range of columns, hold down the SHIFT key while you click the mouse. To select a noncontiguous range of columns, hold down the CTRL key while you click the mouse.

**Figure 12-6. Different methods for selecting multiple columns**

### Changing Column Properties

Select the first column in the table. In the Change Column Width dialog box, change the proportional measurement from 1 unit to 2 units. Click Apply and Interleaf 6 will increase the width of the first column (see Figure 12-7). This column will hold names of bowlers. To make room for longer names, it is necessary to increase the width of the column. Right now, it is sufficient to set the width proportionally instead of fixed.
Type in a value of 2 for the proportional units of column 1. Click Apply. Interleaf 6 increases the width of column 1 so that it is twice as wide as each remaining column.

---

<table>
<thead>
<tr>
<th>Amy</th>
<th>18</th>
<th>149</th>
<th>194</th>
<th>164</th>
<th>507</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tony</td>
<td>28</td>
<td>152</td>
<td>138</td>
<td>152</td>
<td>452</td>
</tr>
<tr>
<td>Geaff</td>
<td>35</td>
<td>151</td>
<td>119</td>
<td>126</td>
<td>398</td>
</tr>
<tr>
<td>Tom</td>
<td>61</td>
<td>129</td>
<td>149</td>
<td>110</td>
<td>388</td>
</tr>
<tr>
<td>Andy</td>
<td>11</td>
<td>167</td>
<td>214</td>
<td>170</td>
<td>551</td>
</tr>
</tbody>
</table>

**Figure 12-7.** Changing the width of the first column

**Note** You also noticed that the other columns were decreased in width. This is because the newly created table contained columns that were all proportional with a value of 1 unit. By entering a value of 2 units in the first column, you are telling Interleaf 6 to make the first column twice as wide as other proportional columns with a value of 1 unit. Since the overall width of the table did not change, Interleaf 6 increased the width of first column while decreasing the width of the other columns.

The second column will hold each bowler's handicap. This column does not need to be as wide as the remaining columns, so change its proportional width to 0.75 units. The next three columns hold the score for game one, game two, and game three, respectively. The final column holds the total of the three games, so it should be a little wider than the game columns. Change the width of the last column to 1.25 units. Figure 12–8 shows the table with the new column widths. Later, you’ll copy these first six columns and paste them back into the table to create both halves of the recap sheet. When you do, Interleaf 6 will readjust the column widths and the proper proportions will be maintained. With a little luck, you won’t have to make any changes to the table when you add another six columns to it.
You might be wondering how Interleaf 6 determines the width to use for proportional columns. Basically, the concept is to assign to each unit a fixed measurement based on the total units in the table and the total proportional width (the width that isn't allocated to fixed columns) assigned to the units. When you start mixing fixed-width columns with proportional-width columns, Interleaf 6 will take care of subtracting the fixed width from the total table width to determine the proportional width. This proportional width is divided by the total proportional units to determine the width for each unit. This concept deserves a picture (see Figure 12–9).

**Figure 12–8.** Appearance of recap table with adjusted column widths

<table>
<thead>
<tr>
<th>Unit</th>
<th>Amy 19</th>
<th>149</th>
<th>194</th>
<th>164</th>
<th>507</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tony</td>
<td>28</td>
<td>152</td>
<td>138</td>
<td>162</td>
<td>452</td>
</tr>
<tr>
<td>Geoff</td>
<td>35</td>
<td>151</td>
<td>119</td>
<td>126</td>
<td>398</td>
</tr>
<tr>
<td>Tom</td>
<td>61</td>
<td>129</td>
<td>149</td>
<td>110</td>
<td>388</td>
</tr>
<tr>
<td>Andy</td>
<td>11</td>
<td>167</td>
<td>214</td>
<td>170</td>
<td>551</td>
</tr>
</tbody>
</table>

**Table Width:** 5.5 inches

<table>
<thead>
<tr>
<th>Units</th>
<th>2</th>
<th>0.75</th>
<th>1</th>
<th>1</th>
<th>1</th>
<th>1.25</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inches</td>
<td>1.5714</td>
<td>0.7857</td>
<td>0.7857</td>
<td>0.7857</td>
<td>0.9821</td>
<td>0.589</td>
</tr>
</tbody>
</table>

**Figure 12–9.** How Interleaf 6 determines widths of proportional columns

<table>
<thead>
<tr>
<th>Table Width:</th>
<th>2</th>
<th>0.75</th>
<th>1</th>
<th>1</th>
<th>1</th>
<th>+ 1.25</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>0.75</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>7.00 units wide</td>
</tr>
</tbody>
</table>

\[\text{Inches/Unit} = \frac{5.5}{7} = 0.7857\]
**Formatting Column Contents**

With the column widths adjusted, it's time to modify the formatting of the contents of the table. Modifying the contents involves making changes to the components that make up the cells of the table. You saw that when you first created the table, Interleaf 6 gave all of the components within the table the same name. Formatting the table will involve giving new names to the components in the cells, in addition to changing the component properties. So, let's get started.

**Defining a New Table Component Master**

Click in a cell of the first column. The component bar changes to show the name of the component within this cell. Select the component name and open the Component Properties dialog box. Click on New... to define a new master. Name the master *recap:bowler*. When you click Define, Interleaf 6 will ask you to decide how much of the table should be affected by this new master. Your choices are apply the change to the current cell only, to all cell components with the same name in the row, in the column, or in the table. Since you are formatting this component for bowler's names, apply the change to the entire column. All of the cells in the first column now contain *recap:bowler* as the component. The remaining components in the table are still named *cell* (actually, they're name *recap:cell*). Figure 12–10 shows the process.

When you type in the name of a new master and click Define, Interleaf 6 will ask you how you want to apply the changes. You can apply them to the current cell, the row that contains the cell, the column that contains the cell, or the table that contains the cell. If you click Row, Column, or Table, only cells with the old name—in this case *recap:cell*—will be changed to the new name.

![Defining Master dialog box](image)

![Interleaf 6 dialog box](image)

*Figure 12–10. Defining new table component masters*
Modifying Properties of a Table Component

Now that the new master for recap:bowler has been defined and copied to the cells of the first column, modify its properties. Change Size to 12 points, Bold and Italic off, and text Color to black. Now, you're ready to apply these changes. Because you are defining a master table, it is best to apply Changes to All (see Figure 12-11).

Now that the first column has been taken care of, format the other columns. The one thing that all of the other columns have in common is that they all contain numbers. Further, each of these numbers will always be an integer. Because the contents of each of the remaining cells is the same, you can modify the properties of the cell component and apply the changes to all. Change cell's properties to the following: Size 12 points, Bold and Italic off, Alignment Right, Color black. Apply changes to all. After that is done, you can modify the components in each column separately, if required. For now, no specific formatting is required.

After setting the appropriate properties of the component, apply the changes to all. Since the recap:bowler component is only in the first column, only the cells in the first column will be changed.

There are many choices for applying your changes. For work defining a master, you will usually apply Changes to All.

Figure 12-11. Updating components and masters within a table
Note If you look at the Apply options, you'll see that there are many more options for components within a table than for regular (non-table) components (see Figure 12–11). In addition to the three standard options (Changes to Current, Changes to All, All Props to All), the following options have been added: Changes to Row, Changes to Column, and Changes to Table to apply the changes made to the component to all components with the same name within the same row, column, or table as the component; All Props to Row, All Props to Column, and All Props to Table to apply all of the current component's properties to all components with the same name within the same row, column, or table as the component. The scope of these Apply options is greater than the scope of Changes to Current, but less than the global changes caused by Changes to All or All Props to All, which update all components with the same name. The less than global options are good for modifying an instance of a table master.

Formatting Table Headers

Looking at the table, it isn't easy to tell what the different columns of numbers represent. The table needs headings over each column. To create these headings, create a row at the beginning of the table. Position the current insertion point in the component bar so it is touching the top of the topmost row of the table. Choose Tables→ Create Row... to open the Create dialog box with the Table Rows option selected. The recap table has one row type defined; so choose it and click Create (see Figure 12–12).
To create a row to use for column headings, position the component caret just above the top row of the table.

Choose **Tables → Create Row...** from the menu to open the Create dialog box with Tables selected.

![Create dialog box](image)

**Select the only row available at this time and click Create. A new row will be added to the beginning of the table.**

**Figure 12-12. Creating a new row for a header**

### Changing the Format of Heading Cells

In the new first row, type the following text—one word per cell—to form the six column headings: Bowler, HDCP, 1, 2, 3, and Total. Now format the cells to make them look like headings: Click the cell in the last column of the first row and open the Component Properties dialog box. Create a new master named **recap:head** and apply the change to the row. Change the following properties of **recap:head**: center Alignment, Bold on, Color blue, and Caps set to All Caps. Apply the changes to all (see Figure 12-13).

**Tip** The reason you want to use the table name as the first part of a component name is to ensure the component is unique to the table. If you name all of your table headings with just the word head, regardless of what table they are in, you risk making changes to head components in tables other than the one you are currently working in. This isn't all bad, however. If you add captions to your tables, defining a single component—without a preceding table name—is the best way to manage the caption across all tables.
After creating a new master named `recap:head` and applying it to the row, modify the heading properties. When you apply changes to all and look at the table, you'll see the first column hasn't been affected. Because the name of the component in the first column was `recap:bowler` and not `recap:cell`, the application of the new master definition to the row had no effect. The component remained a `recap:bowler` component.

When you look at the headings, you'll see that all of them have changed except for the very first column (it contains a component named `recap:bowler` and was not affected when you applied the change of name to the row). It needs to be updated, too. So, click the cell of the first column of the first row; select the component and open the Component Properties dialog box; and choose More→Convert to... from the menu in the dialog box. Select `recap:head` and click Convert. Now all of the items in the first row are `recap:head` components.

**Rename the Row and Make It a Header Row**

Everything within the row is complete, except that it should receive a new name indicating that it is a header row. Table rows have properties that can be accessed by double-clicking the row, or selecting the row and choosing
**Properties** → **Row**... from the menu. Click on New... to define a new row master. Name the master `hdr` and turn on Copy Properties and Content so that the content of the current row is made the content of the master. Click Define. In the Row Properties dialog box, turn on the Header option and set content to Read-Only (see Figure 12-14). The reason for making a row read-only is to keep it from being inadvertently altered. Turning the Header option on is not so obvious.

Choose **Properties** → **Row**... to open the Row Properties dialog box. Define a new master row named `hdr`.

![Row Properties dialog box](image)

To make the row a header row, turn on the Header option.

To make the row read-only, turn on the Read-Only option. Apply the changes to the current row.

**Figure 12-14.** Making a row a header row

**Tip** As you work more with table design, you'll develop your own style for doing things. Normally, I leave the Read-Only property off until I am finished with a table design. Turning it on too early only serves to make more work for you when you try to adjust other items in the table (you'll see what I mean soon enough). For now, turn Read-Only on to see the effect it has.

When a table spans more than one page, Interleaf 6 has the ability to automatically copy a header row to the top of the rows that appear on each page. To see how this works, select another row in the table and tell Inter-
leaf 6 to start the row on another page (use the Row Properties dialog box). In Figure 12–15, you can see on the second page of the table that the header row is repeated, but its name doesn’t appear in the component bar. Clicking on the row to edit it will cause Interleaf 6 to scroll the document back to the actual header row. Since the *hdr* row is read-only, Interleaf 6 will scroll back to the page where the row first appears, but will not let you edit the row. Rejoin the table by resetting the Begin New Page property of the row you modified.

When a table spans more than one page, the header rows are copied to the subsequent pages. However, header rows don’t have a component visible in the component bar.

![Header rows appear on multiple pages of a table](image)

**Figure 12–15.** Header rows appear on multiple pages of a table

**Notes About Header Rows**

There are a couple of things to remember about header rows. First, you can have more than one header row in a table; but each header row must have a unique name (if you want all header rows to appear on subsequent pages). Second, you can create a header row within the body of the table and it will appear on subsequent pages in the table header. You can create an existing header row (a row that already appears in the header) where it is needed within the table, modify its contents, and the new contents will replace the previous header row on the remaining pages of the table. Of course, since this is the latest header row to appear in the table, it will appear as the last header row in the header. In other words, use caution to maintain proper header row order.

To demonstrate the first point, add another *hdr* row at the beginning of the table (either use the Create dialog box, or copy and paste the existing *hdr* row). Empty the contents of the first row by selecting the cells of the first row and choosing **Tables → Empty Cell(s)**. Check the row properties to ensure that both *hdr* rows are header rows. Force the table to span two pages and check the second page. You should see only the second *hdr* row displayed (see Figure 12–16). To have both header rows display, they need unique names. Create a new master from the first *hdr* row and name it *hdr1*. Rename the remaining *hdr* row (and its master to *hdr2*). Ensure that both of these rows have the Header option turned on. Now, when you look
at the second page of the table, you'll see both header rows. You're now ready to create the straddles within the header rows and add the final content.

**Note** Footer rows are created in a similar fashion to header rows. Footer rows occur at the end of the table. If the table spans more than one page, the footer row will appear on the last page of the table and copies of the footer row will appear at the bottom of all preceding table pages.

<table>
<thead>
<tr>
<th>BOWLER</th>
<th>HDCP</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>TOTAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Amy</td>
<td>19</td>
<td>149</td>
<td>194</td>
<td>164</td>
<td>607</td>
</tr>
<tr>
<td>Tony</td>
<td>28</td>
<td>162</td>
<td>138</td>
<td>162</td>
<td>452</td>
</tr>
<tr>
<td>Geoff</td>
<td>35</td>
<td>151</td>
<td>119</td>
<td>126</td>
<td>398</td>
</tr>
</tbody>
</table>

Because these header rows have the same name, only the most current (the second row) will show up on subsequent pages of the table.

<table>
<thead>
<tr>
<th>BOWLER</th>
<th>HDCP</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>TOTAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tom</td>
<td>31</td>
<td>129</td>
<td>149</td>
<td>110</td>
<td>388</td>
</tr>
<tr>
<td>Andy</td>
<td>11</td>
<td>167</td>
<td>214</td>
<td>170</td>
<td>551</td>
</tr>
</tbody>
</table>

Because these header rows have unique names, both appear on subsequent rows of the table.

<table>
<thead>
<tr>
<th>BOWLER</th>
<th>HDCP</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>TOTAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Amy</td>
<td>19</td>
<td>149</td>
<td>194</td>
<td>164</td>
<td>607</td>
</tr>
<tr>
<td>Tony</td>
<td>28</td>
<td>162</td>
<td>138</td>
<td>162</td>
<td>452</td>
</tr>
<tr>
<td>Geoff</td>
<td>35</td>
<td>151</td>
<td>119</td>
<td>126</td>
<td>398</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>BOWLER</th>
<th>HDCP</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>TOTAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tom</td>
<td>31</td>
<td>129</td>
<td>149</td>
<td>110</td>
<td>388</td>
</tr>
<tr>
<td>Andy</td>
<td>11</td>
<td>167</td>
<td>214</td>
<td>170</td>
<td>551</td>
</tr>
</tbody>
</table>

**Figure 12–16.** Header rows should have unique names.
**Using Straddles in a Table Definition**

Interleave 6 allows you to use straddles in a table. A straddle is when two or more cells are joined horizontally, vertically, or both horizontally and vertically to form a single cell. The resulting cell will span, or straddle, more than one row or column of the table.

**Creating a Horizontal Straddle**

After looking at the table, you decide that you want to add the word Game above, and straddling, the columns labeled 1, 2, and 3. To do this, select the three cells above these columns and choose Tables → Join Cells. Interleave 6 will join the three cells together. When you click on the cell, you will see a single component named head in the component bar. Type in the word Game. Figure 12-17 shows the process.

Select the horizontal cells you want to join. Choose Tables → Join Cells and Interleave 6 will join the cells together.

When you type text into the cell, it will straddle the joined columns.

**Creating a Vertical Straddle**

Columns labeled BOWLER, HDCP, and TOTAL contain one empty cell and one cell with a column heading at the top of each column. The horizontal rule splitting the two cells needs to be removed. The ruling can be made invisible using the Rulings dialog box or you can join the two cells vertically. Joining the cells vertically gives you the advantage of being able to vertically align the text within the cell.
Select the two cells in the first column and join them as you did before by choosing **Tables → Join Cells.** Interleaf 6 will join the cells together, and the resulting cell will straddle the first two rows. (If a table row is Read-Only, you must change this property before joining the cells. You can change the row back to Read-Only when finished joining the cells.) Currently, the text is aligned to the top of the cell (see Figure 12-18) but you can change that too. Join the cells of the second and sixth columns together as you did the first column. You are ready to adjust the alignment of the cell contents.

Select the vertical cells you want to join. Choose **Tables → Join Cells** and Interleaf 6 will join the cells together.

The text in the cell is now spanning both rows. Currently, the cell alignment is set to top; but, you can change that to center the contents vertically in the cell.

![Figure 12-18. Creating a vertical straddle](image)

**Note** When Interleaf 6 joins cells, it creates a single component in the resulting cell if all of the cells are empty, or if only one cell contains text. If the cells being joined are not empty, but have the same content, Interleaf 6 will create a single component and preserve the content of one of the cells. If the cells have different content, Interleaf 6 will create a cell containing all of the components of the joined cells.

**Changing a Cell’s Vertical Alignment**

To adjust a cell’s vertical alignment, you first select it and then access the cell properties. (You learned how to select cells in Chapter 7, *Table Basics.*) Select the cell with the word Bowler in it. Open the Cell Properties dialog box by choosing **Properties → Cell...** from the menu. Change the Vertical Alignment option to Center. Change the Apply options to Changes to Row...
and click Apply. Interleave 6 will ask you to confirm that all cells in both rows will be affected (see Figure 12-19). Confirm that you want this to happen. The result is that all of the vertical straddles, as well as all other cells in the two rows, are aligned to the center of the cell vertically.

Open the Cell Properties dialog box by choosing Properties→Cell... after you have positioned the table caret or text insertion point in the cell.

Change Vertical Alignment to Center and click Apply. Interleave 6 will ask you to confirm that the changes will be applied to all rows in the straddle. Click Confirm.

You can see that all text in the header is vertically aligned to the center of the cell.

**Figure 12-19.** Changing a cell's vertical alignment

### Updating Row Masters with Straddle Information

Now that straddle information has been set for these header rows, you need to tell Interleave 6 that it should remember this straddle information whenever it creates these rows. If you were to create a new hdr1 or hdr2 row within the table right now, Interleave 6 would create the rows with the mas-
ter definitions it has stored. There will be no straddles, and some content is missing, because you haven't told Interleaf 6 to update the masters yet.

To update the master row definitions, select the row—*hdr1*—that contains the properties and content that you want for the master of the same name. Open the Row Properties dialog box. On the More menu, choose **Update Master Content** to copy the content of the row to the master. Interleaf 6 will ask you to confirm whether you want just the cell structure copied to the master to be used as a template, or if the structure and content should be copied to the master. Click on All to copy everything to the master (see Figure 12-20). Perform these same steps to ensure the *hdr2* row master is up to date.

![Figure 12-20. Updating a row master](image)

Now, when you create new *hdr1* and *hdr2* rows within the table, the content, including the horizontal straddle information is recreated. The vertical straddle is not maintained by Interleaf 6.
**Note** Although you have told Interleaf 6 about the vertical straddles in your table, Interleaf 6 will not recreate the table with the vertical straddles. Normally, rows are created one at a time, so trying to maintain a vertical straddle doesn't make much sense in that case. But when you create the entire table at once, you would expect the vertical straddles to be maintained. They are not. Your authors will have to select the cells and recreate the straddles themselves. (Maybe a later release of Interleaf 6 will maintain vertical straddle information.)

When you create the hdr1 and hdr2 rows after their masters have been updated, you get the horizontal straddle and content you expect. Since the rows are created individually, Interleaf 6 does not maintain the vertical straddle.

![Figure 12-21. Creating rows with updated masters](image)

**USING RULINGS IN A TABLE DEFINITION**

Rulings are the lines in a table that separate the cells from each other. In Chapter 7, *Table Basics*, you saw how to modify the rulings in a table using the Rulings dialog box. Now, you're going to see how to manipulate rulings so that they become part of the master definition of a table.

**Making Final Changes to the Table**

Before going any further with rulings, create new masters for the last three rows of the table, giving them the names *subtot*, *hdcp*, and *total*, respectively. Change the component in the Bowler column for each row to *recap:label*. *recap:label* should be given a right alignment. Enter *Sub-Total*, *Handicap*, and *Total* in the *recap:label* of the respective row.

Earlier, I mentioned that you were creating just one side of the recap sheet. Before the finishing touches can be put on the table, you need to have the entire recap sheet. Now, copy all of the columns in the table and paste them to the right of the last column of the table. You can see that there isn't
enough room in some of the cells for the text to fit comfortably, so use an additional function from the Tables menu, Tables→Fonts→Smaller, to adjust the font sizes of the column headings and labels. You may even have to make final adjustments to the column widths until the table looks right. Figure 12–22 shows the table with some of these adjustments being made.

After putting together both halves of the recap table, some of the fonts are too large for the text to fit without wrapping.

Select the cells that hold column heads and other labels in the table and reduce the font size until the table looks right.

**Figure 12–22.** Recap table before modifying rulings

**Using the Rulings Dialog Box**

Now that the table looks like a real recap sheet, it is easier to see where you might want to change the properties of the table rulings to enhance the functional divisions in the sheet. You’re going to modify only a couple of rulings so that it will be clear how the rulings are stored in the table. Open the Rulings dialog box by choosing Tables→Edit Rulings.... Modify the ruling below the hdr2 row and the ruling above the subtot row by making the rulings double. Increase the weight of the rulings around the table bor-
der, and separate the two halves of the recap sheet with a thicker ruling (see Figure 12–23).

<table>
<thead>
<tr>
<th>Bowler</th>
<th>HCP</th>
<th>Game 1</th>
<th>Game 2</th>
<th>Game 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Amy</td>
<td>19</td>
<td>149</td>
<td>194</td>
<td>184</td>
</tr>
<tr>
<td>Tom</td>
<td>28</td>
<td>152</td>
<td>138</td>
<td>162</td>
</tr>
<tr>
<td>Geoff</td>
<td>35</td>
<td>161</td>
<td>119</td>
<td>126</td>
</tr>
<tr>
<td>Tom</td>
<td>61</td>
<td>129</td>
<td>149</td>
<td>110</td>
</tr>
<tr>
<td>Andy</td>
<td>11</td>
<td>167</td>
<td>214</td>
<td>170</td>
</tr>
</tbody>
</table>

Figure 12–23. Recap table after modifying point sizes and rulings

**Note** Rulings are stored internally by Interleaf 6 as a property of a cell. Each cell owns the rulings bordering the top and left edges of the cell. The rulings bordering a table, and separating the header and footer rows from a table, are stored as properties of the table.

The table really looks good now, but it is not complete. If a new subtot row is created in the table, it will not have the double ruling above it to separate it from the regular rows. Also, the last three rows are missing the content they need to have if they are created from scratch. To finish the definition of the rows of the table, it is necessary to update the row definitions once again. In fact, before the table is functional as a template, all of the unique rows need to have their masters updated, and the table itself needs to be updated.

**Keeping a Table Master Definition Current**

Throughout this chapter, you have been making changes to the recap table instance in the online document. The master recap table has remained unchanged from when it was first created. (To prove this to yourself, create another recap table from the menu and you'll end up with the eight row by six column table you initially created. Look at Figure 12–24). The master definition of the recap table is not very useful as a template in its present state and needs to be updated.
Creating another recap table without updating the master will give you the same table as when you first created it.

Figure 12-24. Creating another recap table proves the master is unchanged

Updating a master table definition requires the following steps: ensure table cell (component) masters are updated, ensure table row masters are updated, and update the master table content.

**Ensure Table Component Masters Are Updated**

You have already seen how to keep component masters updated. If you keep the masters updated as you go—using Apply Changes to All—you should be in good shape when it comes to updating the table master. You can also use Apply All Props to All if you aren’t sure about the status of the master components, or if you have made last minute changes to the fonts using the Tables → Fonts → Smaller or Tables → Fonts → Larger menu choices.

**Ensure Table Row Masters Are Updated**

You have already seen how to keep row masters updated. Again, keeping them updated as you go will keep you prepared for updating the master. If you are not sure about the status of a row master, use Update Master Content and Update Master Props from the Row Properties dialog box. You may wish to empty some of the cells within the row before you update the content.
Update the Master Table Content

Finally, after you’re sure that the component masters and row masters are up to date, you can update the master table definition. To update the table master, first position the insertion point within the table. Choose Properties→Table... from the document menu to open the Table Properties dialog box. As with row masters, update the master content by choosing Update Master Content. Interleaf 6 will ask you to confirm the operation (see Figure 12-25). Finally, choose Update Master Props to copy the table’s properties to the master.

![Table Properties dialog box](image)

Update the table master from the Table Properties dialog box. Choose Update Master Content.

Confirm that the contents should be copied to the master.

Figure 12-25. Updating a table master
Tip  It isn’t always necessary to use the Update Master Props command. You can save yourself a step if you are positive that you haven’t made any changes to the table properties, or that any changes you have made were applied as changes to all. If you have any doubts, use the command (it could save you some effort later when you discover that the properties of the master weren’t kept up to date).

Congratulations! If all of the masters were properly updated prior to updating the table master, you have a usable master that other authors can use by simply creating the table from the Create dialog box. (They will, of course, have to reestablish the vertical straddles in the header; thus, preventing you from using the Read-Only properties on the header rows.) If everything wasn’t done just right, the table you create will be missing some rows or content. Now is the time to test the master—by creating one yourself—and fixing any problems you discover.

**SUMMARY**

In this chapter, you learned how to build a table template from scratch. You accomplished the different steps of creating a table, modifying the table columns (column width and components within the cells), defining headers, creating cell straddles, and adjusting table rulings. Finally, you learned the very important process for keeping a table master up to date so that the table can be useful as a template.

The next chapter will show you how to take the online document that you have been working on over the last few chapters and turn it into a document template.
CHAPTER 13

Document Templates

This chapter describes how to take all of the changes you have made in the previous chapters and make them available as document templates. You will learn how Network Style Sheets can help you control the format and content you worked so hard to create.

WHAT IS A TEMPLATE?

You just went through a lot of work defining the objects your authors should use when writing online documentation. Can you imagine going through all that work for each online document you create? If you had to define the headings, paragraphs, lists, and tables every time you wanted to create an online manual, you would be spending most of your time designing instead of writing. It wouldn't be long before you grew tired of the repetitive, routine task of creating a new document. Now, add a more complicated document to the documents you work with on a daily basis and you can see that you'd probably get more words on paper if you use a typewriter.

To save you from all that misery, Interleaf 6 allows you to create templates from your documents. A template is the blueprint to building a document and contains all of the layout and formatting for the text and graphics you might include in the document. You can have templates for memos, letters, executive reports, and even online versions of software documenta-
tion. When you need to create a certain type of document, start with the corresponding template. With a template, you just pick the Interleaf 6 objects you need and insert your text and graphics. (It’s as easy as hanging clothes in your closet.) The predefined objects will take care of formatting your data for you.

I will show you how to create a template and put it to use. I will also show you how to take the template a step further by turning it into a Network Style Sheet that can be used to enforce style and content in all of the documents throughout your organization.

**Creating a Template**

Creating a template is a straightforward task that involves four main steps: design the document, remove unused objects from the document, add initial document content, and make the document easily accessible.

**Design the Document**

In the last few chapters, you were designing your document. You defined page layout, paragraphs, headings, lists, inline components, and tables. Other things you might include in your design are graphics (which you’ll learn more about in Part IV of this book).

I wasn’t able to show you how to design every object that is in the User Guide template, so I have included an online version of the User Guide on the companion diskette to this book. If you want to create the online version, choose File→New→Inside Interleaf→Online→online to create an online document on your Desktop.

**Remove Unused Objects**

Once you have designed a document for use as a template, remove the unused objects from the template. There are a few good reasons for removing the unused objects. Removing unused objects can help unclutter the template and make it less confusing to authors. An added benefit is that authors will not be able to use one of these unnecessary objects incorrectly (they have plenty of other objects to use incorrectly—putting titles in paragraph components).

Removing unused objects reduces the size of the document since Interleaf 6 will not have to store the object definitions. Smaller documents will
save you disk space, and the document will open faster. Now that I have—hopefully—convinced you that unused objects should be removed from a template, let's get to it.

**Create an Instance of Each Wanted Object**

When it's time to delete the unused objects in your document, Interleaf 6 will let you delete objects not currently in use in the document. For this reason, you should create an instance of each object that you wish to keep in the document. Remember, an instance is an object that actually appears in your document. If you open the *online* document you just created, you'll see that there is at least one instance of every object (see Figure 13–1).

![Figure 13-1. Online version of the User Guide has an instance of each object](image)

**Purge Object Masters**

Now that you have an instance of each object in the document, you can delete, or purge, the unused master definitions. Choose **Edit → Delete Master**... from the document menu. The Delete Masters dialog box will open. To delete all unused masters, click on the All Types option. `<All Unused Masters>` appears in the selection list. Click on Delete All. Because deleting
all masters is potentially destructive, Interleaf 6 will give you an opportunity to change your mind. Click on Delete, and all unused masters will be gone from your document (see Figure 13–2).

<table>
<thead>
<tr>
<th>Edit</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Delete</td>
<td></td>
</tr>
<tr>
<td>Duplicate</td>
<td></td>
</tr>
<tr>
<td>Select</td>
<td></td>
</tr>
<tr>
<td>Find/Change</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>Find Object</td>
<td></td>
</tr>
<tr>
<td>Convert</td>
<td></td>
</tr>
<tr>
<td>Hyphen</td>
<td></td>
</tr>
<tr>
<td>Tab Fill</td>
<td></td>
</tr>
</tbody>
</table>

Figure 13–2. Deleting all unused masters

**Tip** It is a good idea to save your document just before using the Delete All command. This will allow you to recover all of the deleted components in the event you really didn't want to delete them in the first place. If you get the feeling that you shouldn't have clicked the Delete button just as you released the mouse, simply choose **File → Revert → to Saved** from the document menu. All of the deleted objects will be restored and you'll have no loss of data. (If you didn't save before the Delete All, you may still recover all of the objects—and most of your recent edits—if you use the **File → Revert → to Checkpoint** or **File → Revert → to Backup** menu command. A checkpoint document is saved automatically by Interleaf 6 as you work. A backup document is created each time you save a document.)
If you don’t want to take such drastic measures, you can delete smaller groups or individual objects at a time. For example, you can click on the Components option, select bullet, and then click Delete to purge just the bullet master. If you want to delete all unused component objects, you can simply click on Delete All and confirm that you want to delete the objects. Figure 13–3 shows these methods.

![Figure 13-3. Deleting selected masters](image)

To delete a single master, select the master by name and click Delete. You will not be requested to confirm the deletion.

To delete all unused masters of a certain type (in this example, Components), turn on the desired option and then click Delete All. Interleaf 6 will ask you to confirm the deletion by clicking on Delete.

**Tip** If an instance of an object doesn’t appear in the document, but doesn’t appear in the Delete Master dialog box, then it is being used in the definition of another object. (This can happen quite often with frame masters that may be used in other masters or contain instances of component masters you are trying to delete.) To delete the object, find the parent object that contains it in its master definition. Create an instance of the parent, delete the object from the new instance, and update the parent object’s master definition from the new instance. You should now see the unused object in the Delete Master dialog box, and then you can delete it.

**Add Initial Document Content**

After the unnecessary master objects have been deleted from the document, you can cut all of the object instances from the document and add back any initial content you wish. For example, for the online version of the User Guide, you want to add enough to the document to allow your authors to begin a new chapter without having to create a lot of components.
After you have deleted all of the components from the document, add back the following components in order: \texttt{h:chapter}, \texttt{h:1}, and \texttt{p:0} (see Figure 13–4).

Select all of the components within the document by choosing \texttt{Edit} $\rightarrow$ \texttt{Select} $\rightarrow$ \texttt{All}. Next, cut all of the items so that you’ll have an empty document.

Now add back any content (components) you want a new document to begin with.

\textbf{Figure 13–4.} Creating initial document content
Initial Component Content

You noticed that the $h$:chapter component had some content in it (besides the content located in the prefix) when it was first created. This content is known as initial content and is different from shared content. With shared content, every component will contain the same content. With initial content, when you first create a component, it will contain a copy of the master's content. You can then edit the content. Initial content components can be edited without affecting other components. If you edit the content of a shared content component, all components with the same name will also have their content modified.

Adding Initial Component Content

Initial content is helpful for creating a boiler plate that can be edited by authors, or for creating hints to authors on how to use components in a template. To display text whenever an author creates an $h$:1 component, begin by typing *This is a section heading.* in the $h$:1 component. Open the Component Properties dialog box. On More, choose Update Master Content. Now, create another $h$:1 component and you'll see the initial text. You can delete the text and add the section title (see Figure 13–5) without affecting the other $h$:1 component.

Tip Creating initial content in a component will cause that content to appear every time a new component is created. This could cause some grumbling among your authors when they have to constantly delete the initial content before they add their own content.

You can make your authors happier by making the content part of the document's content but not part of the component's initial content (so it won't show up every time the component is created). If the component is present as initial content of the document (as is the case here) just add the text to the component instance, but don’t update the master's content. The text will be available when the document is first created and won't get in the way when a new component is created. Use initial content with some of the less used and less known components of the template.

Save the Document

Once you are satisfied with the initial content of the document, save it. After the document has been saved, it is a good idea to remove the backup copy of the document before you place it into action as a template. To re-
move the document backup, select the document icon and then choose **Tools**→**Admin**→**Cleanup** from the **Desktop** or other container menu. Interleaf 6 will ask you to confirm and then will show all the backup files that were removed (see Figure 13–6).

**Make the Document Accessible**

Your document is now suitable for use as a template, but how do you make it accessible to your authors? You could place a copy of the template in a shared directory where the authors could find it and make a copy of it. Better yet, you could give a copy of the template to all of your authors. Once the authors have the document, they can place the document in their local **Create** cabinets. Both of these methods are easy to implement, but can lead to other problems when it comes to updating the template.

To create initial content that will appear in newly created components, select a component that has the content you desire or add some content.

On the Component Properties dialog box for the component, choose Update **Master Content**. Interleaf 6 will ask you to confirm the update: click on Copy Content.

Now, whenever you create a new **h:1** component, it will have content. You can delete the content in one **h:1** component without affecting the other.

**Figure 13–5. Creating initial component content**
Add the Document to the Master Create Cabinet

The best method for making the template accessible is to place it in the master Create cabinet. Placing the template in the master Create cabinet makes it accessible to all of your authors, and makes it easy for you to maintain the template.

**Warning** Working with the master Create cabinet is a task normally left to Interleaf 6 administrators. In fact, you may not even have permission to edit the master Create cabinet. But if you do, proceed with caution. If you don't, ask your Interleaf 6 administrator to perform this task for you.

You first need access to the master Create cabinet, which is inside the master System6 cabinet. The master System6 and Create cabinets are so called because they form the basis for the System6 and Create cabinets used by every user—not to be confused with your local System6 and Create cabinets. To access the master cabinets, choose **Goto** → **Pathname...** from the menu and enter the correct path to the master System6 cabinet. If running under Windows, type `d:\ileaf6\englicab` (substitute the correct drive on EarthFiles).

To remove backup copies of a document, choose **Tools** → **Admin** → **Cleanup** from the menu. Interleaf 6 will ask you to confirm the operation and then will generate a report of all removed backup files.

*Figure 13-6. Removing document backup files*
your system) for the pathname. If you're running Interleaf 6 on Motif, type in /ILEAF6_HOME/english.cab (the actual path may vary at your site; check with your Interleaf 6 administrator). Turn on the Open in Separate Window box, and click Apply. This will open a window to the master System6 cabinet (see Figure 13-7). Here, you can see the master Create cabinet. Open the Create cabinet to prepare for adding the template.

**Warning** Don't delete, move, or rename anything in the System6 cabinet!

In the GoTo Pathname dialog box, type in the correct path to the master System6 cabinet. On Windows, the path is <drive>:\ileaf6\english.cab.

![Interleaf 6 - GoTo Pathname](image)

In the GoTo Pathname dialog box, type in the correct path to the master System6 cabinet. On Windows, the path is <drive>:\ileaf6\english.cab.

![Interleaf 6 - english (d:\ileaf6\english.cab)](image)

*Figure 13-7. Accessing the master Create cabinet*

Open the File Properties dialog box (choose File→File Properties...) and change the file permission on the template document to allow everyone Read access (see Figure 13–8). If your operating system allows setting separate permissions for the owner and everyone else, then give the owner Write permission also; otherwise, you'll be forced to give everyone write permission to the document. Now, Cut (or create a Link to) the document and Paste it into the master Create cabinet. You are finished with the master Create cabinet, so close its window.
Change the file permissions so that when a new document is created from the template, the author can read and write the document.

Now, add the template to the master Create cabinet.

**Figure 13-8. Add document to the master Create cabinet**

**Each Author Updates His or Her System6 Cabinet**

Now that the document has been (safely) placed in the master Create cabinet, each author will need to update the System6 cabinet before the document will show up on the File→New menu. To update the System6 cabinet, each author must open the System6 cabinet on his or her Desktop. On the menu, choose Tools→Admin→Update. Interleaf 6 will recreate the links within the System6 cabinet. In the process, the online document will become accessible on the File→New menu (see Figure 13-9).
Each author will need to update his or her System6 cabinet by choosing Tools→Admin→Update in the System6 cabinet.

Once that is done, each author will have access to the online document from the File→New menu.

**Figure 13-9.** Updating the System6 cabinet

**Note** If you don’t have access to the master Create cabinet, or if you are running on a standalone computer (or don’t have access to other users running Interleaf 6,) you can install the online document in your local Create cabinet. Open the System6 cabinet, and then the Create cabinet. Paste the online document in the Create cabinet. It will now appear on the File→New menu.

**Creating Style-Enforcing Network Style Sheets**

Your template can also be used as a Network Style Sheet to help you enforce the properties of the objects in your Interleaf 6 documents. Creating a style sheet from the online document is straightforward. Create an online document on your Desktop using the new entry File→New→online. Select the online document and choose File→File Properties... to open the File Properties dialog box. Change the Class of online to catalog, which Interleaf 5 users will recognize as the old name for a style sheet. When you do, the bottom half of the dialog box becomes active. Here, you can choose which properties of online are exported to other documents. Turn on all of the properties and click OK. Interleaf 6 will change the icon associated with online to a style sheet icon so that you can see at a glance that it is a style sheet (see Figure 13-10).
Create an online document using the File New menu. Open the File Properties dialog box by choosing File → File Properties...

On the Interleaf Info sheet, change the class of the file to catalog. When you do, you’ll be able to select the items that are exported by the catalog. Turn on all of the items.

When you click Apply, Interleaf 6 will change the icon for online into a style sheet icon.

**Figure 13–10.** Turn the document into a style sheet

When you place the style sheet within a book and in front of other documents, its properties will be exported to the documents. To see the effect of your online style sheet, create a book. Inside the book, place a copy of the Introduction document in the book (or create one using File → New → Inside Interleaf → Exercises → Introduction). Open Introduction. Now, place a copy of the online style sheet in front of the Introduction icon in the book. Watch Interleaf 6 apply your new properties to the Introduction document (see Figure 13–11).
1.1 The History of Bowling

Bowling has become a popular recreational and sporting activity. Bowling has been around since approximately 5200 B.C. Evidence to support this is an ancient version of a ball and pins in an Egyptian child's grave. Stone age man (as evidenced by the popular cartoon character Fred "Twinkle-Toes" Flintstone) also enjoyed the recreational activity of rolling rocks at other rocks. "Nine-pins," where the pins are arranged in a diamond shape, became very popular as a recreational sport in the 1800's in New York. Gamblers soon invaded the sport, and participation in "nine-
With the style sheet in front of the document, you don't have the same free reign over your document that you once had. For example, if you position the text insertion point in the prefix of `h:chapter` and begin typing, Interleaf 6 will not let you make any changes. In the status bar of the document window you'll get a message that the component's prefix is exported from a style sheet (see Figure 13-12).

If you try to modify the prefix of a component (or any other shared content controlled by a style sheet), Interleaf 6 won't let you do it.

---

*Figure 13-12. Network Style Sheets force you into compliance*

**Table of Contents Style Sheet**

A good application for a style sheet is to override the default formatting used by Interleaf 6 when it creates a table of contents. To create a style sheet, either start with a table of contents document that you created with the **Book→TOC** command and modify the properties of the components, or predefine the components that Interleaf 6 will create.

To predefine components for formatting the table of contents, you need to know the names of the components Interleaf 6 will use. In Chapter 8, you learned that Interleaf 6 forms component names by appending `TOC` to the name of a component marked for inclusion in the table of contents. In the **User Guide** template, the items marked for the table of contents are named `h:part`, `h:chapter`, `h:1`, `h:2`, and `h:3`. The corresponding components that you'll need to predefine are `h:partTOC`, `h:chapterTOC`, `h:1TOC`, `h:2TOC`, and `h:3TOC`, respectively.

**Note** If the resulting component name exceeds 19 characters by appending TOC, Interleaf 6 deletes enough characters from the end of the name so that the last three characters will still be TOC. You should ensure that all components marked for the table of contents are unique within the first 16 characters of their name.
When Interleaf 6 copies the new component to the table of contents document, it copies the component content as text—tokens representing auto-numbers are converted to text, and frame tokens are ignored. To this text, Interleaf 6 adds a leader tab, a plain tab, and the page number where the component appears. When you define a component to format a table of contents item, you need to define tabs stops for the two tabs that Interleaf 6 will add.

The table of contents style sheet you create must export components. If page properties are not exported by another style sheet, you may also want to export them from the table of contents style sheet. The companion diskette contains an online version of the table of contents style sheet (File→New→Inside Interleaf→Online→TOC). You may want to study the component definitions.

**Index Style Sheet**

Another good application for a style sheet is to override the default formatting used by Interleaf 6 when it creates an index. Again, to create a style sheet for an index, either start with an index document that you created with the Book Index command and modify the properties of the components, or predefine the components that Interleaf 6 will create.

To predefine components for formatting an index, you need components with the following names: IndexLet, Level1, Level2, Level3, Level4, Level5, and Level6. There is nothing special that you need to know about defining the properties of these components. Unlike the table of contents components, Interleaf 6 will not add any tabs to the content of the index component. Like the table of contents style sheet, an index style sheet must export components. You may want to also export the page properties from the style sheet for the index since the index is well suited to a multiple column document. The companion diskette contains an online version of the index style sheet (File→New→Inside Interleaf→Online→index).

**Creating Content-Controlling Network Style Sheets**

One last type of Network Style Sheet that I like to use is what I call a content-controlling style sheet. With a content-controlling style sheet, you can gather, in one central location, information about the documentation you are creating. For example, assume that you develop many software manuals for many different software programs. Each program uses the same ba-
sic format for the software documentation, but specific program information will change from manual to manual. If you gather information about a program in one location—a style sheet—it is a lot easier to change the program information.

The online version of the *User Guide* uses the same content-controlling style sheet as the paper version of the *User Guide* (File → New → Inside Interleaf → User Guide → Master → data). The reason for this is that the style sheet controls content by using inline components. The inline component’s properties are set to inherit all of the text and font properties. If you look at the contents of the *data* style sheet, you’ll see that the inline components are organized within a table. You are free to organize the information any way you like. I like the formatting capabilities of tables. Notice that you can include descriptive text next to each item. This makes editing data in the style sheet as simple as filling in a form (see Figure 13–13).

The table in the *data* style sheet is used to organize inline components. Each of these inline components has a unique name. The properties are set to share content. Most of these inline components are set to inherit the font properties of the surrounding text.

![Table](image)

**Figure 13–13.** Content-controlling data style sheet

**Tip** By using a content-controlling style sheet in this manner, you can easily obtain a summary of all pertinent information about your documentation by printing the style sheet. Since style sheets are special classes of document objects, they can be printed like a document.

To create an inline component within your document from the content-controlling *data* style sheet, use the drop down list to change the Create dialog box source of objects to data and turn on the Inlines option. In the
list of available components, you’ll see each of the shared content inlines (see Figure 13–14). Pick the one you need and click Create.

![Diagram showing steps to create inline components]

Click on Inlines.

Change the drop down list to read data to see the inline components exported by the data style sheet.

Highlight the inline component wanted and click Create to create the component in your document.

Figure 13–14. Creating an inline component from the data style sheet

PUTTING IT ALL TOGETHER

Now that you have seen how to turn a document into a template and style sheet, the benefit of using style sheets for formatting table of contents and indexes, and how to use a style sheet to control content, let’s see how all of these items can be put together to form a more complex template.

Templates can be more than just a single document. If you examine the User Guide template (see Appendix A), you’ll see that it consists of a top-level book and many different sub-books. Within each different sub-book are one or more style sheets to control items within the sub-book. When the User Guide is placed in the Create cabinet, you have the ability to create an entire template structure or just a subset of the template on the File → New menu (see Figure 13–15). When you’re just starting a new documentation project, you’ll probably create an entire template by choosing <whole book>. When you are in the middle of a project, you can choose a Chapter sub-book to add a new chapter.
This selection will create the entire User Guide template on your Desktop.

You can create different parts of the User Guide template by traversing the menus.

Figure 13-15. Creating different parts of a complex template

**Summary**

In this chapter, you learned what a template is and how to create one. Related to the template is the Network Style Sheet. You saw how you could create a version of a style sheet to enforce style within your documents and another version to control content. Finally, you saw how a complex document template could be put together. With a complex document template in your Create cabinet, the entire template is available, either whole or in part, for editing documents.

This finishes Part III on designing a template. In Part IV, you’ll design a couple of objects useful for illustrations, and then you’ll get a chance to work with Interleaf 6 graphics.
PART IV

Who Needs a Drawing Program?

Part IV describes how to use the built-in tools to create graphics in your documents. You will learn a technique for including graphics that may make it easier to format your documents. You will learn how to create graphic objects and work with the various graphic tools Interleaf 6 provides. You will learn how to use the built-in raster editor, chart editor, and equation editor.
CHAPTER 14
Defining Objects for Illustrations

This chapter describes a method for creating illustrations within a document. You'll learn to define a frame and its properties to serve as a placeholder for an illustration. You'll also learn to provide a predefined component for creating a figure title and callout. You'll set up initial content for the frame so that all new illustration frames will have the required items. You'll learn why you should put an illustration frame in its own dedicated component, and you'll see some of the drawbacks of doing so. Finally, you'll learn how to create footnotes (which are themselves frames) and modify them.

GRAPHICS BELONG IN FRAMES

In this part of the book, you'll be working with graphics. All graphics in an Interleaf 6 document must be placed into frames. Frames can be anchored anywhere within a document, and you can tell Interleaf 6 how to place the frame on the page through frame properties.

Interleaf 6 contains some predefined frames in the default document. You can see these by opening a default document and viewing the list of frames on the Create Frame dialog box (see Figure 14–1).
Figure 14-1. Predefined frames in a default document

**Frame Layout Properties**

When you create an illustration, you begin by creating a frame from this list. After you've created a frame, you can adjust the frame's properties to position the frame where you want it on the page. Figure 14-2 shows the many frame layout properties that are available for adjustment. Depending on the type of frame you are defining, you'll have to set one or more of these properties. When you have many illustrations to put in a user guide, you'll most likely find that you're applying the same adjustments to each frame that you create. When this is the case, you should define a new frame that has all of the desired layout properties to serve as a standard illustration frame.

**Defining an Illustration Frame**

Defining a new frame master is as easy as defining a new component master: On the Frame Properties dialog box, click on New.... Type a new name (in this case figure) in the Define Master dialog box, and click Define (see Figure 14-3). Now, you can make changes to the frame's properties without affecting other existing frames.
When you select a frame, the frame and its anchor (if visible) will be highlighted.

When you open the Frame Properties dialog box (by choosing **Properties → Frame...**) you'll see the many types of layout properties for frame placement, width, height, and references. References will vary with the type of placement selected.

**Figure 14-2.** Various frame layout properties
Define a new frame master the same way you would define a new component master—with the Define Master dialog box. At this point, there is no content in the floating frame, so you don’t need to copy contents.

**Figure 14-3.** Defining a new frame master

For frame placement, you have many different choices. I like to use At Anchor frames when creating illustration frames, because I know exactly where the frame will be positioned. When I use another frame type, I need to keep in mind how Interleaf 6 will position the frame; and, sometimes, I don’t want to give Interleaf 6 that much control over my document. (Table 14–1 describes how Interleaf 6 positions the various frames.)

Other settings that I use for illustration frames are to set frame width to the page and frame height to contents. Because the figure frame you are working on is currently empty, you will end up with a very short frame. This will make the frame a little difficult to work with until you add content. An alternative is to set the height to a fixed amount and then change it back to Contents when you have added some contents.

**Figure 14-4.** Setting frame properties
ing with is empty, setting height to contents will leave you with a very short frame (see Figure 14–4). Of course, the frame will grow in height as you add objects to it; but, until there is some content, the frame will be a little annoying to work with. For this reason, it is a good idea to wait until you add some initial content to the frame before changing its height to contents. Until then, you could set its height to some fixed value, for instance, 2 inches.

Table 14–1. Frame Placement Properties

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>At Anchor</td>
<td>Frame appears at anchor. Useful for special characters and equations in text. (Use single space before and after frame so that the frame will not be considered part of a word. This is very useful for text justification.) Frame height is used to determine line spacing.</td>
</tr>
<tr>
<td>Following Anchor</td>
<td>Frame appears below text line containing anchor, or at top of next page if not enough room left on current page.</td>
</tr>
<tr>
<td>Top</td>
<td>Frame appears at top of current page, or at top of next page if not enough room on current page for both frame and its anchor.</td>
</tr>
<tr>
<td>Following Text</td>
<td>Frame follows all text on page (but is not placed at bottom). If frame does not fit between component containing anchor and bottom of page, it is placed at top of next page.</td>
</tr>
<tr>
<td>Bottom</td>
<td>Frame appears after anchor on bottom of same page. If not enough room for anchor and frame on same page, frame appears on bottom of next page, or at top of page if next page is empty. (Can be used for footnotes.)</td>
</tr>
<tr>
<td>Underlay</td>
<td>Overlay frame is a transparent layer over other contents on the page. Underlay frame lies under content of page. Neither displaces text on the page.</td>
</tr>
<tr>
<td>Overlay</td>
<td>Selection can be tricky: if frame is empty, you select frame; if frame has contents, and you point to contents, you select frame; if frame has contents and you point to empty area of frame, you select main level object or text.</td>
</tr>
</tbody>
</table>
**Using an Illustration Title or Caption**

The first item you can add to an illustration frame is an illustration title and an optional caption. You add an illustration title by creating a microdocument in the frame. A microdocument is so named because it behaves a lot like a miniature document—you can set page properties and it contains components.

**Creating a Microdocument**

To create a microdocument, you need to be working in an open frame. Double-click on the frame you just created to open it. The toolbar at the top of the document window will change when you are in an open frame. Open the graphics palettes by choosing Tools→Graphics Palettes→Drawing... and Tools→Graphics Palettes→Commands..., or click on the Graphics Palettes button on the tool bar. Create a microdocument using the Drawing palette as you did in Chapter 9 (see Figure 9–14, page 9–173). The default component name in the microdocument is micro:caption. If you wish to create a microdocument with a different name, click on the ar-

---

**Figure 14-5.** Creating a microdocument with a specific component
Defining Objects for Illustrations

row next to the name. Interleaf 6 will present a Create Microdocument dialog box and you can choose the desired component name. Close the dialog box and a microdocument with the chosen name will be created in the frame. You can then position and size the microdocument.

**Defining a Title Component**

Because a microdocument contains components just like a regular document, you can use different component names, and their associated properties, in a microdocument. You can create a component that is specifically used for figure titles. Using the Define Master dialog box, define a new component named `title:fig`. Once you have defined the component, you can modify it to look like a title. If you examine the `title:fig` component in the online version of the *User Guide* template, you'll see that it contains a prefix. The prefix contains an autonumber so that Interleaf 6 can automatically number the illustrations in the document. You can also set the alignment of the component to Centered, which will center the text horizontally in the microdocument. After you have defined the `title:fig` component, close the microdocument and then position it in the `figure` frame. The microdocument can be positioned by either dragging it into position, or by using the Commands palette (see Figure 14–6).

**Using an Illustration Callout**

Illustrations normally have descriptive text, or callouts, within them. Using predefined microdocuments is one way to create the callouts. So far, when you've created a microdocument using the Drawing palette, Interleaf 6 has created a fixed width microdocument. A fixed width microdocument wraps the text you type onto multiple lines when the text reaches the right edge of the microdocument.

An alternate method for creating a microdocument—one that creates a variable width microdocument—is to position the mouse cursor in the frame and begin typing. Interleaf 6 will create a variable width microdocument at the location of the cursor. The name of the component in the microdocument is the default `micro:caption`. 
Select the microdocument. It is selected when you can see its handles.

Align the microdocument to the top of the frame.

Size the microdocument to the width of the frame.

When you have finished, the microdocument will be in place to serve as the illustration title.

**Figure 14-6.** Positioning a microdocument with the Commands palette

As you type text into the microdocument, its width will expand to keep all of the text on a single line. If you wish to modify the font in the variable width microdocument, you can do so by using the document toolbar. If you need to change the text alignment you can use keyboard commands: \( \text{CTRL}-L \) for left alignment, \( \text{CTRL}-R \) for right alignment, and \( \text{CTRL}-E \) for centered. (\( \text{CTRL}-J \), which is used to justify text, is not applicable to a variable width microdocument.) The alignment will be relative to the anchor point of the microdocument. Figure 14-7 shows how to create a variable width microdocument.
Position the mouse within a frame where you want the microdocument to appear and begin typing.

Interleaf 6 will create a variable width microdocument that will continue to increase in size as you type in text.

The name of the microdocument will be micro:caption.

**Figure 14–7.** Creating a variable width microdocument

**Warning** Be careful when changing the properties of your text. If you change the properties of the micro:caption component using the Component Properties dialog box, Interleaf 6 will convert the variable width microdocument into a fixed width microdocument, and there is no way to convert a fixed width microdocument into a variable width microdocument.

If you don't care to use variable width microdocuments for callouts, you can create predefined components using the Drawing palette. There are no predefined components for callouts in the *User Guide*, but in your own documents you can define a few to use.

After you have created the text of a callout using either method, you can then reposition the text within the frame. If you are using a fixed width microdocument, you will be able to change the width of the callout. Finally, you can use the Line tool on the Drawing palette to create a line from the callout to a specific area in the illustration (see Figure 14–8).
Tip To change a variable width microdocument into a fixed width microdocument, press the ENTER key. Interleaf 6 will either create a new component or insert a hard return—depending on the preferences you have set—and fix the microdocument's width. You can delete the second component or the hard return and continue typing text. Interleaf 6 will automatically wrap the text to maintain the microdocument's fixed width.

If you need to add a line to your illustration, use the Line tool on the Drawing palette. Position the mouse at one endpoint of the line. Click and drag the mouse to the line's other endpoint and release the mouse.

Figure 14-8. Adding a line to the callout

Adding Initial Content to a Frame

Normally, when you create a new frame for illustrations, you won't have any microdocuments for callouts already present in the frame—you'll add them when you need them. You can cut the callout and line from the frame before you update the frame's master. However, you may have some additional content in the frame such as a horizontal rule or two to help form a boundary to separate the illustration from the rest of the body text. You can add these rules now using the Line tool. Add a horizontal line to the top of the frame and another to the bottom. Size both lines to the width of the frame. Adjust the spacing of the top line so that there is enough white space around the figure: title microdocument (see Figure 14–9).
**Tip** When creating a line, you can press the Shift key while you drag the mouse to constrain the line to horizontal sizing.

Use the Measurements dialog box to precisely position the top rule above the illustration title.

Move the line up by clicking on the + button entering a negative value in the vertical change field. This value can be entered as points.

Click on OK to move the line up from its current location in the frame.

Figure 14-9. Adding horizontal rules to the frame

Now that the frame contains the desired content, you can change its height property to Contents and then copy the content of this frame to the master frame. When you copy the contents to the master, Interleaf 6 will ask you to confirm (see Figure 14-10).
After you have added the desired content to the frame, change its height to Content and update the content of the master. Interleaf 6 will ask you to confirm the update.

**Figure 14-10.** Copy content to the master frame

**Using Illustration Components**

Now that you have defined a frame—and its initial contents—for illustrations, let’s revisit the frame’s placement. When you set a frame’s placement property to At Anchor, you know exactly where Interleaf 6 will place the frame. If the frame anchor is in the middle of text, Interleaf 6 will move the text—some before the frame and some after the frame—to position the frame. This can lead to very short lines of text being stretched awkwardly to justify the line. Sometimes, that may be the effect you want; but most often this is not desirable. If you place the frame’s anchor in a component without text, then you can overcome this unsightly splitting of text. I call this top-level component where a frame anchor is located an *illustration component*.

**Creating an Illustration Component**

You create an illustration component like you would any other component: start with a component and define a new master. Since the illustration frame you have been working with is already in a component that contains no text, you can open the Component Properties dialog box and define a new master. You can name the illustration component anything you wish; the *User Guide* uses `figure:num` as the name of the component because it is designed for numbered figures. Make sure you check the Copy Contents option when you define the new master (see Figure 14–11). Now,
you can modify figure:num's properties. Two of the most important are the Above and Below margins. You can set these to 0.167 inches. Apply changes to all to update the master. Now, whenever you create a figure:num component, it will contain a frame suitable for illustrations.

You might be wondering, what are the benefits of using an illustration component? Well, you have seen the argument that using an illustration component gives you very precise control over the placement of the frame. Another benefit is that you now have the ability to assign margins above and below the frame by setting Above and Below margins on the illustration component. There is no way to set a margin on a frame. When you use a frame outside of a dedicated component, Interleaf 6 will control the frame's margins (which are normally zero unless Interleaf 6 is trying to justify a column or page).

You can simulate setting margins on a frame by using a fixed frame height and avoid placing any graphics within specified regions at the top and bottom of the frame. This method takes a lot of work on the part of the user to define consistent margins; and if you need to adjust the frame "margins" you will have to visit each and every frame to make the adjustments. You can also set the frame's height to contents plus a fixed amount to give you a consistent Below margin. If you also need a top margin, you can create one by putting a non-printing object at the top of the frame, being careful to keep other graphics and text in the frame at a specific distance away from the non-printing object. Again, you'll have the same problems as before. An illustration component overcomes these problems.
Limitations of Illustration Components

If illustration components have so much benefit, why not use them all the time? Well, one drawback is that using illustration components will tend to leave more white space in your document. This white space may become visually annoying at times, and it can disrupt your work flow when you spend time moving components around to reduce some of the white space.

If instead of using illustration components you use frames that Interleaf 6 has more control over, then Interleaf 6 can make the adjustments to best use the space in the document. For example, Interleaf 6 takes a frame that follows the frame anchor and places it below the line of text that contains the anchor. Interleaf 6 will split the text in a component to make room for the frame. However, if there isn't enough room to place the frame on the same page as the frame anchor, Interleaf 6 will place the frame at the top of the next page. This allows Interleaf 6 to more effectively use the space on the page.

So, what's wrong with that? Absolutely nothing. Except in the case where you use a frame that follows the anchor to place an illustration that must stay with its frame anchor. At the time you create the frame, you know that Interleaf 6 has placed the frame on the same page. Later, when you are involved in editing the document, you won't know that Interleaf 6 had to move the frame to the next page because a change you (or someone else) made didn't allow the frame to fit. Sure, this could be overcome by using a different type of frame placement; but, again, more planning and effort are required on the part of the user.

The bottom line is that you'll probably achieve the best results with frame placement and white space using a combination of illustration components, containing At Anchor frames, and frames with other types of placement anchored in the middle of the text. Normally, you won't know what works best for a particular document until you try a few different combinations.

Defining and Using Footnotes

Finally, I would like to talk about footnotes. I know, footnotes are not illustrations, but frames are the key to implementing footnotes in Interleaf 6, and footnote frames offer an opportunity to learn more about frame properties. A default document contains two frames related to footnotes:
footnote:numbered and footnote:unnumbered. The next couple of sections will show how to use these frames to create footnotes and explore some properties that make footnotes behave the way they do.

**Numbered Footnotes**

The first type of footnote is a numbered footnote. To create a numbered footnote, position the text caret where you want the footnote number to appear and create a footnote:numbered using the Create dialog box. Interleaf 6 will create a frame that appears on the bottom of the same page as the frame anchor. The frame will be opened automatically and you'll be in a microdocument where you can type the text of the footnote (see Figure 14-12).

What makes the footnote:numbered frame act as it does are its properties. The placement of the frame is set to Bottom, which causes it to appear at the bottom of the page. The footnote number is set with the frame's anchor properties: numbered, using footnote as the autonumber, and set as a superscript. The microdocument within the footnote:numbered frame is named micro:ftnote. It contains, as initial content, an autonumber reference to the frame's anchor and a tab. Of course, you have the ability to modify these properties—change the autonumber stream used, and modify the microdocument's properties and initial content—to make a numbered footnote conform to your documentation requirements.

**Tip** If you wish to use footnotes in a document that doesn't contain the footnote:numbered or footnote:unnumbered frames, copy these frames from the default document and paste them into the current document. All you'll have left to do is modify the microdocument, autonumber, and frame properties.
When you create a footnote:numbered frame, Interleaf 6 opens the frame to the micro:ftnote microdocument so that you can type in the footnote. The microdocument contains an autonumber reference and a tab.

The Placement of a footnote frame is at the bottom of the page.

The anchor properties of a footnote:numbered frame are set to Numbered using the footnote autonumber stream. Superscript is turned on for the anchor.

Figure 14-12. Properties of a numbered footnote
**Unnumbered Footnotes**

Now that you know about numbered footnotes, you can probably guess how unnumbered footnotes are created. To create an unnumbered footnote, position the text caret where you want the frame anchor to occur and create a `footnote:unnumbered` frame with the Create dialog box. Again, Interleaf 6 will create a frame at the bottom of the page and place you in the open `micro:ftnote` microdocument.

The frame anchor does not use an autonumber and the initial content of the microdocument is empty (see Figure 14–13). You may want to use a superscript character in the text and the same character at the start of the footnote as a way to link the footnote to the text. As with a numbered foot-

![Create dialog box](image)

When you create a `footnote:unnumbered` frame, Interleaf 6 opens the frame to the `micro:ftnote` microdocument so that you can type in the footnote.

![Open micro:ftnote microdocument](image)

Unlike the anchor properties of a `footnote:numbered` frame, a `footnote:unnumbered` anchor is not numbered. It is only set to visible.

![Frame Properties dialog box](image)

**Figure 14–13.** Properties of an unnumbered footnote
note, you can make changes to the properties and initial content of the 
*footnote:unnumbered* frame or *micro:ftnote* microdocument.

**Adding a Horizontal Rule Above a Footnote**

Most style guides suggest separating footnotes from the rest of body text 
with a horizontal rule. You can accomplish this within an Interleaf 6 foot-
note frame by adding a line with the Line tool. Before you actually add the 
line, you need to understand why the footnote frame opens to the micro-
document, and how you can override this behavior so that you can add the 
line. The reason that you are immediately placed in the microdocument 
for editing when one of the footnote frames is opened is the result of the 
frame’s editing property being set to Object instead of Graphics.

**Footnote Frames Use an Object Editor**

Most frames you have worked with up until now have been using a Graph-
ics editor. With a Graphics editor, Interleaf 6 waits for you to select an 
object and then open it. When an object can be opened, the Graphics edi-
tor will invoke the appropriate built-in editor for the object. For a microdo-
cument, a Text editor is used. For raster images, an Image editor is used 
and is covered in detail in Chapter 16. In Chapter 17, you’ll see other Inter-
leaf 6 object editors: a Chart editor and an Equation editor.

When using an object editor as the default editor of a frame, the first object 
in a frame that can be opened will be, and the appropriate object editor will 
be used. When you close the object editor, the frame will close. When you 
want to add additional objects to the frame, you’ll have to change the 
frame editor back to a graphic editor first.

**Add Lines with a Graphics Editor**

To add a line to a footnote frame, select the frame and open the Frame 
Properties dialog box. Change the frame editor from Object to Graphics 
and apply your changes to the current frame. Now when you double-click 
to open the frame, you will be able to use the Line tool to add a horizontal 
line (see Figure 14–14). After you have positioned the line in the frame, you 
can change the editor back to Object. Since the line cannot be opened for 
editing with a dedicated editor, double-clicking on the frame will put you 
back into the microdocument under the Text editor.
Defining Obiects for Illustrations

Changing the frame editor from Object to Graphics will allow you to add a line (or other graphic objects) to the footnote frame.

![Frame Properties for footnote:numbered - document](image)

**Figure 14-14.** Changing a footnote frame’s editor to add a line

**SUMMARY**

In this chapter, you learned that all graphics in an Interleaf 6 document must be placed in a frame. You took a brief look at frame properties and created a generic frame suitable for holding illustrations. You created a microdocument to hold a title for your illustration and another for callouts; in the process, you learned the difference between fixed and variable width microdocuments. After adding a little more content to the illustration frame, you updated the frame master so that each time you create an illustration frame, it will have the required items for your User Guide illustrations. You created a component dedicated to holding illustration frames and learned the advantages and disadvantages of using such a component. Finally, you took a brief detour to look at footnote frames, and learned about a few more frame properties.

In the next chapter, you’re going to be given a whirlwind tour of the different types of objects that can be used to create illustrations with Interleaf 6.
CHAPTER 15
Working in Frames

This chapter describes creating and manipulating graphic objects. You will learn to use the graphics toolbar and graphics palettes. You will learn how to use locks to control properties of a graphic object—such as preserving aspect ratio or size. You will also learn how to change the pattern or color used to fill the interior of objects. Finally, you’ll learn how to create three-dimensional objects using Interleaf 6 tools and commands.

CREATING GRAPHIC OBJECTS

To create a graphic object, you must be working in a frame. Interleaf 6 provides you with the ScratchPad document that already contains a frame. You can create your graphics in the ScratchPad and then transfer them to your final document. To create a ScratchPad document, choose File→New→ScratchPad (see Figure 15–1). Open the ScratchPad document and you will be immediately working in a full page frame.

Describing how to use Interleaf 6 graphics in just a few pages will not do them justice—there are just too many features and commands. In an effort to give you some exposure to the different things you can do with graphics, I am going to work through the creation of a very simple drawing—it has to be simple since I don’t claim to be a graphic artist. I am going to create a graphic of a T-shirt. The T-shirt will demonstrate how to use a number of

15–293
features within the graphics subsystem of Interleaf 6. Let's begin by looking at some of the tools available within a frame.

The first thing you might notice about the ScratchPad document window is that the tool bar is different (see Figure 15-2). The tool bar puts many of the graphics commands that you'll use within easy reach. One of the buttons on the tool bar will also open up graphics palettes that make working with graphics easier. When you click on the Graphics Palettes button, the Drawings and Commands palettes will be opened (see Figure 15-2). The palettes can be moved anywhere you want and will remain on top of the document they belong to. When you minimize the document window to an icon, the palettes will also disappear from the screen. Later, when you restore the document window, the palettes will return to their last location.

Using a Grid

The first thing I want to do is set up the graphics environment for the way I want to work. Since I am not very good at “eyeballing” objects in a frame, I want to turn on the grid and make sure that grid alignment is also on. To turn on a grid, just click on the Grid Visible toggle button in the graphics tool bar. The grid is now visible in the frame. When the Grid Align toggle button is on, objects that you create, move, or size will snap to the grid.

Note The grid will not print, even if it is visible. Also, when the grid is invisible, items will still snap to the grid as long as the Grid Align toggle button is on.
Figure 15–2. Graphics tool bar and palettes
Changing Grid Properties

The default grid may be too coarse or too fine for the work you are doing. If so, you can change the grid by clicking on the Grid Dialog button on the Commands palette to open the Grid dialog box. To change the spacing of the grid, enter new values in the Spacing fields on the dialog box. The first column sets the spacing between the major grid units, and the second column determines the number of minor grid units that occur within each major grid unit. Let's change the spacing between the major grid units to half an inch with five minor grid units within each major grid unit (these minor grid units will then be a tenth of an inch apart). These changes will be applied to both the horizontal and vertical axis of the grid, so enter val-
ues only in the first row. Apply the changes and the grid will change to the new values (see Figure 15-3).

**Creating Objects While Grid Align Is On**

When you create an object while grid align is on, the anchor point and control point of the object will snap to the grid. The anchor point is a stationary point on the object that remains fixed while you initially size the object using the control point. To see how these points work, let's begin by creating a line.

To create any graphic object, you can use the Create menu on the document window. If you look at the Create menu, you’ll see the different types of objects you can create in Interleaf 6. Choose Create → Line on the menu. Position the mouse in the frame where you want one endpoint of the line and press the mouse button. The endpoint will snap to the nearest grid location and become the anchor point. Drag the mouse to the location of the second endpoint and release the mouse button. As you drag the second endpoint, you are dragging the control point. The control point will only move to another grid location because grid align is on. This process is shown in Figure 15-4.

![Figure 15-4. Creating a line](image-url)

To create a line, choose Create → Line. In the frame, position the mouse cursor at one endpoint of the line. Press and hold the mouse button and drag the mouse. The first point you create will become the anchor point. It can only be created on a grid point because grid align is on.

As you drag the other endpoint of the line around the frame, you’ll see the control point snap from grid point to grid point. When you release the mouse, you’ll have created a line.
Creating a Line with the Drawing Palette

Instead of using the Create menu on the document window, you can use the Drawing palette. The Line Tool button on the palette allows you to create lines just as the Create→Line menu selection does. The Drawing palette can minimize the amount of mouse movement for creating graphic objects, and you’ll find you probably won’t be using the menu as much. To use the Line Tool, click on it and then create a line as you did before. The Line Tool button will be deselected and the Selection Tool will become active after you finish creating the line. Create a few more lines for our drawing by using the Line Tool. Your drawing should form the right side of the T-shirt (see Figure 15–5).

Tip If you will be creating a number of lines, you can double-click on the Line Tool (or any other tool on the palette) to cause the tool to remain on. Double-clicking enables the tool’s stickiness. You can tell when stickiness is on by looking at the Active Tool Stickiness toggle button on the graphics tool bar (see Figure 15–5). You can also turn stickiness on and off by using the toggle button on the tool bar.

Add a few more lines to the drawing to create the right-hand side of the T-shirt. To make the job go faster, use tool stickiness so that the line tool is left on after you create a line.

Figure 15–5. Adding more lines to the drawing
Working with Arcs

For the collar of the T-shirt, we'll use another Interleaf 6 graphic object: an arc. When you create an arc, you can choose either a clockwise or counterclockwise orientation. The type of orientation you choose really doesn't matter—you'll have an arc either way. These choices are provided as a matter of convenience and the choice you make depends on where you'll place the arc's anchor point, where you want the control point, and where you want the curve of the arc to be. To see what I mean, let's create the collar.

Creating an Arc

Click on the Arc Tool in the Drawing palette. For the collar, we want to use the Clockwise Arc Tool (you can tell whether the arc is clockwise or counterclockwise by looking to see which way the arc curves as you move from the upper left to the lower right of the arc). If you need to switch the type of arc, then click on the little triangle in the upper right corner of the Arc Tool button and choose from the two choices (see Figure 15-6).

Position the mouse cursor near the line that forms the top of the right sleeve and press the mouse button. This will set the anchor point. Drag the control point to the left and release the mouse button to finish creating the arc (see Figure 15-6).

Click on the clockwise arc tool. Position the anchor point near the top right side of the T-shirt. Press and hold the mouse button while you drag the control point to the left. Release the mouse button to form a collar.

Figure 15-6. Drawing an arc

Modifying an Arc

Now that you have created the arc, you can modify it further by dragging one of its size handles (see Figure 15-7) or you can change to a sub-edit of the arc and modify the extent and eccentricity of the arc.
When you drag the size handles of an arc, you can change the arc's eccentricity as well as its size. You can even cause the arc to flip.

Figure 15–7. Modifying an arc using the size handles

**Warning** When changing the size of an arc by dragging its size handles, it is possible to convert the arc into a line. Once the arc has been converted into a line, you can't change it back into an arc. Of course, you can use the Undo command to restore the arc if you haven't done anything else.

An arc is formed as part of a conic section. If you’ve taken a geometry class, you may remember the ellipse, parabola, and hyperbola conic sections. Most of the arcs we’ll deal with in Interleaf 6 come from ellipses (See Figure 15–8). The extent of an arc is how much of the conic section is displayed, while the eccentricity is a measure of how circular the arc is (eccentricity only applies to elliptical arcs).

Figure 15–8. Arcs come from ellipses

**Entering a Sub-Edit**

To change an arc’s eccentricity and extent, you need to be in a sub-edit of the arc. The quickest way to enter a sub-edit is to double-click on the arc.
You’ll know that you’re in a sub-edit by a change in the display of the arc, as well as a change in the graphic tool bar and the Drawing palette (see Figure 15–9). The handles displayed when in a sub-edit of an arc are the endpoints, midpoint, and tangent control points.

When you enter a sub-edit of an arc, you will see a change in the Sub-Edit Level tool of the Drawing Palette. It shows that you are in the first sub-edit of an arc. The tool bar will have a similar display.

You’ll also see the endpoints, midpoint, and tangent control points of the arc. (Sometimes, the tangent control points lie outside the visible area of the frame.)

Figure 15–9. Entering a sub-edit of an arc

Changing an Arc’s Extent

To change the extent of an arc, select one of its endpoints and drag it with the mouse. You will be constrained to moving the control point along the elliptical section that the arc belongs to (see Figure 15–10).
To change an arc’s extent, grab an endpoint and drag it around the path of the arc. Regardless of where you move the mouse, the control point will remain on the ellipse that describes the arc.

**Figure 15-10.** Changing the extent of an arc

**Changing an Arc’s Eccentricity**

For the collar of the T-shirt we are creating, we don’t want to change the extent of the arc; but, we do want to change its eccentricity. To change the eccentricity of an arc, we drag the tangent control handles to a new location. In the process, the eccentricity changes (see Figure 15-12).

To change an arc’s eccentricity, drag a tangent control point to a new location.

**Figure 15-11.** Changing the eccentricity of an arc

Change the eccentricity of the arc used for the T-shirt collar until it looks similar to Figure 15-12.

**Figure 15-12.** The collar of the T-shirt after changing eccentricity
Reusing Graphic Objects

To create the left-hand side of the T-shirt, we can repeat the steps used to create the right-hand side; or, we can reuse what we have already created by using other Interleaf 6 graphic commands. The commands we'll use are the Group Command, the Duplicate Command, and the Flip Command.

Group Command

Since we want to reuse the right-hand side of the shirt, it will be easier to use the lines that make up that side if we can work with them as a single object. The Group Command allows us to group the objects together and then work with them as a single object. To use the group command, we first need to have objects selected. To select the objects, you can use a drag select. Drag selecting requires that you place the mouse cursor at the corner of an imaginary rectangle, holding down the mouse button, and dragging to the opposite corner of the imaginary rectangle. (The outline of the rectangle will appear on the screen.) When the rectangle is surrounding all of the objects you want to select, release the mouse button. All of the objects that fall completely within the rectangle will be selected (see Figure 15–13). Now, click on the Group Command button in the Command palette and the objects will be grouped together (see Figure 15–14). Whenever you select an object of the group, the entire group will be selected.

To select multiple objects, position the mouse cursor in one corner of an imaginary rectangle and press the mouse button. Drag the mouse to the opposite corner of the imaginary rectangle and release the button. All of the objects enclosed within the rectangle will be selected. A bounding box that surrounds all of the objects will have size handles. The control points of the individual objects will also be visible.

Figure 15–13. Drag selecting multiple objects
After the objects are selected, clicking on the Group Command button will group all of the individual objects together. You'll still see size handles at the corners of the bounding box, but the individual control points of each object will not be visible. Whenever you select one object of the group, the entire group will be selected.

**Figure 15-14.** Grouping objects together

### Duplicate Command

The right-hand side of the T-shirt is exactly what we want to copy and use for the left-hand side of the T-shirt (of course, we will really use the mirror image). With the right-hand side still selected, we can click on the Duplicate Command button in the Command palette. When you click on the button, nothing apparent will happen to your graphic because the duplicated object is left on top of the original object. To prove that the duplicated object is really there, place the mouse cursor on a line of the object and drag the object to a new location (see Figure 15-15). You should see two identical objects.

### Flip Command

Finally, we need to flip the new object so that it can form the left-hand side of the T-shirt. With the object still selected, click on the Flip Horizontal Command button. The Flip Horizontal Command flips the object horizontally (see Figure 15-16). Another way of saying this is that the Flip Horizontal Command reflects the object about a vertical plane. Have you ever placed a mirror on a sheet of paper next to some text and looked at the reflection of the text? That is exactly what the Flip Command does—it gives you an object that results from reflecting the object about some plane. As you rotate the mirror, you can get many different reflections. The Flip Command provides you with three: Flip Horizontal (which you have already seen), Flip Vertical (which flips the image upside down), and Flip Diagonal (which is a combination of Flip Horizontal and Flip Vertical).
With an object selected, click on the Duplicate Command button. Nothing apparent will happen; but, if you drag the object to the side, you’ll see that there are two objects.

![Figure 15-15. Duplicating an object](image)

To create a mirror image of an object, use the Flip Command. To create the left-hand side of the T-shirt from the right-hand side, flip the right-hand side horizontally.

![Figure 15-16. Flipping an object](image)

**Moving Objects**

Now, let’s move the left side of the T-shirt into place. When you select an object to move it, a control point becomes active. The control point that becomes active is the one closest to the mouse cursor when you begin the move. Figure 15–17 shows different control points on the left side of the T-shirt. The active control point will snap to the grid as the object is moved.
When moving (or sizing) an object, the active control point is determined by the initial location of the mouse cursor. The control point closest to the cursor becomes the active control point. Here, you can see how the mouse cursor location controls the selection of the active control point.

**Figure 15-17. Control point on an object**

Before we actually move the left side of the T-shirt into place, let’s turn off the Grid Align toggle so that we can see how the object moves without grid alignment. Without grid alignment, we are free to move the control point of an object anywhere we want. But this freedom can cause problems. When we try to join two objects together, two points that look like they are touching on screen aren’t necessarily touching. Unless we apply fill to the objects, we may not even know that the objects aren’t touching until we print the document. This happens because output devices have better resolution than a video screen. Sure, you can use grid align to make points line up, but that only works if every object control point falls on a grid boundary. When you manipulate graphics, control points can end up between grid points. The solution to this sticky problem is to use gravity.

**Sticking Objects Together with Gravity**

In this context, the term *gravity* is just what you might imagine it to be: an attraction between two objects. When you turn on the Gravity toggle button in the graphics tool bar, you can let the Interleaf 6 graphics system join objects together; and you can be assured that points actually touch. Gravity works by snapping the control point of the animated (moving) object to...
the control point (or an edge) of the stationary object when the two objects get close together. How close the two objects must be is a value you can determine. The default value is eight screen pixels.

To change the gravity distance setting, click on the Animation dialog button in the Command palette. The Animation dialog box will open. On this dialog, you can toggle Grid Align and Detent (used to control angular rotations) as well as make changes to the gravity setting (see Figure 15–18). After you have made your settings, click OK or Apply.

![Animation Dialog]

You can set the gravity distance to a value between one and eight screen pixels.

One screen pixel

Eight screen pixels

**Figure 15–18.** Changing gravity settings

**Note** Detent is a restriction on the angular rotation of objects. If you have set a detent of 90 degrees, then you’ll be limited to 90, 180, 270, or 360 degrees when rotating an object.

With gravity turned on, move the left side of the T-shirt (by dragging it near its upper right control point so that it is the active control point) close to the left side of the collar. When you get close enough, the objects will snap together. You can tell that gravity is working by the circle that appears around the control point. This is your indication that gravity is holding
these two objects together (see Figure 15–19). If you try to move the left side of the shirt away from the collar, you will notice that you have to move the mouse a small distance before the left side of the T-shirt pulls away from the collar.

When moving an object with gravity on, the objects will snap together when they are within the gravity distance. You'll know that gravity is holding two objects together when the control point turns into a circle.

**Figure 15–19.** Joining two objects with gravity on

The T-shirt is almost finished. Add a line between the two sides of the T-shirt. When you create the line with gravity on, the anchor point will snap to one side of the shirt (if you begin creating the line close to the control point). The control point of the line will snap to the other side of the shirt as you get within gravity's range (see Figure 15–20).

When you create a line with gravity on, the anchor point will snap to another object (if you start creating the line close to the object). The control point will snap to an object when you get close to it. You'll know gravity is working when the control point changes to a circle.

**Figure 15–20.** Creating a line with gravity on
After you have created the new line, select all of the objects that make up the T-shirt and group them together (see Figure 15–21).

**Figure 15–21.** The finished T-shirt

**Using Graphic Locks to Prevent Chaos**

Now that we have created this new graphic object, let's see what happens to it when we size it. Grab the T-shirt by one of its size handles and drag the handle to a new location. (You may want to duplicate the shirt and work with a copy.) As you can see in Figure 15–22, you can really distort the T-shirt. This isn't what I want to happen when I size the T-shirt; so, I can try to be really careful when I size the shirt, or I can set a graphic lock—specifically, the aspect lock—to preserve the original aspect of the shirt.

When you size an object by a handle without an aspect lock set, you can really distort an object as you drag the handle around the frame.

**Figure 15–22.** Sizing an object without an aspect lock
Tip  You can size an object by a handle and preserve the aspect ratio if you size diagonally. To size diagonally, press and hold the CTRL key as you drag the handle. While holding down the CTRL key, mouse motion will be constrained to a diagonal line. Another key to note is the SHIFT key. When you press and hold the shift key, mouse motion will be constrained to either horizontal or vertical motion (depending on the first motion of the mouse).

**The Aspect Lock**

To turn on an aspect lock, or one of the many other types of locks, you need to open the Locks dialog box. Click on the Locks Dialog button on the Command palette. In the Locks dialog box, turn on the Aspect lock by clicking the option box. Apply your changes. Now, when you grab any handle and try to size the T-shirt, it will maintain its proper proportions regardless of how you try to move the control point (see Figure 15–23).

**Other Uses of Locks**

You can use other graphic locks to keep unintended things from happening to a graphic object. For example, you can set a printing lock to prevent the object from being printed. You can also set a selection lock to prevent an object from being selected. These two locks are useful if you use Interleaf 6 to design forms—you can embed the instructions for the form right in the form using the printing lock; and the lines of a form can be selection locked to allow the user to select only the important parts of the form that need to be filled in. For a description of the different locks you can set on a graphic object, see Table 15–1.

**Locks on Objects Within Groups**

Locks are also useful to control other properties of an object, especially when that object may be included as part of another object. You have already seen how to use the aspect lock, but let's see how this works when the T-shirt is grouped with another object. Create a rectangle next to the T-shirt (using the Box Tool). Select the T-shirt (which should already have an aspect lock set) and the rectangle, and group them together. Now size the resulting group and notice what happens to the T-shirt and the rectangle (see Figure 15–24).
In the Locks dialog box, you can turn on the different types of locks for an object. To preserve the aspect ratio of an object, click on the aspect lock and then Apply. With an aspect lock set, you can't distort the T-shirt as you size it with one of its handles.

**Figure 15-23.** Sizing an object with aspect lock on

Locks are useful to preserve properties of an object when the object is part of a group. Here, the T-shirt has the aspect lock on. As the T-shirt and rectangle—both part of the same group—are sized, the T-shirt maintains its proportions while the rectangle does not.

**Figure 15-24.** Locks can be applied to individual objects of a group
### Table 15.1. Lock Types

<table>
<thead>
<tr>
<th><strong>Type</strong></th>
<th><strong>Action</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Aspect</td>
<td>Object maintains its proportion of height to width. Sizing only occurs diagonally regardless of how the size handles are moved.</td>
</tr>
<tr>
<td>Control</td>
<td>Makes an object take precedence when you move, size, rotate, etc. the object with other objects.</td>
</tr>
<tr>
<td>Cutting</td>
<td>Object cannot be cut from frame.</td>
</tr>
<tr>
<td>Edge</td>
<td>Edge color, dashes, visibility, and weight are protected. Each is set individually.</td>
</tr>
<tr>
<td>Fill</td>
<td>Fill color, pattern, and visibility are protected. Each is set individually.</td>
</tr>
<tr>
<td>Font</td>
<td>Protects the font of a text string or microdocument. Font commands have no effect.</td>
</tr>
<tr>
<td>Gravity</td>
<td>Disables an object’s gravity points. Objects are not attracted to a gravity-locked object.</td>
</tr>
<tr>
<td>Grouping</td>
<td>Protects a group against ungrouping.</td>
</tr>
<tr>
<td>Position</td>
<td>Protects an object’s size, position, proportions, and orientation. Basically, the object can’t be moved, sized, or transformed (translated, scaled, rotated).</td>
</tr>
<tr>
<td>Printing</td>
<td>Object will not print.</td>
</tr>
<tr>
<td>Rotation</td>
<td>Protects an object’s rotation. If you rotate a group containing a rotation-locked object, the rotation-locked object will move about its center of rotation but will not rotate.</td>
</tr>
<tr>
<td>Selection</td>
<td>Object cannot be selected except by the Select→ Locked command.</td>
</tr>
<tr>
<td>Size</td>
<td>Protects object’s size—size commands have no effect.</td>
</tr>
<tr>
<td>Smoothness</td>
<td>Protects the contours of a poly or spline. Colinearity of bézier handles is protected. (A <strong>poly</strong> is multiple objects that have fill in common. A <strong>spline</strong> is created from multiple objects that have a smooth, curved corner where the objects join together.)</td>
</tr>
<tr>
<td>Stickiness</td>
<td>Protects an object’s intersections. If two lines are attached at their endpoints and stickiness is set, moving one line will cause the other line to remain attached.</td>
</tr>
</tbody>
</table>
FILLING OBJECTS WITH COLOR AND PATTERNS

The T-shirt we've created is pretty dull and needs a little bit of color added to it. To add color to the T-shirt, select it and then open the Fill/Edge dialog box by clicking on the Fill/Edge Dialog button on the Command palette.

To change the fill color or pattern, click on the appropriate button of the Fill/Edge dialog box. When you click on a button, you'll be presented with either the Color or the Pattern dialog box. On either dialog box, click on the desired color or pattern and click OK. When you return to the Fill/Edge dialog box, the Fill check box will have been turned on for you. All you have to do is click Apply. The T-shirt will take on the new color and pattern properties. Figure 15-25 shows how to use the different dialog boxes.

To change the fill color or pattern of the T-shirt, use the Fill/Edge dialog box. When you click on the color button, the Color dialog box will open. Click on a color and click OK. To choose a pattern, click on the pattern button. On the Pattern dialog box, click on a pattern and then click OK. Apply your changes and the T-shirt will have some color added to it.

Figure 15-25. Changing fill color and pattern
Adding More Colors to a Document

The Color dialog box displays only the colors that are present on the document's color palette. If you want to use additional colors with your graphics (and text, too), you need to add additional colors to the document's color palette.

Colors are added with the Color Palette Editor. To gain access to the Color Palette Editor, choose **Tools → Colors...** from the document window menu (see Figure 15–26). The Color Palette Editor window contains menu commands that allow you to save and load colors (**File** menu) and commands that allow you to add, copy, and paste colors (**Edit** menu) into the main part of the window.

![The Color Palette Editor](image)

The Color Palette Editor is where you can change and add to the colors in your document. To open the editor, choose **Tools → Colors...** from the document menu.

**Figure 15–26.** The Color Palette Editor

Editing an Existing Color Using a Color Model

To edit an existing color, double-click on that color in the Color Palette Editor window. The Color Editor dialog box will open with that color's definition and a sample displayed in the center of the dialog box (see Figure 15–27). Along the top of the Color Editor dialog box is a row of buttons that allow you to pick the color model. There are different ways for specifying a color. The color I have selected uses the CMYK color model. This color model uses four colors: C – Cyan, M – Magenta, Y – Yellow, and K – Black.
The Color Editor dialog box contains sliders that allow you to change the percentages of the values that produce a color. As you change the sliders, the resulting color is displayed alongside the sliders. If you have a paint chip for a color, it will probably contain the percentages of each of the four basic colors along with it. If you have these values, you can simply type the numbers in the percentage field along the left side of the dialog box. When you are satisfied with the color, click on Apply to update the color in the Color Palette Editor window.

Pick a color model to work with.

The percentages of each color in the model are displayed here. You can adjust these values by typing in new numbers or using the spin buttons. Or, you can...

...select a slider bar and drag it to a new value. Your changes can be seen immediately in the color sample.

**Figure 15-27.** Editing a color using a color model

**Note** For the curious, the other color models are: CMY – Cyan, Magenta, Yellow; RGB – Red, Green, Blue; and HSB – Hue, Saturation, and Brightness. All of these color models are standard models. Interleaf 6 provides you with a lot of flexibility for defining colors!

**Picking a Color from a Color Library**

In addition to using one of the four color models to define a color, you can select a color from a library of colors. Interleaf 6 comes with a default library that you can use. To use the library, click on the Library button in the Color Editor dialog box. The dialog box will change to the controls that are used for the library (see Figure 15–28).

After you have picked a library, you can choose a color in a couple of different ways: scroll through the drop down list, or use the slider to quickly
scroll the colors displayed in the window. After you have selected a color, you can even adjust the color's tint. When you are satisfied with your color selection, click OK to update the color in the Color Palette Editor and close the Color Editor dialog box.

![Image of the Color Editor dialog box]

**Figure 15-28.** Using a color library

### Making Color Changes Permanent

After you have done all that work to define a new color, the color is still not available for use in your document. The changes you have made so far have been updated in the Color Palette Editor dialog box, but they have gone no further. To permanently save your changes, you must save the colors using the File→Save command on the Color Palette Editor menu. After you have saved the colors, they will be available the next time you use the Color dialog box (see Figure 15-29).

To make the color changes permanent, choose File→Save in the Color Palette Editor dialog box. The next time you choose a color with the Color dialog box, the new color will be available. You can see in the Color dialog box the name of the color that was selected from the library.

![Image of the Color dialog box]

**Figure 15-29.** Using a new color
Adding More Patterns to a Document

Adding more patterns to a document is similar to adding more color—except the Pattern Editor is much easier to use. You get to the Pattern Editor dialog box through the Pattern Palette Editor dialog box, which is opened by choosing Tools→Patterns... from the document menu.

The Pattern Editor dialog box displays a 16 by 16 grid, divided into four quadrants, for creating a pattern and a preview area of that pattern (see Figure 15-30). Basically, you turn pixels of the grid on or off to create a pattern. Under the Edit menu, you'll find some commands that will allow you to copy the pattern in one quadrant to the other quadrants, commands to invert the pattern, and commands to shift the pattern.

![Pattern Editor dialog box](image)

When you are finished editing a pattern, you must save it using the File→Save command. Just as with the Color Palette Editor, pattern changes are not permanent until you save the changes in the Color Palette Editor dialog box. Once the patterns are saved, they are available on the Pattern dialog box.

Adding Color and Patterns the Easy Way

Using the Color and Pattern Editors can be a very tedious way to add different colors and patterns to a document. Fortunately, there is an easier way to add colors and patterns—let someone else do the work and you copy what he or she has done.
Within the *System6* cabinet is a *ClipArt* drawer. This drawer has a group of documents with different colors and patterns. You can open up any of these documents, select a group of patterns or colors, cut them (they won’t be deleted because they all have a Cut lock turned on), and then paste them into a frame in a document (see Figure 15–31). After you have pasted the objects into your document, you can delete the objects—their colors and patterns will remain on the respective palette.

**Making Objects Look Three-Dimensional**

To make realistic looking objects, you may have to make them look three-dimensional. Making objects look three-dimensional on a two-dimensional computer screen or piece of paper is not easy, but Interleaf 6 provides a few tools to help you with that task. The tools are the isometric grid and the projection commands.

*Figure 15–31.* Pasting existing colors into a document
The Isometric Grid

Earlier, you saw that a grid could be rectangular or isometric. An isometric grid maps three dimensions onto a two-dimensional plane. In Figure 15–32, a cube has been created by using lines for all of the edges. Each line was placed along a major grid line of the isometric grid. After all of the lines were created, the lines were grouped into a single object.

An isometric grid allows you to create objects with a three-dimensional look to them. Here, nine lines were used to create a cube. Each line was created along a major grid line.

Figure 15–32. Using an isometric grid to create objects with depth

Using Projection Commands

An alternative to using the isometric grid is to create objects in two dimensions and then project those objects into three dimensions using the project, or Convert to Isometric, commands. There are three different Convert to Isometric commands: Top, Left, and Right. To use the command, your graphic object must have three different views in the two-dimensional plane—you guessed it: top, left, and right. You select each of the views and convert using the appropriate Convert to Isometric command: Top for top, Left for left, and Right for right. When you have converted the three views, you piece them together to create a three-dimensional object. Figure 15–33 shows how to use these commands to create another cube.
Select each view of the object and convert using the appropriate Convert to Isometric command. When all views have been completed, assemble the views into a final object.

**Figure 15-33.** Projecting two dimensions into three

**EXAMPLE OF A COMPLEX GRAPHIC**

The purpose of this chapter was to give you a start with Interleaf 6 graphics. With Interleaf 6 graphics, it is possible to create very complex graphics. For an example of a complex graphic, see Figure 15-34. The graphic was created by Colette Renteria using Interleaf 6 objects and is not a scanned image. Colette has graciously provided the graphic as a file on the companion disk. You can access the graphic by choosing **File → Inside Interleaf → Graphics → complex** on the **Desktop** menu.
SUMMARY

In this chapter, we took a fast and furious look at Interleaf 6 graphics. You learned how to use the graphics tool bar and palettes to set up the graphics environment and create objects. You were introduced to graphic locks and saw how they could be used to control properties of graphic objects. You saw how color and patterns can spice up graphic objects and how to add them to a document. You also saw how to make graphics look more realistic by making them three-dimensional. Finally, an example of a complex graphic was shown to give you an appreciation for the power of Interleaf 6 graphics.

In the next chapter, you'll get a look at another Interleaf 6 editor—the Image Editor.
CHAPTER 16

Using Raster Images

This chapter describes using raster images in Interleaf 6. Using images may require editing them—it certainly requires placing them in your document. Both of these topics will be addressed. You'll see how to edit images using the raster Image Editor included in Interleaf 6. The Image Editor is actually three separate editors: a Picture Editor, a Frame Editor, and a Contrast Editor. With these editors, you can bring scanned images and screen captures into Interleaf 6 and perform final touchup of the objects. How images are placed in documents affects the availability of the three different editors.

THE IMAGE EDITOR WINDOW

The Image Editor window is where you perform touchup of raster or bit images. You can obtain a raster image from many sources: from your scanner, from a Kodak Photo CD, clip art, and even your faxes. If you have access to a scanned image, you may want to use it for this chapter as we work with the Image Editor. If you don't have access, there is an image included on the companion diskette.

You can create the image on your desktop by choosing File→New→Inside Interleaf→Graphics→photo. When you do, you'll see a distinctive icon with a very famous lady on it (see Figure 16-1). You'll also see the letters TIFF on the icon. This stands for Tagged Image File Format and is a standard format used for raster images. Interleaf 6 will automatically convert
this file format into its own file format when you use the image. This image will be used throughout this chapter.

When you double-click on the TIFF file, Interleaf 6 converts the image and then opens the Image Editor.

The author in his younger days.

**Figure 16-1.** Creating the included image on your Desktop

You can open the Image Editor in one of two ways: paste the image into a frame and double-click on the image, or double-click the icon and edit the image file right on the Desktop. Later, we'll see how to work with the Image Editor when the image is inside a document. For now, let's work with the image file on the Desktop. So, double-click on the image. After Interleaf 6 converts the file, it will open the Image Editor. The Image Editor window can be seen in Figure 16-2.

**Note** The Image Editor window will have different menu commands available to you, depending on which of the three editors is being used.

**Using the Picture Editor to Edit an Image**

Because this image has been opened as a file on the Desktop—instead of being opened from within a document—only the Picture Editor is available, and you're working with the Picture Editor window. Before actually editing the image, let's get acquainted with the Picture Editor window. As you can see in Figure 16-2, the Picture Editor displays the image in the
main part of the window. There are two scroll bars for adjusting the portion of the image displayed in the window. On the left side of the window, you’ll find the tool palette of the Picture Editor. At the top of the window, you’ll find menu commands for saving and loading images, simple editing, and adjusting the view within the window. Finally, at the bottom of the window you’ll see information about the image: the dimensions of the image in pixels, and the number of bits per pixel—which is another way of saying how many colors are in the image. Let’s spend a little time manipulating the image and see how this might make it easier to perform editing operations.

![Image Editor window](image.png)

**Figure 16-2.** The Image Editor window

**Manipulating the View of an Image**

Unlike a conventional artist’s canvas, the Picture Editor allows you to zoom in on the image and then scroll to different parts of the image. This allows you to concentrate on specific areas—even specific pixels—of the image. You can also rotate the image you’re editing by 90-degree increments to assist you with editing.
Zooming In for a Better View

Since an image is made up of very small pixels, you may find it difficult to edit fine detail unless you zoom in on the image. Zooming in on the image will make the pixels larger, and at the same time display less of the overall image in the Picture Editor window. To zoom in on an image, you can use the View→Zoom menu. The Zoom submenu gives you the option of zooming to a specific percentage, resetting the zoom, toggling from one zoom setting to another and back again, or making the image larger or smaller in predefined increments.

You can also use the Zoom Tool from the Picture Editor tool palette to zoom an image. To use the tool, select it in the tool palette. Now, position the mouse cursor within the image and click the left button. The magnifi-
cation of the image will be doubled and the point over which the mouse cursor was visible will be centered in the new view of the image (see Figure 16–3). Each time you click the left button, the image magnification will double. To decrease the magnification, click on both buttons at the same time (or use the middle button if your mouse has one).

**Scrolling to Different Areas of an Image**

Now that you have zoomed into the image, you may need to scroll to another part of the image that isn't displayed. The scroll bars make this very easy to do. Just position the mouse in the scroll bar and click the left button (see Figure 16–4). These scroll bars work like other scroll bars within Interleaf 6—when you click on an arrow, you scroll a small amount in that direction; when you click in the scroll bar, you scroll a large amount in that direction; and when you drag the scroll elevator, you scroll to the position of the elevator. After you have had some fun scrolling around the image, reset the zoom to 100%.

![Scrolling to different parts of an image](image)

**Figure 16–4.** Scrolling to different parts of an image

**Deleting Unwanted Parts of an Image**

Now that you have seen how to zoom and move around an image, it's time to start editing. The first thing you might want to do to an image is get rid of those parts of the image that you don't want. The main reason for getting rid of the unwanted parts of an image (besides deleting unnecessary detail) is that raster images take up a lot of disk space and computer memory. Getting rid of the unwanted parts of an image will free up disk space and make your document open and save faster.
Getting rid of unwanted parts of an image is called cropping. Cropping allows you to remove horizontal and vertical regions of an image. These regions occur along the four edges of the image. It's like taking out your scissors and cutting straight lines along the edges of your photographs. To get rid of unwanted parts of an image, you use the Crop Tool.

**Tip** Before cropping an image, size the Picture Editor window to its full size, or scroll the image so that you can view the edge, or corner, of the image you are trying to crop. With the Picture Editor window at full size, and the magnification at 100%, you can perform coarse cropping. To perform fine cropping, zoom the image so you can get a closer view of the exact pixels you are cropping.

To use the Crop Tool, click on its button in the tool palette. Now, position the mouse cursor in the image and click the left button. If the cursor is close to the corner of the image, the image will be cropped both horizontally and vertically. Everything from the cursor to the edge (or edges) of the image will be deleted. If you hold the mouse button down, you can drag the crop line (or lines) to where you want them. When you release the button, the image will be cropped at the final location of the mouse cursor (see Figure 16-5).

If you make a mistake, you can choose Edit→Undo on the menu to restore the image. After you have cropped the image to its final size, save the image. You can save the image using the File→Save or File→Save As...
menu command. Saving the image will allow you to use the **File → Revert to → Saved** command in the event you make a mistake while editing the image.

**Warning** The Crop Tool makes permanent changes to an image. If you need to use the full image at a later date, use the Frame Editor instead.

**Performing Image Touch Up**

You may want to use the Picture Editor to perform some touch up of the image. For example, you can paint to remove parts of an image or alter the image background. You can paint to cover up blemishes in the image—especially images that come from scanning very old photographs. Using the Picture Editor, you can add shadows and other effects to the image; you can even clone a portion of the image onto a different section of the image. All of this painting is done using the tools provided on the tool palette. Each of the tools use a brush and a paint color. Before examining the tools, let’s see how to change the brush and choose a paint color.

**Choosing a Brush**

In the Picture Editor window, the current brush is always displayed in the brush preview box. You can choose any one of 48 different brushes by clicking on the brush selection button (see Figure 16–6). Choose a larger brush to paint large areas of the image at a time. A smaller brush will allow

You can choose one of 48 different brushes: there are 8 different sizes and 6 different shapes. The default brush is round and 5 pixels in diameter.

Clicking on the brush preview button will toggle between the current brush and a one-pixel brush.

**Figure 16–6.** Choosing a brush
you to perform fine detail painting. When you open the Image Editor, the default brush is round and has a diameter of 5 pixels.

**Choosing a Color**

In the Picture Editor window, the current color is always displayed in the color preview box. You can choose a different color by clicking on the color preview button. In the Color Editor dialog box that opens, you can choose a value of gray for the gray scale image you're editing. When you're editing a monochrome image (each pixel is either white or black), you'll have a choice of only two colors: white or black. Color images will allow you to choose a color based on a color model. Figure 16–7 shows how to use the color palette to choose a color.

---

**Figure 16–7.** Choosing a color using the color editor
There is another way to choose a color to paint with—the Pickup Tool. The Pickup Tool allows you to choose a color by using the mouse. To use the Pickup Tool, click on its button in the tool palette. Position the mouse cursor over the desired color in the image and click the left mouse button. The selected color will be displayed in the color preview box. You can also hold down the left mouse button as you move the cursor over the image; the x and y location of the cursor will be shown along with the color value of the pixel (see Figure 16–8). There are two more tools that allow you to choose color, the Auto Pickup Tool and the Clone Tool. I’ll tell you about both of those tools shortly.

![Figure 16–8. Choosing a color using the Pickup Tool](image)

**Painting Over Parts of an Image**

Now that you’ve seen how to choose a brush and a color, it’s time to put them to work by painting over part of the image. I am going to choose black as my paint color and a small round brush. I want to put my name on the side of the building, so I am going to use the Paint Tool by clicking on it in the tool palette. Next, I’ll position the mouse cursor over the area of the image I want to paint. While holding down the left mouse button, I can paint with my selected color and brush. As long as the mouse button is held down, paint will be applied. When I release the mouse button, I can move my brush to a different area of the image and paint some more. You can see the result of my efforts in Figure 16–9.
Click on the Paint Tool.

Apply the current color using the current brush by pressing and holding the left mouse button as you move the mouse cursor. You can constrain the brush to either horizontal or vertical motion if you press the SHIFT key before you begin painting—motion will be limited to the direction you begin moving.

**Figure 16–9. Painting with the Paint Tool**

---

**Note** If you hold down both mouse buttons (or the middle button if you have one) while you paint, the color used will be the complement of the color shown in the color preview box.

---

**Undoing Changes**

As a child, I was never allowed to paint on the side of buildings or on walls. If I did, I would have been made to clean up my mess. Fortunately, I can use the Scraper Tool to undo the paint I just applied to the image—I wish I'd had it many years ago. To use the Scraper Tool, I click on it in the tool palette and then move the mouse cursor into the image window. I press and

**Figure 16–10. Scraping newly applied paint from an image**
hold the mouse button and scrape the cursor over the unwanted paint. Magically, the paint is removed and the image appears as it did before I painted on it (see Figure 16–10).

**Note** If you use the Scraper Tool while holding down both mouse buttons (or the middle button if you have one) the image will be scraped back to the original image. Using the left mouse button will only restore the image back to the previously saved image (or the last coat of paint applied).

**Picking Your Paint Color Automatically**

Earlier, I said that there were two other ways to pick the paint color. The first of those ways is to use the Auto-Pickup Tool. To use the Auto-Pickup Tool, click on its button in the tool palette. Now, position the mouse cursor over the area where you want to begin painting. When you press the left mouse button, the color under the cursor will become the active color (and be displayed in the color preview box). You will paint in this color until you release the mouse button. You can then begin painting in another area of the image. At that time, the color under the mouse cursor will become the active color for painting until you release the mouse again. The effects of using the Auto-Pickup Tool can be seen in Figure 16–11.

![Auto-Pickup Tool](Image)

When you begin painting, the color under the cursor becomes the brush color.

This area was painted with the mouse starting in this location. The dark color became the paint color and was painted into the other areas.

This area was painted starting in this light color.

*Figure 16–11. Painting with the Auto-Pickup Tool*
Cloning Part of an Image

The second alternative to choosing a paint color is to use the Clone Tool. Cloning doesn't just pick one color, but uses all of the colors found in the source area of an image. When you paint, the colors from the source area of the image are copied to the area you are painting—as the brush moves, the color of the brush changes—until the final result is that you copy or clone the source area into another area of the image. Cloning can be used to paint the background of an image over another object that you want to remove from the image. You can also have some fun with cloning, as I am about to show you.

To use the Clone Tool, click on its button in the tool palette. The first thing you have to do is select the source area of the image. Actually, selecting the source area means picking a point that serves as the starting point for copying colors. Next, you'll position the brush over the area you want to paint (keeping in mind the starting point of the source image) and begin painting. Figure 16-12 shows an area I cloned to another part of the image.

Other Picture Editor Tools

There are three other tools in the tool palette that I want to briefly describe. They are the Fill Tool, the Fade Tool, and the Blend Tool. The Fill Tool allows you to fill areas of the same color with the current color shown in the color preview box. When working with a gray scale image (especially a scan of a photograph), it is difficult to find large areas that are the same color, and so using the Fill Tool is not very effective. If you are working with an image that has fewer colors (like line art, or a monochrome image), then the Fill Tool will allow you to change the color of enclosed areas of the image more effectively than using the Paint Tool.

Note When filling or painting an image, only the visible area of the image is altered—paint and fill will not extend past the edge of the visible image. This keeps you from inadvertently painting over a part of the image you can't see. When using the Fill Tool, you'll have to make the Picture Editor window large enough to display the entire area you want to fill, or fill an area and then scroll to another area and use the Fill Tool again.
Click on the Clone Tool.

The first thing you have to do is pick a source for cloning. Here, the bottom center of the pumpkin is chosen as the source.

Now, position the brush where you want to paint a copy of the source. Here, the painting was started at the middle of the neck. As the brush is painted left and right in an upward motion, the pumpkin is painted on the image.

The finished masterpiece.

**Figure 16-12. Using the Clone Tool**

The Fade Tool allows you to fade the areas you are painting to lighter or darker colors. To fade lighter, position the mouse cursor over the image and begin painting by pressing the left mouse button. To fade darker, position the mouse cursor over the image and begin painting using both mouse buttons (or the middle button if your mouse has one). The amount of fading depends on the size of the brush you use and the number of passes you make over the area of the image. Use fading to adjust the brightness or darkness of a portion of an image. If you want to adjust the brightness of the image as a whole, you can use the Contrast Editor.
The Blend Tool allows you to blend the colors of each pixel to more closely match the surrounding pixels. The Blend Tool is useful if you want to remove sharp edges (or dramatic changes in color) from an image. To use the Blend Tool, click on its button in the tool palette, position the cursor in the image window, and begin painting with the brush. As you pass over each pixel, the Picture Editor will change the color of the pixel to the average of the pixel's current color and the colors of its neighboring pixels. If you use the Blend Tool over and over in the same area, all of the pixels will eventually change to the same color. (It's a lot like mixing different colors of paint—the resulting color is a blend of the original colors.)

You have now seen the many different ways of using the Picture Editor. The Image Editor consists of two additional editors that are not available at this time because the image you are editing is a file on the Desktop. To gain access to the other editors, you'll have to paste a copy of the image into a frame in a document. Open a ScratchPad document and paste a copy of the image in the frame. Double-click on the image to open the Image Editor. You now have access to the other two editors: the Frame Editor and the Contrast Editor.

**Using the Frame Editor to Display Part of an Image**

Now that the image you are working on is actually in a frame (and not on the Desktop) you have access to the other two editors. Currently, the Image Editor window shows the Picture Editor. You may have noticed that a new control is located above the tool palette. This control allows you to switch
between the three different editors that make up the Image Editor. Change to the Frame Editor by using this control (see Figure 16-13).

**Framing Part of an Image**

When you switch to the Frame Editor, no tools are displayed in the tool palette (see Figure 16-14). In the Frame Editor, you are here to do one thing, and one thing only—frame the image. By *frame an image*, I mean that you decide what rectangular region of the overall image to display. “Wait a minute,” you say. “I already know how to do that. I use the Crop Tool that I just read about.” Yes, you can use the Crop Tool to delete all unwanted parts of an image and leave only what you want to display. However, once you use the Crop Tool to delete part of an image, you can never get it back. If, on the other hand, you use the Frame Editor to frame the image, you can always get to the other unused parts of the image and display them somewhere else in your document. If you’re not sure how you can use this to your advantage, I describe a situation where using the Frame Editor is not only a more useful alternative than the Crop Tool, but the only alternative. First, let’s see how to use the Frame Editor.

The Frame Editor works in much the same way as the Crop Tool: you position the mouse cursor near an edge of an image and press the mouse button. As you drag the mouse cursor, both horizontal and vertical lines are adjusted to show the extent of the image that will be displayed (see Figure 16-14).

![Image of frame editor usage](image)

*Figure 16-14. Using the Frame Editor to frame an image*
When you’re working with the Frame Editor, the entire image starts off being displayed in the window, and you have no need for scroll bars. If you want to increase the size of the image, you’ll have to increase the size of the Image Editor window (there is no Zoom Tool).

**Moving a Frame to a Different Part of an Image**

You can change the part of an image displayed in the frame without resizing the frame by dragging the frame around the image. To drag the frame around the image, position the mouse cursor near the center of the frame. Press and hold the left mouse button while moving the mouse (see Figure 16–15). When a new section of the image is within the frame, release the mouse button.

**Tip** Whenever possible, you should use the Crop Tool to remove the unwanted parts of an image. Don’t use the Frame Editor to perform this task. Remember, the Frame Editor doesn’t remove the image data—it just hides it from view. Use the Frame Editor when there are other parts of the image that you want to save for display at some other time or in another part of your document.

![Figure 16–15. Changing the image under the frame](image)

Of course, you can resize the frame to any size you wish and display more or less of the image. This is possible because you haven’t removed any of the image data with the Frame Editor. If you need to resize the frame to the
size of the original image, choose **Edit**→**Whole Image** on the Image Editor window to do the job quickly.

**Using the Contrast Editor to Adjust Image Colors**

The final editor in the Image Editor is the Contrast Editor. As the name implies, you use the Contrast Editor to adjust the contrast within an image. Actually, you can do more than adjust the contrast; I like to say you can adjust the colors in an image. Let’s first take a look at the Contrast Editor window, and then see how to use it to adjust the displayed colors in an image.

**The Contrast Editor Window**

The Contrast Editor window displays a few tools in the tool palette, a color mapping curve, and a preview of the image with the current mapping curve applied (see Figure 16–16). The color mapping curve—I’m using curve in the strict mathematical sense of the word—begins as a straight line at 45 degrees. This initial curve represents the identity function because it performs the function of mapping a color found in the image (which is read along the horizontal axis) to the same color displayed in the document (which is read along the vertical axis).

**Tip** A simple technique for reading the color map is to begin with the horizontal axis (the colors in the image). Find an image color and draw a vertical line from it until it intersects with the color map curve. At the point of intersection, draw a horizontal line until it intersects the vertical axis (the colors in the document). The intersection with the vertical axis shows the color used to display the image in the document.

**Changing Contrast**

The initial color mapping curve has only two endpoints; therefore, it is a straight line. With the Selection Tool, you can select either of the endpoints and drag the point to a new location. The more horizontal the line becomes, the less contrast there will be in the image. The closer to vertical you can make the curve, the greater the contrast in the image. In order to make the curve more vertical, you’ll need to add more points to the curve.
Image Preview

Color Map Curve shows the relationship between colors in the image and colors used to display the image in the document.

**Figure 16-16.** The Contrast Editor window

**Adding a Point**

To add a point to the curve, click on the Add Point Tool. Position the mouse cursor within the color map square and click the left mouse button. A new point will be added that you can then drag to a different area of the square.

**Figure 16-17.** Adding a point to the color map
(see Figure 16–17). Release the mouse button to drop the point in its new location. The preview of the image will show the result of the new color map curve.

**Easy Special Effects with the Contrast Editor**

There are a few other buttons within the Contrast Editor window. These buttons allow you to quickly adjust the color map curve. One of the but-

To invert the current color map curve, click on the Invert button. If you begin with the identity map, you get a "negative" of the image.

To reduce the number of colors displayed, click on one of the predefined posterizing buttons. You can then modify the image further by moving the interior points on the curve.

![Image](image.png)

**Figure 16–18.** Different contrast settings
tons will reset the map back to the identity function (the button has a single 45-degree line on it that looks like the identity function). Another button will create an inverse of the current color map. If you begin with the identity function and then use the invert button, you’ll display an image that looks like a negative of the original (see Figure 16–18). The other buttons provide default maps for reducing the number of colors in the image. Reducing the number of colors is a technique known as posterizing. One type of posterizing is to produce a two-color, or black and white, image. Figure 16–18 shows the use of the two-color button.

**Using Links to Images in a Document**

Finally, we’ll end this chapter on images by discussing another method for including images in your document—using file links. First, we’ll create a link, and then we’ll look at some of the advantages and disadvantages of using them.

**Creating a Link**

Creating a link to an image is easy—select the image icon on the Desktop and choose Edit→Link from the Desktop menu. In an open frame, paste the link. Interleaf 6 will ask you to choose how you want the image pasted: Link to paste the link, or Copy to paste a copy of the image. Choose Link to complete the operation (see Figure 16–19).

![Creating a link to an image file](image.png)

**Figure 16–19.** Creating a link to an image file

**Link Effects on the Image Editor**

When you open the Image Editor for the image, you’ll see that you no longer have access to the Picture Editor. Access to the Picture Editor is
removed because the image you are using may be used by someone else in another document. You do have access to the Frame Editor and the Contrast Editor so that you can perform adjustments specific to your document. For example, you may not want to display all of the original image, so use the Frame Editor to hide the unwanted portions of the image. If you need to change the content of the image, you'll have to find the image icon and perform your edits directly on the file using the Picture Editor.

When you paste a link to an image, you only have access to the Frame Editor and the Contrast Editor.

Figure 16–20. Linked images limit choice of editors

Pitfalls of Using Links

The main reason for using links is that you can save disk space when the image is used in more than one document. But this efficiency of storage can be offset with some rather nasty pitfalls of using links. To understand the problems with links, it's necessary to understand how a link works.

How a Link Works

When you create a link, the original image is left as a file on the disk. What you paste into a document is a screen representation of the link. This screen representation is what you use to position the image within the document. When it is time to print the document, the original image file is read and included as part of the print job sent to the printer. Thus, you can save on disk space without sacrificing print quality.

Since most displays range from 72 to 90 dots per inch, and most scanned images will be 200 dots per inch or greater, the potential for saving disk space is great when you use more than one link to the image. The more times the image is used, the greater the disk savings over copying the image into each document.
Missing Links

The drawback to using a link is what happens when the image file is deleted, renamed, or moved. When any of the above occurs to the image file, you won’t know you have a problem until you try to use the Image Editor to adjust the frame or contrast of the image, or you try to print the document. If you try to edit the image in the document, Interleaf 6 will present you with the warning shown in Figure 16–21. When you try to print the document, a Mona Lisa image is substituted for your image. Once you replace the missing image file, everything will return to normal.

Don’t let these drawbacks frighten you from using links. Links can be quite valuable for the storage savings they provide. You also gain the added benefit of changing all occurrences of an image by editing a single image file. If you plan on using links, just keep the drawbacks in mind when you decide where you’re going to store them. It’s easy to move the image files to a different directory on your hard disk, but it is a big task to update all of the documents where links to these images occur.

If you try to edit a linked image whose image file has been deleted, renamed, or moved, you’ll receive a warning.

Figure 16–21. Warning message associated with using linked images

Note To help you maintain the integrity of your linked images, Interleaf 6 won’t let you delete, cut, or rename a linked image. Make sure you organize the images before you link them into documents.

Summary

In this chapter, you learned how to use the three editors of the Image Editor to manipulate raster images. You also saw how you could use a link to an image in a document. In the next chapter, you’ll round out your knowledge of graphic objects when you learn how to use charts and equations in a document.
CHAPTER 17

Creating Charts and Equations

This chapter describes the chart and equation editors included in Interleaf 6. You'll get a chance to create a couple of simple charts and a couple of equations (one of the equations is not so simple). When you have finished with this chapter, you'll have gotten a glimpse at these two different editors and how they can help you create very professional charts and typeset the most complicated of mathematical expressions.

THE CHART EDITOR

If you need to use charts to illustrate concepts in your documentation, you are in luck. Interleaf 6 contains a very powerful charting capability in its Chart Editor. The Chart Editor allows you to create data-driven charts. Data-driven means that the boxes, lines, and circles that form a chart are based upon numerical data, and, when you change the data, the chart will change to reflect the new data.

Creating a Chart

Since a chart is a graphic object, you need to be in an open frame in order to create one. Create a ScratchPad document on your desktop (File→
New→ScratchPad) and open it. Create a chart by using the Chart Tool but­
tton on the Drawing Palette or by choosing Create→Chart from the menu. In
either case, position the mouse cursor in the frame and click and drag
until you have outlined the size of the chart. When you release the mouse
button, Interleaf 6 will create a default chart (see Figure 17–1).

Choose Create→Chart
from the document menu
and Interleaf 6 will
create a default chart.

You can position the
chart anywhere within a
frame, and size it like
other graphic objects by
dragging the handles.

Figure 17–1. Creating a chart

Now that you have a chart, you’ll need to edit it so that it contains the data
and properties you want it to have. Charts are edited using the Chart Edi­
tor. The Chart Editor consists of two main interfaces: the Chart Data and
Chart Properties dialog boxes. To open the Chart Editor, double-click on
the chart.

The Chart Data Dialog Box

When you open the Chart Editor, the Chart Editor will open the Chart Data
dialog box. It is through this dialog box that you tell the Chart Editor what
data you want displayed in the chart. The layout of the Chart Data dialog
box will change slightly depending on the type of chart being displayed.
Bar and pie charts allow you to enter a label for each set of points and a
single data value for each point. If a line chart is being used, you’ll enter
data in an x, y format for each data point. Figure 17–2 shows the two differ­
ent types of formats for entering data.

Editing Chart Data

Within the Chart Data dialog box, you can change the amount of data pres­
ent in the chart and change the values of the chart data. Add another row
to the data by entering 4 in the Rows field and clicking Apply. The Chart
Editor will create a new row, and it will also change the chart in the frame to make room for the new data (see Figure 17–3). For bar charts, the first column is a text label for the data in the row. In the new row, type This is 95 as the label. Type in the following data in the other three columns: 75, 78, and 55. Now click Apply and the chart will be updated (see Figure 17–3).

The Chart Data dialog box is where you edit a chart’s data. If the type of chart is a bar or pie chart, the data you enter consists of one value for each data point.

You’ll have to enter two values for a line chart.

![Chart Data dialog box](image)

*Figure 17–2. Chart Data dialog box formats*

If you are using a chart type that has both an x and y value for each data point, you can use the Edit→Set Horizontal→Same Increment or Edit→Set Horizontal→Same Value to set the x values for each column. To use the Edit→Set Horizontal→Same Increment command, enter x values in column 1 row 1 and column 1 row 2 (e.g., 3 and 5, respectively). When you choose Edit→Set Horizontal→Same Increment, each of the other rows will be incremented based on the difference of the first two rows. The values for all columns will be the same as the first column (see Figure 17–4). Edit→Set Horizontal→Same Values will copy the x values from column 1 to the other columns.
To add additional data to a chart, change the number of rows and columns. In this case, the number of rows was increased from 3 to 4. After the change is applied, the Chart Editor will adjust the chart to make room for the additional data.

Fill in the data and click Apply. The Chart Editor will draw the chart with the new data.

*Figure 17-3. Adding new chart data*

**Changing the Data Displayed in the Chart**

The check boxes along each row and column of data allow you to disable the data in the chart. When chart data is disabled, it is still saved as part of the chart, but it will no longer be displayed by the Chart Editor when the chart is drawn. For example, if the second column of data and the third row of data are disabled, their values become grayed out and the bars representing the data are removed from the chart (see Figure 17-5). In addition to disabling the display of data, disabling data can be handy when copying and pasting data in the Chart Data dialog box.
To quickly update the x values in a line chart, enter values in the first and second rows of the first column...

...then choose **Edit → Set Horizontal → Same Increment**...

...and the Chart Editor will fill in the values based on the difference of these two values.

**Figure 17-4.** Setting x values with commands

To disable chart data, turn off the appropriate check boxes.

When you click Apply, the Chart Editor will redraw the chart based on the active data.

**Figure 17-5.** Disabling chart data
Copying Data from the Chart Data Dialog Box

Now that you have all of this data in the Chart Data dialog box, you may decide that you want to use it in the text of your document, possibly as a table. The Edit→Copy and Edit→Copy Special... commands let you copy data from the Chart Data dialog box.

Choose Edit→Copy from the menu. The active chart data will be copied to the Clipboard. Now open a document and paste the contents of the Clipboard into the document. You'll see that the data is copied as tab delimited numbers (see Figure 17-6). At this point, you can use the Tables→Convert Text to Table... command to make a table from the text.

![Image of data copied from chart](chart-data.png)

If you choose Edit→Copy, the Chart Editor will copy the data as is.

If you use Edit→Copy Special..., you can tell the Chart Editor to transpose the data as it is copied.

![Image of copy special options](copy-special.png)

When you paste the data, the values are transposed.

![Image of transposed data](transposed-data.png)

**Figure 17-6.** Copying data from a chart

If you use the Edit→Copy Special... command, you can choose how you want the data copied. Turn on the Transposed option in the Copy Special... dialog box and click Copy. When you paste the data into another compo-
Warning If the number of rows and columns of data is not the same, copying transposed will have the effect of mixing row and column data.

Pasting Data

You can also paste data into the Chart Data dialog box. When you paste data into the dialog box, all active data cells will be overwritten. The data you paste into the dialog box can come from many sources: data from a spreadsheet, tabbed numerical data, and free flowing text. When you paste data from free flowing text, words are ignored, but all occurrences of numbers are used to fill in the chart data. To see how this might be used, type in the following text in a para component of a document (you can insert the hard returns by typing SHIFT-ENTER):

It was an uneventful night of bowling.
Tom bowled scores of 112, 123, and 148.
Amy bowled 185, 174, and 183;
while Andy bowled 168, 184, and 201.
Tony bowled better than the rest.
He had scores of 194, 222, and 235.

Note In order for the numerical data to paste into more than one row of the Chart Data dialog box, it must appear within separate components, or a hard return must separate the data. The sample text you type above requires a hard return to separate each set of three numbers.

Now, select the text and copy it. In the Chart Data dialog box, turn on all of the rows and columns. Now choose Edit→Paste from the menu. Change the labels for each row of data to Tom, Amy, Andy, and Tony. Now click Apply to redisplay the chart with new data (see Figure 17–7).

Tip You can also use the Edit menu to delete data from the chart. If you have disabled some of the data in the chart, choosing Edit→Delete→Unused Data will remove the disabled data. If you want to empty all of the data from the chart, choose Edit→Delete→All Data. The deleted data can't be recovered.
Copy text containing numerical data from your document. (If you want the data to span rows in your chart, it must come from separate components or be separated by hard returns.) Now, in the Chart Data dialog box, choose **Edit → Paste** to paste the numerical data into the chart.

Change the label for each row and then click **Apply** to cause the Chart Editor to redraw the chart.

**Figure 17-7.** Pasting data into a chart

**Editing Chart Properties**

Now that you have seen various ways to edit the data of a chart, it’s time to see how to modify chart properties. Chart properties fall into four categories: style, layout, margins, and axis. These items are accessible from the Chart Data dialog box menu (see Figure 17-8).

**Style**

On the Style sheet of the Chart Properties dialog box, you choose the type of chart to display. There are three basic types of charts: bar charts, line charts, and pie charts. As you change the chart type from one of these basic types to another, the style sheet changes to reflect properties associated with that style. For example, when you choose a line chart, you will have the ability to set the line fill (color and dashes), point style, and line weight (see Figure 17-9). In addition, you can specify whether the line chart is a stacked line chart (each data point is drawn relative to the corresponding data point in the previous line) and whether to display a marker at each data point. Similar properties can be set for bar charts (see Figure 17-8) or pie charts.
On the Style sheet of the Chart Properties dialog box (which you access by choosing Properties → Style... from the Chart Data dialog box) you can choose the type of chart to create.

As you change the chart type, the bottom of the dialog box will change to reflect properties specific to the chart type. Here is a Style sheet for a bar chart.

Figure 17-8. Accessing chart properties

Here is the Style sheet for a line chart. You can set the properties of each line in the chart, and determine if the lines are stacked (or summed together). You can also turn on or off the display of a point at each data point.

Figure 17-9. Line chart style properties
**Tip** To create a scatter plot, use a line chart. On the Style sheet, turn on Line Points Visible and turn off the display of the line edges (using the Fill button).

**Layout**

The Layout sheet allows you to set properties that relate to the grid and axes used to draw a chart (see Figure 17-10). You can specify the grid weight and location, display of an origin line (the origin has a value of zero), display of a border around the data, and display of major and minor hash marks. You can also control the location of the axes used to draw the chart. Whether or not these properties are active depends on the type of chart being created.

![Figure 17-10. Grid and axes layout](image17-10.png)

**Margins**

On the Margins sheet, you can adjust the two types of margins in a chart: label margins and data margins (see Figure 17-11). A label margin is the space that occurs between a label and the data border. There are three label margins corresponding to the three label positions: left or right side of
the data and at the bottom of the data. Increasing these numbers will put more space between the labels and the data border. A data margin is the amount of space between the data border and the bounding box of the chart. This is the area where labels appear on the chart. Larger numerical values for labels, and larger font sizes, will require a larger data border so that the label is not clipped at the chart’s bounding box.

On the Margins sheet, you can adjust the margins of the chart. The label margins are found between a label and the data border. The data margins are the areas between the data border and the bounding box of the chart (shown as a dotted line).

![Chart Properties](image)

**Figure 17-11. Chart margin properties**

**Axis**

The final sheet of chart properties is the Axis sheet. On the axis sheet you can determine the scale to use for each axis as well as the numerical range of each axis (see Figure 17-12). For large valued data, you may wish to use a logarithmic scale. For range, you can allow the Chart Editor to determine the range automatically (the default), or you can set the values yourself.

**Note** A logarithmic axis is very handy in many situations. Data with a large range can tend to hide information. When you use a logarithmic axis, you can get a better view of the data—especially the data at the smaller end of the range. Figure 17-12 shows how the data can be brought out when a logarithmic axis is used.
Here are two charts with the same data. One chart uses a linear y-axis while the other uses a logarithmic y-axis.

**Figure 17-12. Chart axis properties**

**Creating a Bar Chart**

The best way to learn how to use the Chart Editor is to create a chart. Begin by creating a new chart. Open the Chart Editor. We're going to create a chart showing the income and expenses for an 8-month bowling season. So, change the number of rows to 8 (one for each month) and the number of columns to 2 (for income and expenses). For the labels of each row, type in the following: Aug, Sep, Oct, Nov, Dec, Jan, Feb, and Mar. Column 1 represents income. Type in the following amounts: 175, 400, 375, 425, 380, 400, 375, and 150. Column 2 represents expenses. Type in the following amounts: -145, -345, -150, -385, -325, -360, -450, and -115. Apply your changes and you should have a chart like the one shown in Figure 17-13. This chart shows the income and expenses as separate bars.
Creating an income and expense bar chart for an 8-month bowling season beginning in August. For this chart, we'll use a bar chart with 8 rows and 2 columns.

![Chart Data](image)

**Figure 17-13.** Creating an income and expense bar chart

**Force Bars to Overlap**

We would also like to see the net income for each month. You can use a couple of methods to display this information. The first method is to change the overlap of the bars so that the bars will be added together.

On the Styles sheet of the Chart Properties dialog box, there is a section relating to bar overlap. Use the spin buttons to set the value of overlap for both bars to 0. Now, Apply the changes. The Chart Editor will overlap the bars. By overlap, I mean that the bars for the second column of data start where the bars for the first column leave off. In the process, you can see the net income for each month represented by the portion of the income bar left exposed (see Figure 17-14).

An alternate method to show the net income is to use a superimposed line chart. You'll create the line chart in the next section.
To force the bars in a bar chart to overlap, set the overlap for each bar to an identical value. A value of zero will cause the bars to overlap without any horizontal offset. The top of each bar column represents the value of income. The expenses (represented by the black bars) are subtracted from the top of the income bars.

![Chart Properties dialog box](image)

**Figure 17-14.** Overlapping bars on a bar chart

### Creating a Line Chart

Change the bar overlap properties of the bar chart to their original values: −12 and −3, respectively. Click OK to apply the changes and close the Chart Properties dialog box. Close the Chart Editor. To create the line chart, copy the existing bar chart. Open the Chart Editor on this copy of the bar chart. On the Style sheet of the Chart Properties dialog box, change the chart type to a line chart. Turn on stacked line, and make the line for the income data invisible (see Figure 17-15).

### Entering Chart Data

Line charts have an x and y value for each data point. The data from the bar chart has been preserved as the y value for each data point. You'll need to supply an x value for each point. You can do this quickly by using the **Edit→Set Horizontal→Same Increment** command to fill in the x values. Before using the command, set the first x value of column 1 to 1 and the second x value of column 1 to 2. The rest of the x values in column 1 will be computed and all of column 1’s x values will be copied to the second column.
To create a stacked line chart to show the differences between income and expenses, change the chart type to line, and turn on the Stacked Lines property. To prevent the first line from being displayed, click on the fill box and set Visible to off.

Figure 17-15. Creating a stacked line chart

Manually Adjust Chart Axes

In order to superimpose this line chart on top of the bar chart, the axes on both charts must be the same range. Since the bar chart axes are okay in the present settings, you'll modify the axes of the line chart. On the Axis sheet of the Chart Properties dialog box, change the range to manual. Enter the following values: vertical minimum -500, vertical maximum 500, vertical interval 100, horizontal minimum 0.5, horizontal maximum 8.5, and horizontal increment 1 (see Figure 17-16). Click Apply. The vertical scale on the line chart now matches the bar chart. Since the bar chart has no horizontal scale, just about any value could be used for the horizontal increment—just be sure to set the minimum and maximum values so the data is spread evenly across the width of the chart.
To manually set the range of the axes in a chart, click on the Manual Range option on the Axis sheet. The value fields are now active and you can type in the desired values. When you have entered all the values, click Apply.

**Figure 17-16.** Manually setting the axis range on a chart

### Turn Off Labels and Data Borders

Finally, when the charts are overlapped, you don't want the labels or the data border from the line chart to interfere with the labels and data border of the bar chart. Therefore, turn these items off on the Layout sheet of the Chart Properties dialog box (see Figure 17-17). Apply your changes and close the Chart Editor.

### Superimpose Charts

You should now have two charts: the original bar chart, and a squiggly line that doesn't look like a chart at all. Now, select both charts and align their centers. You now have a chart that shows both income and expenses as a bar chart, and the net income as a line chart. This composite chart can be seen in Figure 17-18.
To turn off the display of labels, change to the Layout sheet. Under the section labeled Axes, click on the Major Labels Left (or Right) and Bottom properties to turn off labels. Click Apply to make your changes effective.

**Figure 17-17.** Turning chart labels off

**Figure 17-18.** Composite chart created from two superimposed charts

**Adding Titles and Legends to a Chart**

You may wish to add a title and a legend to the chart you have just created. These items aren’t automatically built into the chart, but you can use other Interleaf 6 objects to create them.
Using Other Objects for Title and Legends

For a title, you can use a microdocument. For a legend, you can use filled rectangles and microdocuments if you’re creating a bar chart, or lines and microdocuments for line charts. Modify the fill and edge properties of these items to create your legend.

Note  You can also use a copy of a chart to serve as a legend for the chart. Just change the data and other chart properties so that all of the different types of fill or lines are visible in the chart. Reduce the size the chart and turn off all labels, grids, and axes. Microdocuments can be used to provide the text of the legend.

Modifying Chart Font

You have already seen in an earlier chapter (Chapter 14) how to modify microdocument font properties. This will suffice for modifying the titles and legends you add to your chart but how do you modify the built-in labels on your chart? You accomplish this by selecting the chart and then modifying the text properties of the chart as a whole. Choose Properties→Selection... or Properties→Text... to open the Text Properties dialog box. Change the text properties to the properties you want applied to the chart and then click Apply. If the font becomes too large for the labels to fit within the data border of the chart, you’ll have to revisit the Chart Properties dialog box and increase the appropriate data border.

Tip  If you must change the font properties of part of a chart, you’ll have to use other drawing elements to accomplish the task. For example, if you want to highlight a single value on an axis by making the font italic or a point or two larger, you can create a microdocument with the value and the desired font properties to place over the existing chart value. To keep the existing value from showing through, you can turn on the fill of the microdocument.

Using Predefined Chart Templates

The last point I want to make about Interleaf 6 charts is that you don’t have to create them from scratch each time. In the System6 cabinet you’ll find a Samples drawer. Inside the Samples drawer is a document named All_Charts. Open the All_Charts document and you’ll see a few pages with
many different types of charts with many combinations of chart properties (see Figure 17–19). Find the one that is appropriate for the chart you want to create and copy it. Add your own data, and you have a very professional chart with very little effort on your part.

Open the document and find the style of chart you want to create. Select the chart, copy it, and paste it into your own document. Change the data to your specific data, and you have a professional chart with almost no work at all!

Figure 17–19. Predefined charts in the Samples drawer
THE EQUATION EDITOR

In addition to using the Chart Editor to create sophisticated charts, you can use the Equation Editor that comes with Interleaf 6 to create some very complicated equations. To start the Equation Editor, click on the Equation Tool button on the Drawing palette, or choose Create→Equation from the menu. In either case, click the mouse in the frame to create an equation. A default equation will be created: $\sqrt{a^2}$. You can modify the equation with the Equation Editor. Open the Equation Editor by double-clicking on the equation (see Figure 17-20).

After you have created an equation, double-click on the equation to open the Equation Editor.

Figure 17-20. Opening the Equation Editor

The Equation Editor Dialog Box

The Equation Editor window (shown in Figure 17-20) consists of three areas. At the top of the dialog box is an area that provides push button access to the symbols, operators, relations, functions, and levels that are used in the language of mathematics (see Figure 17-21). Clicking on one
of these buttons will create the corresponding equation keyword in the batch editing window, which is the second area of the dialog box. In the batch editing window, you can type in the keywords that will be used to build the equation. You can select all or portions of the equation text in the window and Cut, Copy, or Paste the equation text. When you click on the Preview button, the Equation Editor will draw the equation in the third area of the dialog box, the preview window.

The top of the Equation Editor dialog box provides push button access to many different mathematical symbols, operators, relations, functions, and levels.

Figure 17-21. Various mathematical symbols, operators, relations, functions, and levels in the Equation Editor

The Language of the Equation Editor

The equation editor uses a language that is very similar to the eqn language. If you are familiar with eqn, you should feel right at home with the Equation Editor. You simply type the keywords, separated by spaces, that represent your equation and let the Equation Editor create the equation for you. You can group portions of the equation using curly braces { } to make it easier for you to see what is going on or to explicitly determine the
grouping of terms. For example, you can enter Einstein's famous equation by typing $e = mc^2$, or $e = m \{c\}^2$, where $sup$ stands for superscript. Each will be interpreted the same way and will be displayed as $e = mc^2$.

**Editing an Equation**

The best way to learn the Equation Editor is to use it. So, let's create a couple of equations. Create an equation and open the Equation Editor. Select all of the text in the batch editing window. When you begin typing the new equation, the Equation Editor will replace the selected text. We'll begin with the equation $ax^2 + bx + c = 0$. This equation is entered by typing $ax^{sup\;2} + bx + c = 0$. (Instead of typing the word plus, you can position the insertion point where you want the plus sign to occur and click on the appropriate button on the operators sheet.) Click on Preview to see what the equation will look like (see Figure 17–22). When you are satisfied with the results, click on Apply (or OK to close the Equation Editor dialog box).

![Equation Editor - text (modified)](image)

Type in the keywords that constitute an equation and then click the Preview button to see how it will appear. When you are happy with the equation's appearance, click Apply to update the equation within the frame.

**Figure 17–22.** Entering an equation
Now let’s create a more complicated equation related to the first equation. We are going to create the equation that solves for the roots of the first equation. The roots of the first equation are found by

\[ x = \frac{-b \pm \sqrt{b^2 - 4ac}}{2a} \]

What makes this equation more complicated is that we have to explicitly tell the Equation Editor how to group some of the terms so that the fraction and the square root show up correctly. We do this by using the curly braces. The text for this equation is given by \( x = \{ \text{minus} \ b \pm \sqrt{b^2 - 4ac} \} \over \{ 2 \ a \}. \) To represent a fraction, use the word \text{over} between the numerator and the denominator. Since the numerator and denominator are not simple terms, braces are required to group the terms. The square root symbol is given by \text{sqrt} and requires braces around the terms so the the square root is properly applied. Edit the equation text. Preview the equation, and when satisfied with the result, click Apply (see Figure 17–23).

Here is a slightly more complicated equation. Use braces \{ \} to keep the parts of the equation (numerator and denominator) together.

\[ x = \{ \text{minus} \ b \pm \sqrt{b^2 - 4ac} \} \over \{ 2 \ a \} \]

Figure 17–23. Creating a more complicated equation
Changing the Font Size of an Equation

If you find it necessary to increase the size of the font used to display the equation, select the equation and choose Properties→Selection... from the document menu. On the Text Properties dialog box that appears, you can change the size of the font used in the equation. After you have made your changes, click Apply (see Figure 17-24).

Select an equation and choose Properties→Selection... to access the Text Properties dialog box. Change the point size of the font and click Apply to increase the font size of the equation as a whole.

\[ ax^2 + bx + c = 0 \]

\[ x = \frac{-b \pm \sqrt{b^2 - 4ac}}{2a} \]

Figure 17-24. Changing the font size of an equation

You are not limited to changing the font size of the equation as a whole—you can change the font size of part of the equation. To change just part of the equation, use the size keyword, followed by an absolute point size, or a delta point size (be sure to use a + or a – before the point size), and the argument you want increased. For example, in the first equation above, change the font size of the first x to 4 points more than the default by placing size +12 in front of the x and click Preview. A different result will be obtained by placing size +12 in front of \(x\ sup\ 2\) since the contents of the brackets are seen as the argument to the size keyword (see Figure 17-25).
When you have more than one equation in a frame, you will probably want to line them up over one another along an equals sign that appears in each equation. You saw in an earlier chapter (Chapter 15) how to use the Alignment button on the Commands palette to align objects. This command is good for aligning other objects on their left or right sides, but this will not work with equations because the equals sign can appear anywhere within the equation. You could try moving the equations manually to visually align the equations. This might work for two equations, but is inefficient for three or more equations. So, what should you do? Well, if you use the \texttt{mark} keyword in your equations, then Interleaf 6 can determine where you want the equations aligned when you use the Alignment button.

To use the \texttt{mark} keyword, edit each equation and place the keyword to the left of the equals sign (see Figure 17–26). Now, select both equations and
align the equations using the Alignment Left/Right Center command button. Interleaf 6 will align the equations at the mark you set in the Equation Editor.

To line up more than one equation, add the mark keyword to each equation. The two equations we have been working with have the keyword added before the equals sign.

Select both equations and align their Left/Right Centers using the Command Palette.

The equations will be lined up along the equals sign.

\[ ax^2 + bx + c = 0 \]
\[ x = \frac{-b \pm \sqrt{b^2 - 4ac}}{2a} \]

**Figure 17-26.** Aligning equations with the mark keyword

**Equation Keywords Reference**

That's it for equations in this chapter. We'll only scratched the surface with the many different types of equations you can create. For a complete reference to the keywords available in the Equation Editor, see Interleaf 6's online help.

**Summary**

In this chapter you learned about Interleaf 6's Chart Editor and Equation Editor. These two editors will allow you to build charts and equations that display almost any type of numerical data and the equations used to generate them. This chapter has completed this part of the book on Interleaf 6 graphics and brings to a close this book on Interleaf 6. You are now equipped to use the most powerful publishing software available for Windows or Motif. Begin publishing with an attitude!
APPENDIX A

The Companion Document Template

This appendix describes a document template used in the examples throughout this book. The document template is used for building a software user guide. You will be presented with a reference guide describing the objects in the template. You may use this template as is or as a starting point for your own documentation.

USER GUIDE TEMPLATE REFERENCE

Think of this appendix as the closet supply catalog I spoke of earlier—it contains descriptions of the different hangers available for organizing your information closet.

Template Structure

At the top level, the User Guide contains a MASTER binder, as well as Front, Body, and Rear sub-books (see Figure A–1).
The MASTER binder is a special container that holds Network Style Sheets. It contains two Network Style Sheets: data for controlling information common to the entire User Guide template, and style for controlling the properties—such as fonts, margins, or content—of the different objects used in the template. Figure A-2 shows the contents of the MASTER binder.

The Front sub-book holds the front matter of the User Guide. There is a title page (Title document), table of contents (TOC sub-book), and a preface (Preface document). Figure A-2 shows the contents of the Front sub-book.

The Body sub-book holds the main material of the User Guide. Body contains a single sub-book named Part. Part is provided so you can separate the User Guide into parts, or sections. As you add more sections to your documentation, you'll add more Part sub-books. Part contains a style sheet for part data, a title, and a chapter. As you add more chapters, you'll add more Chapter sub-books. Chapter contains two documents: start for starting a chapter, and cont for additional documents that make up a chapter. Figure A-2 shows all of the contents of the Body sub-book.

The Rear sub-book holds the back matter of the User Guide. Rear contains a glossary (glossary document and its controlling style sheet) and an index (index document and its controlling style sheet). Figure A-2 shows the contents of the Rear sub-book.
Figure A-2. Desktop objects in User Guide template
MASTER Objects

Now that the top-level structure of the User Guide has been covered, it's time to concentrate on the objects used to create text and graphics on a page. This section will present the different objects used in the template, giving the name of the object and a description of its intended use. So you can see what each object looks like, examples will also be shown for each. If you wish to follow along, open a start document.

The objects fall into the following general categories: headings and titles, paragraphs, lists, footnotes, emphasized text, figures, tables, and code reference.

Headings and Titles

Headings and title are used to separate the User Guide into groups of related information. The objects used for identifying a User Guide part are listed below and shown in Figure A-3.

**h:part**  Heading for a part within the User Guide. Provides automatic numbering of parts. Marked for inclusion in the table of contents.

**title:part**  Used within h:part as an inline component for control of the text that is the part title. Appears as the running head on left-hand pages.

*Figure A-3. Heading and title for User Guide part*
Headings and titles related to chapters, and the chapter body, are listed below and shown in Figure A-4.

**h:chapter** Heading for a chapter within the *User Guide.* Provides automatic numbering of chapters. Marked for inclusion in the table of contents.

**title:chap** Used within **h:chapter** as an inline component for control of the text that is the chapter title. Appears in the running head on right-hand pages as a reference in variable content components.

**h:0** Used within both **h:part** and **h:chapter** as an inline component for control of text formatting only.

**h:1** First level heading within a chapter. Used to highlight a main topic within a chapter. Provides automatic number of main topics. Marked for inclusion in table of contents.

**h:2** Second level heading within a chapter. Used to highlight a subtopic within a chapter. Provides automatic number of subtopics. Marked for inclusion in table of contents.

The following titles are used in equations, figures, and tables. They're not intended to be used alone, but as a part of the figures and tables. You can see their formatting in Figures A–8 and A–9 where figures and tables, respectively, are shown.

**title:equ** Provides automatic numbering of equations.


**title:tbl** Used for titling tables. Provides automatic numbering of tables. Marked for inclusion in the list of tables file.
Paragraphs

Paragraphs are used for the main text of the User Guide. The different types of paragraphs are listed below and shown in Figure A-4.

**p:0**  
Used for main paragraphs.

**p:1**  
Used for sub-paragraphs.

*Figure A-4. Chapter title, headings, and paragraphs*
Lists

There are four types of list objects in the User Guide template. These four types are listed below and shown in Figure A-5.

**list:bullet**  
Used for lists where each item begins with a bullet. The bullet is created automatically.

**list:check**  
Used for lists where each item begins with a check box. The check box is created automatically.

**list:num**  
Used for lists where each item is numbered sequentially. The numbers are created automatically.

**list:num**  
Special version of **list:num** that automatically restarts the number in the list.

**list:alpha**  
Used for lists where each item begins with a letter of the alphabet. The letters are created automatically.

**list:alpha**  
Special version of **list:alpha** that automatically restarts the letter in the list.

---

Figure A-5. Different types of lists
Footnotes

The User Guide template has numbered and unnumbered footnotes. These footnotes are described below and shown in Figure A-6.

**numbered**  Used for creating numbered footnotes at the bottom of a page.

**unnumbered**  Used for creating unnumbered footnotes at the bottom of a page.

![Figure A-6. Different types of footnotes](image)

Emphasized Text

The template has objects for emphasized text. These objects are described below and shown in Figure A-7.

**emp:function**  Used to add emphasis to text that corresponds to the name of a function.

**emp:user**  Used to add emphasis to text that corresponds to something typed by a user.

**emp:variable**  Used to add emphasis to text that corresponds to a program variable.

![Figure A-7. Different types of emphasized text](image)
Figures

Four basic figure objects are used in the template. These figures are described below and shown in Figure A-8.

**figure:num** Used for creating numbered figures.

**figure:equ** Used for creating equations.

**figure:note** Used for creating notes to the reader. A note calls out important information for the reader.

**figure:warn** Used for creating warnings to the reader. Similar to a note, but the importance of the information is greater than information in a note.

![Different types of figures](image-url)
Tables

Two table types are defined in the *User Guide*. These tables are described below and shown in Figure A-9.

**TABLE NAME:** field-desc

**PURPOSE:** Used for creating a simple, two-column, unnumbered table. The first column contains the field value, and the second column contains a description of the field’s value.

**CELLS IN TABLE:**
- **field**: Used for creating text in the left column.
- **desc**: Used for creating text in the right column.

**TABLE NAME:** 2col

**PURPOSE:** Used for creating a simple, two-column, numbered table. The table contains title and heading rows, followed by a table body.

**CELLS IN TABLE:**
- **heading**: Used for creating text in the heads row.
- **cell**: Used for creating text in all rows except heads and title.

---

*Figure A-9. Different types of tables*
### Code Reference

Because this is a *User Guide* about software, a special set of objects have been provided for documenting functions. The objects used are described below and shown in Figure A–10.

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>rule:a</code></td>
<td>Used for creating a rule at the beginning of a function definition.</td>
</tr>
<tr>
<td><code>function</code></td>
<td>Used for identifying a function name.</td>
</tr>
<tr>
<td><code>rule:b</code></td>
<td>Used for creating a rule internal to a function definition.</td>
</tr>
<tr>
<td><code>prototype</code></td>
<td>Used for displaying a function prototype. A prototype describes the arguments passed and value returned from a function.</td>
</tr>
<tr>
<td><code>text</code></td>
<td>Used for displaying software instructions, contents of files, or computer terminal displays. Uses a monospaced font.</td>
</tr>
<tr>
<td><code>header</code></td>
<td>Used for identifying the source code header files required for the proper operation of a function.</td>
</tr>
<tr>
<td><code>p:0</code></td>
<td>Used for main paragraphs within the code reference section. Similar to a <code>p:0</code> component.</td>
</tr>
<tr>
<td><code>p:1</code></td>
<td>Used for sub-paragraphs within the code reference section. Similar to a <code>p:1</code> component.</td>
</tr>
<tr>
<td><code>returns</code></td>
<td>Used for identifying the returned value from a function.</td>
</tr>
<tr>
<td><code>related</code></td>
<td>Used for identifying other functions related to the currently described function.</td>
</tr>
</tbody>
</table>
The following components are for creating a reference section for functions:

```
index
```

```c
void index (n, arrayin, arrayindex);
```

Indexes an array `arrayin` of length `n` and puts indexed array into `arrayindex`.

The input variables `arrayin` and `n` are not changed.

```c
int n, arrayindex[];
```

```c
float arrayin[];
```

```c
for (j=1; j<=n; j++) arrayindex[j]=j;
```

**Headers:** `function-header.h`

**Returns:** nothing

**Related Functions:** `index`, `qsort`

---

**Figure A-10. Code reference objects**
APPENDIX B

Customizing Your Environment

This appendix presents a few different ways to customize your Interleaf 6 environment. First, you'll learn how to create a link that will make documents easier to get to. Next, for you Interleaf 6 for Motif users, you see how to add or change a printer. Finally, you'll see how to set up your own preferences for the way you want Interleaf 6 to work.

CREATING LINKS TO DESKTOP OBJECTS

Creating links to desktop objects is a feature of Interleaf 6 that allows you to work more efficiently. A link to a document that you work with frequently can be placed right on the Desktop so that you don't have to open a series of containers each time you want to open the document. You can use links to access other parts of your file system, or other file directories that may be located on different parts of your network. Links can also be used to shorten the menu path needed to create a document that might otherwise be buried inside a document template. In fact, this example was given back in Chapter 3. To refresh your memory, take a look at Figure 3-4 on page 3-41. It shows a very long menu to a document named start. The start document is part of the User Guide template and is used whenever a
new chapter is started. This document could be used quite a bit, so using a link to shorten the menu will make it easier to work with.

**Creating a Link to the start Document**

To create a link to the start document, you need access to its icon. To access the start document icon, double-click on the System6 cabinet, double-click on the Create cabinet, and double-click on the Inside Interleaf drawer. At this point, you'll see the top level of the User Guide template. Double-click on User Guide, which will open in its own window. Now, double-click on the following icons to reveal the start document: Body, Part, and Chapter. Select the start document. (Quite a long path to the start document!)

With the start document selected, you can create a link to it by choosing Edit → Link (see Figure B–1). This will create a link to the start document and place the link on the Clipboard. Now, close the Chapter window, which should reveal the Inside Interleaf window. Choose Edit → Paste on the Inside Interleaf window, and the link to the start document will be created. You'll see the cursor change to an hourglass shape to indicate that the software is busy. You might even notice a message appear in the information area at the bottom of the window. The message indicates that the menus are being modified.

**Note** As you work with Interleaf6, you will undoubtedly add your own templates and will choose some method of organizing them in your Create cabinet. You could place the link to the start document higher in the Create cabinet hierarchy, but placing it in the Inside Interleaf drawer will help you remember its association with this book and the User Guide template.

The start document is now a link to the original document. It is identified as a link by having the icon name appear in italics, and, when selected, the pathname of the start document link will appear in the message area of the window (see Figure B–1).
You can move the start document higher in the File→New menu to make it easier to create one when you need one. Select the start document and create a link to it. Open the System6 cabinet and then the Create cabinet. Paste the link anywhere in the Create cabinet (here it is within the Inside Interleaf drawer). You can see the pathname to the link in the message area of the container window.

**Figure B-1.** Making the start document more accessible with a link

### Using the start Document Link

Return to the Desktop by using the GoTo→Desktop menu choice. Now when you choose File→New→Inside Interleaf, you’ll see the addition of start at the same level as User Guide on the menu (see Figure B–2). You have eliminated the need to choose four more levels of menus in order to create a start document. Since you’ll be working with the start document regularly as you create the different chapters of a user guide, you have improved your efficiency with Interleaf 6.

After Interleaf 6 has rebuilt the popups, you can create a start document without having to traverse the entire template menu.

**Figure B–2.** Creating a start document with a shorter menu
Tip Creating links to documents and containers is a good technique to use when regularly working with documents and containers buried within many levels of containers, or scattered about your network. Your system administrator may even establish a link to a common area, known as a BulletinBoard, to make it easier for you to share documents with other Interleaf 6 users.

**ADDING A PRINTER IN MOTIF**

Here is a special treat for you *Interleaf 6 for Motif* users—you can add your own printer definition. You might want to add your own printer definition to make use of printers that are local to your system, but were not set up as site printers by the Interleaf 6 administrator. Or, you might use a printer that was set up by the Interleaf 6 administrator, but you find that you’re always making changes to some part of the printing properties and you’re really tired of making these changes. In either case, you can add a printer definition without bothering your Interleaf 6 administrator.

To add a printer, open the Printer Setup dialog box by choosing **Edit**→**Printers**... from the Desktop menu (see Figure B–3). Along the top of the dialog box are buttons that allow you to add, change, or remove a printer, or set the default printer. Click on the Add button.

**Pick the Printer Menu and Name**

Next, you’ll pick the printer menu and name. The printer menu will be the Custom menu—unless you have permission to write to files in the Interleaf 6 hierarchy; in which case you can choose either menu. The printer name you provide should be something descriptive about the printer to help you differentiate one printer from another.

**Set Filtering Options**

The next section of the Printer Setup dialog box deals with how a print file is sent to a printer. Turn on Printer as the destination of the print job. Filter the file on the Desktop. If the printer queue is located on your workstation, choose Local for the location of the printer; otherwise, choose Remote. In either case, you must enter a valid printer queue name. Your Interleaf 6 administrator should be able to provide you with a valid name.
**Note** Filtering converts an intermediate file that Interleaf 6 creates into the final file for the printer. If you are setting up an Adobe PostScript compatible printer, then the file sent to the printer will be a PostScript file. If you have a printer that understands Hewlett–Packard's Printer Control Language (PCL), then a PCL file will be sent to the printer. Either file type is generated from the same intermediate file by a filtering process. If you filter on the Desktop, it will take longer to get a cursor back so that you can continue working in Interleaf 6. Filtering on a server will get you to work much quicker, while increasing the load on the print server. Check with your Interleaf 6 administrator for the best location for filtering.

Open the Printer Setup dialog box and click on Add. You'll only be able to change the printers on the Custom menu (unless you are an Interleaf 6 administrator).

Set the printer's job properties (use an existing print queue or have your administrator create one).

Pick the printer type and the printer model. You can customize the printer further by clicking on Set Printer Options....

**Figure B-3.** Adding a printer to Interleaf 6 for Motif

**Pick Printer Type and Modify Options**

Finally, pick the printer type. If you are using a PostScript printer, click on PostScript. As soon as you do, Interleaf 6 will scan all of the PostScript Printer Description (PPD) files in the Interleaf 6 directory. After all of the files have been scanned, you'll be able to pick a printer model from the drop down list. In the example shown in Figure B–3, I have chosen a Lino-
tronic 300. The PPD file associated with the Linotronic 300 tells Interleaf 6 about the features of the printer. You can set the default features by clicking on the Set Printer Options... button to open the Set Printer Options dialog box (see Figure B–4).

One of the features you might set is the output resolution of the printer. According to the PPD file, the output resolution for a Linotronic 300 can be 635, 1270, or 2540 dots per inch. Unless you disable an option, all of the options will be available on the Print Options dialog box when you print a document (refer to Figure 5–9, page 5–91). You can also see on the Set Printer Options dialog box that the default setting for resolution is 635 dpi.

Other options can be set besides resolution. Some of these options might include output trays, input trays, paper sizes and types available, duplexing, and sorting. These options can be accessed by using the Printer Option drop down list.

Pick the printer option to set and then identify the settings you want available. You can disable some settings (e.g., paper trays or duplexing options) if your printer doesn’t have those features installed by clicking on the setting in the Available list (it will move to the Disabled list).

You can set the default value for the different options.

**Figure B–4.** Setting printer options

After you have made all of your changes to the printer options, apply your changes. Also, apply the changes on the Printer Setup dialog box. After these changes have been applied, your printer will be available the next time you print a document.
You can set preferences in the Interleaf 6 Preferences dialog box. Open the dialog box by choosing **Tools → Preferences**... from a container window. Along the left side of the dialog box are the different categories of preferences.

Some you might consider changing are turning off **BACKSPACE** joining components in the Keyboard preferences...

...and changing the initial zoom of documents in View preferences.

**Figure B-5.** Setting Interleaf 6 Preferences
**Setting Your Own Preferences**

Finally, I would like to show you some of the useful options you can set up. To set your preferences, choose Tools→Preferences... to open the Interleaf 6 Preferences dialog box. The dialog box is divided into different categories that are accessible through the option buttons along the left side (see Figure B–5). The first category, Desktop, controls containers and icons. Options that you should consider setting are Keyboard and View preferences.

**Keyboard Preferences**

If you don't like the BACKSPACE key joining components together, then turn the option off under the Keyboard preferences. Also, if you are an Interleaf 5 user, you may want to change the use of the RETURN key from the Interleaf 6 default of creating a new component to the old behavior of Interleaf 5.

**View Preferences**

Some large monitors show an entire letter size page, but, at the expense of very fine type. If you find you’re constantly zooming the document so that you can read it on screen as you work, then you can set the initial zoom under the View preferences. If the component names you’re using in your documents are long, you might consider changing the size of the component bar. The component bar size is given by screen pixels.

After you have made changes on the Interleaf 6 Preferences dialog box, Apply them. The changes will take effect immediately and will be remembered from session to session.

**Summary**

In this appendix, you learned a few ways that you can customize your Interleaf 6 environment. You learned how to create links to documents, add a printer in Motif, and set a few useful preferences. These customizations are specific to your Desktop and can really improve the way you work with Interleaf 6. Use the topics presented in this appendix as a starting point for tuning the Interleaf 6 environment to your liking.
Index

Italicized numbers refer to pages on which figures appear.

A

accessibility of template, 13–258
active regions, 4–62
Add Point Tool, 16–340
alignments, illustrations, 6–105
alphabetized lists, companion document, A–377
anchor points, 15–297
application icon, 1–5
apply options for components, 12–235
arcs
  changing eccentricity, 15–302, 15–302
  changing extent, 15–301, 15–302
  creating, 15–299
  eccentricity of, 15–300, 15–300
  extent of, 15–300, 15–300
  modifying, 15–299
  modifying with size handles, 15–300
  orientation, 15–299, 15–299
  sub-edit, entering, 15–300, 15–301
aspect lock, 15–310, 15–312
At Anchor frame, 14–277
attributes, defining, 9–176
Auto-Pickup Tool, 16–333, 16–333
autonumbers
  autonumber stream alpha, 11–218
  changing list:num to second level, 11–215, 11–217
  heading numbers, correcting, 4–61
  hierarchy of objects in book, 8–136
  multiple level autonumbers, defining, 11–214
  ordered lists, 11–211
  restarting, 11–213
  page number reference creation, 6–112
  properties modification, 11–215
Properties→Autonumber Streams..., 11–214
autonumbers (continued)
  rearranging objects in books, 8–137
reference creation
  automatic method, 6–107
  manual method, 6–109, 6–111
  restarting, 11–213
  tag modification, 6–109
axis
  editing chart properties, 17–355, 17–356
  setting range, 17–359, 17–360

B

BACKSPACE key function, 3–47, B–389
backup documents
  removing, 13–257, 13–259
  template copies, removing, 13–257, 13–259
Tools→Admin→Cleanup, 13–258, 13–259
bar chart, creation, 17–356, 17–357
bit images. See raster images
bleed, headers and footers, 9–167, 9–168
Blend Tool, 16–336
Body sub-book, companion document, A–372
bold, changing text, 3–54
Book Catalogs. See Network Style Sheets
book icons, described, 1–8
Book→Index→Master, 8–154, 8–155
Book→Index→Normal, 8–153, 8–153
Book→TOC, 8–142, 8–143, 8–143, 8–144
books
  advantages, 8–133
  binders, 8–135
Book→Index→Master, 8–154, 8–155
Book→Index→Normal, 8–153, 8–153
Book→Sync, 8–143
books (continued)

Book→TOC, 8–142, 8–143, 8–143, 8–144
Create→Index..., 8–147, 8–148
creating, 8–135
document order in book, maintaining, 8–138
documents in books, 8–134
Edit→Properties..., 8–152
File→New→Containers→Book, 8–135, 8–136
hierarchy of objects, 8–136
indexes, 8–147
changing headings, 8–151, 8–152
creating new entries, 8–147, 8–148
cutting and pasting tokens, 8–150
generating master index, 8–154
generating normal index, 8–153
modifying entries, 8–150
range and typeface, 8–149
reformatting, 8–154
sort column, 8–152
Network Style Sheets, 8–135
objects used in books, 8–134
rearranging objects, 8–137
relationships of objects in book, 8–135
summary files, 8–143
synchronizing documents, 8–143
table of contents
creating, 8–139
reformatting, 8–144
tagging components, 8–140
tagging information, 8–139
TOC command, 8–142
View→Line Up Icons, 8–138, 8–138
books, sub-books. See sub-books
Bottom frame, 14–277
brush choice, 16–329, 16–329
bullet lists
See also unordered lists
companion document, A–377

callouts (continued)
variable width microdocuments, creating,
14–281
Cancel, 1–19
print job, 5–85
print job in Motif, 5–88
cancel, documents, 2–25


cell selection
menu use, 7–123
mouse and keyboard use, 7–124
mouse use, 7–123

cells
cell edit mode, 7–126
changing vertical alignment, 12–242, 12–243
Empty Cell(s) command, 7–125
heading cells, changing format, 12–236
tables, cell default name, 12–227
text, entering in table cells, 7–126
View→Markers..., 7–127

CGM file, conversion for Interleaf 6 use, 6–101
Change, 4–79
Change All, 4–79
Change Properties dialog box, 4–70
Change→Measurements..., 6–104
changes
undoing change, 3–49
undoing changes in cropping, 16–328
undoing changes in touching up image,
16–332
Chapter sub-book, companion document,
A–372
chapter title
changing, 3–42
entering, 3–42
Chart Data dialog box
adding new data, 17–346, 17–348
changing data, 17–348
copying data, 17–350
disabling chart data, 17–348, 17–349
Edit→Copy, 17–350, 17–350
Edit→Copy Special..., 17–350, 17–350
Edit→Delete→All Data, 17–351
Edit→Delete→Unused Data, 17–351
Edit→Paste, 17–351
Edit→Set Horizontal→Same Increment,
17–347
Edit→Set Horizontal→Same Value, 17–347
editing data, 17–346
editing properties, 17–352
formats, 17–346, 17–347
pasting data into, 17–351
Tables→Convert Text to Table..., 17–350

C

Cabinet icons, described, 1–8
cabinets, books, 8–135
callouts
creating with microdocuments, 14–279
creating with predefined components,
14–281
creating with variable width microdocu-
ments, 14–279
Chart Editor
- bar chart, creation, 17-356, 17-357
- Chart Data dialog box
  - adding new data, 17-346, 17-348
  - changing data, 17-348
  - copying data, 17-350
  - disabling chart data, 17-348, 17-349
  - editing data, 17-346
  - editing properties, 17-352
  - formats, 17-346, 17-347
  - pasting data into, 17-351
- composite chart from two superimposed charts, 17-361
- Create→Chart, 17-346
- creating charts, 17-345
- Edit→Copy, 17-350, 17-350
- Edit→Copy Special..., 17-350, 17-350
- Edit→Delete→All Data, 17-351
- Edit→Delete→Unused Data, 17-351
- Edit→Paste, 17-351
- Edit→Set Horizontal→Same Increment, 17-347, 17-358
- Edit→Set Horizontal→Same Value, 17-347
- editing chart properties
  - axis, 17-355, 17-356
  - layout, 17-354, 17-354
  - margins, 17-354, 17-355
  - style, 17-352, 17-353
- font, changing, 17-362
- line chart
  - creation, 17-358
  - setting axis range, 17-359
  - stacked line chart creation, 17-359
  - turning labels off, 17-360
- Properties→Selection..., 17-362
- Properties→Text, 17-362
- scatter plot, 17-354
- stacked line chart creation, 17-358
- superimposing charts, 17-360
- Tables→Convert Text to Table..., 17-350
- titles and legends, adding, 17-361
- Charts, predefined templates, 17-362
- check lists, companion document, A-377
- ClipArt drawer, colors and patterns from, 15-318
- Clipboard
  - creating reference on, 6-109
  - deleting objects, 1-16
  - pasting from, 1-15
- Clipboard icon, 1-8
- Clone Tool, 16-334, 16-335
- cloning part of image, 16-334, 16-335
- close, 2-25
- closing documents, 2-24, 3-55
- code reference, companion document, A-381
- color
  - Add Point Tool, 16-340
  - automatically picking color, 16-333, 16-333
  - Blend Tool, 16-336
  - changing component’s text color, 10-196
  - changing contrast, 16-339
  - changing text, 3-53
  - choice, 16-330, 16-330, 16-331
  - Color Palette Editor, 15-314
  - Contrast Editor, color adjustment, 16-339
  - Fade Tool, 16-335
  - Fill Tool, 16-334
  - inverse color map curve, 16-342
  - library, 15-315
  - mapping curve, 16-339
    - adding a point, 16-340, 16-340
  - model, 15-314
  - CMY, 15-315
  - CMYK, 15-314
  - HSB, 15-315
  - RGB, 15-315
- colors and patterns
  - adding with Color Palette Editor, 15-314
  - adding with Pattern Editor, 15-317
  - changing, 15-313
  - choosing from color library, 15-317
  - ClipArt drawer, cutting and pasting from, 15-318
  - editing with color model, 15-314
  - File→Save, 15-316
  - Samples drawer, cutting and pasting from, 15-318
  - saving changes, 15-316
- Tools→Colors..., 15-314, 15-314
- Tools→Patterns..., 15-317
- columns
  - apply options for components, 12-234
  - gutter width, 9-163
  - page layout, 9-163
  - properties, changing, 12-230
  - proportional, 12-232, 12-232
  - recap table, 12-232
  - selecting, 12-228
  - selecting for copying or cutting, 12-229
  - selecting multiple, 12-230
  - selecting single, 12-229
  - table component master, defining new, 12-233, 12-233
  - table component properties, modifying, 12-234
components (continued)
masters
creating new, 10–195
renaming, 10–192
modifying table component properties, 12–234
moving component, 3–51
multiple components, changing, 4–66
Network Style Sheets, 13–266
new page, starting, 4–74
ordered lists, component properties modification, 11–211, 11–212
p:0 component, 3–45
page properties, 10–190, 10–190
page revision information, attaching, 9–176
predefined component, use for illustrations, 6–98
Properties → Selection..., 4–64
range of indexes
this component, 8–150
to named component, 8–150
tab properties, 10–191, 10–191
table of contents, tagging components, 8–140
tables, apply options, 12–234, 12–235
text properties, 10–185, 10–186
titles or captions, 14–279
utility components, restarting ordered lists, 11–214
variable content component, adding to
header, 9–174, 9–175
components, illustrations. See illustration components
components, inline. See inline components
composite chart, 17–361
content-controlling Network Style Sheets, 13–266
contrast, changing, 16–339
Contrast Editor
Add Point Tool, 16–340
adding a point, 16–340
changing contrast, 16–339
color adjustment, 16–339
Contrast Editor (continued)
color mapping curve, 16–339
inverse color map curve, 16–342
negative, creating, 16–341, 16–342
window, 16–339, 16–340
control lock, 15–312
control points, 15–297, 15–305
conversion
  RTF files to Interleaf 6 components, 4–62
tagged image file format file, 6–101
text, converting to inline component, 10–199, 10–199
TIFF conversion by Interleaf 6, 16–323
Cut, 1–15, 1–17
cutting, selecting columns for, 12–229
cutting and pasting, index tokens, 8–150
cutting lock, 15–312
customizing
  creating links, B–383
  printer, adding in Motif, B–386
  Tools→Preferences..., B–390
copy component, 3–52
copying
  columns, selecting for cutting, 12–229
document editing, copying selected items, 4–59
  index tokens, cutting and pasting, 8–150
  printing documents, 5–82
  printing documents in Motif, 5–88
  range of text, 3–52
  rows, 7–129
Create cabinet, 1–17
Create→Autonumber..., 11–211, 11–212
Create→Autoreference, 6–109
Create→Character, 3–46
Create→Character→Bullet, 11–207, 11–207
Create→Character→Other..., 11–210, 11–210
Create→Chart, 17–346
Create→Component, 3–44
Create→Equation, 17–364
Create→Frame..., 6–98
Create→Index..., 8–147, 8–148
Create→Line, 15–297, 15–298
Create→Reference→Attributes..., 9–178
Create→Reference→Autonumber, 6–110, 6–111
  Create→Reference→Page Number..., 9–172, 9–173
creating books, 8–135
creating document from templates, 3–41
creating documents, 2–21, 2–22
creating icons, 1–8
creating table, 12–225
Crop Tool, 16–328, 16–337
cropping image, 16–328, 16–328
current page, 8–150
current point, jumping from point to point, 4–73
Custom menu, 1–17
default printer, 5–82, 5–85, 5–87
defining objects for illustrations
callout
  creating variable width microdocument, 14–281
  creating with microdocuments, 14–279
  creating with predefined components, 14–281
  creating with variable width microdocuments, 14–279
footnotes
  adding horizontal rule above, 14–290
  adding lines with graphics editor, 14–290
  defining, 14–286
  numbered, 14–287
  properties of numbered, 14–288
  properties of unnumbered, 14–289
  unnumbered, 14–289
  using object editor, 14–290
frames
  adding horizontal rules, 14–283
  adding initial content, 14–282
  At Anchor frame, 14–276
  defining illustration frame, 14–274
  layout properties, 14–274
  placement properties, 14–277
  predefined, 14–273
  setting properties, 14–276
illustration components
  benefits of using, 14–285
  creating, 14–284
  limitations of using, 14–286
Properties→Frame..., 14–275
titles
  defining component, 14–279
  microdocument creation, 14–278
  microdocument creation with specific component, 14–278
  positioning microdocument, 14–280
defining objects for illustrations (continued)
titles (continued)
using, 14-278
Tools→Graphic Palettes→Commands..., 14-278
Tools→Graphic Palettes→Drawing..., 14-278
Delete, 1-16
DELETE key function, 3-47
Delete All, 1-16, 1-16
Delete Selected, 1-16
deleting component, 3-48
deleting paragraph, 3-48
deleting text, 3-47
deleting unwanted parts of image, 16-327
deleting words, 3-48
deletion marks, 5-87
desktop icons
book icons, 1-7
cabinet icons, 1-7
changing display of names, 1-10
Clipboard
deleting objects, 1-16
pasting from, 1-15
Clipboard icon, 1-8
container icons, 1-7
creating icons, 1-8
directory icons, 1-7
dragging icons, 1-13
drawer icons, 1-7
dropping icons, 1-13
file or desktop names, 1-10
finding containers, 1-11
folder icons, 1-7
host file icons, 1-8
italicized icon names, 1-18
Lisp icons, 3-40
moving files among containers, 1-11
moving icons by dragging and dropping, 1-13, 1-14
opening icons, 1-11
popup menus, 1-12
renaming icons, 1-9
System6 cabinet, 1-17
Create cabinet, 1-17
opening, 1-17
System6 icon, 1-8
unwanted icons, cutting, 1-14
window minimized, 1-7
desktop names, displaying, 1-10
desktop objects, creating links, B-383
Desktop window, 1-7
minimized, 1-7
restoring, 1-7
destination printer, 5-82
detent, 15-307
Dictionary Add, 4-79
Dictionary Remove, 4-79
dimensions of page, 9-159
directory icons. See container icons
distance settings, gravity, 15-307
document composition properties, 10-187, 10-188
document creation
Desktop window menu, 1-12
popup menu, 1-13, 1-13
document editing
active regions, 4-62
component types, changing, 4-63
Convert to..., 4-64
converting RTF files to Interleaf 6 compo-
nents, 4-62
copying selected items, 4-59
Edit→Select→All of..., 4-66
Edit→Select→To End, 4-60
finding objects, 4-70
format, search and replace, 4-69
heading numbers, correcting, 4-61
inline components left selected, 4-71
Introduction document creation, 4-58
jumping from point to point, 4-72
keeping items together, 4-75
minimizing windows, 4-59
multiple components, changing, 4-66
multiple documents, working with, 4-59
non-Interleaf 6 documents, adding, 4-62
objects, finding, 4-70
overriding pasted items, 4-60, 4-60
page breaks, 4-73
pasting specific components, 4-61
program management document creation, 4-58
Properties→Selection..., 4-64
search and replace format, 4-64
search and replace text, 4-68
single components, changing, 4-64
spelling check, 4-77
text, search and replace, 4-68
Tools→Find Object..., 4-70
Tools→Find/Change..., 4-69
Tools→Spelling..., 4-77
document name, referencing in text string, 9-171
document objects, finding, 4–70

document ruler, properties adjustment in unordered lists, 11–208, 11–209

document templates
  accessibility of template, 13–258
  accessing, 3–38
  adding initial content
    components, 13–257, 13–258
    saving, 13–257
  BACKSPACE key function, 3–47
  change file permissions, 13–261
  chapter title
    changing, 3–42
    entering, 3–42
  closing document, 3–55
  companion document, A–371
  copy component, 3–52
  copy range of text, 3–52
  Create ~ Component, 3–44
    creating, 13–252
    creating document, 3–41
  DELETE key function, 3–47
  deleting component, 3–48
  deleting paragraph, 3–48
  deleting text, 3–47
  deleting word, 3–48
  designing the document, 13–252
  double quotes, 3–46
  Edit ~ Delete Master ...., 13–253, 13–254
  Edit ~ Redo, 3–50
  Edit ~ Undo, 3–49
  ENTER key function, 3–46
  File ~ Close, 3–55
  File ~ File Properties ...., 13–260
  File ~ New menu, 3–38
  File ~ New ~ Inside Interleaf ~ Online ~
    online, 13–252
  File ~ New ~ Inside Interleaf ~ User
    Guide ~ Body ~ Part ~ Chapter ~
    start, 3–41
  File ~ New ~ online, 13–262
  File ~ Save, 3–56
  font, color, size, changing, 3–53
  formatting components, 10–195
  GoTo ~ Pathname ...., 13–259
    h:1 component, 3–44
    h:chapter, 3–41
  install program, running, 3–38
  installing, 3–37
  master Create cabinet
    accessing, 13–259, 13–260
    add template to, 13–259
    moving component, 3–51

document templates (continued)
  moving range of text, 3–50
  Network Style Sheets
    content-controlling, 13–266
    in sub-books, 13–268
    index, 13–266
    style-enforcing, 13–262
    table of contents, 13–265
    using, 13–264
  opening document, 3–41
  p:0 component, 3–45
  paragraph, creating, 3–45
  Properties ~ Selection, 3–54
  Properties ~ Text, 3–54
  removing backup copies, 13–257, 13–259
  removing unused objects
    create instance of wanted object, 13–253
    deleting selected masters, 13–255
    deleting unused masters, 13–254
    purge object masters, 13–253
  replacing selected text, 3–49
  replacing text, 3–47
  RETURN key function, 3–46
  saving document, 3–55
  section, creating, 3–43
  section title, creating, 3–44
  selecting range of text, 3–48
  selecting text to be changed, 3–47
  selecting word, 3–48
  structure, companion document, A–371
  System6 cabinet, updating, 13–261
  text, entering, 3–41
  text properties, changing, 3–54
  Text Properties dialog box, 3–54, 3–54
  Tools ~ Admin ~ Cleanup, 13–258, 13–259
  Tools ~ Admin ~ Update, 13–261, 13–262
  true hyphen, 3–46
  undoing change, 3–49
  Update Master Content, 13–257, 13–258
  window opening, 3–38

document vertical properties, 10–189, 10–189

document window, 2–23
  described, 2–22
  minimizing, 2–23, 2–24
  restoring, 2–24

documents
  cancel, 2–25
  close, 2–25
  closing, 2–24
  closing without saving, 2–25
  component bar, 2–29
  components, 2–30
documents (continued)
creating, 2-21, 2-22
document window, 2-23
described, 2-22
minimizing, 2-23
restoring, 2-24
documents in books, 8-134
formatting documents with Interleaf 6, 2-27
hold, 2-25
inferring structure from document design, 2-26
instance objects, 2-32
master objects, 2-31, 2-32
masters
instances of, 2-32
variations of, 2-33
opening, 2-22
order in book, maintaining, 8-138
save, 2-25
structure of Interleaf 6 documents, 2-28, 2-29
structured information, 2-25
synchronizing documents in books, 8-143
documents, illustrations. See illustrations
documents, page layout. See page layout
documents, printing. See printing documents
documents, template. See document template
double quotes, 3-46
creating, 3-46
double sided page layout, 9-161
drag selecting multiple objects, 15-303, 15-303
dragging icons, 1-13
drawer icons, described, 1-8
drawers, books, 8-135
Drawing palette
creating lines, 15-298
Tools→Graphics Palettes→Drawing..., 9-170
dropping icons, 1-13
duplex, 5-92
duplicate command, reusing graphic objects, 15-304, 15-305

E
eccentricity of arcs, 15-300, 15-300, 15-302
edge color lock, 15-312
edge dashes lock, 15-312
edge visibility lock, 15-312
edge weight lock, 15-312
Edit→Close, 1-14
Edit→Convert to Inline..., 10-199, 10-199
Edit→Copy, 17-350, 17-350
Edit→Copy Special..., 17-350, 17-350
Edit→Create, 2-31
Edit→Cut, 1-14, 1-15
Edit→Delete, 1-17
Edit→Delete Master..., 13-253, 13-254
Edit→Delete→All Data, 17-351
Edit→Delete→Unused Data, 17-351
Edit→Find Object..., 10-200, 10-201
Edit→Link, 16-342
Edit→Paste, 1-15, 6-109, 17-351
Edit→Properties..., 6-109, 8-152
Edit→Redo, 3-50
Edit→Select→All of..., 4-66
Edit→Select→To End, 4-60
Edit→Set Horizontal→Same Increment, 17-347, 17-358
Edit→Set Horizontal→Same Value, 17-347
Edit→Undo, 3-49, 16-328
Edit→Whole Image, 16-338
editing chart properties
axis, 17-355, 17-356
layout, 17-354, 17-354
margins, 17-354, 17-355
style, 17-352, 17-353
emp:function, 11-220
emp:user, 11-221
emp:variable, 11-221
emphasized text
See also formatting highlighted or repeated words
companion document, A-378
empty cell(s), 7-125
emptying contents of table, 7-122
ENTER key function, 3-46
entire document, printing documents in Motif, 5-88
environment
application icon, 1-5
book icons, 1-7
cabinet icons, 1-7
changing display of names, 1-10
Clipboard
deleting objects, 1-16
pasting from, 1-15
Clipboard icon, 1-8
container icons, 1-7
creating icons, 1-8
Desktop icons, 1-7
desktop names, displaying, 1-10
environment (continued)
Desktop window, 1-6, 1-7
dragging icons, 1-13
drawer icons, 1-7
dropping icons, 1-13
file names, displaying, 1-10
finding containers, 1-11
folder icons, 1-7
host file icons, 1-8
italicized icon names, 1-18
license selection, 1-4
Microsoft Windows, 1-3
mnemonics, 1-9
moving files among containers, 1-11
moving icons by dragging and dropping, 1-13
Network Style Sheets, license, 1-4
opening icons, 1-11
popup menus, 1-12
quitting Interleaf 6, 1-18
Cancel, 1-19
renaming icons, 1-9
starting Interleaf 6, 1-3
startup screen, 1-5
System6 cabinet, 1-17
Create cabinet, 1-17
opening, 1-17
System6 icon, 1-8
unwanted icons, cutting, 1-14
EPS file
conversion for Interleaf 6 use, 6-101
printing documents in Motif, 5-88
Equation Editor
Create→Equation, 17-364
editing equation, 17-366
entering equation, 17-366, 17-367
Equation Editor dialog box, 17-364, 17-364,
17-365
font size, changing, 17-368, 17-368, 17-369
keywords reference, 17-370
language, 17-365
lining up equations, 17-369
opening, 17-364
extent of arcs, 15-300, 15-300, 15-301

F
Fade Tool, 16-335
figures, companion document, A-379
file names, displaying, 1-10
file permissions
change, 13-261
master Create cabinet, 13-261
File→Close, 2-24, 3-55
File→Exit, 1-18
File→File Properties..., 13-260, 13-263
File→New menu, 3-38, 3-40
File→New submenu, 1-17
File→New→Containers→Book, 8-135, 8-136
File→New→document, 2-21
File→New→Inside Interleaf→Graphics→spare1, 6-96
File→New→Inside Interleaf→Online→
online, 13-252
File→New→Inside Interleaf→User Guide→
Body→Part→Chapter→start, 3-41
File→New→Inside Interleaf→User Guide→
Front→TOC→<whole book>, 8-145
File→New→Inside Interleaf→User Guide→
Rear→Index_sty, 8-154, 8-156
File→New→online, 13-262
File→New→ScratchPad, 15-293
File→Open, 2-22
File→Print..., 5-82, 5-87
File→Revert to→Saved, 16-329
File→Save, 3-56, 15-316, 16-328
File→Save As..., 16-328
files
moving among containers, 1-11
summary files, 8-143
tagged image file format file, creating, 6-101
fill color lock, 15-312
fill pattern lock, 15-312
Fill Tool, 16-334
fill visibility lock, 15-312
filtering on the print server in Motif, 5-90
Find & Change dialog box, 4-69
Find Object dialog box, 4-70, 4-72
finding containers, 1-11
finding objects, 4-70
finger tab frames, 9-180, 9-183
first level paragraphs, 10-192
flip command, reusing graphic objects, 15-304,
15-305
folder icons, described, 1-8
folders, books, 8-135
Following Anchor frame, 14-277
Following Text frame, 14-277
font lock, 15-312
fonts
change, 5-86
changing text, 3-54
charts, changing fonts, 17-362
equations, changing size, 17-368, 17-368, 17-369
indexes, specifying, 8-149
inline component, font size, 10-202
tables, font size adjustment, 12-246
footer rows, formatting tables, 12-240
footers. See headers and footers
footnotes
companion document, A-378
defining, 14-286
horizontal rule above, adding, 14-290
lines, adding with graphics editor, 14-290
numbered, 14-287
object editor, using, 14-290
unnumbered, 14-289
format
Network Style Sheets, 8-135
search and replace, 4-69
format, page layout. See page layout
format properties, components, 10-186, 10-187
formatting documents with Interleaf 6, 2-27
formatting highlighted or repeated words
emp: function, 11-220
emp: user, 11-221
emp: variable, 11-221
inline components used for function names, 11-220
inline components used for highlighted words, 11-219
inline components used for repeated words, 11-222
maintaining text information while formatting, 11-219
shared content inline, 11-222, 11-223
formatting lists (continued)
restarting ordered lists, 11-213
autonumber properties modification, 11-215
defining multiple level autonumbers, 11-214
defining utility component, 11-214, 11-216
unordered lists
adding content to prefix, 11-207
creating other lists, 11-210
defining, 11-206, 11-206
properties adjustment with document ruler, 11-208, 11-209
setting up component prefix, 11-206
formatting paragraphs and headings
components
document composition properties' effect, 10-187, 10-188
document vertical properties' effect, 10-189, 10-189
format properties, 10-186, 10-187
page properties, 10-190, 10-190	
tab properties, 10-191, 10-191
text properties, 10-185, 10-186
Edit⇒Convert to Inline..., 10-199, 10-199
Edit⇒Find Object..., 10-200, 10-201
headings
converting text to inline component, 10-199, 10-199
creating as separate, 10-196
defining, 10-196
font size for inline component, 10-202
inline, 10-198
inline component properties, 10-201, 10-203
selecting inline components, 10-200, 10-200
Inline Properties dialog box, 10-201
More⇒Rename Master..., 10-192
page justification, 10-189
paragraphs
applying changes to master, 10-193
defining, 10-194
first level, 10-192
second level, 10-194
Properties⇒Inline..., 10-201
Rename Master..., 10-192
formatting tables
cell default name, 12-227
columns
apply options for components, 12-234
changing properties, 12-230
formatting tables (continued)
columns (continued)
changing width, 12–227, 12–231, 12–231
contents, 12–233
defining new table component master, 12–233, 12–233
formatting, 12–227
modifying table component properties, 12–234
proportional, 12–232, 12–232
recap table, 12–232
selecting, 12–232
selecting for copying or cutting, 12–229
selecting multiple, 12–230
selecting single, 12–229
components, updating instances and masters, 12–235
creating table, 12–225
tables, adding content, 12–227
font size adjustment, 12–246
footer rows, 12–240
headers
changing format of heading cells, 12–236
creating, 12–235
modifying heading row components, 12–237
names, 12–239, 12–240
on multiple pages, 12–238, 12–239
read-only property, 12–238
renaming row as header row, 12–237
within body of table, 12–239
Properties→Cell..., 12–242, 12–243
Properties→Row..., 12–238, 12–238
Properties→Table..., 12–249
recap table, adding content, 12–227
rulings
final changes to table, 12–245
recap table, 12–246
Rulings dialog box use, 12–246
using in table definition, 12–245
straddles
changing a cell's vertical alignment, 12–242, 12–243
creating rows with updated masters, 12–245
horizontal, 12–241, 12–241
updating row masters with straddle information, 12–243, 12–244
using, 12–241
vertical, 12–241, 12–242
table master definition updates
component masters, 12–248
content, 12–249
need, 12–247
formatting tables (continued)
table master definition updates (continued)
row masters, 12–248
Tables→Change Width..., 12–227, 12–228
Tables→Create Row..., 12–235, 12–236
Tables→Create Table..., 12–225, 12–226
Tables→Edit Rulings..., 12–246
Tables→Empty Cell(s), 12–239
Tables→Fonts→Smaller, 12–246
Tables→Join Cells, 12–241, 12–241, 12–242, 12–242
Tables→Select Cells→in Current Column, 12–228, 12–229
Update Master Content, 12–244, 12–248, 12–249
Update Master Props, 12–248, 12–249
Frame Editor
Edit→Whole Image, 16–339
framing part of image, 16–337, 16–337
moving frame to different part of image, 16–338, 16–338
frames
adding content, 9–181
adjusting frame's properties, 6–113
At Anchor frame, 14–276, 14–277
Bottom frame, 14–277
closing, 6–104
creating frame, 6–88, 6–99
defining illustration frame, 14–274
defining detent, 15–307
document name, referencing in text string, 9–171
finger tab, 9–180, 9–183
Following Text frame, 14–277
footnotes
numbered, 14–287
unnumbered, 14–289
graphics editor, 14–290
gravity, 15–306
grids, 15–294
changing grid properties, 15–296, 15–296
isometric grids, 15–319
height and width, 14–276
horizontal rules, adding, 14–283
initial content, adding, 14–282
layout properties, 14–274
object editor, 14–290
opening, 6–100
Overlay frame, 14–277
page format, repeating frames, 9–180, 9–182
page number, referencing in text string, 9–170
frames (continued)
pasting illustration in, 6–101
placement properties, 14–277
predefined, 14–273, 14–274
Properties → Frame..., 9–180, 14–275
setting properties, 14–276
Top frame, 14–277
Underlay frame, 14–277
frames, graphic objects. See graphic objects
Front sub-book, companion document, A–372
function names, inline components, 11–220

G
GoTo, finding containers, 1–11
GoTo → Desktop, 3–40
GoTo → Pathname, 3–39
GoTo → Pathname..., 13–259
graphic frame, spelling check, 4–80
graphic objects, 15–293
arcs
changing eccentricity, 15–302
changing extent, 15–301
creating, 15–299
eccentricity of, 15–300, 15–300
entering a sub-edit, 15–300, 15–301
extent of, 15–300, 15–300
modifying, 15–299
modifying with size handles, 15–300
orientation, 15–299
colors and patterns
adding with Color Palette Editor, 15–314
adding with Pattern Editor, 15–317
changing, 15–313
choosing from color library, 15–315
cutting and pasting from ClipArt drawer, 15–318
cutting and pasting from Samples drawer, 15–318
editing with color model, 15–314
saving changes, 15–316
complex graphic example, 15–321
Create → Line, 15–297, 15–298
Drawing palette, tool stickiness, 15–298
File → New → ScratchPad, 15–293
File → Save, 15–316
gravity
changing distance settings, 15–307
creating a line with gravity on, 15–308
joining two objects with gravity on, 15–308
sticking objects together with, 15–306
graphic objects (continued)
moving objects, 15–305, 15–306
reusing objects
drag selecting multiple objects, 15–303
Duplicate command, 15–304, 15–305
Flip command, 15–304, 15–305
Group command, 15–303, 15–304
rotation, detent, 15–307
ScratchPad document
changing grid properties, 15–296
creating, 15–293
creating graphic object when grid align is on, 15–297
creating graphics in, 15–293
creating line, 15–297
creating lines with Drawing palette,
15–298
grids, 15–294
palettes, 15–294, 15–295
tool bar, 15–294, 15–295
three-dimensional objects
isometric grid, 15–319
projection commands, 15–319
Tools → Colors..., 15–314, 15–314
Tools → Patterns..., 15–317
graphic objects, locks. See also locks
applying to individual objects of group, 15–310, 15–311
controlling properties of object, 15–310
sizing object with aspect lock, 15–311
sizing object without aspect lock, 15–309
types, 15–312
graphics
defining objects. See defining objects for illustrations
illustrations. See illustrations
graphics commands
Duplicate, 15–304, 15–305
Flip, 15–304, 15–305
Group, 15–303, 15–304
graphics editor, adding lines in footnotes,
14–290, 14–291
graphics palettes
Tools → Graphic Palettes → Commands..., 14–278
Tools → Graphic Palettes → Drawing..., 14–278
gravity
changing distance settings, 15–307
creating a line with gravity on, 15–308
joining two objects with gravity on, 15–308
sticking objects together with, 15–306
grids
  changing grid properties, 15–296, 15–296
  creating graphic object when grid align is on, 15–297, 15–297
frames, 15–294
grid align, 15–297, 15–297
isometric grids, three-dimensional objects, 15–319

grouping lock, 15–312

groups
  group command, reusing graphic objects, 15–303, 15–304
  grouping lock, 15–312
  locks, applying to individual objects of group, 15–310, 15–311

h:1 components, 3–44, 8–140
h:2 components, 8–141
h:chapter components, 3–41, 8–141

headers
  body of table, header row within, 12–239
  creating, 12–235
  heading row components, modifying, 12–237
  multiple pages, header rows appearing on, 12–238
  names, 12–239, 12–240

headings
  companion document, A–374
  heading cells, changing format, 12–236
  index headings, changing, 8–151, 8–152
  headings, formatting. See formatting paragraphs and headings

height, frames, 14–276

hierarchy of objects in book, 8–136

highlighted words. See formatting highlighted or repeated words

hold documents, 2–25

horizontal rules
  footnotes, adding above, 14–290
  frames, adding to, 14–283

horizontal straddles, 12–241

host file icons, 1–8

HPGL file, conversion for Interleaf 6 use, 6–101

hyphens, true, 3–46

icons
  book icon, 8–134, 8–134
  RTF files, 4–62, 4–62
  View→Line Up Icons, 8–138, 8–138

icons, desktop. See desktop icons

IGES file, conversion for Interleaf 6 use, 6–101

Ignore All, 4–79

ileaf6 command, 1–6
  Motif, 1–4

illustration components
  benefits of using, 14–285
  creating, 14–284
  limitations of using, 14–286

illustrations
  adjusting other objects in frame, 6–104
  alignment, 6–105
  Change→Measurements..., 6–104
  closing frame, 6–104
  Create→Frame..., 6–98
  creating frame, 6–98
  figure:num, 6–107

File→New→Inside Interleaf→Graphics→spare1, 6–96

Measurements dialog box, 6–104

opening frame, 6–100

page number reference creation, 6–112

pasting graphics into open frame, 6–97

pasting graphics into text, 6–95

pasting illustration in frame, 6–101

position adjustment, 6–104

headers and footers, page revision information. See page revision information

heading numbers, correcting, 4–61
illustrations (continued)
predefined component, use, 6-98
Properties → Selection..., 6-99
reference creation
automatic method, 6-107
manual method, 6-109
repositioning graphic in frame, 6-104
shaping text around illustrations, 6-112
size adjustment, 6-103
illustrations, defining objects. See defining
objects for illustrations
Image Editor
changing editors, 16-336
window, 16-325
Image Editor window, opening, 16-324
indexes
Book → Index → Master, 8-154, 8-155
Book → Index → Normal, 8-153, 8-153
books, 1-8
Create → Index..., 8-147, 8-148
Edit → Properties..., 8-152
entries, modifying, 8-150
File → New → Inside Interleaf → User
Guide → Rear → index_sty, 8-154,
8-156
headings, changing, 8-151, 8-152
index tokens, cutting and pasting, 8-150
master index, generating, 8-154
Network Style Sheets, 13-266
reformatting with, 8-154
new entries, creating, 8-147, 8-148
normal index, generating, 8-153
range and typeface, specifying, 8-149
reformatting, 8-154
sort column, 8-152
initial content, adding to frames, 14-282
inline components
document editing, 4-71
Edit → Find Objects..., 10-200, 10-201
emp:function, 11-220
emp:user, 11-221
emp:variable, 11-221
function names, 11-220
Inline Properties dialog box, 10-201
Network Style Sheets, 13-267
properties, 10-201, 10-203
Properties → Inline..., 10-201
repeated words, 11-222
selecting, 10-200, 10-200
shared content inline, 11-222, 11-223
table of contents, tagging components, 8-142
text, converting, 10-199, 10-199
inline headings, 10-198
install program
Lisp, 3-37
running, 3-38
instance, creating instance of wanted object,
13-253
instance objects, 2-32
Introduction document creation, 4-58
inverse color map curve, 16-342
isometric grid, 15-319
italics
changing text, 3-54
icon names, 1-18
J
joining two objects with gravity on, 15-308
jumping from point to point, 4-72
justification of pages, 10-189
K
keywords reference, Equation Editor, 17-370
L
labels, line chart, turning off, 17-360
labels in chart, turning labels off, 17-361
layout, editing chart properties, 17-354, 17-354
layout properties, frames, 14-274
licenses, checking out, 1-4
line chart
creation, 17-358
Edit → Set Horizontal → Same Increment,
17-358
setting axis range, 17-359
stacked line chart creation, 17-359
turning labels off, 17-360
lines
creating, 15-297
Drawing palette, creating with, 15-298
gravity, creating a line with gravity on, 15-308
titles and legends, adding to charts, 17-362
links
creating, 16-342, 16-342
described and explained, 16-343
Edit → Link, 16-342
editing in Image Editor, 16-342
missing, 16-344, 16-344
Lisp
  document templates, 3–37
  tables, 7–130
lists
  companion document, A–377
  keeping items together, page breaks, 4–75
lists, formatting. See formatting lists
locks
  applying to individual objects of group,
    15–310, 15–311
  aspect, 15–310, 15–312
  control, 15–312
  controlling properties of object, 15–310
  cutting, 15–312
  edge color, 15–312
  edge dashes, 15–312
  edge visibility, 15–312
  edge weight, 15–312
  fill color, 15–312
  fill pattern, 15–312
  fill visibility, 15–312
  font, 15–312
  gravity, 15–312
  grouping, 15–312
  position, 15–312
  printing, 15–310, 15–312
  rotation, 15–312
  selection, 15–310, 15–312
  size, 15–312
  sizing graphic object with aspect lock, 15–311
  sizing graphic object without aspect lock,
    15–309
  smoothness, 15–312
  stickiness, 15–312
logarithmic axis, editing chart properties,
  17–355, 17–356
long documents. See books

M

margins
  double sided layout, 9–162, 9–163
  editing chart properties, 17–354, 17–355
  illustration components, benefits of using,
    14–285
  size, 9–159
mark, lining up equations, 17–369
marks
  exchanging, 4–73
  jumping from point to point, 4–73
  selecting range of text, 4–73
  setting, 4–73
MASTER binder, companion document, A–372
master Create cabinet
  accessing, 13–259, 13–260
  add template to, 13–259
GoTo → Pathname..., 13–259
master index, generating, 8–154
master objects, document structure, 2–31
masters
  creating new, 10–195
  defining new table component master,
    12–233, 12–233
document templates
  deleting selected masters, 13–255
  deleting unused masters, 13–254
  purging object masters, 13–253
Edit → Delete Master..., 13–253, 13–254
paragraphs, applying changes to master,
  10–193
Properties → Table..., 12–249
renaming, 10–192
table master definition updates
  component masters, 12–248
  content, 12–249
  need, 12–247
  row masters, 12–248
Update Master Content, 12–248, 12–249,
  13–257, 13–258
Update Master Props, 12–248, 12–249
Measurements dialog box, 6–103, 6–104
menu, popup, 1–12
menu item selection, mnemonics, 1–9
microdocument
  positioning, 14–280
  titles or caption, 14–278
microdocuments
  callouts
    creating, 14–279
    creating with variable width microdocu-
      ments, 14–279
  page number, referencing, 9–172, 9–173
  titles and legends, adding to charts, 17–362
  titles or caption, 14–279
Microsoft Windows, 1–3
  print options in, 5–85
  printing documents, 5–81
minimize button, 2–24
minimizing windows
  Desktop window, 1–7
  document editing, 4–59
  document window, 2–23, 2–24
missing links, 16–344, 16–344
mnemonics, menu item selection, 1–9
monochrome images
color choice, 16–330
posterizing, 16–341, 16–342
More... button, printing documents, 5–85
More → Rename Master..., 10–192

Motif
adding printer, B–386
master Create cabinet, accessing, 13–260
starting Interleaf 6 on, 1–4
Motif, printing. See printing documents in Motif
mouse, selecting table rulings with, 7–131
moving component, 3–51
moving icons, dragging and dropping, 1–13
moving objects, 15–305, 15–306
control point, 15–305
moving range of text, 3–50
multiple columns, 12–230
multiple components, changing, 4–66
multiple documents
editing, 4–59
minimizing document window, 2–23
multiple objects, drag selecting, 15–303, 15–303
multiple page numbers, 9–170

N
names
desktop names, displaying, 1–10
file names, displaying, 1–10
headers, 12–239, 12–240
renaming row as header row, 12–237
italicized icon names, 1–18
renaming icons, 1–9
tables
cell default name, 12–226
component names, 12–236
negative image, creating, 16–341, 16–342
Network Style Sheets, 8–135
components, exporting, 13–266
content-controlling, 13–266
using, 13–268
creating from document, 13–263
File → File Properties..., 13–263
File → New → Inside Interleaf → User
Guide → Front → TOC → <whole book>, 8–145
File → New → online, 13–262
index, 13–266
indexes, reformatting with, 8–154
inline components, 13–267
license, 1–4

Network Style Sheets (continued)
style-enforcing, 13–262
table of contents, 8–146, 13–265
reformatting, 8–145
using, 13–264
new page, starting, 4–74
new table, creating, 7–120
No Change, 4–79
NO TAG, 6–111
node locked licenses, 1–4
non-Interleaf 6 documents
component types, changing, 4–63
Convert to..., 4–64
converting files, 4–62
Edit → Select → All of..., 4–66
multiple components, changing, 4–66
Properties → Selection..., 4–64
normal index, generating, 8–153
numbered footnotes, companion document, A–378
numbered lists, companion document, A–377

O
object editor, using with footnotes, 14–290
objects
book use, 8–134
companion document, A–374
document templates
purging object masters, 13–253
removing unused objects, 13–253
documents in books, 8–134
finding, 4–70
hierarchy in book, 8–134
instance objects, 2–32
master objects, document structure, 2–31
order in book, maintaining, 8–138
rearranging objects in books, 8–137
objects, illustrations. See defining objects for
illustrations
odd page, 9–161
opening documents, 2–22, 3–41
opening icons, 1–11
ordered lists
autonumber creation, 11–211
autonumber properties modification, 11–215
companion document, A–377
component properties modification, 11–211, 11–212
Create → Autonumber..., 11–211, 11–212
creating, 11–212
ordered lists (continued)
defining, 11–210
defining multiple level autonumbers, 11–214
list:num* and list:num, creating lists with, 11–217

Properties → Autonumber Streams..., 11–214
restarting, 11–213
utility component, defining, 11–214, 11–216

orientation, 5–87
output bin, 5–92
Overlay frame, 14–277

P

p:0 components, 3–45, 8–141
page breaks, document editing, 4–73
page format
Create → Reference → Attributes..., 9–178
Create → Reference → Page Number..., 9–172, 9–173
frames
adding content, 9–181
finger tab, 9–180, 9–183
repeating, 9–180, 9–182
page revision information
adding to headers and footers, 9–174
attaching to components, 9–176
defining revision attributes, 9–176
referencing revision attributes, 9–178
using revision attributes, 9–177
Properties → Attributes Setup..., 9–176, 9–177
Properties → Frame..., 9–180
section titles, adding to header, 9–173
variable content component, adding to header, 9–174, 9–175

page layout
column number, 9–163
column width, 9–164
dimensions of page, establishing, 9–159
document properties, 9–164
gutter width, 9–163
headers and footers, 9–166
bleed, 9–167
changing number, 9–168
changing size, 9–167
extending to side of page, 9–167
viewing boundaries, 9–166
margins
double sided layout, 9–162
size, 9–159

page layout (continued)
page numbers
creating new number, 9–170
multiple numbers on page, 9–170
referencing number in text string, 9–170
printed sides, defining single or double, 9–161, 9–161, 9–162
Properties → Document..., 9–159
Properties → Page Number Streams..., 9–170
size of margins, 9–159
size of page, 9–159
size properties, 9–159, 9–160
starting page, double sided layout, 9–162
View → Markers..., 9–166

page numbers
Create → Reference → Page Number..., 9–172, 9–173
new page number, creating, 9–170
page layout, multiple numbers on page, 9–170
reference creation, 6–112
streams, defining, 9–170, 9–171
text string, referencing number in, 9–170
Tools → Graphics Palettes → Drawing..., 9–170, 9–172

page revision information
components, attaching to, 9–176
Create → Reference → Attributes..., 9–178
headers and footers, adding to, 9–174
Properties → Attributes Setup..., 9–176, 9–177
revision attributes
defining, 9–176
referencing, 9–178
using, 9–177

pages
header rows appearing on multiple pages, 12–238
page justification, 10–189
printing documents, pages to be printed, 5–82
pages, page layout. See page layout
pages to be printed, Motif, 5–88
pagination
hierarchy of objects in book, 8–136
keeping items together, 4–75
new page, starting, 4–74
Properties → Selection..., 4–74
rearranging objects in books, 8–137
Paint Tool, 16–331, 16–332
painting over parts of image, 16–331, 16–332
palettes, graphics, 15–294, 15–295
paper, changing information about paper used, 5–85
paper size, 5–92
paper source, 5–92
paragraphs
  companion document, A–376
  deleting, 3–48
paragraphs, formatting. See formatting paragraphs and headings
Part sub-book, companion document, A–372
Paste, 1–15
pasting data into Chart Data dialog box, 17–352
pasting graphics into open frame
  adjusting other objects in frame, 6–104
  alignment, 6–105
  Change→Measurements..., 6–104
  closing frame, 6–104
  creating frame, 6–98
  opening frame, 6–100
  pasting illustration, 6–101
  position adjustment, 6–104
  repositioning graphic in frame, 6–104
  screen capture, creating, 6–101
  size adjustment, 6–103
pasting items
  combining Interleaf 6 documents, 4–61
  overriding, 4–60
pasting reference into text, 6–109
Pattern Editor, 15–317
patterns. See colors and patterns
Pickup Tool, 16–331, 16–331
Picture Editor
  Auto-Pickup Tool, 16–333
  Clone Tool, 16–334
  Crop Tool, 16–328, 16–337
  cropping image, 16–328, 16–328
  Edit→Undo, 16–328
  editing links, 16–342
  File→Revert to→Saved, 16–329
  File→Save, 16–328
  File→Save As..., 16–328
  rotating image, 16–325
  scrolling to areas of image, 16–327, 16–327
  touching up, 16–329
    Blend Tool, 16–336
    brush choice, 16–329, 16–329
    cloning part of image, 16–334
    color choice, 16–330, 16–330
    color picked automatically, 16–333
    Fade Tool, 16–335
    Fill Tool, 16–334
    Paint Tool, 16–331
Paint Tool, 16–331
Picture Editor (continued)
  touching up (continued)
    painting over parts of image, 16–331
  Pickup Tool, 16–331
  undoing changes with Scraper Tool, 16–332
  undoing changes in cropping, 16–328
  view manipulation, 16–325
  View→Zoom, 16–326
  window described, 16–324
  Zoom Tool, 16–326
  zooming in, 16–326, 16–326
placement properties, frames, 14–277
points
  adding to color mapping curve, 16–340,
  16–340
  jumping from point to point, 4–72
popup menus, 1–12
position lock, 15–312
posterizing, 16–342
precedence of objects in book, 8–136
predefined components
  callouts, creating, 14–281
  use for illustrations, 6–98
predefined table, creating, 7–121
print destination, choice in Motif, 5–88
print options in Motif, 5–91
printer, adding in Motif, B–386
printing documents
  cancelling print job, 5–85
  copies, number of, 5–82, 5–83
  default printer, 5–82, 5–85
  deletion marks, 5–87
  destination printer, 5–82
    changing, 5–85
  File→Print..., 5–82
  fonts, change, 5–86
  header page, 5–84
  More... button, 5–85
  orientation, 5–87
  pages to be printed, 5–82
  paper, changing information, 5–85
  print range, 5–82, 5–83
  Properties→Printing..., 5–86, 5–86
  quality of print, change, 5–86
  resolution of print, change, 5–86
  revision bars, 5–87
  scale of printed output, change, 5–86
  status of print job, 5–84, 5–84
  strikethroughs, 5–87
  underlines, 5–87
printing documents (continued)

Windows
  print options in, 5-85
  use, 5-81

WorldView file, printing to, 5-82

printing documents in Motif
  cancelling print job, 5-88
  copies, number of, 5-88
  default printer, 5-87
  deletion marks, 5-87
  duplex, 5-92
  entire document, 5-88
  EPS file, printing to, 5-88
  File→Print..., 5-87
  filtering on the print server, 5-90
  header page, choosing, 5-82
  orientation, 5-87
  output bin, 5-92
  pages to be printed, 5-88
  paper size, 5-92
  paper source, 5-92
  print destination, choice, 5-88
  print options, selection, 5-91
  revision bars, 5-87
  status of print job, 5-88, 5-90
  strikethroughs, 5-87
  underlines, 5-87
  WorldView file, printing to, 5-88

printing lock, 15-310, 15-312

program management document creation, 4-58
Program Manager, starting Interleaf 6 from, 1-5
projection commands, three-dimensional objects, 15-319

Properties→Attributes Setup..., 9-176, 9-177
Properties→Autonumber Streams..., 11-214
Properties→Cell..., 12-242, 12-243
Properties→Document..., 9-159
Properties→Frame..., 9-180, 14-275
Properties→Inline..., 10-201
Properties→Page Number Streams..., 9-170
Properties→Printing..., 5-86, 5-86
Properties→Row..., 12-238, 12-238
Properties→Selection, 3-54
Properties→Selection..., 4-64, 4-74, 6-99,
  6-110, 6-114, 17-362
Properties→Table..., 12-249
Properties→Text, 3-54
Properties→Text..., 17-362
proportional columns, 12-232, 12-232

Q
  quality of print, change, 5-86
  quitting Interleaf 6, 1-18, 1-19

R
  range of indexes
    current page, 8-150
    page range, 8-150
    see (also), 8-150
    specifying, 8-149
    this component, 8-150
    to named component, 8-150

raster images
  Add Point Tool, 16-340
  Auto-Pickup Tool, 16-333
  Clone Tool, 16-334
  Contrast Editor
    adding a point, 16-340
    changing contrast, 16-339
    color adjustment, 16-339
    color mapping curve, 16-339
    special effects, 16-341
    window, 16-339, 16-340
  Crop Tool, 16-328, 16-337
  cropping image, 16-328, 16-328
  Edit→Undo, 16-328
  Edit→Whole Image, 16-339
  File→Revert to→Saved, 16-329
  File→Save, 16-328
  File→Save As..., 16-328
  Frame Editor
    framing part of image, 16-337, 16-337
    moving frame to different part of image,
      16-338, 16-338
  Image Editor
    window, 16-325
    opening, 16-324
  links, 16-342
    creating, 16-342, 16-342
    described and explained, 16-343
    editing in Image Editor, 16-342
    missing, 16-344, 16-344
  Picture Editor
    editing links, 16-342
    manipulating view, 16-325
    rotating image, 16-325
    window described, 16-324
raster images (continued)
  Picture Editor (continued)
    zooming in, 16-326, 16-326
    scrolling to areas of image, 16-327, 16-327
    TIFF as standard format, 16-323
    touching up, 16-329
      Blend Tool, 16-336
      brush choice, 16-329, 16-329
      cloning part of image, 16-334
      color choice, 16-330, 16-330
      color picked automatically, 16-333
      Fade Tool, 16-335
      Fill Tool, 16-334
      Paint Tool, 16-331
      painting over parts of image, 16-331
      Pickup Tool, 16-331
      undoing parts of image, 16-331
      undoing changes with Scraper Tool, 16-332
  undoing changes in cropping, 16-328

  View~Zoom, 16-326
  Zoom Tool, 16-326

read-only property, 12-238

Rear sub-book, companion document, A-372

  recap table, 12-232, 12-246

rectangles, filled, adding titles and legends to charts, 17-362

reference creation
  automatic method
    autonumber selection, 6-107
    Clipboard, creating reference on, 6-109
    Create~Autoreference, 6-109
    Edit~Paste, 6-109
    pasting reference into text, 6-109
  manual method
    autonumber reference creation, 6-111
    autonumber reference tag modification, 6-111
    autonumber selection, 6-109
    autonumber tag modification, 6-109
    Create~Reference~Autonumber, 6-110, 6-111
    Edit~Properties..., 6-109
    Properties~Selection..., 6-110
    NO TAG, 6-111

reformatting
  indexes, 8-154
    table of contents, 8-144
  regions, active, 4-62
  Rename Master..., 10-192
  renaming icons, 1-9

repeated words. See formatting highlighted or repeated words

repeating frames, 9-180, 9-182
replacing selected text, 3-49
replacing text, 3-47
repositioning graphic in frame, 6-104
resolution of print, change, 5-86
restoring Desktop window, 1-7
RETURN key function, 3-46
reusing graphic objects
  drag selecting multiple objects, 15-303
  duplicate command, 15-304, 15-305
  flip command, 15-304, 15-305
  group command, 15-303, 15-304
revision attributes, defining, 9-176
revision bars, 5-87
rotation
  detent, 15-307
  Picture Editor, rotating image, 16-325
rotation lock, 15-312
row masters
  creating rows with updated masters, 12-245
  straddle information, updating with, 12-243, 12-244
  table master definition updates, 12-248
rows
  copying, 7-129
  creating, 7-128
  moving, 7-129
rulings
  final changes to table, 12-245
  properties, modifying, 7-132
  recap table, 12-246
  Rulings dialog box use, 12-246
  table definition, using in, 12-245
  table rulings
    changing, 7-131
    selecting with mouse, 7-131
    selecting with Rulings dialog box, 7-132
  Tables~Edit Rulings..., 12-246

S

Samples drawer
  chart templates, 17-362
  colors and patterns from, 15-318
  saving changes, colors and patterns, 15-316
  saving documents, 2-25, 3-55
  saving initial content, document templates, 13-257
  scale of printed output, change, 5-86
  Scraper Tool, 16-332, 16-332
ScratchPad document
changing grid properties, 15–296
Create → Line, 15–297, 15–298
creating, 15–293, 15–294
creating graphic object when grid align is on, 15–297
creating graphics in, 15–293
creating line, 15–297
creating lines with Drawing palette, 15–298
File → New → ScratchPad, 15–293
grids, 15–294
palettes, 15–294, 15–295
tool bar, 15–294, 15–295
screen capture, creating, 6–101
scrolling to areas of image, 16–327, 16–327
search and replace
format, 4–69
text, 4–68
second level paragraphs, 10–194
section titles
creating, 3–44
header, adding to, 9–173
sections
Create → Component, 3–44
creating, 3–43
selecting text, 3–48
selecting words, 3–48
selection lock, 15–310, 15–312
separate headings, 10–196
setting properties, frames, 14–276
shape bar
moving, 6–117
selection, 6–115
shaping text
adjusting frame’s properties, 6–113
Properties → Selection..., 6–114
shape bar, moving, 6–117
shape bar selection, 6–115
Tools → Shape Text, 6–116
Tools → Shape Text..., 6–115
shared content inline, 11–222, 11–223
single column, 12–229
single components, changing, 4–64, 4–64
single sided page layout, 9–161
size
changing text, 3–54
equations, changing size, 17–368, 17–368, 17–369
graphic objects
sizing with aspect lock, 15–311
sizing with handles, 15–309, 15–310
sizing without aspect lock, 15–309
size (continued)
headers and footers, 9–167, 9–167
inline component, font size, 10–202
margins, 9–159
page dimensions, 9–159
pasting graphics into open frame, size adjustment, 6–103
size lock, 15–312
tables, font size adjustment, 12–246
size handles, modifying arcs, 15–300
size lock, 15–312
smoothness lock, 15–312
sort column, indexes, 8–152
spelling check
Change, 4–79
Change All, 4–79
Dictionary Add, 4–79
Dictionary Remove, 4–79
entire document, 4–77
graphic frame, 4–80
Ignore All, 4–79
No Change, 4–79
range of text, 4–80
unrecognized word, 4–79
word check, 4–80
stacked line chart creation, 17–359
starting Interleaf 6, 1–3
startup screen, 1–5
status of print job
information about, 5–84
printing documents in Motif, 5–88, 5–90
stickiness lock, 15–312
straddles
changing a cell’s vertical alignment, 12–242, 12–243
creating rows with updated masters, 12–245
horizontal, 12–241, 12–241
Properties → Cell..., 12–242, 12–243
row masters, updating with straddle information, 12–243, 12–244
Tables → Join Cells, 12–241, 12–241, 12–242, 12–242
Update Master Content, 12–244
vertical, 12–241, 12–242
 strikethroughs, 5–87
structured information, 2–26, 2–27
defined, 2–25
style, editing chart properties, 17–352, 17–353
style sheets. See Network Style Sheets
sub-books, 8–135
  companion document, A–372
Network Style Sheets, 13–268
TOC sub-book creation, 8–145
sub-edit, changing arcs, 15–300, 15–301
subsections, table of contents, 8–143
summary files, 8–143
superimposing charts, 17–360
synchronizing documents in books, 8–143
System6 cabinet
  Create cabinet, 1–17
document templates, 13–261
opening, 1–17
upgrading, 13–261, 13–262
uses, 1–17
System6 icon, 1–8

T

table caret, moving, 7–122
table of contents
Book→Sync, 8–143
Book→TOC, 8–142, 8–143, 8–143, 8–144
books, 1–8
changing TOC document, 10–197
creating, 8–139
File→New→Inside Interleaf→User Guide→Front→TOC→<whole book>, 8–145
Network Style Sheets, 13–265
  reformatting with, 8–145
  reformatting, 8–144
summary files, 8–143
synchronizing documents in book, 8–143
tabs, 13–266
tagging information, 8–139
TOC command, 8–142
TOC sub-book creation, 8–145
tokens, 13–266
tables
  cell edit mode, 7–126
cell selection by menu, 7–123
cell selection by mouse, 7–123
cell selection by mouse and keyboard, 7–124
companion document, A–380
Empty Cell(s) command, 7–125
emptying contents of table, 7–122
  Tables→Empty Cell(s), 7–122, 7–125, 7–126
new table, creating, 7–120
predefined table, creating, 7–121
tables (continued)
  rows
    copying, 7–129
    creating, 7–128
    moving, 7–129
  ruling properties, modifying, 7–132
  rulings
    changing, 7–131
    selecting with mouse, 7–131
    selecting with Rulings dialog box, 7–132
table caret, moving, 7–122
Tables→Create Row..., 7–128, 7–128
Tables→Create Table..., 7–120, 7–120
Tables→Edit Rulings..., 7–131, 7–131
Tables→Select Cells→in Current Row, 7–123, 7–124
Tables→Select Cells→Toggle, 7–123, 7–124
text, entering in table cells, 7–126
text caret, moving, 7–123
View→Markers..., 7–127
tables, formatting. See formatting tables
Tables→Change Width..., 12–227, 12–228
Tables→Convert Text to Table..., 17–350
Tables→Create Row..., 7–128, 7–128, 12–235, 12–236
Tables→Create Table..., 7–120, 7–120, 12–225, 12–226
Tables→Edit Rulings..., 7–131, 7–131, 12–246
Tables→Empty Cell(s), 7–122, 7–125, 7–126, 12–239
Tables→Fonts→Smaller, 12–246
Tables→Join Cells, 12–241, 12–241, 12–242, 12–242
Tables→Select Cells→in Current Column, 12–228, 12–229
Tables→Select Cells→in Current Row, 7–123, 7–124
Tables→Select Cells→Toggle, 7–123, 7–124
tabs
  measured from column margin, 11–213
  measured from component margin, 11–213
Network Style Sheets, 13–266
ordered lists, component properties modification, 11–211, 11–212
  tab properties, components, 10–191, 10–191
table of contents, 13–266
  versus spaces, 11–208
tagged image file format file, creating, 6–101
templates
  charts, 17–362
templates, documents. See document templates
tokens
  index tokens, cutting and pasting, 8-150
  table of contents, 13-266
  tool bars, graphics, 15-294, 15-295
  tool stickiness, 15-298, 15-298
  tool stickiness, 15-298, 15-298
  Tools→Admin→Cleanup, 13-258, 13-259
  Tools→Admin→Update, 13-261, 13-262
  Tools→Colors..., 15-314, 15-314
  Tools→Find Object..., 4-70
  Tools→Find/Change..., 4-69
  Tools→Graphic Palettes→Commands..., 14-278
  Tools→Graphic Palettes→Drawing..., 14-278
  Tools→Graphics Palettes→Drawing..., 9-170, 9-172
  Tools→Load, 3-40
  Tools→Patterns..., 15-317
  Tools→Preferences..., B-390
  Tools→Shape Text..., 6-115
  Tools→Spelling..., 4-77
  Top frame, 14-277
touching up images, 16-329
  Auto-Pickup Tool, 16-333, 16-333
  Blend Tool, 16-336
  brush choice, 16-329, 16-329
  Clone Tool, 16-334, 16-335
  cloning part of image, 16-334, 16-335
  color choice, 16-330, 16-330, 16-331
  color picked automatically, 16-333, 16-333
  Fade Tool, 16-335
  Fill Tool, 16-334
  Paint Tool, 16-331, 16-332
  painting over parts of image, 16-331
  Pickup Tool, 16-331
  undoing changes with Scraper Tool, 16-332
true hyphen, 3-46
  creating, 3-46
typefaces. See fonts

U
Underlay frame, 14-277
underlines, 5-87
underlining, changing text, 3-54
undoing changes, 3-49
cropping, 16-328
touching up images, Scraper Tool, 16-332, 16-332
unnumbered footnotes, companion document, A-378
unnumbered lists, companion document, A-377
unordered lists
  adding content to prefix, 11-207
  bullet symbol, creating, 11-207
  companion document, A-377
  component prefix, setting up, 11-206
Create ➔ Character ➔ Bullet, 11-207, 11-207
defining, 11-206, 11-206
other lists, creating, 11-210
properties adjustment with document ruler, 11-208, 11-209
unrecognized word, spelling check, 4-79
unused objects, removing from document templates, 13-253
unwanted icons, cutting, 1-14
Update Master Content, 12-244, 12-248, 12-249, 13-257, 13-258
Update Master Props, 12-248, 12-249
utility components
  defining, 11-214, 11-216
  ordered lists, restarting, 11-214

V
variable content component
  adding to header, 9-174, 9-175
  read only, 9-174
variable width microdocuments, creating callouts, 14-279, 14-281
variations of masters, 2-33
vertical justification, 10-190
vertical straddles, 12-241, 12-242, 12-242, 12-243
view manipulation, Picture Editor, 16-325

W
width
columns, 9-164, 12-231, 12-231
changing, 12-227
frames, 14-276
windows
book, 8-134, 8-134
document templates, 3-38
master Create cabinet, accessing, 13-259
minimizing, 4-59
  See also minimizing windows
resizing, 4-60
windows, Microsoft Windows. See Microsoft Windows
words
  deleting, 3-48
  selecting, 3-48
  spelling check, 4-80
WorldView file
  printing documents, 5-82
  printing documents in Motif, 5-88

X
X terminal window, Motif, 1-4

Z
Zoom Tool, 16-326
zooming in, Picture Editor, 16-326, 16-326
### More OnWord Press Titles

#### Pro/ENGINEER and Pro/JR. Books

<table>
<thead>
<tr>
<th>Title</th>
<th>Price</th>
<th>Includes Disk</th>
</tr>
</thead>
<tbody>
<tr>
<td>INSIDE Pro/ENGINEER</td>
<td>$49.95</td>
<td></td>
</tr>
<tr>
<td>Pro/ENGINEER Exercise Book</td>
<td>$39.95</td>
<td></td>
</tr>
<tr>
<td>Pro/ENGINEER Quick Reference, 2d ed.</td>
<td>$24.95</td>
<td></td>
</tr>
<tr>
<td>Thinking Pro/ENGINEER</td>
<td>$49.95</td>
<td></td>
</tr>
<tr>
<td>INSIDE Pro/JR.</td>
<td>$49.95</td>
<td></td>
</tr>
</tbody>
</table>

#### Interleaf Books

<table>
<thead>
<tr>
<th>Title</th>
<th>Price</th>
<th>Includes Disk</th>
</tr>
</thead>
<tbody>
<tr>
<td>INSIDE Interleaf</td>
<td>$49.95</td>
<td></td>
</tr>
<tr>
<td>Adventurer's Guide to Interleaf Lisp</td>
<td>$49.95</td>
<td></td>
</tr>
<tr>
<td>The Interleaf Exercise Book</td>
<td>$39.95</td>
<td></td>
</tr>
<tr>
<td>The Interleaf Quick Reference</td>
<td>$24.95</td>
<td></td>
</tr>
<tr>
<td>Interleaf Tips and Tricks</td>
<td>$49.95</td>
<td></td>
</tr>
</tbody>
</table>

#### MicroStation Books

<table>
<thead>
<tr>
<th>Title</th>
<th>Price</th>
<th>Includes Disk</th>
</tr>
</thead>
<tbody>
<tr>
<td>INSIDE MicroStation 5X, 3d ed.</td>
<td>$34.95</td>
<td></td>
</tr>
<tr>
<td>MicroStation Reference Guide 5.X</td>
<td>$18.95</td>
<td></td>
</tr>
<tr>
<td>MicroStation Exercise Book 5.X</td>
<td>$34.95</td>
<td></td>
</tr>
<tr>
<td>MicroStation Delta Book</td>
<td>$19.95</td>
<td></td>
</tr>
<tr>
<td>MicroStation for AutoCAD Users, 2d ed.</td>
<td>$34.95</td>
<td></td>
</tr>
<tr>
<td>Adventures in MicroStation 3D</td>
<td>$49.95</td>
<td></td>
</tr>
<tr>
<td>MicroStation Productivity Book</td>
<td>$39.95</td>
<td></td>
</tr>
<tr>
<td>Optional Disk $49.95</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MicroStation Bible</td>
<td>$49.95</td>
<td></td>
</tr>
<tr>
<td>Optional Disks $49.95</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Build Cell</td>
<td>$69.95</td>
<td></td>
</tr>
<tr>
<td>101 MDL Commands</td>
<td>$49.95</td>
<td></td>
</tr>
<tr>
<td>Optional Executable Disk $101.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Optional Source Disks (6) $259.95</td>
<td></td>
<td></td>
</tr>
<tr>
<td>101 User Commands</td>
<td>$49.95</td>
<td></td>
</tr>
<tr>
<td>Optional Disk $101.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Bill Steinbock’s Pocket MDL</strong></td>
<td><strong>The MicroStation Database Book</strong></td>
<td></td>
</tr>
<tr>
<td>--------------------------------</td>
<td>----------------------------------</td>
<td></td>
</tr>
<tr>
<td>Programmer’s Guide</td>
<td>Book $29.95</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Optional Disk $29.95</td>
<td></td>
</tr>
<tr>
<td><strong>Managing and Networking</strong></td>
<td><strong>INSIDE I/RAS B</strong></td>
<td></td>
</tr>
<tr>
<td><strong>MicroStation</strong></td>
<td>Book $24.95 Includes Disk</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>The MicroStation Database Book</strong></td>
<td>Book $29.95</td>
<td></td>
</tr>
<tr>
<td><strong>Optional Disk $29.95</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Managing and Networking</strong></td>
<td><strong>INSIDE I/RAS B</strong></td>
<td></td>
</tr>
<tr>
<td><strong>MicroStation</strong></td>
<td>Book $24.95 Includes Disk</td>
<td></td>
</tr>
<tr>
<td><strong>Book $29.95</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Optional Disk $29.95</strong></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Windows NT**

<table>
<thead>
<tr>
<th><strong>Windows NT for the Technical Professional</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Book $39.95</td>
</tr>
</tbody>
</table>

**SunSoft Solaris Series**

<table>
<thead>
<tr>
<th><em><em>The SunSoft Solaris 2.</em> User’s Guide</em>*</th>
<th><strong>Five Steps to SunSoft Solaris 2.</strong>*</th>
</tr>
</thead>
<tbody>
<tr>
<td>Book $29.95 Includes Disk</td>
<td>Book $24.95 Includes Disk</td>
</tr>
<tr>
<td><em><em>SunSoft Solaris 2.</em> for Managers and</em>*</td>
<td><strong>One Minute SunSoft Solaris Manager</strong></td>
</tr>
<tr>
<td>Administrators</td>
<td>Book $14.95</td>
</tr>
<tr>
<td>Book $34.95</td>
<td><em><em>SunSoft Solaris 2.</em> for Windows Users</em>*</td>
</tr>
<tr>
<td><em><em>The SunSoft Solaris 2.</em> Quick Reference</em>*</td>
<td>Book $24.95</td>
</tr>
<tr>
<td>Book $18.95</td>
<td></td>
</tr>
</tbody>
</table>

**The Hewlett Packard HP-UX Series**

<table>
<thead>
<tr>
<th><strong>The HP-UX User’s Guide</strong></th>
<th><strong>Five Steps to HP-UX</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Book $29.95 Includes Disk</td>
<td>Book $24.95 Includes Disk</td>
</tr>
<tr>
<td><strong>The HP-UX Quick Reference</strong></td>
<td><strong>One Minute HP-UX Manager</strong></td>
</tr>
<tr>
<td>Book $18.95</td>
<td>Book $14.95</td>
</tr>
</tbody>
</table>

**CAD Management**

<table>
<thead>
<tr>
<th><strong>One Minute CAD Manager</strong></th>
<th><strong>Manager’s Guide to</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Book $14.95</td>
<td>Computer-Aided Engineering</td>
</tr>
<tr>
<td></td>
<td>Book $49.95</td>
</tr>
</tbody>
</table>
### Other CAD

<table>
<thead>
<tr>
<th>Product</th>
<th>Price</th>
<th>Includes Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAD and the Practice of Architecture: ASG Solutions</td>
<td>$39.95</td>
<td>Disk</td>
</tr>
<tr>
<td>INSIDE CADVANCE</td>
<td>$34.95</td>
<td>Disk</td>
</tr>
<tr>
<td>Using Drafix Windows CAD</td>
<td>$34.95</td>
<td>Disk</td>
</tr>
<tr>
<td>Fallingwater in 3D Studio: A Case Study and Tutorial</td>
<td>$39.95</td>
<td>Disk</td>
</tr>
</tbody>
</table>

### Geographic Information Systems/ESRI

<table>
<thead>
<tr>
<th>Product</th>
<th>Price</th>
<th>Includes Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>The GIS Book, 3rd ed.</td>
<td>$34.95</td>
<td></td>
</tr>
<tr>
<td>INSIDE ARC/INFO</td>
<td>$74.95</td>
<td>CD</td>
</tr>
<tr>
<td>INSIDE ArcView</td>
<td>$39.95</td>
<td>CD</td>
</tr>
<tr>
<td>ArcView Developer's Guide</td>
<td>$49.95</td>
<td></td>
</tr>
<tr>
<td>ARC/INFO Quick Reference</td>
<td>$24.95</td>
<td></td>
</tr>
</tbody>
</table>

### DTP/CAD Clip Art

<table>
<thead>
<tr>
<th>Product</th>
<th>Price</th>
<th>Includes Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>1001 DTP/CAD Symbols Clip Art: Architectural</td>
<td>$29.95</td>
<td></td>
</tr>
<tr>
<td>DISK FORMATS: MicroStation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DGN Disk $175.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Book/Disk $195.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AutoCAD</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DWG Disk $175.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Book/Disk $195.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CAD/DTP</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DXF Disk $195.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Book/Disk $225.00</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
OnWord Press Distribution

End Users/User Groups/Corporate Sales
OnWord Press books are available worldwide to end users, user groups, and corporate accounts from your local bookseller or computer/software dealer, or from HMP Direct/Softstore: call 1-800-223-6397 or 505-473-5454; fax 505-471-4424; write to High Mountain Press Direct/Softstore, 2530 Camino Entrada, Santa Fe, NM 87505-8435, or e-mail to ORDERS@BOOKSTORE.HMP.COM.

Wholesale, Including Overseas Distribution
High Mountain Press distributes OnWord Press books internationally. For terms call 1-800-4-ONWORD or 505-473-5454; fax to 505-471-4424; e-mail to ORDERS@IPG.HMP.COM; or write to High Mountain Press/IPG, 2530 Camino Entrada, Santa Fe, NM 87505-8435, USA. Outside North America, call 505-471-4243.

Comments and Corrections
Your comments can help us make better products. If you find an error in our products, or have any other comments, positive or negative, we’d like to know! Please write to us at the address below or contact our e-mail address: READERS@HMP.COM

OnWord Press
2530 Camino Entrada, Santa Fe, NM 87505-8435 USA
INSIDE Interleaf
Covers Interleaf 6 for Windows NT, Windows 95, and Motif

INSIDE Interleaf is the insider’s guide to the ins and outs of Interleaf 6, a powerful publishing tool with a new user interface. Written in an accessible and concise manner and focused on user productivity, this book demystifies Interleaf’s document management principles and execution. A must-have for computer-aided publishers who are serious about sharpening their cutting edge.

COVERS:
THE INTERLEAF 6 ENVIRONMENT DOCUMENTS—CREATING, EDITING, AND PRINTING ILLUSTRATIONS AND GRAPHIC OBJECTS TABLES—CREATING AND FORMATTING STYLE SHEETS AND GLOBAL MODIFICATIONS DOCUMENT TEMPLATES THE CHART, EQUATION, AND IMAGE EDITORS

The enclosed bonus disk includes a document template, document and graphic files used in the exercises in the book, plus an Interleaf Lisp program to automatically install the disk files.

Also Available from OnWord Press
Interleaf Quick Reference
Interleaf Exercise Book
Interleaf Tips and Tricks
Adventurer’s Guide to Interleaf Lisp